Skip to main content
  • In Stock
  • Sold by Newegg
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Stackable
Sold by
VLAN Support
Availability
Useful Links
Customer Ratings
Sort By:
View:
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-501T
  •  
  • $114.99 –
  • Free Shipping
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
Quick View
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x full-duplex Flow Control
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX interface on
  • MAC Address Table: 2K
  • Model #: ISW-621TS15
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-801T
  •  
  • $657.00 –
  • Free Shipping
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
Quick View
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-804HPT
  •  
  • $259.60 –
  • Free Shipping
Planet IGS-12040MT Industrial 8-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
Quick View
Planet IGS-12040MT Industrial 8-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
  • Format: DIN Rail Mount
  • Uplink Ports: 4
  • Primary Port Speed: 10/100/1000Mbps
  • VLAN Support: Yes
  • Model #: IGS-12040MT
  • $520.00
  •  
  • $519.00 –
  • $8.00 Shipping
PLANET IVC-234GT Unmanaged Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
Quick View
PLANET IVC-234GT Unmanaged Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet ITU-T G.993.1 VDSL ITU-T G.997.1 ITU-T G.993.2 VDSL2 (Profile 17a/30a Support) ITU-T G.993.5 G.Vectoring and G.INP ITU-T G.998
  • Primary Ports: 4 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IVC-234GT
Planet IGS-5225-4T2S Industrial L2+ 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
Quick View
Planet IGS-5225-4T2S Industrial L2+ 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
  • Format: DIN Rail Mount
  • VLAN Support: Yes
  • Jumbo Frames: 9000 bytes
  • SNMP: Yes
  • Model #: IGS-5225-4T2S
  • $352.00
  •  
  • $343.20 –
  • Free Shipping
Planet GS-4210-16T2S 16-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces
Quick View
Planet GS-4210-16T2S 16-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces
  • Format: Rackmount
  • Primary Port Speed: 10/100/1000Mbps
  • VLAN Support: Yes
  • Jumbo Frames: 9000 bytes
  • Model #: GS-4210-16T2S
  •  
  • $164.00 –
  • Free Shipping
Planet IGS-20040MT L2+ Industrial 16-Port 10/100/1000T + 4 100/1000X SFP Managed Switch (-40 ~ 75 degrees C)
Quick View
Planet IGS-20040MT L2+ Industrial 16-Port 10/100/1000T + 4 100/1000X SFP Managed Switch (-40 ~ 75 degrees C)
  • Format: DIN Rail Mount
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100Mbps + 1000Mbps
  • VLAN Support: Yes
  • Model #: IGS-20040MT
  • $1,026.00
  •  
  • $712.00 –
  • Save: 30%
  • Free Shipping
Planet WGS-818HP Industrial 8-Port 10/100/1000T Wall-mounted Gigabit PoE+ Switch
Quick View
  •  
  • $236.00 –
  • Free Shipping
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
Quick View
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
  • Format: Rail-mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-duplex flow control
  • Primary Ports: 8x 10/100/1000Base-T Ports
  • Primary Port Speed: 10/100/1000Base-T
  • Model #: IGS-801T
  •  
  • $164.00 –
  • Free Shipping
Planet SGS-6340-24T4S Layer 3 24-Port 10/100/1000T + 4-Port 1000X SFP Stackable Managed Switch
Quick View
Planet SGS-6340-24T4S Layer 3 24-Port 10/100/1000T + 4-Port 1000X SFP Stackable Managed Switch
  • Format: Rackmount
  • Primary Ports: 24 10/100/1000BASE-T RJ45 auto-MDI/MDI-X ports
  • Primary Port Speed: 4 1000BASE-X SFP interfaces
  • MAC Address Table: 16K MAC address table with auto learning function
  • Model #: SGS-6340-24T4S
  •  
  • $299.00 –
  • Free Shipping
PLANET GS-5220-24P4X L2+ 24-Port 10/100/1000T 802.3at PoE+ 4-Port 10G SFP+ Managed Switch
Quick View
PLANET GS-5220-24P4X L2+ 24-Port 10/100/1000T 802.3at PoE+ 4-Port 10G SFP+ Managed Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN tagging IEEE 802.1x port authentication network control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 24 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ injector 4 x 100/1000BASE-X mini-GBIC/SFP combo interface with Port-21 to Port-24 4 x 10GBASE-SR/LR ...
  • Model #: GS-5220-24P4X
  •  
  • $575.00 –
  • $14.00 Shipping
Planet GS-4210-24UP4C 24-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
Quick View
Planet GS-4210-24UP4C 24-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
  • Format: Rackmount
  • VLAN Support: Yes
  • PoE: Yes
  • SNMP: Yes
  • Model #: GS-4210-24UP4C
  •  
  • $1,139.60 –
  • $14.00 Shipping
Planet FGSW-2624HPS4 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Ethernet Switch / 420W PoE budget
Quick View
Planet FGSW-2624HPS4 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Ethernet Switch / 420W PoE budget
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet over Fiber-Optic IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 24 x 10/100BASE-TX RJ45 copper with 24-port IEEE 802.3at / af PoE injector 2 x 10/100/1000BASE-T Gigabit RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots, shared with port-25 to port-26
  • MAC Address Table: 4K
  • Switching Method: Store and Forward
  • Model #: FGSW-2624HPS4
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
Quick View
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
  • Format: Wall-mount and DIN Rail Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az EEE (Energy Efficient Ethernet) RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2 ITU-T G.8032 ERPS (Ethernet Ring Protection Switching)
  • Primary Ports: 6 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5226-4P2T
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
  • Format: DIN-rail and Wall-mount Ear
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-4215-4P4T
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
  • Brand: PLANET
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGSW-24040R
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
Quick View
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-511S15
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: 19-inch Rack-mountable Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-16T4S
Planet POE-2400G 24-Port Gigabit 60W Ultra PoE Managed Injector Hub (800W)
Quick View
Planet POE-2400G 24-Port Gigabit 60W Ultra PoE Managed Injector Hub (800W)
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T Ethernet IEEE 802.3u 100Base-TX Fast Ethernet IEEE 802.3ab 1000Base-T Gigabit Ethernet IEEE 802.3af Power over Ethernet
  • Primary Ports: "Data" Input Ports: 24x RJ-45 STP "PoE (Data+Power)" Output Ports: 24x RJ-45 STP Management Port: 1 x RJ-45; 10/100Base-TX, auto-negotiation, auto-MDI / MDIX
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: POE-2400G
  •  
  • $485.99 –
  • Free Shipping
Planet POE-1200G 12-Port Gigabit IEEE 802.3at PoE+ Managed Injector Hub (220 watts)
Quick View
Planet POE-1200G 12-Port Gigabit IEEE 802.3at PoE+ Managed Injector Hub (220 watts)
  • Primary Ports: 12-Port 'Data input' 12-Port 'PoE (Data + Power) output'
  • Primary Port Speed: 24-Port 10/100/1000Base-T Gigabit RJ-45 STP
  • Jumbo Frames: Complies with IEEE 802.3af Power over Ethernet Mid-Span PSE
  • PoE: Supports PoE power up to 15.4 Watts for each PoE ports
  • Model #: POE-1200G
  •  
  • $380.99 –
  • Free Shipping
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
  • Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
  • Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
  • Model #: WGSW-24040
Planet IGS-10080MFT Industrial 8 100/1000X SFP + 2-Port 10/100/1000T Managed Switch (-40 ~ 75 degrees C)
Quick View
Planet IGS-10080MFT Industrial 8 100/1000X SFP + 2-Port 10/100/1000T Managed Switch (-40 ~ 75 degrees C)
  • Format: DIN Rail Mount
  • Primary Ports: 8 100/1000Base-SX/LX mini-GBIC SFP slots
  • MAC Address Table: 8K entries, automatic source address learning and ageing
  • VLAN Support: Yes
  • Model #: IGS-10080MFT
  •  
  • $436.00 –
  • $8.00 Shipping
Planet MGSW-28240F 24-Port 100/1000BASE-X SFP with 4-Port 10G SFP+ L2/L4 Managed Metro Ethernet Switch
Quick View
Planet MGSW-28240F 24-Port 100/1000BASE-X SFP with 4-Port 10G SFP+ L2/L4 Managed Metro Ethernet Switch
  • Primary Ports: 24 1000Base-SX/LX/BX SFP interfaces, (Compatible with 100Base-FX SFP Transceiver), 4 1/10GBase-SR/LR SFP+ slots, 4 10/ 100/1000Base-T TP/SFP combo ports
  • MAC Address Table: 16K entries, automatic source address learning and ageing
  • Switching Method: Store and Forward
  • VLAN Support: Yes
  • Model #: MGSW-28240F
Planet GSD-1222VHP 8-Port 802.3at PoE + 2-Port 10/100/1000T 2-Port SFP Ethernet Switch with PoE LCD Monitor
Quick View
Planet GSD-1222VHP 8-Port 802.3at PoE + 2-Port 10/100/1000T 2-Port SFP Ethernet Switch with PoE LCD Monitor
  • Format: Desktop
  • Primary Ports: 10 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 1000Mbps
  • VLAN Support: The LCD switch features “Standard”, “VLAN” and “Extend” mode selection; the “Extend” mode features 30-watt PoE transmit distance of 250m
  • Model #: GSD-1222VHP
  •  
  • $220.50 –
  • Free Shipping
Planet GS-4210-24P4C IPv6/IPv4 24-Port Managed 802.3at POE+ Gigabit Switch 4-Port Gigabit TP/SFP (220W)
Quick View
Planet GS-4210-24P4C IPv6/IPv4 24-Port Managed 802.3at POE+ Gigabit Switch 4-Port Gigabit TP/SFP (220W)
  • Format: Rackmount
  • Primary Port Speed: 28 x 10/100/1000BASE-T RJ45 Auto-MDI/MDI-X port 4 x 100/1000BASE-X SFP
  • MAC Address Table: 8K entries
  • VLAN Support: Yes
  • Model #: PLA-GS-4210-24P4C
  •  
  • $556.00 –
  • Free Shipping
Planet SGS-6340-24P4S Layer 3 24-Port 10/100/1000T 802.3at PoE + 4-Port 1000X SFP Stackable Managed Switch (370W)
Quick View
Planet SGS-6340-24P4S Layer 3 24-Port 10/100/1000T 802.3at PoE + 4-Port 1000X SFP Stackable Managed Switch (370W)
  • Format: Rackmount
  • Uplink Ports: 4
  • Uplink Interface: SFP & RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: SGS-6340-24P4S
  •  
  • $775.00 –
  • Free Shipping
Planet Technology GSD-805 8-Port 10/100/1000Mbps Desktop Gigabit Ethernet Switch (Internal Power)
Quick View
Planet Technology GSD-805 8-Port 10/100/1000Mbps Desktop Gigabit Ethernet Switch (Internal Power)
  • Format: Desktop
  • Standards: IEEE 802.3: Ethernet IEEE 802.3u: Fast Ethernet IEEE 802.3ab: Gigabit Ethernet IEEE 802.3x: Full-duplex flow control
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-805
  •  
  • $53.60 –
  • $8.00 Shipping
Planet ISW-501T 5-Port 10/100Mbps Industrial Fast Ethernet Switch, -40~75 Degree C
Quick View
  •  
  • $76.00 –
  • $8.00 Shipping