Skip to main content
  • Shop All PLANET Products At Newegg

All Products
Sort By
234 Items
View
  1. 325 / 4
PLANET LRP-101CH 1-Port 10/100 TX PoE PD + 1-Port Coax Long Reach PoE Injector
PLANET LRP-101CH 1-Port 10/100 TX PoE PD + 1-Port Coax Long Reach PoE Injector
  • Type: PoE Injector
  • Specifications: Ethernet Interface: Copper: 10/100BASE-TX RJ45, auto-negotiation / auto-MDI / MDI-X Power over Ethernet Standard: IEEE 802.3at/af PoE PD (Powered Device) PoE Input: Supports both Mid-span and End-span PSE Input Range: 48~56V DC Data Rate: 100/100 Mbps Cabling: Cat5e or above Maximum Distance: 100 meters Maximum Frame Size: 1522 bytes LED Indicators: 4 x LEDs PWR LRP LNK PoE IN LNK / ACTESD Protection: 4 KV DC EFT Protection: 2 KV Enclosure Metal: case Installation: Wall mount or DIN rail with optional kit Power Requirements: RJ45 PoE Input: 802.3at/af 48~56V DC DC Input: 48~56V DCStandards Compliance: Standards Compliance: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3af Power over Ethernet (802.3at Type 1) IEEE 802.3at Power over Ethernet (802.3at Type 2)
  • Model #: LRP-101CH
  • Item #: N82E16833987256
  • Return Policy: 15-Day Return Policy
$163.80
Free Shipping
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
PLANET GSD-1008HP 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-1008HP
  • Item #: N82E16833322083
  • Return Policy: 15-Day Return Policy
$125.99
Free Shipping
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T
  • Item #: N82E16833322217
  • Return Policy: 15-Day Return Policy
$201.60
Free Shipping
PLANET POE-E202 1-port 802.3at PoE+ to 2-port 802.3af/at Gigabit PoE Extender
PLANET POE-E202 1-port 802.3at PoE+ to 2-port 802.3af/at Gigabit PoE Extender
  • Type: PoE Extender
  • Specifications: Interfaces: PoE IN:1 x 10/100/1000BASE-T Ethernet with IEEE 802.3at PoE "Data + DC power" in auto MDI/MDI-X, auto-negotiation RJ45 connector PoE OUT: 2 x 10/100/1000BASE-T Ethernet with IEEE 802.3at/802.3af PoE "Data + DC power" out auto MDI/MDI-X, auto-negotiation RJ45 connector Power over Ethernet PoE Standard: "PoE In" Port: IEEE 802.3at Power over Ethernet Plus end-span/mid-span PD class 4 PD Per "PoE Out" Port: IEEE 802.3at Power over Ethernet Plus end-span PSE IEEE 802.3af Power over Ethernet end-span PSE PoE Power Supply Type: End-span (Type A) PoE Power: "PoE In" Port: 52 - 56V DC, max. 30.8 watts Per "PoE Out" Port: 44 - 55V DC, max. 25 watts Power Pin Assignment: "PoE In" Port: 1/2 (+), 3/6 (-); 4/5 (+), 7/8 (-) Per "PoE Out" Port: 1/2 (+), 3/6 (-) Data Rate: 10/100/1000Mbps MAC Address Table: 2K Data Bu...
  • Model #: POE-E202
  • Item #: N82E16833987036
  • Return Policy: 15-Day Return Policy
$90.99
Free Shipping
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: WGS-5225-8T2SV
  • Item #: N82E16833322235
  • Return Policy: 15-Day Return Policy
$345.99
Free Shipping
Planet IGS-10020HPT L2+ Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch with Wide Operating Temperature
Planet IGS-10020HPT L2+ Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch with Wide Operating Temperature
  • MAC Address Table: 8K entries, automatic source address learning and ageing
  • Buffer Memory: 4Mbits
  • QoS: Traffic classification based, Strict priority and WRR 8-Level priority for switching - Port Number - 802.1p priority - 802.1Q VLAN tag - DSCP/TOS field in IP Packet
  • Model #: IGS-10020HPT
  • Return Policy: View Return Policy
$596.00
$8.00 Shipping
PLANET IGT-805AT Industrial 10/100/1000BASE-T to 100/1000BASE-X SFP Media Converter
PLANET IGT-805AT Industrial 10/100/1000BASE-T to 100/1000BASE-X SFP Media Converter
  • Device Type: Converter
  • Media Conversion: RJ45 - SFP
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet IEEE 802.3x full-duplex flow control
  • Ports: 1 x 10/100/1000BASE-T RJ45 with auto MDI / MDI-X function 1 x SFP interface, 100/1000BASE-X dual mode (auto detection)
  • Model #: IGT-805AT
  • Return Policy: View Return Policy
$112.00
Free Shipping
PLANET Technology - IGS-624HPT - Planet IGS-624HPT Ethernet Switch - 4 Ports - 2 Layer Supported - Modular - Optical
PLANET Technology - IGS-624HPT - Planet IGS-624HPT Ethernet Switch - 4 Ports - 2 Layer Supported - Modular - Optical
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 Ethernet / 10Base-T - IEEE 802.3u Fast Ethernet / 100Base-TX - IEEE 802.3ab Gigabit Ethernet / 1000Base-T - IEEE 802.3z Gigabit Ethernet / 1000Base-SX/LX - IEEE 802.3x Full-Duplex Flow Control - IEEE 802.3at High Power over Ethernet- IEEE 802.3af Power over Ethernet
  • Primary Ports: 4-port 10/100/1000Base-T RJ-45 with IEEE 802.3af / 802.3at PoE Injector 2-port SFP slot interface, SFP supports 1000Base-X and 100Base-FX transceiver via DIP switch configured
  • PoE: IEEE 802.3af / IEEE 802.3at Power over Ethernet / PSE
  • Model #: IGS-624HPT
  • Return Policy: View Return Policy
Save 13%
$344.00
$399.04
Free Shipping
Planet POE-E304 1-Port Ultra PoE to 4-Port 802.3af/at Gigabit PoE Extender
Planet POE-E304 1-Port Ultra PoE to 4-Port 802.3af/at Gigabit PoE Extender
  • Type: PoE Extender
  • Color: Black
  • Specifications: Network Connector: PoE In Port 1 x 10/100/1000BASE-T Ethernet with Ultra PoE "Data + DC" in, auto MDI / MDI-X, auto-negotiation RJ45 connector PoE Out Port 4 x 10/100/1000BASE-T Ethernet with IEEE 802.3at/802.3af PoE "Data + DC" out, auto MDI / MDI-X, auto-negotiation RJ45 connector Data Rate: 10/100/1000 Mbps Switch Architecture: Store-and-Forward MAC Address Table: 2K Data Buffer: 2 Mbits Switch Fabric: 10 Gbps Switch Throughput: 7.44 Mpps @ 64 bytes Jumbo Frame: 9K Flow Control: IEEE 802.3x pause frame for full duplex Back pressure for half duplex LED Indicators: PoE In Port 10/100 LNK / ACT (Orange), 1000 LNK / ACT (Green) PoE Out Port 1 to Port 4 10/100 LNK / ACT (Orange), 1000 LNK / ACT (Green) PoE-in-Use (Orange) PoE Max. (Orange) Protection: ESD (Ethernet): 6 KV Surge (EFT for powe...
  • Model #: POE-E304
  • Item #: 2WG-003T-00002
  • Return Policy: 15-Day Return Policy
$97.99
Free Shipping
PLANET POE-172 Single-Port 10/100/1000 Mbps 60W Ultra PoE Injector
PLANET POE-172 Single-Port 10/100/1000 Mbps 60W Ultra PoE Injector
  • Type: PoE Injector
  • Specifications: Interface LAN: 1 x RJ45 STP, "Data" Input Port PoE: 1 x RJ45 STP, "Data + Power" Output Port AC Connector: 1 x AC input power socket, IEC-320 C6 Network Cable Ultra PoE (60W): 4-pair UTP Cat. 5, 5e, 6 up to 100m (328 ft.) 802.3af/at PoE (15W/30W): 2-pair UTP Cat. 3, 4, 5, up to 100m (328 ft.) LED Indicator System: Power x 1 (green) PoE Port: Active, PoE ready/in-use x 1 (green) Data Rate: 10/100/1000Mbps Unit Output Voltage: DC 56V, 1.08A Power Requirements: 100 - 240V AC at 50/60Hz, 1.5A max. Power Consumption: 60 watts max. Temperature 0 - 50 degrees Celsius (Operating) -10 - 70 degrees Celsius (Storage) Humidity: 5 - 95%, relative humidity, non-condensing PoE Standard: Ultra PoE over 4-pair UTP cable IEEE 802.3at Power over Ethernet Plus End-span/Mid-span PSE PoE Power Supply Type: End-span + Mid-span ...
  • Model #: POE-172
  • Item #: N82E16833987035
  • Return Policy: 15-Day Return Policy
$73.99
Free Shipping
PLANET MTB-RJ 1-Port 10GBASE-T SFP+ Copper Fiber Optic Module - 30m
PLANET MTB-RJ 1-Port 10GBASE-T SFP+ Copper Fiber Optic Module - 30m
  • Specifications: Package: SFP+ PHY Type: IEEE 802.3an 10 Gigabit Ethernet Standard Connector: Copper Maximum Distance: 30m
  • Model #: MTB-RJ
  • Item #: N82E16833322233
  • Return Policy: 15-Day Return Policy
$113.99
Free Shipping
Planet LRP-101CE 1-Port Long Reach PoE Over Coaxial Extender
Planet LRP-101CE 1-Port Long Reach PoE Over Coaxial Extender
  • Type: PoE Extender
  • Color: Black
  • Specifications: Ethernet Interface: Copper: 10/100BASE-TX RJ45 auto-negotiation / auto-MDI / MDI-X Power over Ethernet Standard: IEEE 802.3at/af PoE PSE (Power Source Equipment) PoE Output: 56V DC, 600mA max. PoE Budget: Up to 25 watts PoE Mode: End-span, RJ45 Pin 1/2 (+), 3/6 (-) Data Rate: 100/100 Mbps Cabling: Cat5e or above Maximum Distance: 100 meters Maximum Frame Size: 1522 bytes LED Indicators: 4 x LEDs PWR LRP LNK PoE-in-use LNK / ACT ESD Protection: 4KV DC Enclosure: Metal case Installation: Wall mount or DIN rail with optional kit Power Requirements: BNC Power over Coaxial Input: 44~56V DC Standards Compliance: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3af Power over Ethernet (802.3at Type 1) IEEE 802.3at Power over Ethernet Plus(802.3at Type 2)
  • Model #: LRP-101CE
  • Item #: 0YH-00JP-000G4
  • Return Policy: 15-Day Return Policy
$163.80
Free Shipping
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8P2S
  • Item #: N82E16833322216
  • Return Policy: 15-Day Return Policy
$435.60
Free Shipping
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3af Power over Ethernet
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with IEEE 802.3af PoE injector 1-port 100Base-FX SFP interface
  • MAC Address Table: 2K
  • Switching Method: Store and Forward
  • Model #: ISW-514PTF
  • Item #: 0YH-00JP-00010
  • Return Policy: 15-Day Return Policy
$215.99
Free Shipping
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T2S
  • Item #: N82E16833322218
  • Return Policy: 15-Day Return Policy
$243.99
Free Shipping
PLANET XT-705A 10G/5G/2.5G/1G/100M Copper to 10GBASE-X SFP+ Media Converter
Planet ISW-800T IP30 Compact Size 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 degrees C)
PLANET LRP-101UH 1-Port 10/100 TX PoE PD + 1-Port UTP Long Reach PoE Injector
PLANET LRP-101UH 1-Port 10/100 TX PoE PD + 1-Port UTP Long Reach PoE Injector
  • Type: PoE Injector
  • Specifications: Ethernet Interface: Copper: 10/100BASE-TX RJ45, auto-negotiation / auto-MDI / MDI-X Power over Ethernet Standard: IEEE 802.3at/af PoE PD (Powered Device) PoE Input: Supports both mid-span and end-span PSE Input Range: 48~56V DC Data Rate: 100/100 Mbps Cabling: Cat5e or above Maximum Distance: 100m Maximum Frame Size: 1522 bytes LED Indicators: 4 x LEDs PWR LRP LNK PoE IN LNK / ACTESD Protection: 4 KV DC EFT Protection: 2 KV Enclosure Metal: case Installation: Wall mount or DIN rail with optional kit Power Requirements: RJ45 PoE Input: 802.3at/af 48~56V DC DC Input: 48~56V DC Standards Compliance: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3af Power over Ethernet (802.3at Type 1) IEEE 802.3at Power over Ethernet (802.3at Type 2)
  • Model #: LRP-101UH
  • Item #: N82E16833987257
  • Return Policy: 15-Day Return Policy
$163.80
Free Shipping
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-621T series 2 x port 100Base-FX interface on ISW-621T for up to 2km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-621T
  • Item #: N82E16833322144
  • Return Policy: 15-Day Return Policy
$132.00
Free Shipping
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15km (-40 ~ 75 Degrees C Operating Temperature)
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15km (-40 ~ 75 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511TS15 for up to 15km (single-mode fiber 9/125µm) transmission distance
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-511TS15
  • Item #: N82E16833322142
  • Return Policy: 15-Day Return Policy
$123.99
Free Shipping
Planet MFB-FX SFP-Port 100Base-FX Transceiver (1310 nm) - 2 km
Planet MFB-FX SFP-Port 100Base-FX Transceiver (1310 nm) - 2 km
  • Device Type: Transceiver
  • Wavelength: 1310nm
  • Fiber Cable: Multi-Mode
  • Ports: LC
  • Model #: MFB-FX
  • Item #: N82E16833322152
  • Return Policy: 15-Day Return Policy
$32.99
Free Shipping
PLANET UPOE-1600G 16-Port Gigabit 60W Ultra PoE Managed Injector Hub (600 watts)
PLANET UPOE-1600G 16-Port Gigabit 60W Ultra PoE Managed Injector Hub (600 watts)
  • Type: PoE Injector
  • Specifications: Interface: "Data" Input Ports: 16 x RJ45 "Data + Power" Output Ports: 16 x RJ45 Management Port: 1 x RJ45; 10/100/1000BASE-T, auto-negotiation, auto-MDI/MDIX Data Rate: 10/100/1000Mbps LED System: SYS PWR x 1 (Green), PoE Failure x 1 (Red), Fan Failure x 2 (Red) Management port x 2: 1000 (Green), 10/100(Orange) Per PoE Port: Ultra 60W PoE-in-use x 1 (Green), 802.3at/af PoE-in-use x1 (Orange), PoE Power Usage LED x4 (Green) Power Requirements: 100 - 240V AC, 50/60 Hz, 8A Power Consumption: 800 watts (max.) / 2729BTU Ventilation: Fan x 3 Enclosure: Metal PoE Standard: IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus 4-pair Ultra PoE PoE Power Supply Type: End-span / Mid-span / UPoE (Ultra PoE) Power Pin Assignment: Pair 1 end-span: 1/2(-), 3/6(+) Pair 2 mid-span: 4/5(+), 7/8(-) UPoE: 1/2(-), 3/6(+),...
  • Model #: UPOE-1600G
  • Item #: N82E16833987038
  • Return Policy: 15-Day Return Policy
$1,029.60
Free Shipping
Planet MFB-TFX SFP-Port 100Base-FX Transceiver (1310 nm) - 2 km (-40 ~ 75 Degree C)
Planet MFB-TFX SFP-Port 100Base-FX Transceiver (1310 nm) - 2 km (-40 ~ 75 Degree C)
  • Device Type: Transceiver
  • Wavelength: 1310nm
  • Fiber Cable: Multi-Mode
  • Ports: LC
  • Model #: MFB-TFX
  • Item #: N82E16833322157
  • Return Policy: 15-Day Return Policy
$35.60
Free Shipping
Planet LRP-101C-KIT 1-Port Long Reach PoE Over Coax Extender Kit (LRP-101CH + LRP-101CE)
Planet LRP-101C-KIT 1-Port Long Reach PoE Over Coax Extender Kit (LRP-101CH + LRP-101CE)
  • Type: PoE Extender
  • Color: Black
  • Specifications: Ethernet Interface: LRP-101CH Copper: 10/100BASE-TX RJ45, auto-negotiation / auto-MDI/MDI-X Power over Ethernet Standard: IEEE 802.3at/af PoE PD (Powered Device) PoE Input: Supports both Mid-span and End-span PSE Input Range: 48~56V DC Data Rate: 100/100 Mbps Cabling: Cat5e or above Maximum Distance: 100 meters Maximum Frame Size: 1522 bytes LRP-101CE Copper: 10/100BASE-TX RJ45, Auto-negotiation / auto-MDI/MDI-X Power over Ethernet Standard: IEEE 802.3at/af PoE PSE (Power Source Equipment) PoE Output: 56V DC, 600mA max. PoE Budget: Up to 25 watts PoE Mode: End-span, RJ45 Pin 1/2 (+), 3/6 (-) Data Rate: 100/100 Mbps Cabling: Cat5e or above Maximum Distance: 100 meters Maximum Frame Size: 1522 bytes LED Indicators: LRP-101CH 4 x LEDs PWR LRP LNK PoE IN LNK / ACT LRP-101CE 4 x LEDs PWR LRP LNK PoE-in-us...
  • Model #: LRP-101C-KIT
  • Item #: 0EP-0060-000A5
  • Return Policy: 15-Day Return Policy
$301.99
Free Shipping
Planet MTB-SR SFP+ Port 10GBASE-SR Mini-GBIC Module (Multi-mode / 850 nm / max. 300m)
Planet MTB-SR SFP+ Port 10GBASE-SR Mini-GBIC Module (Multi-mode / 850 nm / max. 300m)
  • Wavelength: 850nm
  • Fiber Cable: Multi-mode
  • Ports: LC
  • Max Distance: 300m
  • Model #: MTB-SR
  • Item #: N82E16833322190
  • Return Policy: 15-Day Return Policy
$60.00
Free Shipping
PLANET PWR-480-48 DC Single Output Industrial DIN Rail Power Supply Units
PLANET PWR-480-48 DC Single Output Industrial DIN Rail Power Supply Units
  • Type: Power Supply
  • Specifications: Hardware Version: 2 Dimensions: 5.04" x 3.35" x 4.92" Weight: 3.31 lbs. Input Voltage: 100-240V AC, 50/60 Hz, 4.8A Power Output: 480 watts, 48V, 10A Temperature: Operating: -20 ~ 70 degrees C Storage: -40 ~ 85 degrees C Humidity: Operating: 20 ~ 95% Storage: 10 ~ 95% (non-condensing) Installation: DIN rail TS-35/7.5 or 15
  • Model #: PWR-480-48
  • Item #: N82E16833962009
  • Return Policy: 15-Day Return Policy
$161.99
Free Shipping
Planet LRP-101U-KIT 1-Port Long Reach PoE Over UTP Extender Kit (LRP-101UH + LRP-101UE)
Planet LRP-101U-KIT 1-Port Long Reach PoE Over UTP Extender Kit (LRP-101UH + LRP-101UE)
  • Type: PoE Extender
  • Color: Black
  • Specifications: Ethernet Interface: LRP-101UH Copper: 10/100BASE-TX RJ45, auto-negotiation / auto-MDI / MDI-X Power over Ethernet Standard: IEEE 802.3at/af PoE PD (Powered Device) PoE Input: Supports both mid-span and end-span PSE Input Range: 48~56V DC Data Rate: 100/100 Mbps Cabling: Cat5e or above Maximum Distance: 100m Maximum Frame Size: 1522 bytes LRP-101UE Copper: 10/100BASE-TX RJ45, auto-negotiation / auto-MDI / MDI-X Power over Ethernet Standard: IEEE 802.3at/af PoE PSE (Power Source Equipment) PoE Output: 48~56V DC, 600mA max. PoE Budget: Up to 25 watts PoE Mode: End-span, RJ45 Pin 1/2 (+), 3/6 (-) Data Rate: 100/100 Mbps Cabling: Cat5e or above Maximum Distance: 100m Maximum Frame Size: 1522 bytes LED Indicators: LRP-101UH 4 x LEDs PWR LRP LNK PoE IN LNK / ACT LRP-101UE 4 x LEDs PWR LRP LNK PoE-in-u...
  • Model #: LRP-101U-KIT
  • Item #: 0YH-00JP-000M6
  • Return Policy: 15-Day Return Policy
$289.80
Free Shipping
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-8P2S2X
  • Item #: N82E16833322129
  • Return Policy: 15-Day Return Policy
$979.80
Free Shipping
Planet VC-232G 1-Port Gigabit Ethernet over Coaxial Converter  Downstream: 200Mbps Upstream: 100Mbps
PLANET IXT-705AT Industrial 10G / 5G / 2.5G / 1G / 100M Copper to 10GBASE-X SFP+ Media Converter
PLANET IXT-705AT Industrial 10G / 5G / 2.5G / 1G / 100M Copper to 10GBASE-X SFP+ Media Converter
  • Device Type: Converter
  • Standards: IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3bz 2.5G / 5GBASE-T IEEE 802.3an 10GBASE-T IEEE 802.3ae 10Gbps Ethernet IEEE 802.3x full-duplex flow control
  • LEDs: System: Fault Alert (Red), PWR (Green) 10000/5000/2500/1000/100 BASE-T RJ45 Interfaces: 1/10G LNK(Orange) 5000/2500/100M LNK (Green)
  • Power Adapter: Power Requirements: DC 12~48V or 24V AC
  • Model #: IXT-705AT
  • Item #: N82E16833322227
  • Return Policy: 15-Day Return Policy
$281.99
Free Shipping
Planet MGB-SX2 SFP-Port 1000BASE-SX Mini-GBIC Module – 2 km
Planet MGB-SX2 SFP-Port 1000BASE-SX Mini-GBIC Module – 2 km
  • Device Type: Transceiver
  • Wavelength: 1310nm
  • Fiber Cable: Multi-Mode
  • Ports: LC
  • Model #: MGB-SX2
  • Item #: N82E16833322172
  • Return Policy: 15-Day Return Policy
$32.99
Free Shipping
Planet POE-173 60-Watt Ultra Power Over Ethernet Injector
Planet POE-173 60-Watt Ultra Power Over Ethernet Injector
  • Type: PoE Injector
  • Color: Black
  • Specifications: Interface: LAN: 1 x RJ-45 STP, "Data" Input Port POE: 1 x RJ-45 STP, "Data + Power" Output Port AC Connector: 1 x AC Input power socket, IEC-320 C6 Network Cable: Ultra PoE (60W): 4-pair UTP Cat. 5, 5e, 6 up to 100m (328 ft.) 802.3af / at PoE(15W / 30W): 2-pair UTP Cat. 3, 4, 5, up to 100m (328 ft.) LED Indicator: System: Power x 1 (Green) PoE Port: Active, PoE ready / In Use x 1 (Green) Data Rate: 10/100/1000 Mbps Unit Output Voltage: DC 50-57V, 1.2A Power Requirements: 100-240V AC @ 50/60 Hz, 1.5A max. Power Consumption: 60 watts max. PoE Standard: Ultra PoE over 4-pairs UTP, High Power over Ethernet End-Span / Mid-Span PSE PoE Power Supply Type: End-Span + Mid-Span Power Pin Assignment: Pair 1 End-Span: 1/2 (+), 3/6 (-) Pair 2 Mid-Span: 4/5 (+), 7/8 (-) PoE Power Output: DC 50-57V/60-w...
  • Model #: POE-173
  • Item #: 0XP-000B-00044
  • Return Policy: 15-Day Return Policy
$69.99
Free Shipping
Planet MGB-SX SFP-Port 1000BASE-SX mini-GBIC module - 550m
Planet MGB-SX SFP-Port 1000BASE-SX mini-GBIC module - 550m
  • Device Type: Transceiver
  • Ports: 1000Base-SX
  • Transfer Rate: 1 Gbps
  • Model #: MGB-SX
  • Return Policy: View Return Policy
$27.60
$28.99
$8.00 Shipping
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
  • Format: DIN Rail Mount
  • MAC Address Table: 8K MAC address table with auto learning function
  • Jumbo Frames: 9000 bytes
  • Buffer Memory: 1MB
  • Model #: WGS-804HP
  • Item #: 0XP-005D-00030
  • Return Policy: 15-Day Return Policy
$198.00
Free Shipping
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Flow Control
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX SFP interface
  • MAC Address Table: 2K
  • Switching Method: Store and Forward
  • Model #: ISW-621TF
  • Item #: 0EP-0060-00028
  • Return Policy: 15-Day Return Policy
$96.99
Free Shipping
PLANET POE-E201 IEEE802.3at High Power PoE Repeater (Extender)
PLANET POE-E201 IEEE802.3at High Power PoE Repeater (Extender)
  • Type: PoE Extender
  • Specifications: PoE Standard: IEEE 802.3af (Power over Ethernet) IEEE 802.3at (High Power over Ethernet) PoE Power Supply Type: Mid-Span / Type B PoE Power Output: 52V DC, 510 mA, Max. 26 watts Power Pin Assignment: 4/5 (+), 7/8 (-) Maximum Distance: 4 units, daisy-chain installation with 500m support Data Rate: 10/100/1000 Mbps Switch Architecture: Store-and-Forward Maximum Frame Size: 1552 Bytes Flow Control: Back pressure for half-duplex IEEE 802.3x pause frame for full-duplex LED Indicators: 1 x PoE IN (Green) 1 x LAN Data (Green) 1 x PoE OUT (Green) Power Requirements: IEEE 802.3at compliant with voltage within 52V-56V DC Power Consumption: 3.2 watts (system maximum)
  • Model #: POE-E201
  • Item #: 0EP-002Z-00002
  • Return Policy: 15-Day Return Policy
$74.99
Free Shipping
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-501T
  • Item #: 0EP-0060-00063
  • Return Policy: 15-Day Return Policy
$114.99
Free Shipping
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-801T
  • Item #: 0EP-0060-00078
  • Return Policy: 15-Day Return Policy
$159.99
Free Shipping
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x full-duplex Flow Control
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX interface on
  • MAC Address Table: 2K
  • Model #: ISW-621TS15
  • Item #: 0EP-0060-00089
  • Return Policy: 15-Day Return Policy
$152.00
Free Shipping
Planet MGSD-10080F 8-Port 100/1000X SFP + 2-Port 10/100/1000T Managed Metro Ethernet Switch
Planet MGSD-10080F 8-Port 100/1000X SFP + 2-Port 10/100/1000T Managed Metro Ethernet Switch
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid Spanning tree protocol IEEE 802.1s Multiple Spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2
  • Primary Ports: 8 1000Base-SX/LX/BX SFP interfaces, from port 1 to port 8 Compatible with 100Base-FX SFP, 2 10/ 100/1000Base-T RJ-45 Auto-MDI/MDI-X ports, 1 x RJ-45-to-RS-232 serial port (115200, 8, N, 1)
  • Primary Port Speed: 20Gbps / non-blocking
  • Model #: MGSD-10080F
  • Item #: 0XP-000B-00026
  • Return Policy: 15-Day Return Policy
$376.00
Free Shipping
PLANET POE-162S IEEE 802.3at Gigabit High Power Over Ethernet Splitter
PLANET POE-162S IEEE 802.3at Gigabit High Power Over Ethernet Splitter
  • Type: PoE Splitter
  • Color: White
  • Specifications: Interface: PoE (Power + Data) Input Port: 1 x RJ-45 STP Data” Output Port: 1 x RJ-45 STP DC Out Plug Connector: 1 LED Indicator System: PoE In x 1 (Green) Network Cable: 10Base-T: 2-Pair UTP Cat. 3, 4, 5, up to 100m (328 ft.) 100Base-TX: 2-Pair UTP Cat. 3, 4, 5, up to 100m (328 ft.) 1000Base-T: 2-Pair UTP Cat. 5, 5e, 6 up to 100m (328 ft.) EIA / TIA-568 100-ohm STP (100m) Data Rate: 10/100/1000 Mbps (varies on Ethernet device attached) DIP Switch: 12V DC / 24V DC output voltage Power Input: 802.3at PoE+ 52 ~ 56V DC PoE Standard: IEEE 802.3at High Power over Ethernet Number of clients device can be powered: 1 Power Output: 12V DC, 2A max 24V DC, 1A max Standards Compliance: IEEE 802.3 10Base-T Ethernet IEEE 802.3u 100Base-TX Fast Ethernet IEEE 802.3ab 1000Base-T Gigabit Ethernet IEEE 802.3at...
  • Model #: POE-162S
  • Item #: 0EP-002Z-00004
  • Return Policy: 15-Day Return Policy
$53.99
Free Shipping
Planet MGB-TLX SFP-Port 1000BASE-LX mini-GBIC module - 10 km (-40 ~ 75 Degree C)
Planet MGB-TLX SFP-Port 1000BASE-LX mini-GBIC module - 10 km (-40 ~ 75 Degree C)
  • Ports: 1000Base-LX
  • Transfer Rate: 1 Gbps
  • Model #: MGB-TLX
  • Item #: 2AS-0027-00004
  • Return Policy: 15-Day Return Policy
$37.20
Free Shipping
PLANET PWR-120-48 120W 48V DC Single Output Industrial DIN Rail Power Supply (-20 ~ 70 Degrees C)
PLANET PWR-120-48 120W 48V DC Single Output Industrial DIN Rail Power Supply (-20 ~ 70 Degrees C)
  • Type: Power Supply
  • Specifications: Hardware Version: 2 Input Voltage: 100-240V AC,50/60 Hz, 2.25A Power Output: 120 watts, 48V, 2.5A Installation: DIN rail TS-35/7.5 or 15 Safety & Function: Ul508, TUV EN60950-1 approved (meeting EN60204-1)
  • Model #: PWR-120-48
  • Item #: 0EP-0060-00027
  • Return Policy: 15-Day Return Policy
$69.99
Free Shipping
PLANET UPOE-800G 8-Port Gigabit 60W Ultra PoE Managed Injector Hub (400 watts)
PLANET UPOE-800G 8-Port Gigabit 60W Ultra PoE Managed Injector Hub (400 watts)
  • Type: PoE Injector
  • Specifications: Interface: "Data" Input Ports: 8 x RJ45 "Data + Power" Output Ports: 8 x RJ45 Management Port: 1 x RJ45; 10/100/1000BASE-T, auto-negotiation, auto-MDI/MDIX Data Rate: 10/100/1000Mbps LED System: SYS PWR x 1 (Green), PoE Failure x 1 (Red), Fan Failure x 2 (Red) Management port x 2: 1000 (Green), 10/100(Orange) Per PoE Port: Ultra 60W PoE-in-use x 1 (Green), 802.3at/af PoE-in-use x1 (Orange), PoE Power Usage LED x4 (Green) Power Requirements: 100 - 240V AC, 50/60 Hz, 6.5A Power Consumption: 520 watts (max.) / 1774BTU Ventilation: Fan x 3 Enclosure: Metal PoE Standard: IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus 4-pair Ultra PoE PoE Power Supply Type: End-span / Mid-span / UPoE (Ultra PoE) Power Pin Assignment: Pair 1 end-span: 1/2 (-), 3/6 (+) Pair 2 mid-span: 4/5 (+), 7/8 (-) UPoE: 1/2 (-), 3/...
  • Model #: UPOE-800G
  • Item #: N82E16833987040
  • Return Policy: 15-Day Return Policy
$761.20
Free Shipping
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-801T
  • Item #: 0EP-0060-00068
  • Return Policy: 15-Day Return Policy
$657.00
Free Shipping
Planet POE-171 Single-Port 10/100/1000 Mbps Ultra PoE Injector (60 Watts)
Planet POE-171 Single-Port 10/100/1000 Mbps Ultra PoE Injector (60 Watts)
  • Type: PoE Injector
  • Color: Black
  • Specifications: Interface: Input Port 1 x RJ-45 STP Data In Output Port 1 x RJ-45 STP PoE (Data + Power) Out DC socket 56V DC Input LED Indicator: System: Power x 1 (Green) PoE Port: PoE in Use x 1 (Green) Network Cable: Ultra PoE (60W): 10/100/1000Base-T: 4-Pair UTP Cat. 5e, 6 up to 100m (328 ft.) 802.3af/at PoE(15W / 30W): 10/100/1000Base-T: 2-Pair UTP Cat. 3, 5, 5e, 6 up to 100m (328 ft.) Data Rate: 10/100/1000 Mbps Unit Input Voltage: DC 56V Power Requirements: External AC-to-DC adapter 100-240V AC, 50/60 Hz, 1.5A Power Consumption: 65 watts max. PoE Standard: IEEE 802.3at High Power over Ethernet End-span / Mid-span PSE Power Output: DC 56V / 60-watt PoE via 4-pairs DC 56V / 30-watt PoE via 2-pairs PoE Power Supply Type: End-Span + Mid-Span Power Pin Assignment: Pair 1: 1/2 (-), 3/6 (+) Pair 2: 4/5 (+), ...
  • Model #: POE-171
  • Item #: 9SIA8WVKCX0842
  • Return Policy: View Return Policy
$69.99
$9.00 Shipping
PLANET GT-802S 10/100/1000Base-T to 1000LX Gigabit Media Converter (SM, SC, 10 km)
PLANET GT-802S 10/100/1000Base-T to 1000LX Gigabit Media Converter (SM, SC, 10 km)
  • Device Type: Converter
  • Standards: IEEE 802.3, 10Base-T IEEE 802.3u, 100Base-TX IEEE 802.3ab, 1000Base-T IEEE 802.3z, 1000Base-SX/LX
  • Wavelength: 1310nm
  • Ports: 1 x 10/100/1000Base-T port 1 x 1000Base-SX/LX port
  • Model #: GT-802S
  • Return Policy: View Return Policy
$85.99
Free Shipping
PLANET IGS-4215-8P2T2S Managed 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
PLANET IGS-4215-8P2T2S 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 10/100/1000T 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: IGS-4215-8P2T2S
  • Return Policy: View Return Policy
$651.20
$8.00 Shipping
PLANET GS-4210-16P2S Managed 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
PLANET GS-4210-16P2S 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3
  • Primary Ports: 16 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 100/1000BASE-X mini-GBIC/SFP slots 1 x RJ45 console interface for switch basic management and setup
  • MAC Address...
  • Model #: GS-4210-16P2S
  • Return Policy: View Return Policy
$325.00
$14.00 Shipping
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-804HPT
  • Return Policy: View Return Policy
$259.60
Free Shipping
Planet IGS-12040MT Industrial 8-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
Planet IGS-12040MT Industrial 8-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
  • Format: DIN Rail Mount
  • Uplink Ports: 4
  • Primary Port Speed: 10/100/1000Mbps
  • VLAN Support: Yes
  • Model #: IGS-12040MT
  • Return Policy: View Return Policy
$519.00
$520.00
$8.00 Shipping
Planet IGS-5225-4T2S Industrial L2+ 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
Planet IGS-5225-4T2S Industrial L2+ 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
  • Format: DIN Rail Mount
  • VLAN Support: Yes
  • Jumbo Frames: 9000 bytes
  • SNMP: Yes
  • Model #: IGS-5225-4T2S
  • Return Policy: View Return Policy
$343.20
$352.00
Free Shipping
PLANET IVC-234GT Unmanaged Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
PLANET IVC-234GT Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet ITU-T G.993.1 VDSL ITU-T G.997.1 ITU-T G.993.2 VDSL2 (Profile 17a/30a Support) ITU-T G.993.5 G.Vectoring and G.INP ITU-T G.998
  • Primary Ports: 4 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IVC-234GT
  • Return Policy: View Return Policy
$252.00
Free Shipping
PLANET GT-805A 10/100/1000Base-T to 1000FX (SFP) Media Converter
PLANET GT-805A 10/100/1000Base-T to 1000FX (SFP) Media Converter
  • Device Type: Converter
  • Standards: IEEE 802.3, 10Base-T IEEE 802.3u, 100Base-TX IEEE 802.3ab, 1000Base-T IEEE 802.3z, 1000Base-SX/LX
  • Ports: 1 x 10/100/1000Base-T port 1 x 1000Base-SX/LX port
  • LEDs: PWR TP LINK / ACT, 1000 Fiber LINK / ACT
  • Model #: GT-805A
  • Return Policy: View Return Policy
$69.00
Free Shipping
Planet ISW-500T IP30 Compact Size 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 degrees C)
Planet ISW-500T IP30 Compact Size 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 degrees C)
Save 6%
$81.40
$87.00
$8.00 Shipping
Planet IGS-20040MT L2+ Industrial 16-Port 10/100/1000T + 4 100/1000X SFP Managed Switch (-40 ~ 75 degrees C)
Planet IGS-20040MT L2+ Industrial 16-Port 10/100/1000T + 4 100/1000X SFP Managed Switch (-40 ~ 75 degrees C)
  • Format: DIN Rail Mount
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100Mbps + 1000Mbps
  • VLAN Support: Yes
  • Model #: IGS-20040MT
  • Return Policy: View Return Policy
Save 30%
$712.00
$1,026.00
Free Shipping
Planet GS-4210-16T2S 16-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces
Planet GS-4210-16T2S 16-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces
  • Format: Rackmount
  • Primary Port Speed: 10/100/1000Mbps
  • VLAN Support: Yes
  • Jumbo Frames: 9000 bytes
  • Model #: GS-4210-16T2S
  • Return Policy: View Return Policy
$164.00
Free Shipping
PLANET IGT-1205AT Industrial 10/100/1000T to 2-port 100/1000X SFP Media Converter
PLANET IGT-1205AT Industrial 10/100/1000T to 2-port 100/1000X SFP Media Converter
  • Device Type: Converter
  • Standards: IEEE 802.3 Ethernet / 10Base-T IEEE 802.3u Fast Ethernet / 100Base-TX IEEE 802.3ab Gigabit Ethernet / 1000Base-T IEEE 802.3z Gigabit Ethernet / 1000Base-SX/LX IEEE 802.3x Full-Duplex Flow Control
  • Ports: 1-port 10/100/1000Base-T RJ-45 with auto MDI / MDI-X function 2-port SFP slot interface, SFP supports 1000Base-X and 100Base-FX transceiver via DIP switch configured
  • LEDs: 3 x LED for System and Power: Green: DC Power 1 Green: DC Power 2 Green: Power Fault 2 x LED for Per Copper Port: Green: 1000 LNK / ACT Orange:100 LNK / ACT 1 x LED for Per mini-GBIC interface (Port-1 and Port-2): Green: LNK / ACT
  • Model #: IGT-1205AT
  • Return Policy: View Return Policy
$198.00
Free Shipping

Leading the Way in Networking Solutions

Welcome to PLANET, a trailblazer in the realm of networking solutions. Renowned for our cutting-edge technologies, we offer an extensive array of products designed to enhance connectivity and facilitate seamless communication. Our portfolio spans advanced Switches and versatile Network Transceivers, catering to both enterprise and residential needs. PLANET products are engineered to support reliable and efficient data transmission, empowering users to stay connected anytime, anywhere.

Innovative Product Range

With PLANET, you gain access to a diverse product lineup including state-of-the-art Switch Modules and intuitive Wired & Wireless Accessories. Our offerings ensure that all your networking essentials are covered, from Modems / Gateways that provide robust internet access, to Home Safety & Security products that safeguard your connected spaces. At PLANET, innovation meets practicality in every solution we deliver.

Integration and Flexibility

PLANET excels in delivering integration capabilities with our dynamic Powerline Networking and Data Converters, allowing for seamless assimilation into existing setups. Our Network Connectors/Adapters offer unparalleled flexibility, ensuring compatibility and ease of use across various platforms and devices. The adaptability of PLANET products makes them a perfect match for customized networking environments.

Ensuring Top-Notch Connectivity

Stay ahead in the networking world with PLANET's cutting-edge technologies. From versatile 2 in 1 Accessories to reliable Hub devices, each product is designed to improve your connectivity experience. Our commitment to quality and durability ensures that PLANET is the go-to brand for anyone seeking exceptional and reliable networking products. Experience the power of superior connectivity, only with PLANET.