Skip to main content
Interamerican Tech Corp, has provided the most cost effective products of wireless broadband networking equipment, two-way communications, telecommunications solutions, IP surveillance/security, VoIP, marine products, GPS and green technologies.
itamtech Store
  • ITAMTECH STORE
  • 7 Followers 
     
    4.3(32 total ratings)
  • CONTACT
All Products
Reviews
32
Return Policy
About Us
itamtech Store
  • ITAMTECH STORE
  • 7 Followers 
     
    4.3(32 total ratings)
  • CONTACT
All Products
Reviews
32
Return Policy
About Us
Sort By
101 Items
View
  1. 1 / 2
Yealink W76P High-performance DECT IP phone system with user-centric design
Yealink W76P High-performance DECT IP phone system with user-centric design
  • Brand: Yealink
  • Part Number: W76P
  • Type: IP DECT Phone Kit
  • Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) SNTP/NTP VLAN (802.1Q and 802.1P) 802.1x, LLDP STUN Client (NAT Traversal) UDP/TCP/TLS IP assignment: Static/DHCP Support outbound proxy server backup Open VPN Transport Layer Security (TLS) HTTPS (server/client), SRTP (RFC3711) Digest authentication Secure configuration file via AES encryption Support SHA256/SHA512/SHA384 Three-level configuration mode: Admin/Var/User
  • Model #: W76P
  • Return Policy: View Return Policy
$207.65
Free Shipping
Ubiquiti POE-24-30W 24V DC 30W PoE for BaseStation Equipment
Ubiquiti POE-24-30W 24V DC 30W PoE for BaseStation Equipment
  • Type: PoE Adapter
  • Color: Black
  • Specifications: Output Voltage: 24V DC @ 1.25A Gigabit LAN Port: Yes Rated Voltage: 100-240V AC @ 50/60 Hz Input Current: 0.6A @ 120V AC, 0.4A @ 240V AC Inrush Current: <60A Peak @ 120V AC, <120A Peak @ 230V AC Efficiency: 83+% Output Ripple: 1% Max. Switching Frequency: 65 kHz Operating Temperature: 0 to 40°C (32 to 104°F) Storage Temperature: -30 to 70°C (-22 to 158°F) Operating Humidity: 35 to 95% Noncondensing Dimensions: 3.70" x 2.36" x 1.30" Weight: 0.34 lb.
  • Model #: POE-24-30W
  • Return Policy: View Return Policy
$19.00
Free Shipping
Samlex SEC-1212 SEC-1212 Desktop Switching Power Supply
Samlex SEC-1212 SEC-1212 Desktop Switching Power Supply
$215.78
Free Shipping
Grandstream 2x2 Dual Band Wi-Fi 7 Indoor AP, 1 x 2.5 GigE, BLE GWN7670
Thonet and Vander DUNN Sound Bar 2.1 with Wireless Subwoofer Bluetooth 250W Peak Power Speaker System for Home Theater
MikroTik S-85DLC05D SFP module 1.25G MM 550m 850nm
MikroTik S-85DLC05D SFP module 1.25G MM 550m 850nm
$41.76
Free Shipping
PLANET GT-802S 10/100/1000Base-T to 1000LX Gigabit Media Converter (SM, SC, 10 km)
PLANET GT-802S 10/100/1000Base-T to 1000LX Gigabit Media Converter (SM, SC, 10 km)
  • Device Type: Converter
  • Standards: IEEE 802.3, 10Base-T IEEE 802.3u, 100Base-TX IEEE 802.3ab, 1000Base-T IEEE 802.3z, 1000Base-SX/LX
  • Wavelength: 1310nm
  • Ports: 1 x 10/100/1000Base-T port 1 x 1000Base-SX/LX port
  • Model #: GT-802S
  • Return Policy: View Return Policy
$85.99
Free Shipping
GRANDSTREAM GXP1628 SMALL BUSINESS IP PHONE 2 SIP
GRANDSTREAM GXP1628 SMALL BUSINESS IP PHONE 2 SIP
$93.75
Free Shipping
Grandstream GXP2170 -Enterprise IP Phone, 12 Line, Color Display -VoIP
Grandstream GXP2170 -Enterprise IP Phone, 12 Line, Color Display -VoIP
  • Brand: Grandstream
  • Type: Other
  • Weight: 3.5000
  • Model #: GXP2170
  • Return Policy: View Return Policy
$183.53
Free Shipping
Yealink SIP-T34W IP Phone Corded/Cordless Wi-Fi, Bluetooth Wall Mountable + PS
Yealink SIP-T34W IP Phone Corded/Cordless Wi-Fi, Bluetooth Wall Mountable + PS
  • Brand: Yealink
  • Type: Video Conference Device
  • Model #: 841885119780
  • Return Policy: View Return Policy
$129.00
Free Shipping
Planet POE-151 IEEE 802.3af Power Over Ethernet Injector (Mid-Span)
Planet POE-151 IEEE 802.3af Power Over Ethernet Injector (Mid-Span)
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3af Power over Ethernet
  • Ports: 2 x RJ-45 (1 for data + DC out, 1 for Data in)
  • LEDs: 1 x power, 1 x POE ready / in-use
  • Cabling: TIA/EIA-568, Category 5/5e cable
  • Model #: POE-151
  • Item #: 9SIA513KPB8985
  • Return Policy: View Return Policy
$29.99
Free Shipping
Thonet and Vander Fleck 7 300W Peak/70W RMS Outdoor Bluetooth Speaker - White
Thonet and Vander Fleck 7 300W Peak/70W RMS Outdoor Bluetooth Speaker - White
$88.00
$27.54 Shipping
GRANDSTREAM GXP2140 HIGH-END IP PHONE 4 SIP
GRANDSTREAM GXP2140 HIGH-END IP PHONE 4 SIP
  • Brand: Grandstream
  • Model: GXP2140
  • Type: Office Products
  • Parts: 1
  • Model #: GS-GXP2140
  • Return Policy: View Return Policy
$159.67
Free Shipping
MikroTik - RBLTAP-2HND - MikroTik LtAP Weatherproof Wireless 2.4GHz Access Point w/Built in GPS (without LTE card)
MikroTik - RBLTAP-2HND - MikroTik LtAP Weatherproof Wireless 2.4GHz Access Point w/Built in GPS (without LTE card)
  • Brand: MikroTik
  • Series: LtAP series
  • Model #: RBLTAP-2HND
  • Item #: 9SIA513KPA9721
  • Return Policy: View Return Policy
$155.00
Free Shipping
Grandstream Gxp2160 Ip Phone - Bluetooth - Desktop Wall Mountable
Grandstream Gxp2160 Ip Phone - Bluetooth - Desktop Wall Mountable
  • Brand: Grandstream
  • Model: GS-GXP2160
  • Type: IP Phone
  • Protocols: TCP/IP
  • Model #: GS-GXP2160
  • Return Policy: View Return Policy
$181.49
Free Shipping
Thonet and Vander GUT Sound Bar Bluetooth 120W Peak Power Speaker System for Home Theater
Thonet and Vander GUT Sound Bar Bluetooth 120W Peak Power Speaker System for Home Theater
  • Color: Black/Gray
  • Model #: HK096-03607
  • Item #: 9SIA513DMB7555
  • Return Policy: View Return Policy
$56.55
$19.99 Shipping
Grandstream Dp760 Phone Base Station
Grandstream Dp760 Phone Base Station
$154.89
Free Shipping
Yealink SIP- T31P Entry-level IP Phone with 2 Lines & HD voice
Yealink SIP- T31P Entry-level IP Phone with 2 Lines & HD voice
  • Brand: Yealink
  • Part Number: SIP-T31P
  • Type: VoIP Phones
  • Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV (RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE WPA2/WPA3 Secure boot GARP (Generic Attribute Registration Protocol)
  • Model #: SIP-T31P
  • Return Policy: View Return Policy
$82.93
Free Shipping
Yealink RT30 DECT Repeater
Yealink RT30 DECT Repeater
  • Brand: Yealink
  • Frequency Band: Indoor range up to 50m (In ideal conditions) Outdoor range up to 300m (In clear view and ideal conditions) 2 internal QWL omnidirectional antennas Modulation: GFSK Radio frequency range: 1880 MHz to 1900 MHz (EU) 1920 MHz to 1930 MHz (US) 1902 MHz to 1906 MHz (TH) 1910 MHz to 1920 MHz (BR) Transmission power: Average 10mW RX sensitivity: typ. -91dBm
  • Power: AC 100-240V Input and DC 5V/600mA Output
  • Features: Extending the DECT coverage Supports automatic handover of calls between RT30 Up to 4 simultaneous calls per repeater Up to 6 repeaters per base station Up to 2 repeaters can be arranged in cascade (only when connected to W60B/W70B) Auto association Base Link Reset LED Display: LED 1 Power On LED 2 DECT Link LED 3 Active Relay Compatible with Yealink W60B (version 77.81.0.35 or l...
  • Model #: RT30
  • Return Policy: View Return Policy
$196.15
Free Shipping