Your Browsing History
Interamerican Tech Corp, has provided the most cost effective products of wireless broadband networking equipment, two-way communications, telecommunications solutions, IP surveillance/security, VoIP, marine products, GPS and green technologies.
- ITAMTECH STORE
- 7 Followers
All Products
Reviews
32
Return Policy
About Us
- ITAMTECH STORE
- 7 Followers
All Products
Reviews
32
Return Policy
About Us
Filter

Yealink W76P High-performance DECT IP phone system with user-centric design
- Brand: Yealink
- Part Number: W76P
- Type: IP DECT Phone Kit
- Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) SNTP/NTP VLAN (802.1Q and 802.1P) 802.1x, LLDP STUN Client (NAT Traversal) UDP/TCP/TLS IP assignment: Static/DHCP Support outbound proxy server backup Open VPN Transport Layer Security (TLS) HTTPS (server/client), SRTP (RFC3711) Digest authentication Secure configuration file via AES encryption Support SHA256/SHA512/SHA384 Three-level configuration mode: Admin/Var/User
- Model #: W76P
- Return Policy: View Return Policy
$224.26
Free Shipping

Ubiquiti POE-24-30W 24V DC 30W PoE for BaseStation Equipment
- Type: PoE Adapter
- Color: Black
- Specifications: Output Voltage: 24V DC @ 1.25A Gigabit LAN Port: Yes Rated Voltage: 100-240V AC @ 50/60 Hz Input Current: 0.6A @ 120V AC, 0.4A @ 240V AC Inrush Current: <60A Peak @ 120V AC, <120A Peak @ 230V AC Efficiency: 83+% Output Ripple: 1% Max. Switching Frequency: 65 kHz Operating Temperature: 0 to 40°C (32 to 104°F) Storage Temperature: -30 to 70°C (-22 to 158°F) Operating Humidity: 35 to 95% Noncondensing Dimensions: 3.70" x 2.36" x 1.30" Weight: 0.34 lb.
- Model #: POE-24-30W
- Return Policy: View Return Policy
$19.00
Free Shipping

MikroTik - CRS326-24G-2S+IN - Cloud Router Switch 326-24G-2S+RM with 800MHz CPU, 512MB RAM, 24x Gigabit LAN, 2x SFP+
- Model #: CRS326-24G-2S+IN
- Return Policy: View Return Policy
$238.73
Free Shipping

Samlex SEC-1212 SEC-1212 Desktop Switching Power Supply
- Model #: SEC-1212
- Return Policy: View Return Policy
$215.78
Free Shipping

Mikrotik hEX RB750Gr3 Router with 5x Gigabit Ethernet Ports 1x USB Port and 1x microSD Slot
- Switch Type: Ethernet Router
- Uplink Ports: 5
- Uplink Interface: RJ45
- Primary Ports: 5 x 10/100/1000
- Model #: RB750Gr3
- Return Policy: View Return Policy
$81.79
Free Shipping

Grandstream 2x2 Dual Band Wi-Fi 7 Indoor AP, 1 x 2.5 GigE, BLE GWN7670
- Model #: GS-GWN7670
- Return Policy: View Return Policy
$139.74
Free Shipping

Thonet and Vander DUNN Sound Bar 2.1 with Wireless Subwoofer Bluetooth 250W Peak Power Speaker System for Home Theater
- Model #: ADIB07FDH18FY
- Item #: 9SIA513B0E9920
- Return Policy: View Return Policy
$59.99
$30.66 Shipping

MikroTik S-85DLC05D SFP module 1.25G MM 550m 850nm
- Device Type: Transceiver
- Model #: S-85DLC05D
- Return Policy: View Return Policy
$41.76
Free Shipping

Grandstream GRP2613 3-Line Gigabit IP Phone
- Brand: Grandstream
- Model #: GRP2613
- Return Policy: View Return Policy
$98.02
Free Shipping

PLANET GT-802S 10/100/1000Base-T to 1000LX Gigabit Media Converter (SM, SC, 10 km)
- Device Type: Converter
- Standards: IEEE 802.3, 10Base-T IEEE 802.3u, 100Base-TX IEEE 802.3ab, 1000Base-T IEEE 802.3z, 1000Base-SX/LX
- Wavelength: 1310nm
- Ports: 1 x 10/100/1000Base-T port 1 x 1000Base-SX/LX port
- Model #: GT-802S
- Return Policy: View Return Policy
$85.99
Free Shipping

GRANDSTREAM GXP1625 SMALL BUSINESS IP PHONE 2 SIP
- Brand: Grandstream
- Type: Office Products
- Weight: 2.25
- Model #: GXP1625
- Return Policy: View Return Policy
$71.60
Free Shipping

Grandstream GXP2170 -Enterprise IP Phone, 12 Line, Color Display -VoIP
- Brand: Grandstream
- Type: Other
- Weight: 3.5000
- Model #: GXP2170
- Return Policy: View Return Policy
$183.53
Free Shipping

GRANDSTREAM GXP1628 SMALL BUSINESS IP PHONE 2 SIP
- Brand: Grandstream
- Type: Office Products
- Model #: GXP1628
- Return Policy: View Return Policy
$93.75
Free Shipping

GRANDSTREAM GXP2140 HIGH-END IP PHONE 4 SIP
- Brand: Grandstream
- Model: GXP2140
- Type: Office Products
- Parts: 1
- Model #: GS-GXP2140
- Return Policy: View Return Policy
$159.67
Free Shipping

Yealink SIP-T34W IP Phone Corded/Cordless Wi-Fi, Bluetooth Wall Mountable + PS
- Brand: Yealink
- Type: Video Conference Device
- Model #: 841885119780
- Return Policy: View Return Policy
$129.00
Free Shipping

Thonet and Vander Fleck 7 300W Peak/70W RMS Outdoor Bluetooth Speaker - White
- Color: White
- Model #: HK096-03599
- Item #: 9SIA513FGE3495
- Return Policy: View Return Policy
$88.00
$27.54 Shipping

Grandstream Gxp2160 Ip Phone - Bluetooth - Desktop Wall Mountable
- Brand: Grandstream
- Model: GS-GXP2160
- Type: IP Phone
- Protocols: TCP/IP
- Model #: GS-GXP2160
- Return Policy: View Return Policy
$181.49
Free Shipping

Planet POE-151 IEEE 802.3af Power Over Ethernet Injector (Mid-Span)
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3af Power over Ethernet
- Ports: 2 x RJ-45 (1 for data + DC out, 1 for Data in)
- LEDs: 1 x power, 1 x POE ready / in-use
- Cabling: TIA/EIA-568, Category 5/5e cable
- Model #: POE-151
- Item #: 9SIA513KPB8985
- Return Policy: View Return Policy
$29.99
Free Shipping

Yealink SIP- T31P Entry-level IP Phone with 2 Lines & HD voice
- Brand: Yealink
- Part Number: SIP-T31P
- Type: VoIP Phones
- Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV (RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE WPA2/WPA3 Secure boot GARP (Generic Attribute Registration Protocol)
- Model #: SIP-T31P
- Return Policy: View Return Policy
$84.38
Free Shipping

MikroTik - RBLTAP-2HND - MikroTik LtAP Weatherproof Wireless 2.4GHz Access Point w/Built in GPS (without LTE card)
- Brand: MikroTik
- Series: LtAP series
- Model #: RBLTAP-2HND
- Item #: 9SIA513KPA9721
- Return Policy: View Return Policy
$155.00
Free Shipping

Grandstream Dp760 Phone Base Station
- Part Number: DP760
- Model #: DP760
- Return Policy: View Return Policy
$154.89
Free Shipping

Thonet and Vander GUT Sound Bar Bluetooth 120W Peak Power Speaker System for Home Theater
- Color: Black/Gray
- Model #: HK096-03607
- Item #: 9SIA513DMB7555
- Return Policy: View Return Policy
$56.55
$19.99 Shipping

Grandstream - WP810 - Grandstream WP810 WiFi Phone
- Model #: WP810
- Return Policy: View Return Policy
$119.61
Free Shipping

Yealink RT30 DECT Repeater
- Brand: Yealink
- Frequency Band: Indoor range up to 50m (In ideal conditions) Outdoor range up to 300m (In clear view and ideal conditions) 2 internal QWL omnidirectional antennas Modulation: GFSK Radio frequency range: 1880 MHz to 1900 MHz (EU) 1920 MHz to 1930 MHz (US) 1902 MHz to 1906 MHz (TH) 1910 MHz to 1920 MHz (BR) Transmission power: Average 10mW RX sensitivity: typ. -91dBm
- Power: AC 100-240V Input and DC 5V/600mA Output
- Features: Extending the DECT coverage Supports automatic handover of calls between RT30 Up to 4 simultaneous calls per repeater Up to 6 repeaters per base station Up to 2 repeaters can be arranged in cascade (only when connected to W60B/W70B) Auto association Base Link Reset LED Display: LED 1 Power On LED 2 DECT Link LED 3 Active Relay Compatible with Yealink W60B (version 77.81.0.35 or l...
- Model #: RT30
- Return Policy: View Return Policy
$196.15
Free Shipping

Teltonika RUT241098000 RUT241 4G LTE Router New Sealed
- Model #: RUT241098000
- Return Policy: View Return Policy
$399.71
Free Shipping

Grandstream Cordless WiFi IP Phone WP826 SIP Phone
- Parts: 1-Year Warranty
- Labor: 1-Year Warranty
- Model #: GS-WP826
- Return Policy: View Return Policy
$124.36
Free Shipping

Yealink AX83H Wi-Fi Handset
- Brand: Yealink
- Type: Voice Conferencing Device
- Model #: AX83H
- Return Policy: View Return Policy
$146.32
Free Shipping

Grandstream GAC2570 Enterprise Conference Phone with Battery, Part# GAC2570
- Model #: GAC2570
- Return Policy: View Return Policy
$759.82
Free Shipping

Yealink CAM50 HD Camera for SIP-T58V / SIP-T58A, 2 mega-pixel, plug and play
- Model #: CAM50
- Return Policy: View Return Policy
$152.51
Free Shipping

GRANDSTREAM DP752 Powerful DECT VoIP Base Station
- Model #: GS-DP752
- Return Policy: View Return Policy
$83.70
Free Shipping

GRANDSTREAM GXP1620 SMALL BUSINESS IP PHONE 2 SIP
- Brand: Grandstream
- Type: Office Products
- Weight: 2.35
- Model #: GXP1620
- Return Policy: View Return Policy
$69.27
Free Shipping

Grandstream - GAC2500 - Grandstream GAC2500 IP Conference Station - Corded/Cordless - Corded/Cordless - Bluetooth, Wi-Fi
- Model #: GAC2500
- Return Policy: View Return Policy
$424.20
Free Shipping

mikrotik crs125-24g-1s-2hnd-i mikrotik crs125-24g-1s-2hnd-in, cloud router gigabit switch l3 2 mikrotik cloud router switch crs
- Model #: RNAB017ETSU6A
- Item #: 9SIA513D3F5308
- Return Policy: View Return Policy
$303.05
Free Shipping

Grandstream Compact Hotel Phone w/ built-in WiFi - Black GHP611W
- Parts: 1-Year Manufacturer Warranty
- Labor: 1-Year Manufacturer Warranty
- Model #: GS-GHP611W
- Return Policy: View Return Policy
$84.72
Free Shipping

Mikrotik RBFTC11 Fiber to Copper converter 12-57V PoE with 802.3af/at Support and Outdoor Case
- Model #: RBFTC11
- Return Policy: View Return Policy
$59.70
Free Shipping

Mikrotik CCR2004-16G-2S+ 16x Gigabit Ethernet Ports 2x10G SFP+ New Sealed
- Model #: CCR2004-16G-2S+
- Return Policy: View Return Policy
$505.18
Free Shipping

Grandstream Enterprise Layer 3 Managed PoE Network Switch, 48 x GigE (40 x PoE+, 8 x PoE++), 6 x SFP+ GWN7816P
- Model #: GS-GWN7816P
- Return Policy: View Return Policy
$909.72
Free Shipping

Grandstream GWN7605LR Outdoor Long-Range Wi-Fi Access Point
- Wireless Data Rates: 1.27 gigabits_per_second
- Frequency Band: 2.4 GHz / 5 GHz
- Interface: 2
- Brand: Grandstream
- Model #: GWN7605LR
- Return Policy: View Return Policy
$128.51
Free Shipping

Grandstream 2x2x2 Tri-Band Wi-Fi 7 Indoor AP, 1 x 2.5 GigE, 1 x 10G SFP+, BLE GWN7672
- Parts: 1-Year Manufacturer Warranty
- Labor: 1-Year Manufacturer Warranty
- Model #: GS-GWN7672
- Return Policy: View Return Policy
$205.59
Free Shipping

Cambium Networks - PL-R195WUSA-US - Residential Router cnPilot r195W Cloud Management, 5 Ports Gigabit, Dual Band, Ideal
- Frequency Band: 2.4 GHz / 5 GHz
- Model #: PL-R195WUSA-US
- Item #: 9SIA513HWR7421
- Return Policy: View Return Policy
$111.20
Free Shipping

Grandstream Enterprise Layer 2+ Managed PoE Network Switch, 16 x GigE, 4 x SFP GWN7802P
- Parts: 1-Year Manufacturer Warranty
- Labor: 1-Year Manufacturer Warranty
- Model #: GS-GWN7802P
- Item #: 9SIA513KRR2388
- Return Policy: View Return Policy
$271.41
Free Shipping

Mikrotik PowerBox RB750P-PBr2 5 Port Outdoor Router with PoE Output on 4 Ports
- Model #: RB750P-PBr2
- Item #: 9SIA5134U20810
- Return Policy: View Return Policy
$99.34
Free Shipping

Mikrotik RB4011iGS+RM 10 port Router with 1x SFP+ 10Gbps port Quad-core 1.4Ghz CPU and Rack Ears
- Brand: Mikrotik
- Model #: RB4011iGS+RM -1
- Item #: 9SIA513JY39131
- Return Policy: View Return Policy
$250.14
Free Shipping

Grandstream Small Business 1-Line IP Phone w/POE, Part# GXP1615
- Model #: GXP1615*
- Item #: 9SIA513KRU2647
- Return Policy: View Return Policy
$54.78
Free Shipping

Grandstream Ip Video Door System with Ip Surveillance Camera and Ip Intercom (GDS3710)
- Protocol: Bluetooth
- Type: Smart Garage
- Model #: GDS3710
- Return Policy: View Return Policy
$310.46
Free Shipping

Teltonika TSW100000010 TSW100 POE Switch New Sealed
- Model #: TSW100000010
- Return Policy: View Return Policy
$122.63
Free Shipping

Grandstream GS-DP735 (NEW, GA 2H Oct)
- Brand: Grandstream
- Model #: GS-DP735
- Return Policy: View Return Policy
$122.82
Free Shipping

MikroTik CRS326-24S+2Q+RM
- Model #: B08438BGRS
- Item #: 9SIA513JY39132
- Return Policy: View Return Policy
$644.04
Free Shipping

MikroTik CRS518-16XS-2XQ-RM Cloud Router Switch 650MHz 64MB QSFP28 New Sealed
- Model #: CRS518-16XS-2XQ-RM
- Return Policy: View Return Policy
$1,684.33
Free Shipping

MikroTik CCR2116-12G-4S+ Cloud Core Router 16GB 13xGb 4xSFP+
- Model #: BECCR2116-12G-4S+
- Item #: 9SIA513JZ30726
- Return Policy: View Return Policy
$1,052.38
Free Shipping

GRANDSTREAM GXP1610 SMALL BUSINESS IP PHONE 1 SIP
- Brand: Grandstream
- Type: Office Products
- Weight: 2.25
- Model #: GXP1610
- Return Policy: View Return Policy
$63.52
Free Shipping

Yealink SIP-T44W - WI-Fi IP Phone - 12 VoIP Accounts. 2.8-Inch Color Display. Dual-Port Gigabit Ethernet, PoE, Power Adapter Not Included
- Brand: Yealink
- Part Number: SIP-T44W
- Type: Corded
- Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV(RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication: MD5/SHA1/SHA224/-SHA256/SHA384/ SHA512 OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE WPA2/WPA3 Secure boot GARP (Generic Attribute Registration Protocol)
- Model #: SIP-T44W
- Return Policy: View Return Policy
$175.00
Free Shipping

Grandstream GXP1630 Small Business Hd Ip Phone, 3 Sip Accounts 3 Line Keys 8 Blf
- Model #: GXP1630
- Return Policy: View Return Policy
$97.82
Free Shipping

Grandstream GXV3450 IP Video Phone - 16 Lines - 16 SIP Accounts - 5-Inch Color Touch Screen - Wi-Fi 5 - Dual-Port Gigabit Ethernet with Integrated PoE (GXV3450)
- Brand: Grandstream
- Part Number: GXV3450
- Type: Voice Conferencing Device
- Connectivity: Wired/Wireless
- Model #: GXV3450
- Return Policy: View Return Policy
$359.73
Free Shipping

Grandstream One way SIP Intercom Speaker/ No Mic 15 Watt Speaker GS-GSC3506 v2
- Brand: Grandstream
- Part Number: GSC3506 v2
- Type: Voice Conferencing Device
- Specification: Grandstream
- Model #: GSC3506 V2
- Return Policy: View Return Policy
$177.78
Free Shipping

Grandstream Networks DP722 HD DECT IP Phone Handset and Charger
- Answering System Type: Digital
- Model #: DP722
- Return Policy: View Return Policy
$83.13
Free Shipping

RF Elements TPA-RM5 TwistPort Adaptor for UBNT Rocket M5
- Model #: TPA-RM5
- Item #: 9SIA513J1N8025
- Return Policy: View Return Policy
$59.61
Free Shipping

UBIQUITI NETWORKS UMA-D UNIFI DUAL-BAND DIRECTIONAL ANTENNA
- Model #: UMA-D-
- Item #: 9SIA513KPB8990
- Return Policy: View Return Policy
$95.00
Free Shipping

Grandstream Compact Hotel Phone w/ built-in WiFi - White GHP610W
- Brand: Grandstream
- Parts: 1-Year Warranty Manufacturer
- Labor: 1-Year Warranty Manufacturer
- Model #:
- Return Policy: View Return Policy
$84.72
Free Shipping
