Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Useful Links
Customer Ratings
Sort By:
View:
Allied Telesis 8-Port 10/100/1000T Unmanaged Switch With External Psu
Quick View
Allied Telesis 8-Port 10/100/1000T Unmanaged Switch With External Psu
  • Brand: Allied Telesis
  • Series: GS910
  • Part Number: AT-GS910/8E-10
  • Format: Wall Mountable
  • Model #: AT-GS910/8E-10
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
  • Format: DIN Rail and Wall Mount Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 18 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-20160HPT
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
Quick View
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-511S15
TRENDnet 10-Port Multi-Gig Web Smart Switch, TEG-3102WS, 8 x 2.5GBASE-T Ports, 2 x 10G SFP+ Slots, Ethernet Splitter, Metal Housing, NDAA & TAA Compliant, Lifetime Protection, Black
Quick View
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EP-100NAS
  •  
  • ₩601,549 –
  • ₩93,294 Shipping
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EPP-100NAS
  •  
  • ₩521,805 –
  • ₩93,490 Shipping
Black Box LIG1014A 14-Port Industrial Gigabit Ethe Rnet Switch Managed Extreme Temp.
Quick View
  •  
  • ₩1,106,344 –
  • ₩74,027 Shipping
Adder - CATX-USB - Computer Access Module RJ45 Socket - USB & VGA
Quick View
HPE CW 2150 16p 10M/100M/1G PoE+ 4p SFP+ 1G/10G 248W Switch - 16 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 3 Layer Supported - 317 W Power Consumption - 248 W PoE - S6X55A#ABA
Quick View
Netgear Business XS724EMv2 Ethernet Switch - 24 Ports - Manageable - 10 Gigabit Ethernet, 5 Gigabit Ethernet - 139 W Power Consumption - Twisted Pair, Optical Fiber - XS724EM-200NAS
Quick View
Netgear Inc.
Netgear Business XS724EMv2 Ethernet Switch - 24 Ports - Manageable - 10 Gigabit Ethernet, 5 Gigabit Ethernet - 139 W Power Consumption - Twisted Pair, Optical Fiber - XS724EM-200NAS
  • Brand: NETGEAR
  • Part Number: XS724EM-200NAS
  • Package Contents: Business XS724EMv2 Ethernet Switch Power Cord (localized to country of sale) Rackmount Kit Documentation Download Flyer
  • Model #: XS724EM-200NAS
  •  
  • ₩3,069,515 –
  • ₩116,968 Shipping
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
Quick View
Netgear Inc.
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
  • Brand: NETGEAR
  • Part Number: GS748-100NAS
  • Format: Rack-mountable, Desktop, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS748-100NAS
  •  
  • ₩945,305 –
  • ₩113,258 Shipping
HPE Networking Instant On Switch 24p Gigabit CL4 PoE 2p SFP 195W 1830 (JL813A#ABA)
Quick View
HPE Networking Instant On Switch 24p Gigabit CL4 PoE 2p SFP 195W 1830 (JL813A#ABA)
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1.5 MB
  • PoE: Yes
  • Model #: JL813A#ABA
  •  
  • ₩612,753 –
  • ₩116,271 Shipping
QNAP QSW-M3224-24T Layer 3 Switch - 24 Ports - Manageable - Gigabit Ethernet, 2.5 Gigabit Ethernet, 5 Gigabit Ethernet, 10 Gigabit Ethernet - 3 Layer Supported - 116.90 W Power Consumption
Quick View
  •  
  • ₩2,092,792 –
  • ₩108,839 Shipping
TRENDnet 8-Port Unmanaged 2.5G Switch, 8 x 2.5GBASE-T Ports, 40Gbps Switching Capacity, Backwards Compatible with 10-100-1000Mbps Devices, Fanless, Wall Mountable, Black, TEG-S380
Quick View
TRENDnet 8-Port Unmanaged 2.5G Switch, 8 x 2.5GBASE-T Ports, 40Gbps Switching Capacity, Backwards Compatible with 10-100-1000Mbps Devices, Fanless, Wall Mountable, Black, TEG-S380
  • Brand: TRENDnet
  • Format: Desktop
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3az IEEE 802.3bz
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: 2.5 Gigabit Ethernet Network Technology: 2.5GBase-T
  • Model #: TEG-S380
TRENDnet  TI-PG160, 16-Port Hardened Industrial Gigabit PoE+ DIN-Rail Network Switch
Quick View
TRENDnet TI-PG160, 16-Port Hardened Industrial Gigabit PoE+ DIN-Rail Network Switch
  • Features: • 16 x Gigabit PoE+ ports • 240W PoE power budget • 32Gbps switching capacity • Power supply sold separately (models: TI-S24052, TI-S24048, TI-S48048) • Hardened IP30 rated metal switch • Includes DIN-rail and wall mounts • Operating temperature range of -40° – 75° C (-40° – 167° F) • Dual redundant power inputs with overload current
  • Weight: 2.3100
  • Model #: TIPG160
  •  
  • ₩574,260 –
  • ₩68,391 Shipping
TP-Link 24 Port Gigabit Ethernet Switch | Desktop or Rackmount | Lifetime Protection | Plug & Play | Shielded Ports | Sturdy Metal | Fanless Quiet | Traffic Optimization | Unmanaged (TL-SG1024S)
Quick View
TP-Link 24 Port Gigabit Ethernet Switch | Desktop or Rackmount | Lifetime Protection | Plug & Play | Shielded Ports | Sturdy Metal | Fanless Quiet | Traffic Optimization | Unmanaged (TL-SG1024S)
  • Switch Type: desktop
  • Format: Desktop / Rackmount
  • Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab , IEEE 802.3x
  • Primary Ports: 24 x 10/100/1000 Mbps RJ45 Ports (Auto Negotiation / Auto MDI / MDIX)
  • Model #: TL-SG1024S
  •  
  • ₩163,815 –
  • ₩141,206 Shipping
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: 19-inch Rack-mountable Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-16T4S
TP-Link 5 Port Gigabit Ethernet Network Switch | Plug and Play | Desktop or Wall-Mount | Plastic Case Ethernet Splitter | Fanless | Traffic Optimization | Unmanaged (TL-SG1005D)
Quick View
TP-Link 5 Port Gigabit Ethernet Network Switch | Plug and Play | Desktop or Wall-Mount | Plastic Case Ethernet Splitter | Fanless | Traffic Optimization | Unmanaged (TL-SG1005D)
  • Switch Type: Network Switch
  • Format: Desktop
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Primary Ports: 5 x RJ45
  • Model #: TL-SG1005D
RUCKUS ICX 7550, 24-port 10/100/1000 Mbps 802.3at POE+, 2x 40 Gbps QSFP+ dual-mode uplink/stacking ports, modular slot | ICX7550-24P-E2
Quick View
RUCKUS ICX 7550, 24-port 10/100/1000 Mbps 802.3at POE+, 2x 40 Gbps QSFP+ dual-mode uplink/stacking ports, modular slot | ICX7550-24P-E2
  • Brand: Ruckus
  • Part Number: ICX7550-24P-E2
  • Format: Stackable
  • Standards: 802.1AB LLDP 802.1D MAC Bridging 802.1p Mapping to Priority Queue 802.1s Multiple Spanning Tree (MST) 802.1w Rapid Reconfiguration of Spanning Tree 802.1x Port-based Network Access Control (PNAC) 802.3 Carrier Sense Multiple Access/Collision Detection (CSMA/CD) 802.3ab 1000BASE-T 802.1 AX-2008 Link Aggregation 802.3ae 10 Gigabit Ethernet 802.3af Power over Ethernet 802.3at Power over Ethernet Plus 802.3bt 4-Pair Power over Ethernet 802.3u 100Base-TX 802.3x Full duplex and Flow Control 802.3z 1000Base-SX/LX 802.3bz Multi-gigabit Ethernet 802.3 MAU MIB (RFC 2239) 802.3ba 40 and 100 Gbps Ethernet 802.1AE-MACsec (with license) 802.3az Energy Efficient Ethernet 802.1Q VLAN Tagging
  • Model #: ICX7550-24P-E2
  •  
  • ₩10,396,483 –
  • ₩163,685 Shipping
Ubiquiti Ultra 60W 8-Port Layer 2 PoE Switch (USW-Ultra-60W (52W))
Quick View
Ubiquiti Ultra 60W 8-Port Layer 2 PoE Switch (USW-Ultra-60W (52W))
  • Brand: Ubiquiti Networks
  • Series: Network Switch
  • Format: Desktop
  • Network Management Type: Managed
  • Model #: USW-ULTRA-60W
SMART MGD POE+ SWITCH 24PORT
Quick View
SMART MGD POE+ SWITCH 24PORT
  • Switch Type: managed
  • Model #: SM24TAT2SA-NA
Manhattan 153201 4K @ 60 Hz DisplayPort to HDMI Cable (6-Foot)
Quick View
  •  
  • ₩46,609 –
  • ₩52,394 Shipping
Juniper Networks EX4400- Switch, 24-port 10/100/1000BASE-T PoE++ power + 1050 W AC PS (provides 783/1806W PoE++ power with single/dual PS) | EX4400-24P
Quick View
Juniper Networks EX4400- Switch, 24-port 10/100/1000BASE-T PoE++ power + 1050 W AC PS (provides 783/1806W PoE++ power with single/dual PS) | EX4400-24P
  • Brand: Juniper Networks, Inc.
  • Series: EX4400
  • Part Number: EX4400-24P
  • Format: Rackmount
  • Model #: EX4400-24P
Ruckus Wireless ICX 7650 Intake Airflow Fan Back To Front Airflow ICXFAN12I
Quick View
  •  
  • ₩437,553 –
  • ₩58,214 Shipping
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.35
  • Model #: SW-104
ZyXEL XGS2220-54HP 48-Port Gigabit L3 Managed and Nebula Pro Cloud Managed Switch, 40 PoE+ / 10 PoE++ Ports at 600W with 4x SFP+ 10G Uplinks and 2x 10G Ethernet Ports
Quick View
HPE Networking CW 2050 48p 10/100/1000BASE-T 4p SFP 1G/2.5G Switch - S6X70A#ABA
Quick View
HPE Networking CW 2050 48p 10/100/1000BASE-T 4p SFP 1G/2.5G Switch - S6X70A#ABA
  • Brand: HPE
  • Series: Networking CW 2050
  • Part Number: S6X70A#ABA
  • Switch Type: 48-Port Gigabit Managed Switch
  • Model #: S6X70A#ABA
  •  
  • ₩1,275,450 –
  • ₩116,968 Shipping
TP-Link 24 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/Shielded Ports | Rackmount | Fanless | Limited Lifetime Protection | Unmanaged (TL-SG1024)
Quick View
TP-Link 24 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/Shielded Ports | Rackmount | Fanless | Limited Lifetime Protection | Unmanaged (TL-SG1024)
  • Brand: TP-Link
  • Format: Rackmount
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Network Management Type: Unmanaged
  • Model #: TL-SG1024
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.4
  • Model #: SW-108

Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.

Network Switches Are Versatile Networking Solutions

Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.

Switches Accommodate Shifts in Business and IT Trends

Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.

Multiple Network Management Options Provide a Positive User Experience

There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.

Switches Provide the Highest Levels of Security

Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.

Network Switches Provide Comprehensive and Advanced Networking Features

Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.