SHOP BY Primary Ports

Quick View
Cisco Meraki MS130-12X Ethernet Switch - 12 Ports - Manageable - Gigabit Ethernet, 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2 Layer Supported - 260 W - MS130-12X
- Brand: Cisco Meraki
- Series: MS130
- Part Number: MS130-12X
- Switch Type: Managed
- Model #: MS130-12X
- NZ$7,970.65 –
- NZ$205.92 Shipping

Quick View
D-Link 5-Port 2.5Gb Unmanaged Gaming Switch (DMS-105) with 5 x 2.5Gb ports - Multi-Gig, Network, Fanless, Plug & Play
- Brand: D-Link
- Series: 100 Series
- Part Number: DMS-105
- Switch Type: multi-gigabit
- Model #: DMS105
- NZ$167.90 –
- More options from NZ$147.20 - NZ$211.60
- NZ$88.53 Shipping

Quick View
Tripp Lite series 8-Port Managed Gigabit Ethernet Switch - Layer 2, 1 Gbps, 2x GbE SFP Ports - 1U Rack/Desktop - 8 Ports - Manageable - Gigabit Ethernet - NGS8C2-1
- Brand: Tripp Lite
- Part Number: NGS8C2-1
- Model #: NGS8C2-1
- NZ$319.70 –
- More options from NZ$307.05 - NZ$319.70
- NZ$140.49 Shipping

Quick View
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-8P2S2X
- NZ$1,800.00
- See price in cart
- NZ$173.75 Shipping

Quick View
Adder - CATX-USB - Computer Access Module RJ45 Socket - USB & VGA
- Model #: CATX-USB
- NZ$243.80 –
- NZ$100.74 Shipping

Quick View
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
- Brand: NETGEAR
- Part Number: GS116EPP-100NAS
- Format: Desktop, Wall Mountable, Enclosure
- Standards: 10/100/1000Base-T
- Model #: GS116EP-100NAS
- NZ$856.75 –
- NZ$130.37 Shipping

Quick View
EnGenius EWS7952P-FIT 48-Port Managed Ethernet Switch EWS7952PFIT
- Model #: EWS7952PFIT
- NZ$1,227.05 –
- More options from NZ$1,155.75 - NZ$1,227.05
- NZ$582.10 Shipping

Quick View
TP-Link 24 Port Gigabit Ethernet Switch | Desktop or Rackmount | Lifetime Protection | Plug & Play | Shielded Ports | Sturdy Metal | Fanless Quiet | Traffic Optimization | Unmanaged (TL-SG1024S)
- Switch Type: desktop
- Format: Desktop / Rackmount
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab , IEEE 802.3x
- Primary Ports: 24 x 10/100/1000 Mbps RJ45 Ports (Auto Negotiation / Auto MDI / MDIX)
- Model #: TL-SG1024S
- NZ$227.70 –
- NZ$210.10 Shipping

Quick View
Panasonic Toughmate G2 Enhanced Rotating Hand Strap ING2ERHSTP
- Model #: ING2ERHSTP
- NZ$169.05 –
- NZ$107.64 Shipping

Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 2.0 Mb
- PoE: Yes
- Model #: R8R46A#ABA
- NZ$216.20 –
- NZ$140.49 Shipping

Quick View
HPE Networking Instant On Switch 12p 10GBT 4p SFP+ 1960 (JL805A#ABA)
- Primary Ports: 12 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- SNMP: Yes
- Power: 100 - 240 VAC
- Model #: JL805A#ABA
- NZ$3,385.60 –
- NZ$211.49 Shipping

Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 65W 1830 (JL811A#ABA)
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- PoE: Yes
- SNMP: Yes
- Model #: JL811A#ABA
- NZ$440.45 –
- NZ$132.86 Shipping

Quick View
HPE Networking Instant On Switch 48p Gigabit CL4 PoE 4p SFP 370W 1830 (JL815A#ABA)
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- PoE: Yes
- Model #: JL815A#ABA
- NZ$1,458.20 –
- More options from NZ$1,263.85 - NZ$1,458.20
- NZ$255.43 Shipping

Quick View
TRENDnet TPE-082WS 10-Port Gigabit Web Smart PoE+ Switch
- Format: Rackmount
- Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1s IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3af IEEE 802.3at IEEE 802.3az
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit Ethernet: 2000 Mbps (full duplex)
- Model #: TPE-082WS
- NZ$415.15 –
- More options from NZ$338.10 - NZ$415.15
- NZ$264.50 Shipping

Quick View
TRENDnet 8-Port Hardened Industrial Gigabit DIN-Rail Switch, TI-G80, 16 Gbps Switching Capacity, IP30 Rated, Ethernet Splitter, NDAA & TAA Compliant, Lifetime Protection, Black
- Format: Includes DIN-rail and wall mounts Wall Mountable
- Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3x
- Primary Ports: 8 x Gigabit ports
- Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
- Model #: TI-G80
- NZ$253.00 –
- More options from NZ$253.00 - NZ$294.40
- NZ$111.93 Shipping

Quick View
Tripp Lite NFI-U08-1 Ethernet Switch - 8 Ports - Fast Ethernet - 10/100Base-T - TAA Compliant - 2 Layer Supported - 4 W Power Consumption - Twisted Pair - DIN Rail Mountable, Wall Mountable - 3 Year L
- Weight: 6.7
- Parts: 3 Year
- Model #: NFI-U08-1
- NZ$253.00 –
- NZ$107.96 Shipping

Quick View
Zyxel 48-port GbE PoE Lite-L3 Smart Managed Switch with 4 10G Uplink - 48 Ports - Manageable - 10 Gigabit Ethernet - 470.10 W Power Consumption - 375 W PoE Budget (XGS1935-52HP)
- Brand: ZyXEL
- Model: XGS1935-52HP
- Part Number: XGS1935-52HP
- Primary Ports: 48 x 100/1000BASE-T Gigbit Ethernet PoE+ RJ-45 Network Port 4 x 10 Gigbit Ethernet SFP+ Expansion Slot
- Model #: XGS1935-52HP
- NZ$1,666.35 –
- More options from NZ$1,666.35 - NZ$1,706.60
- NZ$248.97 Shipping

Quick View
Yealink RCH80 Ethernet Switch - 8 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 2 Layer Supported - 2 SFP Slots - 130 W PoE Budget - Twisted Pair, Optical Fiber - 1303227
- Brand: Yealink
- Model: RCH80
- Part Number: 1303227
- Switch Type: L2+ Gigabit Managed AV Switch
- Model #: 1303227
- NZ$755.55 –
- More options from NZ$752.10 - NZ$836.05
- NZ$114.65 Shipping

Quick View
Adder - X-USBPRO-US - AdderLink XUSBPRO. Transparent USB & VGA KVMA CATx Extender 300 Mtr
- Model #: X-USBPRO-US
- NZ$2,187.30 –
- NZ$122.04 Shipping

Quick View
Tripp Lite 4K HDMI Audio De-Embedder/Extractor with TOSLINK P130000AUDIO2
- Model #: P130000AUDIO2
- NZ$158.70 –
- More options from NZ$149.50 - NZ$162.15
- NZ$77.64 Shipping

Quick View
TP-Link 5 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Desktop/Wall-Mount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP and Link Aggregation (TL-SG105E)
- Brand: TP-Link
- Format: Desktop
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
- Network Management Type: Unmanaged
- Model #: TL-SG105E
- NZ$82.80 –
- NZ$133.83 Shipping

Quick View
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
- Brand: NETGEAR
- Part Number: GS748-100NAS
- Format: Rack-mountable, Desktop, Enclosure
- Standards: 10/100/1000Base-T
- Model #: GS748-100NAS
- NZ$1,361.60 –
- NZ$193.56 Shipping

Quick View
- NZ$213.00
- See price in cart
- More options from NZ$66.70 - NZ$71.30
- NZ$87.82 Shipping

Quick View
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
- Brand: NETGEAR
- Part Number: GS116EPP-100NAS
- Format: Desktop, Wall Mountable, Enclosure
- Standards: 10/100/1000Base-T
- Model #: GS116EPP-100NAS
- NZ$978.65 –
- NZ$130.37 Shipping

Quick View
Juniper Networks EX4400- Switch, 24-port 10/100/1000BASE-T PoE++ power + 1050 W AC PS (provides 783/1806W PoE++ power with single/dual PS) | EX4400-24P
- Brand: Juniper Networks, Inc.
- Series: EX4400
- Part Number: EX4400-24P
- Format: Rackmount
- Model #: EX4400-24P
- NZ$4,618.40 –
- More options from NZ$4,618.40 - NZ$10,186.70
- Free Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit 2p 10GBT 2p SFP+ 1960 (JL806A#ABA)
- Primary Ports: 26 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- SNMP: Yes
- Layer: 2
- Model #: JL806A#ABA
- NZ$1,600.80 –
- More options from NZ$1,600.80 - NZ$1,657.15
- NZ$267.34 Shipping

Quick View
- NZ$650.90 –
- NZ$77.95 Shipping

Quick View
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
- Switch Type: Others
- Weight: 0.35
- Model #: SW-104
- NZ$156.40 –
- More options from NZ$156.40 - NZ$166.75
- NZ$70.45 Shipping

Quick View
D-Link DGS-1530-28P 24 Port Ethernet Switch - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 2 Layer Supported - 456W Power Consumption - 370W PoE Budget (DGS-1530-28P)
- Brand: D-Link
- Model: DGS-1530-28P
- Part Number: DGS-1530-28P
- Model #: DGS-1530-28P
- NZ$2,194.20 –
- More options from NZ$2,193.05 - NZ$2,194.20
- NZ$176.55 Shipping

Quick View
TRENDnet 8-Port 2.5G Switch, TEG-S381, 8 x 2.5G RJ45 Ports, 40Gps, NDAA + TAA Compliant, Ethernet Splitter
- Brand: TRENDnet
- Series: ProSafe
- Model: TEG-S381
- Part Number: TEG-S381
- Model #: TEG-S381
- NZ$158.70 –
- NZ$111.60 Shipping

Quick View
SMART MGD POE+ SWITCH 24PORT
- Switch Type: managed
- Model #: SM24TAT2SA-NA
- NZ$1,335.15 –
- More options from NZ$1,335.15 - NZ$1,357.00
- NZ$150.97 Shipping

Quick View
HPE Networking CW 2050 48p 10/100/1000BASE-T 4p SFP 1G/2.5G Switch - S6X70A#ABA
- Brand: HPE
- Series: Networking CW 2050
- Part Number: S6X70A#ABA
- Switch Type: 48-Port Gigabit Managed Switch
- Model #: S6X70A#ABA
- NZ$1,810.10 –
- NZ$176.55 Shipping

Quick View
TRENDnet 10-Port Industrial Gigabit L2 Managed PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 24-57V DC Power Input, IP30, VLAN, Black, TI-PG102i
- Switch Type: Switches
- Format: DIN Rail Mount
- Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.1ax IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3az IEEE 802.3af IEEE 802.3at
- Primary Ports: 8 x Gigabit PoE+ ports 2 x 100/1000 Mbps SFP slots
- Model #: TI-PG102i
- NZ$948.75 –
- More options from NZ$948.75 - NZ$1,283.40
- NZ$136.88 Shipping

Quick View
- NZ$1,351.25 –
- NZ$98.04 Shipping

Quick View
TRENDnet 16-Port Gigabit Switch, TEG-S17, 16 x Gigabit RJ-45 Ports, 32Gbps Switching Capacity, Fanless Design, Metal Enclosure, Internal Power Supply, Lifetime Protection, Black
- Weight: 6.3800
- Model #: TEG-S17
- NZ$203.55 –
- NZ$118.22 Shipping

Quick View
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 12.0 Mb
- Layer: 2
- Model #: R8R50A#ABA
- NZ$404.80 –
- NZ$160.19 Shipping
Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.
Network Switches Are Versatile Networking Solutions
Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.
Switches Accommodate Shifts in Business and IT Trends
Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.
Multiple Network Management Options Provide a Positive User Experience
There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.
Switches Provide the Highest Levels of Security
Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.
Network Switches Provide Comprehensive and Advanced Networking Features
Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.


