SHOP BY Primary Ports

Quick View
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
- Switch Type: Others
- Weight: 0.4
- Model #: SW-108
- NZ$292.10 –
- More options from NZ$292.10 - NZ$293.25
- NZ$70.45 Shipping

Quick View
D-Link DMS-1250-28P Ethernet Switch - 24 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 3 Layer Supported - 592.19 W Consumption - 475 W PoE Budget
- Brand: D-Link
- Model: DMS-1250-28P
- Part Number: DMS-1250-28P
- Network Management Type: Manageable
- Model #: DMS-1250-28P
- NZ$2,424.20 –
- NZ$178.55 Shipping

Quick View
ZyXEL 5 Port Gigabit Ethernet Unmanaged POE+ Switch, 4 x PoE+ @ 60W, GS1005HP
- Brand: ZyXEL
- Part Number: GS1005HP
- Switch Type: Manageable: Yes
- Format: Desktop, Wall-Mount
- Model #: GS1005HP
- NZ$99.00
- See price in cart
- More options from NZ$88.55 - NZ$115.00
- NZ$70.54 Shipping

Quick View
BRAINBOXES SW-105 EMBEDDED 5PORT ETHERNET SWITCH
- Switch Type: Others
- Weight: 0.35
- Model #: SW-105
- NZ$195.50 –
- More options from NZ$195.50 - NZ$197.80
- NZ$70.44 Shipping

Quick View
RUCKUS ICX 7550, 24-port 10/100/1000 Mbps 802.3at POE+, 2x 40 Gbps QSFP+ dual-mode uplink/stacking ports, modular slot | ICX7550-24P-E2
- Brand: Ruckus
- Part Number: ICX7550-24P-E2
- Format: Stackable
- Standards: 802.1AB LLDP 802.1D MAC Bridging 802.1p Mapping to Priority Queue 802.1s Multiple Spanning Tree (MST) 802.1w Rapid Reconfiguration of Spanning Tree 802.1x Port-based Network Access Control (PNAC) 802.3 Carrier Sense Multiple Access/Collision Detection (CSMA/CD) 802.3ab 1000BASE-T 802.1 AX-2008 Link Aggregation 802.3ae 10 Gigabit Ethernet 802.3af Power over Ethernet 802.3at Power over Ethernet Plus 802.3bt 4-Pair Power over Ethernet 802.3u 100Base-TX 802.3x Full duplex and Flow Control 802.3z 1000Base-SX/LX 802.3bz Multi-gigabit Ethernet 802.3 MAU MIB (RFC 2239) 802.3ba 40 and 100 Gbps Ethernet 802.1AE-MACsec (with license) 802.3az Energy Efficient Ethernet 802.1Q VLAN Tagging
- Model #: ICX7550-24P-E2
- NZ$15,125.95 –
- NZ$317.14 Shipping

Quick View
SonicWall 100GBase-SR4 QSFP28 850nm 100m Module - For Firewall - 1x 100GBase-SR4 Network - Optical Fiber - Multi-mode - 100 Gigabit Ethernet - 100GBase-SR4 - TAA - 02-SSC-5806
- Brand: SonicWall
- Part Number: 02-SSC-5806
- Switch Type: 100GBase-SR4 QSFP28 Transceiver Module
- Format: QSFP28
- Model #: 02-SSC-5806
- NZ$1,426.00 –
- NZ$130.37 Shipping

Quick View
Netgear Business GS748PP 48-Port Gigabit Unmanaged PoE+ Switch
- Brand: NETGEAR
- Part Number: GS748PP-100NAS
- Format: Rack-mountable, Desktop, Enclosure
- Standards: 10/100/1000Base-T
- Model #: GS748PP-100NAS
- NZ$2,294.25 –
- NZ$215.64 Shipping

Quick View
Black Box LPB3000 Ethernet Switch LPB3028A
- Model #: LPB3028A
- NZ$2,403.50 –
- More options from NZ$2,403.50 - NZ$2,586.35
- NZ$169.55 Shipping

Quick View
HPE Aruba JL259A#ABA 2930F 24G 4 SFP Switch
- Primary Ports: (24) RJ-45 autosensing 10/100/1000 ports (4) SFP
- Dimensions: 1.73" x 17.42" x 7.88"
- Weight: 5.31 lbs.
- Package Contents: (1) Aruba 2930F 24G 4SFP Switch, (1) power cord, (1) screw kit, (4) mounting ears, (4) bumper feet, (1) cable tie
- Model #: JL259A#ABA
- NZ$4,681.65 –
- More options from NZ$2,176.95 - NZ$4,681.65
- NZ$260.69 Shipping

Quick View
Schneider Electric NetBotz 125kHz Rack Access Control
- Model #: 731304332077
- NZ$1,854.95 –
- More options from NZ$1,854.95 - NZ$1,932.00
- NZ$116.07 Shipping

Quick View
Kanexpro Hdmi Extender Over Cat6 Up To 196Ft. (60M)
- Model #: EXT-HD60M
- NZ$216.00
- See price in cart
- NZ$158.64 Shipping

Quick View
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
- Format: DIN Rail Mount
- MAC Address Table: 8K MAC address table with auto learning function
- Jumbo Frames: 9000 bytes
- Buffer Memory: 1MB
- Model #: WGS-804HP
- NZ$364.00
- See price in cart
- NZ$111.00 Shipping

Quick View
D-Link DES-1016D
- Brand: D-Link
- Model #:
- NZ$131.10 –
- More options from NZ$131.10 - NZ$154.10
- NZ$139.04 Shipping

Quick View
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Flow Control
- Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX SFP interface
- MAC Address Table: 2K
- Switching Method: Store and Forward
- Model #: ISW-621TF
- NZ$218.50 –
- NZ$88.00 Shipping

Quick View
OM5 LC/LC MULTIMODE FIBRE CABLE
- Weight: 2.0000
- Model #: LCLCL-20M-OM5-FIBER
- NZ$164.45 –
- More options from NZ$158.70 - NZ$164.45
- NZ$129.96 Shipping

Quick View
10GBASE-SR SFP+, 1310-nm Single-Mode, 10 km, LC
- Model #: LSP422
- NZ$657.80 –
- NZ$69.94 Shipping

Quick View
D-Link DGS-108GL 8-Port Gigabit Unmanaged Switch for Home & Small Business - Plug & Play | DGS-108GL
- Brand: D-Link
- Part Number: DGS-108GL
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Model #: DGS-108GL
- NZ$57.50 –
- More options from NZ$57.50 - NZ$79.35
- NZ$101.18 Shipping

Quick View
Planet POE-2400G 24-Port Gigabit 60W Ultra PoE Managed Injector Hub (800W)
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T Ethernet IEEE 802.3u 100Base-TX Fast Ethernet IEEE 802.3ab 1000Base-T Gigabit Ethernet IEEE 802.3af Power over Ethernet
- Primary Ports: "Data" Input Ports: 24x RJ-45 STP "PoE (Data+Power)" Output Ports: 24x RJ-45 STP Management Port: 1 x RJ-45; 10/100Base-TX, auto-negotiation, auto-MDI / MDIX
- Primary Port Speed: 10/100/1000Mbps
- Model #: POE-2400G
- NZ$1,117.80 –
- NZ$195.93 Shipping

Quick View
RUCKUS ICX 8200 Switch, 24x10/100/1000 Mbps PoE+ ports, 4x25 GbE SFP28 stacking/uplink-ports, 370 W PoE budget, three-year remote TAC support. Power cord not included - OEM
- Part Number: ICX8200-24P
- Primary Ports: Interfaces: 24x10/100/1000 Mbps RJ45 ; 4x1/10/25 Gbps SFP/SFP+/SFP28 uplinks; USB Type-C; RJ45 serial port; USB Type-A port; RJ45 Ethernet port 10/100/1000BASE-T Ports: 24
- Power: Max Power Consumption: 525 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Temperature: Min Operating Temperature: 0 Celsius Max Operating Temperature: 45 Celsius Min Storage Temperature: -40 Celsius Max Storage Temperature: 70 Celsius
- Model #: ICX8200-24P
- NZ$7,992.50 –
- NZ$169.97 Shipping

Quick View
RUCKUS ICX 8100 1RU Switch, 24x10/100/1000 Mbps PoE+ 802.3at, 30W Class 4 ports, 4x1GbE SFP uplink-ports, 370W PoE budget. Power cord not included | ICX8100-24P
- Brand: Fortinet
- Series: RUCKUS ICX 8100
- Part Number: ICX8100-24P
- Switch Type: ICX8100-24P
- Model #: ICX8100-24P
- NZ$3,819.15 –
- NZ$247.84 Shipping

Quick View
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x full-duplex Flow Control
- Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX interface on
- MAC Address Table: 2K
- Model #: ISW-621TS15
- NZ$280.00
- See price in cart
- NZ$88.00 Shipping

Quick View
Havis C-MD-204 Low Profile Tilt Swivel Motion Device
- Model #: C-MD-204
- NZ$179.40 –
- NZ$85.00 Shipping

Quick View
Planet MGSD-10080F 8-Port 100/1000X SFP + 2-Port 10/100/1000T Managed Metro Ethernet Switch
- Format: Wall Mountable
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid Spanning tree protocol IEEE 802.1s Multiple Spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2
- Primary Ports: 8 1000Base-SX/LX/BX SFP interfaces, from port 1 to port 8 Compatible with 100Base-FX SFP, 2 10/ 100/1000Base-T RJ-45 Auto-MDI/MDI-X ports, 1 x RJ-45-to-RS-232 serial port (115200, 8, N, 1)
- Primary Port Speed: 20Gbps / non-blocking
- Model #: MGSD-10080F
- NZ$833.75 –
- NZ$195.93 Shipping

Quick View
BLACK BOX NETWORK SERVICES - INDUSTRIAL 10/100-MBPS ETHERNET SWITCH-UNMANAGED, EXTREME TEMPERATURE, 5-PORT
- Switch Type: ethernet
- Model #: LBH3050A
- NZ$244.95 –
- NZ$107.64 Shipping

Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
- Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
- Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
- Model #: WGSW-24040
- NZ$610.00
- See price in cart
- NZ$275.63 Shipping

Quick View
HP Rack Mount for HP Z2 Mini G9 Workstation (6C1U0AA)
- Brand: HP
- Part Number: 6C1U0AA
- Switch Type: Rack Mount
- Model #: 6C1U0AA
- NZ$2,751.95 –
- More options from NZ$2,751.95 - NZ$2,768.05
- NZ$726.03 Shipping

Quick View
Ubiquiti UniFi WAN Switch RJ45 (USW-WAN-RJ45)
- Model #: USW-WAN-RJ45
- NZ$595.70 –
- More options from NZ$595.70 - NZ$681.95
- NZ$182.27 Shipping

Quick View
RUCKUS ICX 8200 Compact Switch, 8x10/100/1000 Mbps PoE+ ports, 2x10 GbE SFP+ stacking/uplink-ports, 124 W PoE budget, three-year remote TAC support. Power cord not included | ICX8200-C08PF - OEM
- Brand: Ruckus Wireless
- Series: RUCKUS ICX 8200
- Part Number: ICX8200-C08PF
- Format: Desktop
- Model #: ICX8200-C08PF
- NZ$4,425.20 –
- NZ$130.79 Shipping

Quick View
GIGABIT ETHERNET (1000-MBPS) MANAGED SWITCH - (20) SFP, (4) 100/1000-MBPS DUAL-M
- Model #: LGB5124A-R2
- NZ$1,745.70 –
- More options from NZ$1,745.70 - NZ$1,830.80
- NZ$169.37 Shipping

Quick View
Luxul 1Gb L2/L3 Managed Switch - 48 PoE+, 4 SFP Front-Facing Ports - TAA Compliant - SW-515-48P-F
- Brand: Luxul
- Series: SW-515
- Part Number: SW-515-48P-F
- Switch Type: Managed
- Model #: SW-515-48P-F
- NZ$3,479.90 –
- NZ$237.23 Shipping

Quick View
FortiSwitch-424E Layer 2/3 FortiGate switch controller compatible switch with 24 x GE RJ45 ports, 4 x 10 GE SFP+ uplinks
- Format: Rackmount
- Primary Ports: 24x GE RJ45 and 4x10 GE SFP+ ports Note: SFP+ ports are compatlble with 1 GE SFP
- VLAN Support: 4K
- Packet Forwarding Rate: 190 Mpps
- Model #: FS-424E
- NZ$3,609.85 –
- NZ$329.87 Shipping

Quick View
RUCKUS ICX 8200 Compact Switch, 4x100/1000/2500 Mbps PoE++ ports, 4x 1/2.5/5/10Gbps PoE++ ports, 2x25 GbE SFP28 stacking/uplinkports, 240 W PoE budget, 3-Y remote TAC support | ICX8200-C08ZP - OEM
- Part Number: ICX8200-C08ZP
- Uplink Interface: 4× 100/1000/2500 Mbps RJ-45 PoE++ 90W ports; 4× 1/2.5/5/10 Gbps RJ-45 PoE++ 90W ports; 2× 1/10/25 GbE uplink/stacking SFP28 ports; USB Type-C port;RJ45 serial port;USB Type-A port;RJ45 Ethernet port (For console manag
- Power: Power Over Ethernet (PoE) Support: Yes PoE Power Consumption: 240W
- Max Power Consumption: Power / Device Type: Power Supply Max Power Consumption: 305 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Model #: ICX8200-C08ZP
- NZ$7,595.75 –
- NZ$159.79 Shipping

Quick View
Micro Mini Media Converter, 10-/100-/1000-Mbps Copper to 1000-Mbps Duplex Fiber, Multimode, 850-nm, 0.5 km, SC
- Model #: LMC4002A
- NZ$913.10 –
- NZ$100.54 Shipping
Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.
Network Switches Are Versatile Networking Solutions
Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.
Switches Accommodate Shifts in Business and IT Trends
Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.
Multiple Network Management Options Provide a Positive User Experience
There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.
Switches Provide the Highest Levels of Security
Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.
Network Switches Provide Comprehensive and Advanced Networking Features
Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.





