SHOP BY Primary Ports

Quick View
TP-Link 24 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1024DE)
- Format: Rackmount
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG1024DE
- NZ$238.05 –
- More options from NZ$238.05 - NZ$396.75
- NZ$158.87 Shipping

Quick View
Fortinet FortiSwitch-124F-FPOE Layer 2 FortiGate switch controller compatible PoE+ switch with 24 GE RJ45 + 4 10G SFP+ ports, 24 port PoE | FS-124F-FPOE
- Part Number: FS-124F-FPOE
- Format: Rackmount
- Management Interface: 24x GE RJ45 and 4x 10GE SFP+
- Management Feature: Automation Stitches Display Average Bandwidth and Allow Sorting on Physical Port / Interface Traffic Dual Firmware Support HTTP / HTTPS IPv4 and IPv6 Management Link Monitor Managed from FortiGate Packet Capture POE Control Modes Provide warning if L2 table is getting full RMON Group 1 SNMP v1/v2c/v3 SNMP v3 traps SNTP Software download/upload: TFTP/FTP/GUI SPAN, RSPAN, and ERSPAN Standard CLI and Web GUI Interface Support for HTTP REST APIs for Configuration and Monitoring Syslog UDP/TCP System alias command System Temperature and Alert Telnet / SSH
- Model #: FS-124F-FPOE
- NZ$3,014.15 –
- More options from NZ$3,014.15 - NZ$3,482.20
- NZ$176.88 Shipping

Quick View
TP-Link TL-SX1008 | 8 Port 10G/Multi-Gig Unmanaged Ethernet Switch | Desktop/Rackmount | Plug & Play | Sturdy Metal Casing | Speed Auto-Negotiation
- Brand: TP-Link
- Part Number: TL-SX1008
- Format: 8 Port / 10G
- Uplink Interface: RJ45
- Model #: TL-SX1008
- NZ$845.25 –
- More options from NZ$845.25 - NZ$1,021.20
- NZ$207.27 Shipping

Quick View
D-LINK BUSINESS DGS-1510-28X SmartPro 24Port Gigabit Switch
- Brand: D-Link
- Part Number: DGS-1510-28X
- Switch Type: Ethernet Switch
- Uplink Interface: RJ45, SFP+
- Model #: DGS-1510-28X
- NZ$823.40 –
- More options from NZ$823.40 - NZ$1,207.50
- NZ$137.20 Shipping

Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1005P
- NZ$129.95 –
- More options from NZ$105.80 - NZ$162.15
- NZ$136.12 Shipping

Quick View
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (130W) + 2 Optical SFP Ports|L3 Lite|NDAA/TAA Compliant (DGS-1210-10MP)
- Switch Type: 8-Port Gigabit Smart Managed PoE Switch with 2 Gigabit SFP ports, 130W PoE Budget
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-FX 100 Mbps over fiber optic IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twisted- pair copper) IEEE 802.3z 1000BASE-X 1 Gbps over fiber optic IEEE 802.3az Energy Efficient Ethernet (EEE) IEEE 802.3x Flow Control IEEE 802.3af/at compliance (for PoE ports on PoE models)
- Primary Ports: 8 x 10/100/1000 (PoE+) + 2 x Gigabit SFP
- Model #: DGS-1210-10MP
- NZ$409.40 –
- More options from NZ$409.40 - NZ$639.40
- NZ$237.26 Shipping

Quick View
Netgear XS512EM 12-Port 10G-Gigabit/Multi-Gigabit Ethernet Easy Smart Switch Managed with 2 SFP+ Combo Ports, XS512EM-200NAS
- Model #: XS512EM-200NAS
- NZ$2,512.75 –
- NZ$138.37 Shipping

Quick View
Netgear Business GS105PP 5-Port Gigabit Ethernet Unmanaged PoE+ Switch
- Brand: NETGEAR
- Part Number: GS105PP-300NAS
- Format: Desktop, Wall Mountable, Enclosure, Compact
- Standards: 10/100/1000Base-T
- Model #: GS105PP-300NAS
- NZ$351.90 –
- NZ$71.18 Shipping

Quick View
TP-Link TL-SG1008MP - switch - 8 ports - unmanaged - rack-mountabl (TL-SG1008MP)
- Brand: TP-Link
- Series: ProSafe
- Part Number: TL-SG1008MP
- Switch Type: Others
- Model #: TL-SG1008MP
- NZ$251.85 –
- More options from NZ$251.85 - NZ$282.90
- NZ$149.72 Shipping

Quick View
TP-Link 16 Port 10/100Mbps Fast Ethernet Switch | Desktop or Wall-Mounting | Plastic Case Ethernet Splitter | Unshielded Network Switch | Plug and Play | Fanless Quiet | Unmanaged (TL-SF1016D)
- Format: Desktop
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100Mbps
- MAC Address Table: 1K
- Model #: TL-SF1016D
- NZ$88.55 –
- NZ$164.55 Shipping

Quick View
QNAP QSW-M3216R-8S8T-US Half Rackmount 16-Port 10GbE Layer 2 Web Managed Switch - 8 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 2 Layer Supported
- Brand: Qnap
- Model: QSW-M3216R-8S8T-US
- Part Number: QSW-M3216R-8S8T-US
- Model #: QSWM3216R8S8TUS
- NZ$1,382.30 –
- More options from NZ$1,382.30 - NZ$1,458.20
- NZ$139.37 Shipping

Quick View
TP-Link TL-SG2210P, Jetstream 8 Port Gigabit Smart Managed PoE Switch, 8 PoE+ Ports @61W, 2 SFP Slots, Omada SDN Integrated, PoE Recovery, IPv6, Static Routing, Limited Lifetime Protection
- Format: Desktop
- Standards: IEEE 802.3af, IEEE 802.3at
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG2210P
- NZ$270.25 –
- NZ$158.87 Shipping

Quick View
TP-Link 5 Port Gigabit PoE Switch | 4 PoE+ Port @65W | Easy Smart | Plug & Play | Limited Lifetime Protection | Shielded Ports | Support QoS, VLAN, IGMP and Link Aggregation (TL-SG105PE)
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p, IEEE 802.3at
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 2K
- Model #: TL-SG105PE
- NZ$158.70 –
- More options from NZ$148.35 - NZ$247.25
- NZ$133.83 Shipping

Quick View
ZyXEL GS1350-6HP 5-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 3 PoE+ / 2 PoE++ Ports at 60W with 1 SFP Uplink
- Brand: ZyXEL
- Part Number: GS1350-6HP
- Switch Type: Manageable
- Format: Wall Mountable
- Model #: GS1350-6HP
- NZ$385.00
- See price in cart
- More options from NZ$335.80 - NZ$396.75
- NZ$78.00 Shipping

Quick View
TP-Link TL-SG1016PE V3 | 16 Port Gigabit PoE Switch | Easy Smart Managed | 8 PoE+ Ports @150W | Plug & Play | Sturdy Metal w/ Shielded Ports | QoS, Vlan, IGMP & LAG | Limited Lifetime Protection
- Brand: TP-Link
- Series: ProSafe
- Part Number: TL-SG1016PE
- Format: Rackmount
- Model #: TL-SG1016PE
- NZ$346.15 –
- More options from NZ$346.15 - NZ$564.65
- NZ$158.87 Shipping

Quick View
TP-Link 5 Port 10/100 Mbps Fast Ethernet Switch | Desktop Ethernet Splitter | Ethernet Hub | Plug & Play | Fanless Quiet | Desktop Design | Green Technology | Unmanaged (TL-SF1005D), White
- Brand: TP-Link
- Format: Desktop
- Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x
- Network Management Type: Unmanaged
- Model #: TL-SF1005D
- NZ$44.85 –
- More options from NZ$41.40 - NZ$44.85
- NZ$88.54 Shipping

Quick View
TP-Link Omada 16-Port Gigabit Easy Managed Switch - 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 2 Layer Supported - 8.40 W Power Consumption - Twisted Pair - 1U - Desktop, Rack-moun
- Brand: TP-Link
- Format: Desktop / Rackmountable
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: ES216G
- NZ$192.05 –
- More options from NZ$192.05 - NZ$202.40
- NZ$110.58 Shipping

Quick View
Netgear AV Line M4350-16M4V Ethernet Switch - 16 Ports - Manageable - 2.5 Gigabit Ethernet, 25 Gigabit Ethernet - 2.5GBase-T, 25GBase-X - 3 Layer Supported - 689.60 W Power Consumption - MSM4320-100NE
- Brand: Netgear
- Series: M4350
- Part Number: MSM4320-100NES
- Format: 1U
- Model #: MSM4320-100NES
- NZ$15,354.80 –
- NZ$354.40 Shipping

Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T, IEEE 802.3u 100BASE-FX, IEEE 802.3z 1000BASE-SX, IEEE 802.3z 1000BASE-LX, 4-Port IEEE 802.3af/at Power over Ethernet end-span PSE
- Primary Ports: 4 x RJ-45 Female 4 x RJ-45 (PoE+) Female
- Primary Port Speed: 10/100/1000Mbps
- Model #: IES81GPOEW
- NZ$644.00 –
- More options from NZ$644.00 - NZ$668.15
- NZ$107.67 Shipping

Quick View
TP-Link 16 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1016DE)
- Format: Desktop
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
- Uplink Ports: None
- Primary Ports: 16 x RJ45
- Model #: TL-SG1016DE
- NZ$221.95 –
- More options from NZ$221.95 - NZ$243.80
- NZ$239.34 Shipping

Quick View
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-801T
- NZ$358.80 –
- NZ$111.00 Shipping

Quick View
TP-Link TL-SG3428XMP | Jetstream 24 Port Gigabit Smart Managed L2+ PoE switch | 24 PoE+ Port @384W, 4 x 10GE SFP+ Slots | Omada SDN Integrated | IPv6 and Static Routing | Limited Lifetime Protection
- Format: Desktop
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Primary Port Type: 24 x 10/100/1000 Mbps RJ45 Ports 4 x 10G SFP+ Slots
- Model #: TL-SG3428XMP
- NZ$1,340.90 –
- More options from NZ$1,340.90 - NZ$1,409.90
- NZ$239.65 Shipping

Quick View
- NZ$508.30 –
- More options from NZ$508.30 - NZ$529.00
- NZ$84.52 Shipping

Quick View
TP-Link 8 Port Gigabit Ethernet Network Switch | Plug and Play | Desktop or Wall-Mount | Plastic Case Ethernet Splitter | Fanless | Traffic Optimization | Unmanaged (TL-SG1008D)
- Format: Desktop
- Standards: IEEE 802.3i / 802.3u / 802.3ab / 802.3x
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG1008D
- NZ$80.50 –
- NZ$163.49 Shipping

Quick View
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
- Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
- Primary Port Speed: 10/100/1000Mbps
- Model #: GSD-1008HP
- NZ$282.90 –
- NZ$149.75 Shipping

Quick View
Netgear Business GS105P 5-Port Gigabit Ethernet Unmanaged PoE Switch
- Brand: NETGEAR
- Part Number: GS105P-300NAS
- Format: Desktop, Wall Mountable, Enclosure, Compact
- Standards: 10/100/1000Base-T
- Model #: GS105P-300NAS
- NZ$262.20 –
- NZ$120.78 Shipping

Quick View
BRAINBOXES SW-508 INDUSTRIAL ETHERNET 8PORT SW
- Switch Type: Others
- Weight: 0.5
- Model #: SW-508
- NZ$300.15 –
- More options from NZ$300.15 - NZ$309.35
- NZ$80.90 Shipping

Quick View
Netgear Business GS108EP 8-Port Gigabit Easy Smart PoE+ Switch
- Brand: NETGEAR
- Part Number: GS108EP-100NAS
- Format: Desktop, Wall Mountable, Enclosure
- Standards: 10/100/1000Base-T
- Model #: GS108EP-100NAS
- NZ$368.00 –
- NZ$107.67 Shipping

Quick View
D-Link 24-Port Gigabit Smart Managed Switch | Web Managed | Cable Diagnostics | NDAA Compliant - (DGS-1100-24V2)
- Weight: 5
- Model #: DGS-1100-24V2
- NZ$277.15 –
- More options from NZ$277.15 - NZ$563.50
- NZ$241.54 Shipping

Quick View
TP-Link TL-SG3452P | 48 Port Gigabit L2+ Managed PoE Switch | 48 PoE+ Port @384W, 4 x SFP Slots | PoE Auto Recovery | Omada SDN Integrated | IPv6 | Static Routing | 5 Year Manufacturer Warranty
- Format: Rack Mountable
- Primary Ports: 48× gigabit RJ45 ports and 4× gigabit SFP Slots provide high-speed connections.
- VLAN Support: Yes
- Jumbo Frames: 9 KB
- Model #: SG3452P
- NZ$1,246.60 –
- More options from NZ$1,246.60 - NZ$2,599.00
- NZ$237.03 Shipping

Quick View
TP-Link TL-SG3428 | 24 Port Gigabit Switch, 4 SFP Slots | Omada SDN Integrated | L2+ Smart Managed | IPv6 | Static Routing | L2/L3/L4 QoS, IGMP & LAG
- Switch Type: managed
- Model #: TL-SG3428
- NZ$451.95 –
- NZ$132.79 Shipping

Quick View
HPE Aruba Networking 2930F 48G PoE+ 4SFP+ Switch | JL256A#ABA
- Brand: HPE
- Model: JL256A#ABA
- Part Number: JL256A
- Primary Ports: (48) RJ-45 autosensing 10/100/1000 PoE+ ports (4) SFP+ 1/10GbE ports
- Model #: JL256A#ABA
- NZ$7,377.25 –
- NZ$274.76 Shipping

Quick View
Ubiquiti Enterprise 48 PoE, 48-Port Layer 3 PoE+ Switch (USW-Enterprise-48-PoE (720W))
- Brand: Ubiquiti Networks
- Series: UniFi
- Part Number: USW-Enterprise-48-PoE (720W)
- Format: Rackmount
- Model #: USW-Enterprise-48-PoE (720W)
- NZ$3,858.25 –
- NZ$260.69 Shipping

Quick View
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3af Power over Ethernet
- Primary Ports: 4-port 10/100Base-TX RJ-45 with IEEE 802.3af PoE injector 1-port 100Base-FX SFP interface
- MAC Address Table: 2K
- Switching Method: Store and Forward
- Model #: ISW-514PTF
- NZ$485.30 –
- NZ$184.04 Shipping

Quick View
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T IEEE 802.3z 1000Base-SX/LX IEEE 802.3az Energy-Efficient Ethernet, IEEE 802.3x Flow Control, IEEE 802.1q VLAN Tagging, IEEE 802.1p QoS, IEEE 802.1x Port-Based Network Access Control, IEEE802.3ad Link Aggregation, IEEE 802.1d Spanning Tree Protocol, IEEE 802.1w Rapid Spanning Tree Protocol
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IES101GP2SFW
- NZ$991.30 –
- More options from NZ$991.30 - NZ$1,017.75
- NZ$129.67 Shipping

Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8P2S
- NZ$800.00
- See price in cart
- NZ$123.04 Shipping
Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.
Network Switches Are Versatile Networking Solutions
Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.
Switches Accommodate Shifts in Business and IT Trends
Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.
Multiple Network Management Options Provide a Positive User Experience
There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.
Switches Provide the Highest Levels of Security
Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.
Network Switches Provide Comprehensive and Advanced Networking Features
Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.

