Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Show More
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Juniper Networks EX4400- Switch, 24-port 10/100/1000BASE-T PoE++ power + 1050 W AC PS (provides 783/1806W PoE++ power with single/dual PS) | EX4400-24P
Quick View
Juniper Networks EX4400- Switch, 24-port 10/100/1000BASE-T PoE++ power + 1050 W AC PS (provides 783/1806W PoE++ power with single/dual PS) | EX4400-24P
  • Brand: Juniper Networks, Inc.
  • Series: EX4400
  • Part Number: EX4400-24P
  • Format: Rackmount
  • Model #: EX4400-24P
TRANSITION NETWORKS SISPM1040-362-LRT MNGDHRDNDPOE+SW 4X10/100/1000
Quick View
TRANSITION NETWORKS SISPM1040-362-LRT MNGDHRDNDPOE+SW 4X10/100/1000
  • Switch Type: Others
  • Weight: 2.1
  • Parts: 5 Year
  • Model #: SISPM1040-362-LRT
Extreme Networks 5420F 24-port Switch, 4 x1/10Gb SFP+ ports, Base software included | 5420F-24T-4XE
Quick View
Extreme Networks
Extreme Networks 5420F 24-port Switch, 4 x1/10Gb SFP+ ports, Base software included | 5420F-24T-4XE
  • Brand: Extreme Networks
  • Series: 5420
  • Network Management Type: Managed
  • Primary Ports: 24 x 10/100/1000BASE-T ports • Full / Half-Duplex(autosensing) • MACsec-capable 4 x 1/10Gb SFP+ uplink ports(unpopulated) • MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
  • Model #: 5420F-24T-4XE
  •  
  • $3,881.99 –
  • Free Shipping
RUCKUS ICX 7550, 24-port 10/100/1000 Mbps 802.3at POE+, 2x 40 Gbps QSFP+ dual-mode uplink/stacking ports, modular slot | ICX7550-24P-E2
Quick View
RUCKUS ICX 7550, 24-port 10/100/1000 Mbps 802.3at POE+, 2x 40 Gbps QSFP+ dual-mode uplink/stacking ports, modular slot | ICX7550-24P-E2
  • Brand: Ruckus
  • Part Number: ICX7550-24P-E2
  • Format: Stackable
  • Standards: 802.1AB LLDP 802.1D MAC Bridging 802.1p Mapping to Priority Queue 802.1s Multiple Spanning Tree (MST) 802.1w Rapid Reconfiguration of Spanning Tree 802.1x Port-based Network Access Control (PNAC) 802.3 Carrier Sense Multiple Access/Collision Detection (CSMA/CD) 802.3ab 1000BASE-T 802.1 AX-2008 Link Aggregation 802.3ae 10 Gigabit Ethernet 802.3af Power over Ethernet 802.3at Power over Ethernet Plus 802.3bt 4-Pair Power over Ethernet 802.3u 100Base-TX 802.3x Full duplex and Flow Control 802.3z 1000Base-SX/LX 802.3bz Multi-gigabit Ethernet 802.3 MAU MIB (RFC 2239) 802.3ba 40 and 100 Gbps Ethernet 802.1AE-MACsec (with license) 802.3az Energy Efficient Ethernet 802.1Q VLAN Tagging
  • Model #: ICX7550-24P-E2
TP-Link TL-SG105S | 5 Port Gigabit Ethernet Switch | Desktop/Wall-Mount | Plug & Play | Fanless | Sturdy Metal | Limited Lifetime Protection | 802.1p/DSCP QoS & IGMP Snooping | Compact Design
Quick View
TP-Link TL-SG105S | 5 Port Gigabit Ethernet Switch | Desktop/Wall-Mount | Plug & Play | Fanless | Sturdy Metal | Limited Lifetime Protection | 802.1p/DSCP QoS & IGMP Snooping | Compact Design
  • Format: Desktop
  • Standards: IEEE 802.3i, IEEE 802.3u , IEEE 802.3ab, IEEE 802.3x, IEEE 802.1p
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TL-SG105S
Extreme Networks 5420F-16W-32P-4XE Switching 5420F Ethernet Switch - 48 Ports - 2 Layer Supported - Modular - Twisted Pair, Optical Fiber - PoE Ports
Quick View
Extreme Networks
Extreme Networks 5420F-16W-32P-4XE Switching 5420F Ethernet Switch - 48 Ports - 2 Layer Supported - Modular - Twisted Pair, Optical Fiber - PoE Ports
  • Primary Ports: 16 x 10/100/1000BASE-T 802.3bt (90W) ports • Full / Half-Duplex(autosensing) • MACsec-capable 32 x 10/100/1000BASE-T 802.3at (30W) ports • Full / Half-Duplex(autosensing) • MACsec-capable 4 x 1/10Gb SFP+ uplink ports(unpopulated) • MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
  • VLAN Support: Yes
  • PoE: All 5420 models support 30W, 60W, and 90W PoE that conforms with IEEE 802.3bt. This enables the 5420 to address the needs of powered edge devices, while eliminating the need for additional electrical cabling and circuits. In addition, 5420 PoE models support perpetual and fast PoE for even more efficient and reliable powered edge device operation
  • ...
  • Model #: 5420F16W32P4XE
  •  
  • $7,576.99 –
  • Free Shipping
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-104 EMBEDDED 4PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.35
  • Model #: SW-104
Ruckus Wireless ICX 7650 Intake Airflow Fan Back To Front Airflow ICXFAN12I
Quick View
  • $281.90 - $285.20
Black Box 4-Port Modem Splitter
Quick View
Black Box 4-Port Modem Splitter
  • Weight: 0.32
  • Model #: TL421A
TP-Link 9 Port Fast Ethernet 10/100Mbps PoE Switch | 8 PoE+ Ports @65W | Sturdy Metal w/Shielded Ports | Limited Lifetime Protection | Extend Mode | Priority Mode | Isolation Mode (TL-SF1009P)
Quick View
  • $58.51 - $69.79
Netgear AV Line M4250-40G8XF-PoE+ 40-Port Managed Gigabit Ethernet Switch, GSM4248PX-TAANAS
Quick View
Netgear Inc.
Netgear AV Line M4250-40G8XF-PoE+ 40-Port Managed Gigabit Ethernet Switch, GSM4248PX-TAANAS
  • Brand: NETGEAR
  • Part Number: GSM4248PX-TAANAS
  • Network Management Type: Managed
  • Primary Ports: 48 x RJ45 + 8 x SFP+
  • Model #: GSM4248PX-TAANAS
  •  
  • $3,674.99 –
  • Free Shipping
SMART MGD POE+ SWITCH 24PORT
Quick View
SMART MGD POE+ SWITCH 24PORT
  • Switch Type: managed
  • Model #: SM24TAT2SA-NA
TP-Link JetStream 6-Port 10GE L2+ Managed Switch with 4-Port PoE++
Quick View
TP-Link JetStream 6-Port 10GE L2+ Managed Switch with 4-Port PoE++
  • Format: • Rack Mountable • Desktop
  • Standards: 802.3bt/at/af compliant
  • Primary Ports: 4× 10 Gbps RJ45 ports and 2× 10 Gbps SFP+ slots
  • Jumbo Frames: 9 KB
  • Model #: SX3206HPP
  • $450.19 - $456.91
10 PORT GIGABIT MANAGED POE+ SWITCH
Quick View
10 PORT GIGABIT MANAGED POE+ SWITCH
  • Switch Type: ethernet
  • Model #: LPB3010A
TP-Link 8 Port Gigabit PoE Switch | 8 PoE+ Ports @63W, w/ 1 Gigabit Port and 1 SFP Slot | Desktop | Plug & Play | Support QoS and IGMP (TL-SG1210P)
Quick View
TP-Link 8 Port Gigabit PoE Switch | 8 PoE+ Ports @63W, w/ 1 Gigabit Port and 1 SFP Slot | Desktop | Plug & Play | Support QoS and IGMP (TL-SG1210P)
  • Format: Desktop
  • Primary Ports: 9 x RJ45 + 1 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 4K, Auto-learning, Auto-aging
  • Model #: TL-SG1210P
  • $97.50 - $110.25
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
  • Brand: Cisco Systems, Inc.
  • Series: Catalyst C1300 Series
  • Part Number: C1300-24MGP-4X
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
  • Model #: C1300-24MGP-4X
Aruba Rack Mount for Switch Black Silver JL602A
Quick View
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.4
  • Model #: SW-108
TRENDnet TEG-S351, 5-Port 2.5G Switch
Quick View
Available Direct from TRENDnet Available Direct from TRENDnet
HPE Juniper Networking EX2300-C Switch, Compact Fanless 12-port 10/100/1000BASE-T PoE+, 2 X 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-C-12P
Quick View
HPE Juniper Networking EX2300-C Switch, Compact Fanless 12-port 10/100/1000BASE-T PoE+, 2 X 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-C-12P
  • Brand: Juniper Networks
  • Series: EX2300-C
  • Part Number: EX2300-C-12P
  • Switch Type: Layer 3 Switch
  • Model #: EX2300-C-12P
Black Box Gigabit Managed Ethernet Switch - 10-Ports
Quick View
Black Box Gigabit Managed Ethernet Switch - 10-Ports
  • Switch Type: Others
  • Model #: LGB1110A
Ubiquity Lite 8 PoE USW-Lite-8-POE (52W)
Quick View
Ubiquity Lite 8 PoE USW-Lite-8-POE (52W)
  • Brand: Ubiquiti
  • Model #: USWLite8POE
BRAINBOXES SW-105 EMBEDDED 5PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-105 EMBEDDED 5PORT ETHERNET SWITCH
  • Switch Type: Others
  • Weight: 0.35
  • Model #: SW-105
ZyXEL 5 Port Gigabit Ethernet Unmanaged POE+ Switch, 4 x PoE+ @ 60W, GS1005HP
Quick View
ZyXEL 5 Port Gigabit Ethernet Unmanaged POE+ Switch, 4 x PoE+ @ 60W, GS1005HP
  • Brand: ZyXEL
  • Part Number: GS1005HP
  • Switch Type: Manageable: Yes
  • Format: Desktop, Wall-Mount
  • Model #: GS1005HP
TRENDnet TPE-7124SBF 12-Port 10G PoE++ Web Smart Switch (720W)
Quick View
Available Direct from TRENDnet Available Direct from TRENDnet
D-Link DMS-1250-28P Ethernet Switch - 24 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 3 Layer Supported - 592.19 W Consumption - 475 W PoE Budget
Quick View
TRENDnet 8-Port Gigabit GREENnet Switch, Ethernet Network Switch, 8 x 10-100-1000 Mbps Gigabit Ethernet Ports, 16 Gbps Switching Capacity, Metal, Lifetime Protection, Black, TEG-S82G
Quick View
TRENDnet 8-Port Gigabit GREENnet Switch, Ethernet Network Switch, 8 x 10-100-1000 Mbps Gigabit Ethernet Ports, 16 Gbps Switching Capacity, Metal, Lifetime Protection, Black, TEG-S82G
  • Format: Wall Mountable
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3az
  • Uplink Ports: None
  • Primary Ports: 8 x RJ45
  • Model #: TEG-S82g
Available Direct from TRENDnet Available Direct from TRENDnet
Cisco Catalyst C1300-48T-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-48T-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-48T-4X
  • Format: Rack-mountable
  • Model #: C1300-48T-4X