Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Show More
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Ubiquiti Networks UF-OLT-US Gigabit Passive Optical Network
Quick View
Ubiquiti Networks UF-OLT-US Gigabit Passive Optical Network
  • Type: N/A
  • Color: Black
  • Specifications: Processor: MIPS 1004Kc 880 Mhz dual core Memory: 256 Mbyte DDR3, 256M Byte NAND Management Interface: (1) Ethernet out-of-band management (1) Ethernet in-band management (1) RJ45 Serial Console Por (1) Bluetooth Networking Interface: (8) GPON OLT SFP (2) 10 Gbps SFP+ Buttons: (1) Reset, Press 5 seconds - Reset to default LEDs / Display: (1) Power, Blue/White, Blinking Blue: reset to default Steady Blue: system is booting Steady White: service is ready (8) GPON OLT SFP, Steady/Blinking white : GPON link/activity (2) SFP+ Ethernet. White(10G) Green(1G), steady on after link is up, blinking while activity (1) Ethernet RJ45 Out-of-band Management: Green(1G), steady on after link is up, blinking while activity Power Method: 100-240VAC/50-60 Hz universal input Power Supply: (2) Hotswap AC/DC PSU Supported Vo...
  • Model #: UF-OLT
  •  
  • $1,973.99 –
  • Free Shipping
TP-Link TL-SG105PP-M2 Unmanaged Desktop Switch with 4-Port PoE++
Quick View
TP-Link
TP-Link TL-SG105PP-M2 Unmanaged Desktop Switch with 4-Port PoE++
  • Format: Desktop
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 2.5 Gbps
  • Primary Port Type: 5 x 10 Mbps/100 Mbps/1 Gbps/2.5 Gbps RJ45 ports
  • Model #: TL-SG105PP-M2
  • $163.24 - $170.39
PLANET FSD-604HP Unmanaged 4-Port 10/100TX 802.3af/at PoE + 2-Port 10/100TX Desktop Switch (60 Watts)
Quick View
PLANET FSD-604HP Unmanaged 4-Port 10/100TX 802.3af/at PoE + 2-Port 10/100TX Desktop Switch (60 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Flow Control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 4-Port 10/100TX 802.3af/at PoE 2-Port 10/100TX
  • Primary Port Speed: 10/100Mbps
  • Model #: FSD-604HP
  •  
  • $49.99 –
  • Free Shipping
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T, IEEE 802.3u 100BASE-FX, IEEE 802.3z 1000BASE-SX, IEEE 802.3z 1000BASE-LX, 4-Port IEEE 802.3af/at Power over Ethernet end-span PSE
  • Primary Ports: 4 x RJ-45 Female 4 x RJ-45 (PoE+) Female
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES81GPOEW
Planet FGSD-1008HPS 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Switch
Quick View
Planet FGSD-1008HPS 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Switch
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 8 x 10/100BASE-TX RJ45 copper with PoE in-line supported 2 x 10/100/1000BASE-T RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots to share with Port-9 to Port-10
  • MAC Address Table: 4K
  • Switching Method: Store and Forward
  • Model #: FGSD-1008HPS
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8P2S
PLANET FSD-1008HP Unmanaged 8-Port 10/100TX 802.3at PoE + 2-Port 10/100TX Desktop Switch (120 watts)
Quick View
PLANET FSD-1008HP Unmanaged 8-Port 10/100TX 802.3at PoE + 2-Port 10/100TX Desktop Switch (120 watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port 10/100TX
  • MAC Address Table: 8K
  • Model #: FSD-1008HP
  •  
  • $88.99 –
  • Free Shipping
PLANET IGS-4215-8P2T2S Managed 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
Quick View
PLANET IGS-4215-8P2T2S Managed 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 10/100/1000T 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: IGS-4215-8P2T2S
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
Quick View
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3af Power over Ethernet
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with IEEE 802.3af PoE injector 1-port 100Base-FX SFP interface
  • MAC Address Table: 2K
  • Switching Method: Store and Forward
  • Model #: ISW-514PTF
  •  
  • $215.99 –
  • Free Shipping
PLANET IGS-620TF Industrial 4-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch
Quick View
PLANET IGS-620TF Industrial 4-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet / 10Base-T IEEE 802.3u Fast Ethernet / 100Base-TX IEEE 802.3ab Gigabit Ethernet / 1000Base-T IEEE 802.3z Gigabit Ethernet / 1000Base-SX/LX IEEE 802.3x Full-Duplex Flow Control
  • Primary Ports: 4 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-620TF
PLANET IGS-500T Unmanaged Compact Industrial 5-Port 10/100/1000T Gigabit Ethernet Switch
Quick View
PLANET IGS-500T Unmanaged Compact Industrial 5-Port 10/100/1000T Gigabit Ethernet Switch
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet IEEE 802.1p Class of Service
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-500T
  •  
  • $117.99 –
  • Free Shipping
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
Quick View
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-621T series 2 x port 100Base-FX interface on ISW-621T for up to 2km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-621T
Planet FGSW-2624HPS4 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Ethernet Switch / 420W PoE budget
Quick View
Planet FGSW-2624HPS4 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Ethernet Switch / 420W PoE budget
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet over Fiber-Optic IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 24 x 10/100BASE-TX RJ45 copper with 24-port IEEE 802.3at / af PoE injector 2 x 10/100/1000BASE-T Gigabit RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots, shared with port-25 to port-26
  • MAC Address Table: 4K
  • Switching Method: Store and Forward
  • Model #: FGSW-2624HPS4
Ubiquiti Networks - sunMAX SolarPoint (SM-SP-40)
Quick View
Ubiquiti Networks - sunMAX SolarPoint (SM-SP-40)
  • Primary Ports: (4) 10/100 MbE fast ports
  • PoE: Yes
  • Power: Power method PV panel (H4 connectors) Max. power consumption 2W Supported voltage range 10–60V (Reverse protection, surge protection) Max. open circuit voltage: 60V
  • Dimensions: 202 x 190 x 50 mm (8 x 7.5 x 2")
  • Model #: SM-SP-40
  •  
  • $199.00 –
  • Free Shipping
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T2S
  •  
  • $245.99 –
  • Free Shipping
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-8P4S
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15km (-40 ~ 75 Degrees C Operating Temperature)
Quick View
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15km (-40 ~ 75 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511TS15 for up to 15km (single-mode fiber 9/125µm) transmission distance
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-511TS15
  •  
  • $121.99 –
  • Free Shipping
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
  • Brand: PLANET
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGSW-24040R
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
  • Format: DIN-rail and Wall-mount Ear
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-4215-4P4T
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-8P2S2X
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: 19-inch Rack-mountable Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-16T4S
Ubiquiti G2 Touch Max (UTP-TouchMax)
Quick View
Ubiquiti G2 Touch Max (UTP-TouchMax)
  • Brand: Ubiquiti Networks
  • Part Number: UTP-TouchMax
  • Type: VoIP Phones
  • Display: Screen Surface Treatments: Fingerprint-Resistant Coating Size: 178 mm (7") diagonal Resolution: 1280 x 800 HD
  • Model #: UTP-TOUCHMAX-U
  •  
  • $313.99 –
  • Free Shipping
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-801T
  •  
  • $160.99 –
  • Free Shipping
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-501T
  •  
  • $114.99 –
  • Free Shipping
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
Quick View
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Flow Control
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX SFP interface
  • MAC Address Table: 2K
  • Switching Method: Store and Forward
  • Model #: ISW-621TF
  •  
  • $96.99 –
  • Free Shipping
Ubiquiti Mobile Router (UMR-US)
Quick View
Ubiquiti Mobile Router (UMR-US)
  • Wireless Data Rates: Supported Data Rates 802.11n: 6.5 Mbps to 150 Mbps (MCS0 - MCS7, HT 20/40) 802.11g: 6, 9, 12, 18, 24, 36, 48, 54 Mbps 802.11b: 1, 2, 5.5, 11 Mbps
  • Brand: Ubiquiti Networks
  • Part Number: UMR-US
  • WiFi Generation: Wi-Fi 4
  • Model #: UMR-US
  •  
  • $196.99 –
  • $10.99 Shipping
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
Quick View
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x full-duplex Flow Control
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX interface on
  • MAC Address Table: 2K
  • Model #: ISW-621TS15
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-801T
  •  
  • $657.00 –
  • Free Shipping
Intellinet 560993 16-Port Gigabit Ethernet PoE+ Switch
Quick View
Intellinet 560993 16-Port Gigabit Ethernet PoE+ Switch
  • Brand: Intellinet
  • Format: Rackmount
  • Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3ab (Twisted Pair Gigabit Ethernet) IEEE 802.3af (Power over Ethernet 802.3at Type 1) IEEE 802.3at (Power over Ethernet 802.3at Type 2) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3x (flow control, for full duplex mode)
  • Primary Ports: 16 x PoE ports
  • Model #: 560993
d-link 2rj6268 websmart dgs-1210-28 ethernet switch
Quick View
  •  
  • $216.32 –
  • Free Shipping
D-Link DXS-1210-10TS 10-Port 10 Gigabit WebSmart Switch with 8 10GBase-T Ports and 2 SFP+ ports
Quick View
D-Link DXS-1210-10TS 10-Port 10 Gigabit WebSmart Switch with 8 10GBase-T Ports and 2 SFP+ ports
  • Standards: IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3az compliance IEEE 802.3an 10GBASE-T 10GbE over copper IEEE 802.3ae 10GbE over fiber IEEE 802.3z 1000BASE-X Auto MDI/MDIX support for 1000/10GBASE-T
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10 Gbps
  • MAC Address Table: 16K
  • Model #: DXS-1210-10TS
  •  
  • $1,344.90 –
  • Free Shipping
D-Link DES-3852 Managed Layer 3 Switch
Quick View
D-Link DES-3852 Managed Layer 3 Switch
  • Brand: D-Link
  • Standards: IEEE 802.3 Ethernet, 802.3u Fast Ethernet, 802.3ab Gigabit Ethernet, 802.3z Gigabit Ethernet, 802.1d Spanning Tree, 802.1w Rapid Spanning Tree, 802.1p Priority Tags, 802.1q VLANs (4K static/ 255 dynamic), 802.3ad Link Aggregation (32 Groups/8 ports), 802.3x Flow Control, 802.1x Port-based /MAC based Authentication, 802.1s (Multiple Spanning Tree)
  • Primary Ports: 48 10/100 Mbps Ports, 2 Combo SFP/1000BASE-T Ports, & 2 Built-in 1000BASE-T Uplinks
  • Primary Port Speed: 10/100Mbps + 1000Mbps
  • Model #: DES-3852
  •  
  • $1,508.90 –
  • Free Shipping
Ubiquiti Networks airMAX PowerBeam 5AC (PBE-5AC-Gen2)
Quick View
Ubiquiti Networks airMAX PowerBeam 5AC (PBE-5AC-Gen2)
  • Frequency Band: Operating Frequency (MHz) Worldwide 5150-5875 MHz USA U-NII-1 U-NII-2A U-NII-2C U-NII-3 5150-5250 MHz 5250-5350 MHz 5240-5725 MHz 5725-5850 MHz Management Radio (MHz) Worldwide 2412 - 2472 MHz US/CA 2412 - 2462 MHz
  • Power Supply: Power method Passive PoE 2-pair (4, 5+; 7, 8 return) Max. power consumption 8.5W Supported voltage range 20—27V DC Power supply 24V, 0.5A gigabit PoE adapter (Included) ESD/EMP protection Air/contact: ± 24 kV
  • Temperature: -40 to 70 C (-40 to 158 F)
  • Humidity: 5 to 95% noncondensing
  • Model #: PBE-5AC-Gen2
NETIS PE6108G Unmanaged 8-Port Gigabit Switch with 8 PoE Port 120W IEEE802.3af/at
Quick View
NETIS PE6108G Unmanaged 8-Port Gigabit Switch with 8 PoE Port 120W IEEE802.3af/at
  • Format: Desktop
  • Standards: IEEE 802.3u 1000Base-TX, IEEE 802.3u 100BASE -TX, IEEE 802.3 10BASE -T, IEEE 802.3at, IEEE 802.3x Flow Contro
  • Primary Ports: 8 10/100/1000Mbps RJ45 port, with PoE function
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: PE6108G
  •  
  • $49.98 –
  • Free Shipping
Direct from Netis Systems Direct from Netis Systems
  • $48.00 - $49.98
NETIS ST3116G Unmanaged 16 Port Gigabit Ethernet Rackmount Switch
Quick View
NETIS ST3116G Unmanaged 16 Port Gigabit Ethernet Rackmount Switch
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T, IEEE 802.3u 100Base-TX, IEEE802.3ab 1000BASE-T , IEEE 802.3x Flow Control, IEEE 802.3az
  • Uplink Ports: None
  • Primary Ports: 16 x RJ45
  • Model #: ST3116G
  •  
  • $58.88 –
  • Free Shipping
Direct from Netis Systems Direct from Netis Systems
  • $50.00 - $58.88
NETIS ST3124P Unmanaged 24 Port Fast Ethernet Desktop Plastic Switch
Quick View
NETIS ST3124P Unmanaged 24 Port Fast Ethernet Desktop Plastic Switch
  • Format: Desktop
  • Standards: IEEE 802.3 10Base-T, IEEE 802.3u 100Base-TX, IEEE 802.3x Flow Control, IEEE 802.3az
  • Primary Ports: 24 x 10/100 Mbps RJ45 port, Auto-Negotiation, Auto MDI / MDIX
  • Primary Port Speed: 10/100Mbps
  • Model #: ST3124P
  •  
  • $28.88 –
  • Free Shipping
Direct from Netis Systems Direct from Netis Systems
  • $27.00 - $28.88