Your Browsing History
- In Stock
- Sold by Newegg
- Make an Offer
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
TRENDnet TPE-LG80 Switch
- Format: Desktop
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3p, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TPE-LG80
- $95.52 –
- Free Shipping

Quick View
D-Link DGS-1210-52 52-Port Gigabit Web Smart Switch w/ 4 Gigabit SFP Ports
- Switch Type: Ethernet Switch
- Weight: 9.95
- Model #: DGS-1210-52
- $527.99 –
- More options from $527.99 - $630.90

Quick View
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
- Format: DIN Rail Mount
- MAC Address Table: 8K MAC address table with auto learning function
- Jumbo Frames: 9000 bytes
- Buffer Memory: 1MB
- Model #: WGS-804HP
- $198.00
- See price in cart
- More options from $163.99 - $172.00
- Free Shipping

Quick View
Planet IGS-10020PT Industrial 8-Port 10/100/1000T 802.3af PoE + 2 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
- Format: DIN Rail Mount
- Standards: IEEE 802.3/3u/3ab, IEEE 802.3af
- Primary Ports: 8 10/100/1000Base-T RJ-45 Auto-MDI/MDI-X ports / 2 1000Base-SX/LX/BX SFP interfaces (Port-9 and Port-10)
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-10020PT
- $584.00
- See price in cart
- Free Shipping

Quick View
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-501T
- $114.99 –
- Free Shipping

Quick View
CISCO CBS110-8T-D-NA Unmanaged 110 Series Unmanaged Switches
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: CBS110-8T-D-NA
- $87.99 –

Quick View
- $541.88 –
- More options from $541.88 - $787.00
- Free Shipping

Quick View
Planet MGSD-10080F 8-Port 100/1000X SFP + 2-Port 10/100/1000T Managed Metro Ethernet Switch
- Format: Wall Mountable
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid Spanning tree protocol IEEE 802.1s Multiple Spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2
- Primary Ports: 8 1000Base-SX/LX/BX SFP interfaces, from port 1 to port 8 Compatible with 100Base-FX SFP, 2 10/ 100/1000Base-T RJ-45 Auto-MDI/MDI-X ports, 1 x RJ-45-to-RS-232 serial port (115200, 8, N, 1)
- Primary Port Speed: 20Gbps / non-blocking
- Model #: MGSD-10080F
- $376.00
- See price in cart
- Free Shipping

Quick View
Cisco Catalyst 8300 Router, 1RU w/ 10G WAN (1 SM slot and 1 NIM slot, 2 x 10-Gigabit Ethernet and 4 x 1-Gigabit Ethernet ports) | C8300-1N1S-4T2X
- Brand: CISCO
- Part Number: C8300-1N1S-4T2X
- Form Factor: Rack Mountable
- System Memory: Memory (DRAM) default: 8 GB
- Model #: C8300-1N1S-4T2X
- $24,181.89
- $14,443.99 –
- Save: $9,737.90 (40%)
- More options from $14,443.99 - $16,742.82
- Free Shipping

Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
- Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
- Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
- Model #: WGSW-24040
- $332.00
- See price in cart
- Free Shipping

Quick View
LINKSYS PC22224 ProConnect II 2224 Layer 2 Management Ethernet Switch
- Brand: LINKSYS
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3z, IEEE 802.3x, IEEE 802.1p, IEEE 802.1q, IEEE 802.3ab, IEEE 802.1d, IEEE 802.3ad
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: PC22224
- $165.00 –
- $26.99 Shipping

Quick View
mikrotik crs310-1g-5s-4s+in 5 x sfp ports 4 x sfp+ ports and 1 x gigabit ethernet port
- Weight: 1.3500
- Model #: MBVB09W7WBQ77
- $299.99 –
- Free Shipping

Quick View
Intellinet 560993 16-Port Gigabit Ethernet PoE+ Switch
- Brand: Intellinet
- Format: Rackmount
- Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3ab (Twisted Pair Gigabit Ethernet) IEEE 802.3af (Power over Ethernet 802.3at Type 1) IEEE 802.3at (Power over Ethernet 802.3at Type 2) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3x (flow control, for full duplex mode)
- Primary Ports: 16 x PoE ports
- Model #: 560993
- $315.99
- See price in cart

Quick View
HPE Aruba Networking 6300L 48-port Smart Rate 100M/1G/2.5G/5G CL8 2-port SFP56 50G 2-port SFP28 25G L2 Switch | S3L76A
- Brand: HPE Aruba Networking
- Series: CX 6300 Switch Series
- Part Number: S3L76A
- Standards: IEEE 802.3af, 802.3at, and 802.3bt
- Model #: S3L76A
- $19,763.00
- See price in cart
- Free Shipping

Quick View
D-Link DGS-105 5 Port Gigabit Unmanaged Metal Desktop Switch
- Model #: LK9445B
- $113.99 –
- Free Shipping

Quick View
ZyXEL XGS1210-12 Managed 12-Port Web-Managed Multi-Gigabit Switch with 2-Port 2.5G and 2-Port 10G SFP+
- Format: Desktop
- Standards: IEEE 802.3 10BASE-TX Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE802.3ab 1000BASE-T IEEE 802.3bz 2500BASE-T Gigabit Ethernet SFF-8431 IEEE 802.3az Energy Efficient Ethernet IEEE 802.3x full duplex operation and flow control
- Primary Ports: 10 x RJ45 + 2 x SFP
- Primary Port Speed: 8 x RJ-45 10/100/1000 Mbps Ethernet port with metal shielding 2 x RJ-45 100/1000/2500 Mbps Ethernet port with metal shielding 2 x SFP+ (Uplink only)
- Model #: XGS1210-12
- $248.90 –
- Free Shipping

Quick View
Mikrotik CRS112-8G-4S-IN 8 port Gigabit Cloud Router Switch 112-8G-4S-IN 4xSFP
- Model #: BECRS112-8G-4S-IN
- $239.99 –
- Free Shipping

Quick View
Mikrotik CCR2004-16G-2S+ 16x Gigabit Ethernet Ports 2x10G SFP+
- Model #: BEZ60QU8R1
- $859.00 –
- Free Shipping

Quick View
Check Point Quantum 3600 Security Gateway Base security appliance 1 year SNBT CPAP-SG3600-SNBT
- Firewall Type: Firewalls/UTM/VPN
- Model #: CPAP-SG3600-SNBT
- $6,440.90 –
- Free Shipping

Quick View
MikroTik 5-Port Desktop Switch, 1 Gigabit Ethernet Port, 4 SFP+ 10Gbps Ports (CRS305-1G-4S+IN)
- Model #: R321858956739N
- $359.99 –
- Free Shipping

Quick View
Mikrotik netFiber 9 CRS310-1G-5S-4S+OUT outdoor Gigabit Ethernet switch
- Model #: B0H98Z56SW
- $536.99 –
- Free Shipping

Quick View
QXG-25G2SF-CX6 Two Port 25GbE Network Card with SR-IOV and RoCE for Improved Network and VMware® Virtualization Environments (QXG-25G2SF-CX6)
- Model #: QXG-25G2SF-CX6-0
- $698.00 –
- More options from $698.00 - $749.00
- Free Shipping

Quick View
Dell S3124P L3 PoE+ Switch 24x 1GbE Ports 2x 10GbE SFP+ 715W Networking Switch
- Model #: G9YF5, 0G9YF5, S3124P, E06W
- $460.00 –
- Free Shipping

Quick View
Dell EMC N3224P-ON 24x1G 4x10G 2x100G PoE 1050W 3L Network Ethernet Switch GM1R7
- Model #: GM1R7, 0GM1R7, CN-0GM1R7, N3224P-ON,
- $475.00 –
- Free Shipping

Quick View
Brocade 6520 BR-6520-96-16G-R 96 Ports 16 Gbps Switch
- Format: Rail-mountable
- Primary Ports: 96 x RJ45
- Primary Port Speed: 16 Gbps Brocade 6520 requires Brocade hot-pluggable SFP+, LC connector
- Jumbo Frames: 2KB
- Model #: BR-6520-96-16G-R
- $201,329.00
- See price in cart
- Free Shipping

Quick View
HPE 503827-001 NC112T Gigabit Ethernet Card
- Electrical Outlet Plug Type: Gigabit Ethernet Card
- Model #: 503827-001
- $56.76 –
- More options from $56.76 - $69.00
- Free Shipping

Quick View
LSI LOGIC 9240-8i 8-Port 6GB/s PCIe 2.0 Sata+SAS Mega Raid Controller Card
- Part Number: 9240-8i
- Model #: 69089112250
- $55.99 –
- Free Shipping

Quick View
Edge-Core ECS4610-50T L3 Gigabit Ethernet Stackable Switch
- Brand: Edge-Core
- Format: Stackable
- Standards: IEEE 802.3-2005 Ethernet, Fast Ethernet, Gigabit Ethernet Full-duplex flow control IEEE 802.3ae 10 Gigabit Ethernet IEEE 802.3D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1Q Virtual LAN ISO/IEC 8802-3 CSMA/CD
- Primary Ports: 44 x RJ-45 10/100/1000BASE-T 4 x Combination (RJ-45/SFP) Gigabit Ethernet
- Model #: ECS4610-50T
- $1,313.20 –
- More options from $1,299.00 - $1,313.20
- Free Shipping

Quick View
- $500.00 –
- Free Shipping

Quick View
Grandstream Android 11 8" LCD Touchscreen (GXV3480)
- Brand: Grandstream
- Model: GXV3480
- Part Number: GXV3480
- Type: VoIP Phones
- Model #: GXV3480
- $459.73 –
- More options from $404.30 - $499.00
- Free Shipping

Quick View
- $1,199.99 –
- Free Shipping

Quick View
LSI LOGIC 9240-8i 8-Port 6GB/s PCIe 2.0 Sata+SAS Mega Raid Controller Card
- Part Number: 9240-8I
- Accessory Type: Megaraid
- Model #: 968349802078
- $55.99 –
- Free Shipping

Quick View
D-Link DGS-3120-24SC-RI Switch 24 Port Lan 16 X SFP/GIGA Ports+ PHY 10/100/1
- Model #: DGS-3120-24SC-RI
- $421.90 –
- Free Shipping





