Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
MikroTik hAP ac3
Quick View
MikroTik hAP ac3
  • Model #: RBD53iG-5HacD2HnD-US
  •  
  • $115.85 –
  • Free Shipping
HP J4812A Managed ProCurve Switch 2512
Quick View
HP
HP J4812A Managed ProCurve Switch 2512
  • Brand: HP
  • Format: Rackmount
  • Standards: IEEE 802.3x Flow Control IEEE 802.1D Spanning Tree IEEE 802.3ad Link Aggregation Control Protocol IEEE 802.1X Network Login IEEE 802.1Q GVRP IEEE 802.1w Rapid Convergence Spanning Tree IEEE 802.1Q VLANs IEEE 802.1p Priority
  • Network Management Type: Managed
  • Model #: J4812A
  •  
  • $751.00 –
  • Free Shipping
Planet IGS-10020HPT L2+ Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch with Wide Operating Temperature
Quick View
Planet IGS-10020HPT L2+ Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch with Wide Operating Temperature
  • MAC Address Table: 8K entries, automatic source address learning and ageing
  • Buffer Memory: 4Mbits
  • QoS: Traffic classification based, Strict priority and WRR 8-Level priority for switching - Port Number - 802.1p priority - 802.1Q VLAN tag - DSCP/TOS field in IP Packet
  • Model #: IGS-10020HPT
Mikrotik CRS326-24G-2S+RM Cloud Router Switch 326-24G-2S+RM 24 Gigabit port switch with 2 x SFP+ cages in 1U rackmount case, Dual boot (RouterOS or SwitchOS)
Quick View
  •  
  • $423.93 –
  • Free Shipping
Direct from PISKEKAT Direct from PISKEKAT
C&N Mellanox ConnectX-3 Dual-Port QSFP+ 40GbE Network Card - PCIe 3.0 x8 Enterprise/Data Center NIC with Hardware Offload & RoCE Support
Quick View
C&N Mellanox ConnectX-3 Dual-Port QSFP+ 40GbE Network Card - PCIe 3.0 x8 Enterprise/Data Center NIC with Hardware Offload & RoCE Support
  • Brand: C&N
  • Part Number: ST7288
  • Standards: Ethernet
  • Speed: 10 gigabytes_per_second
  • Model #: ST7288
  •  
  • $199.00 –
  • Free Shipping
Direct from C&N Direct from C&N
Mikrotik S+RJ10 6-Speed RJ-45 Module for up to 10 Gbps Copper Module
Quick View
  •  
  • $117.99 –
  • $5.99 Shipping
IBM 42D0491 System X
Quick View
IBM 42D0491 System X
  • Model #: 42D0491
MikroTik hEX S Gigabit Ethernet Router with SFP Port (RB760iGS)
Quick View
  •  
  • $121.99 –
  • $5.99 Shipping
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
Quick View
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-804HPT
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
Quick View
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
  • Format: Rail-mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-duplex flow control
  • Primary Ports: 8x 10/100/1000Base-T Ports
  • Primary Port Speed: 10/100/1000Base-T
  • Model #: IGS-801T
  •  
  • $164.00 –
  • Free Shipping
Mikrotik CRS326-24G-2S+RM Network Switch L2 Gigabit Ethernet (10/100/1000) Grey Power Over Ethernet (PoE)
Quick View
HP V1910-24G-PoE JE007A#ABA Managed V1910-24G-PoE Switch
Quick View
HP V1910-24G-PoE JE007A#ABA Managed V1910-24G-PoE Switch
  • Brand: HP
  • Series: V1910-24G-PoE
  • Format: Rackmount
  • Standards: IEEE 802.3/3u/3ab, IEEE 802.3af
  • Model #: JE007A#ABA
  •  
  • $2,500.00 –
  • Free Shipping
HP J9049A Managed ProCurve Switch 2900-24G
Quick View
HP J9049A Managed ProCurve Switch 2900-24G
  • Brand: HP
  • Format: Rackmount
  • Standards: IEEE 802.1w Rapid Convergence Spanning Tree IEEE 802.3ad Link Aggregation Control Protocol IEEE 802.1Q VLAN tagging IEEE 802.1p Priority IEEE 802.1D Spanning Tree IEEE 802.1s Multiple Spanning Trees IEEE 802.1AB Link Layer Discovery Protocol IEEE 802.1X Network Login IEEE 802.1Q GVRP
  • Network Management Type: Managed
  • Model #: J9049A
  •  
  • $3,000.00 –
  • Free Shipping
Mikrotik Wireless Wire RBwAPG-60ad kit 60GHz PtP 1 Gbit Full Duplex Link up to 100 Meters
Quick View
Mikrotik NetMETAL 5 RB921UAGS-5SHPacD-NM US Version Dual chain 5GHz integrated 802.11ac wireless device
Quick View
MikroTik LHG LTE6 kit CAT6 LTE Modem for Very Remote/Rural Locations Within Cellular Network Coverage
Quick View
Mikrotik Routerboard Metal 52 Ac Outdoor Wireless Ap 802.11ac- RBMetalG-52SHPacn
Quick View
HPE Aruba 3810M 24 SFP+ 250W Switch
Quick View
HPE Networking Instant On
HPE Aruba 3810M 24 SFP+ 250W Switch
  • Format: Rackmount
  • Primary Ports: 48 x 10/100/1000 ports, maximum or 16 x 1/10 GbE SFP+ ports, depending on model, all supporting MACSec 8 x HPE Smart Rate Multi-Gigabit (1/2.5/5/10GBASE-T) ports, available on select model 2 x open I/O module slots, maximum, depending on model PoE / PoE+ on selected models
  • Buffer Memory: 13.5MB Internal
  • Power: 100-240V AC Depending on installed options, model and configuration
  • Model #: JL430A
  •  
  • $4,939.00 –
  • Free Shipping