Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
  • Brand: Cisco Systems, Inc.
  • Series: Catalyst C1300 Series
  • Part Number: C1300-24MGP-4X
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
  • Model #: C1300-24MGP-4X
D-Link 8-Port 2.5Gb Unmanaged Gaming Switch with 8 x 2.5G - Multi-Gig, Network, Fanless, Plug & Play - (DMS-108)
Quick View
D-Link 8-Port 2.5Gb Unmanaged Gaming Switch with 8 x 2.5G - Multi-Gig, Network, Fanless, Plug & Play - (DMS-108)
  • Brand: D-Link
  • Series: ProSafe
  • Part Number: DMS-108
  • Format: Desktop
  • Model #: DMS108
Available Direct from D-Link Available Direct from D-Link
D-Link 5-Port 2.5Gb Unmanaged Gaming Switch (DMS-105) with 5 x 2.5Gb ports - Multi-Gig, Network, Fanless, Plug & Play
Quick View
D-Link 5-Port 2.5Gb Unmanaged Gaming Switch (DMS-105) with 5 x 2.5Gb ports - Multi-Gig, Network, Fanless, Plug & Play
  • Brand: D-Link
  • Series: 100 Series
  • Part Number: DMS-105
  • Switch Type: multi-gigabit
  • Model #: DMS105
Available Direct from D-Link Available Direct from D-Link
Netgear GS108 8-Port Gigabit Ethernet Unmanaged Switch, GS108-400NAS
Quick View
Netgear GS108 8-Port Gigabit Ethernet Unmanaged Switch, GS108-400NAS
  • Brand: NETGEAR
  • Series: ProSafe
  • Part Number: GS108-400NAS
  • Format: Desktop
  • Model #: GS108-400NAS
  •  
  • $49.99 –
  • Free Shipping
Cisco Business CBS220-16P-2G Smart Switch | 16 Port GE | PoE | 2x1G SFP | 3-Year Limited Hardware Warranty (CBS220-16P-2G-NA)
Quick View
Cisco Business CBS220-16P-2G Smart Switch | 16 Port GE | PoE | 2x1G SFP | 3-Year Limited Hardware Warranty (CBS220-16P-2G-NA)
  • Brand: Cisco Systems, Inc.
  • Switch Type: ethernet
  • Network Management Type: Managed
  • Primary Ports: 16 x RJ45 + 2 x SFP
  • Model #: CBS220-16P-2G
Netgear GS524PP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (300W), GS524PP-100NAS
Quick View
Netgear Inc.
Netgear GS524PP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (300W), GS524PP-100NAS
  • Brand: NETGEAR
  • Format: Desktop / Rackmount
  • Network Management Type: Unmanaged
  • Primary Ports: 24 x RJ45
  • Model #: GS524PP-100NAS
  •  
  • $389.99 –
  • Free Shipping
Cisco Business 220 Gigabit Ethernet Switch, 8 x 10/100/1000 ports w/ 130W power budget, 2 x Gigabit SFP | CBS220-8FP-E-2G-NA
Quick View
Cisco Business 220 Gigabit Ethernet Switch, 8 x 10/100/1000 ports w/ 130W power budget, 2 x Gigabit SFP | CBS220-8FP-E-2G-NA
  • Part Number: CBS220-8FP-E-2G
  • Format: Rack-mountable
  • Standards: Layer Supported: 2 Networking Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3ad IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1w IEEE 802.1s IEEE 802.1x IEEE 802.3af IEEE 802.3at
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
  • Model #: CBS2208FPE2GNA
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
Quick View
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
  • Brand: CISCO
  • Series: Catalyst
  • Part Number: C1300-8P-E-2G
  • Format: Rack-mountable
  • Model #: C1300-8P-E-2G
Cisco Catalyst 1200-48P-4G Smart Switch, 48 Port GE, PoE, 4x1GE SFP, Limited Lifetime Protection (C1200-48P-4G)
Quick View
Cisco Catalyst 1200-48P-4G Smart Switch, 48 Port GE, PoE, 4x1GE SFP, Limited Lifetime Protection (C1200-48P-4G)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • PoE: Yes
  • Model #: C1200-48P-4G
Cisco Catalyst C1300-8T-E-2G Ethernet Switch 10 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported - 2 SFP Slots - 10.65 W Power Consumption
Quick View
Netgear ProSafe GS510TPP 8-Port Gigabit Ethernet High-Power PoE+ Smart Switch with 2 Dedicated SFP Ports (190W), GS510TPP-100NAS
Quick View
Netgear ProSafe GS510TPP 8-Port Gigabit Ethernet High-Power PoE+ Smart Switch with 2 Dedicated SFP Ports (190W), GS510TPP-100NAS
  • Brand: NETGEAR
  • Series: ProSafe
  • Part Number: GS510TPP-100NAS
  • Format: Rack-mountable Desktop
  • Model #: GS510TPP-100NAS
  •  
  • $345.99 –
  • Free Shipping
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
Quick View
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 18 x RJ45 + 2 x SFP
  • Layer: 2
  • Model #: CBS220-8T-E-2G
Cisco Business CBS110-16T Unmanaged Switch | 16 Port GE | Limited Lifetime Protection (CBS110-16T-NA)
Quick View
Cisco Business CBS110-16T Unmanaged Switch | 16 Port GE | Limited Lifetime Protection (CBS110-16T-NA)
  • Part Number: CBS110-16T
  • Format: Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Primary Ports: Total Number of Network Ports: 16 Port/Expansion Slot Details: 16 x Gigabit Ethernet Network
  • Model #: CBS11016TNA
Cisco CBS220-48P-4X Smart Switch | 48 Port GE | PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48P-4X-NA)
Quick View
Cisco CBS220-48P-4X Smart Switch | 48 Port GE | PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48P-4X-NA)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 48 x RJ45 + 4 x SFP+
  • PoE: Yes
  • Model #: CBS220-48P-4X-NA
Cisco Business 220 Switch, 48 x 10/100/1000 ports w/ 382W power budget, 4 x Gigabit SFP | CBS220-48P-4G-NA
Quick View
Cisco Business 220 Switch, 48 x 10/100/1000 ports w/ 382W power budget, 4 x Gigabit SFP | CBS220-48P-4G-NA
  • Brand: Cisco Systems, Inc.
  • Series: Business 220 Series
  • Part Number: CBS220-48P-4G-NA
  • Switch Type: managed network switch
  • Model #: CBS22048P4GNA
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
Quick View
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: CBS110-8PP-D-NA
CISCO DESIGNED Business CBS220-24FP-4G Smart Switch | 24 Port GE | Full PoE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-24FP-4G-NA)
Quick View
CISCO DESIGNED Business CBS220-24FP-4G Smart Switch | 24 Port GE | Full PoE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-24FP-4G-NA)
  • Brand: CISCO
  • Part Number: CBS220-24FP-4G-NA
  • Switch Type: managed
  • Format: 24-port GE / PoE + / 382W / 4 x GE uplinks
  • Model #: CBS22024FP4GNA
Cisco Catalyst 1200-48T-4G Smart Switch, 48 Port GE, 4x1GE SFP, Limited Lifetime Protection (C1200-48T-4G)
Quick View
Cisco Catalyst 1200-48T-4G Smart Switch, 48 Port GE, 4x1GE SFP, Limited Lifetime Protection (C1200-48T-4G)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Layer: 3
  • Model #: C1200-48T-4G
Cisco CBS220-48FP-4X Smart Switch | 48 Port GE | Full PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48FP-4X-NA)
Quick View
Cisco CBS220-48FP-4X Smart Switch | 48 Port GE | Full PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48FP-4X-NA)
  • Brand: Cisco Systems, Inc
  • Series: Business
  • Part Number: CBS220-48FP-4X-NA
  • Switch Type: managed
  • Model #: CBS220-48FP-4X
Netgear GS524UP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 16-Ports PoE++ (480W), GS524UP-100NAS
Quick View
Netgear Inc.
Netgear GS524UP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 16-Ports PoE++ (480W), GS524UP-100NAS
  • Brand: NETGEAR
  • Part Number: GS524UP-100NAS
  • Switch Type: unmanged
  • Format: Desktop Rack-mountable
  • Model #: GS524UP-100NAS
  •  
  • $529.99 –
  • Free Shipping
Netgear GS516UP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 8-Ports PoE++ (380W), GS516UP-100NAS
Quick View
Netgear Inc.
Netgear GS516UP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 8-Ports PoE++ (380W), GS516UP-100NAS
  • Brand: NETGEAR
  • Format: Desktop / Rackmount
  • Network Management Type: Unmanaged
  • Primary Ports: 16 x RJ45
  • Model #: GS516UP-100NAS
  •  
  • $369.99 –
  • Free Shipping
Netgear GS516PP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (260W), GS516PP-100NAS
Quick View
Netgear Inc.
Netgear GS516PP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (260W), GS516PP-100NAS
  • Brand: NETGEAR
  • Part Number: GS516PP-100NAS
  • Format: Desktop Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Model #: GS516PP-100NAS
  •  
  • $309.99 –
  • Free Shipping
Cisco Catalyst 9300 Managed Switch, 24-port 25G/10G/1G SFP28 with modular uplinks, Network Essentials | C9300X-24Y-E
Quick View
Cisco Catalyst 9300 Managed Switch, 24-port 25G/10G/1G SFP28 with modular uplinks, Network Essentials | C9300X-24Y-E
  • Brand: Cisco
  • Series: C9300 Series
  • Part Number: C9300X-24Y-E
  • Primary Ports: 24 x SFP28
  • Model #: C9300X-24Y-E
Cisco Business CBS220-48T-4G Smart Switch | 48 Port GE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-48T-4G-NA)
Quick View
Cisco Business CBS220-48T-4G Smart Switch | 48 Port GE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-48T-4G-NA)
  • Brand: Cisco Systems, Inc
  • Series: Business
  • Part Number: CBS220-48T-4G
  • Format: Rack-mountable
  • Model #: CBS220-48T-4G
Cisco Business CBS220-24T-4X Smart Switch | 24 Port GE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-24T-4X-NA)
Quick View
Cisco Business CBS220-24T-4X Smart Switch | 24 Port GE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-24T-4X-NA)
  • Brand: CISCO
  • Switch Type: ethernet
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP+
  • Model #: CBS220-24T-4X
Cisco Catalyst C1300-48MGP-4X, 48-port Layer 3 Managed Switch | C1300-48MGP-4X
Quick View
Cisco Catalyst C1300-48MGP-4X, 48-port Layer 3 Managed Switch | C1300-48MGP-4X
  • Brand: Cisco Systems, Inc.
  • Series: Catalyst 1300 Series
  • Part Number: C1300-48MGP-4X
  • Format: Rackmount
  • Model #: C1300-48MGP-4X
Cisco Catalyst 8500L-8S4X switch 12 ports rack-mountable
Quick View
  •  
  • $50,931.99 –
Arista DCS-7010T-48-F 48P 1GbE 4P 10GbE SFP+ Switch
Quick View
  •  
  • $120.40 –
  • Free Shipping
QSFP-100G-LR-ARISTA 100GBASE-LR 10km SMF QSFP Transceiver XVR-10224-21
Quick View
  •  
  • $456.40 –
  • Free Shipping
Arista DCS-7010T-48-R 48P 1GbE 4P 10GbE SFP+ RA Switch
Quick View
  •  
  • $120.40 –
  • Free Shipping
Arista DCS-7150S-52-CL-R 52P 10GbE SFP+ RA Switch
Quick View
  •  
  • $280.40 –
  • Free Shipping
Arista DCS-7050QX-32S-F 32P 40GbE QSFP+ 4P 10GbE SFP+ Switch (Kit)
Quick View
  •  
  • $199.00 –
HP J4900A ProCurve 2626 Switch
Quick View
HP
HP J4900A ProCurve 2626 Switch
  • Switch Type: Ethernet Switch
  • Model #: J4900A
  •  
  • $279.10 –
  • Free Shipping
Cisco Industrial Ethernet 4000 Series switch 12 ports managed TAA Compliant
Quick View
  •  
  • $1,412.00 –
  • Free Shipping
Cisco Catalyst 1000-24T-4X-L Switch, 24 Ports - Manageable - 2 Layer Supported
Quick View
Cisco Catalyst 1000-24T-4X-L Switch, 24 Ports - Manageable - 2 Layer Supported
  • Part Number: C1000-24T-4X-L
  • Format: Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 10GBase-X
  • Uplink Interface: Total Number of Expansion Slots: 4 Expansion Slot Type: SFP+ Number of SFP+ Slots: 4
  • Model #: C100024T4XL
  •  
  • $2,923.00 –
  • Free Shipping
Cisco Catalyst 9200CX Network Advantage switch compact 12 ports  managed rack-mountable
Quick View
  • $4,129.85
  •  
  • $3,883.99 –
  • Save: $245.86 (5%)
Cisco Catalyst 9300 Network Advantage switch 48ports managed rack-mountable
Quick View
  •  
  • $10,943.99 –
HPE JG296A 5920AF-24XG Switch
Quick View
HP
HPE JG296A 5920AF-24XG Switch
  • Switch Type: Layer 3 Switch
  • Model #: JG296A
  •  
  • $2,251.10 –
  • Free Shipping
HPE JH324A 5130 48G 4SFP+ 1-slot HI Switch
Quick View
HP
HPE JH324A 5130 48G 4SFP+ 1-slot HI Switch
  • Switch Type: Layer 3 Switch
  • Protocols: HCRP, SPP
  • Model #: JH324A
  •  
  • $2,469.10 –
  • Free Shipping
Cisco C9200-24P-A-Refresh with DNA Advantage 1 Year License
Quick View
  •  
  • $3,599.95 –
  • Free Shipping
Cisco IE-4000-16T4G-E IE-4000-16T4G-E Ethernet Switch
Quick View
Cisco IE-4000-16T4G-E IE-4000-16T4G-E Ethernet Switch
  • Format: Rail-mountable
  • Uplink Ports: Yes
  • Uplink Interface: SFP
  • Primary Ports: 16 x Fast Ethernet Network Fast Ethernet Gigabit Ethernet 4 x Gigabit Ethernet Uplink
  • Model #: IE-4000-16T4G-E
  •  
  • $3,455.00 –
  • Free Shipping
Cisco UCS-FI-E16UP-Refresh
Quick View
  •  
  • $12,717.99 –
  • Free Shipping
Arista DCS-7280SR2-48YC6-R 48P 25GbE SFP25 6P 100GbE QSFP100 RA Switch
Quick View
  •  
  • $3,199.00 –
  • Free Shipping
Arista DCS-7280SE-64-F 48P 10GbE SFP+ 4P 40GbE QSFP+ Switch
Quick View
  •  
  • $199.00 –
  • Free Shipping
Arista DCS-7280SR2A-48YC6-R 48P SFP25 6P QSFP100 RA Switch
Quick View
  •  
  • $2,599.00 –
Arista DCS-7280SE-64-R 48P 10GbE SFP+ 4P 40GbE QSFP+ RA Switch
Quick View
Refurbished Arista DCS-7280SE-64-R 48P 10GbE SFP+ 4P 40GbE QSFP+ RA Switch
  • Brand: Arista
  • Model: DCS-7280SE-64-R
  • Model #: 011110906380
  •  
  • $199.00 –
Arista DCS-7050TX-72Q-R 48P 10GbE Base-T 6P 40GbE QSFP+ RA Switch
Quick View
Refurbished Arista DCS-7050TX-72Q-R 48P 10GbE Base-T 6P 40GbE QSFP+ RA Switch
  • Brand: Arista
  • Model: DCS-7050TX-72Q-R
  • Model #: 011110966865
  •  
  • $199.00 –
Arista DCS-7050TX-72Q-F 48P 10GbE Base-T 6P 40GbE QSFP+ Switch
Quick View
  •  
  • $199.00 –
Arista DCS-7050TX-128-R 96P 10GbE RJ45 8P 40GbE QSFP+ RA Switch
Quick View
Refurbished Arista DCS-7050TX-128-R 96P 10GbE RJ45 8P 40GbE QSFP+ RA Switch
  • Brand: Arista
  • Model: DCS-7050TX-128-R
  • Model #: 011110873408
  •  
  • $599.00 –
Arista DCS-7050SX2-128-R 96P 10GbE SFP+ 8P 40GbE QSFP+ Switch
Quick View
  •  
  • $699.00 –
Arista DCS-7050SX-128-R 96P 10GbE SFP+ 8P 40GbE QSFP+ RA Switch
Quick View
  •  
  • $599.00 –
  • Free Shipping
Arista DCS-7050SX-128-F 96P 10GbE SFP+ 8P 40GbE QSFP+ Switch
Quick View
  •  
  • $599.00 –
Arista DCS-7050SX2-128-F 96P 10GbE SFP+ 8P 40GbE QSFP+ Switch
Quick View
  •  
  • $699.00 –
Arista DCS-7050TX-64-R 48P 10GbE RJ45 4P 40GbE QSFP+ RA Switch (Kit)
Quick View
  •  
  • $399.00 –
  • Free Shipping
Arista DCS-7050QX2-32S-R 32P 40GbE QSFP+ 4P 10GbE SFP+ RA Switch
Quick View
  •  
  • $799.00 –
  • Free Shipping
Arista DCS-7280SE-68-R 48P 10GbE SFP+ 2P 100GbE QSFP100 RA Switch
Quick View
Refurbished Arista DCS-7280SE-68-R 48P 10GbE SFP+ 2P 100GbE QSFP100 RA Switch
  • Brand: Arista
  • Model: DCS-7280SE-68-R
  • Model #: 011110001023
  •  
  • $999.00 –
Arista DCS-7050T-36-R 32P 10GbE Base-T 4P SFP+ RA Switch
Quick View
  •  
  • $159.00 –
  • Free Shipping
Arista DCS-7508E-FM 7500E Series Fabric-E Integrated Switch Fan Tray
Quick View
  •  
  • $1,199.00 –
  • Free Shipping
Arista DCS-7048T-A-F 48P 100/1000 4P 10GbE SFP+ ZTP Switch
Quick View
Refurbished Arista DCS-7048T-A-F 48P 100/1000 4P 10GbE SFP+ ZTP Switch
  • Brand: Arista
  • Model: DCS-7048T-A-F
  • Model #: 011110884411
  •  
  • $149.00 –
Arista DCS-7124S-R 24P 10GbE SFP+ RA Switch
Quick View
  •  
  • $199.00 –
  • Free Shipping
Arista DCS-7124SX-R 24P 10GbE SFP+ RA Switch
Quick View
  •  
  • $195.00 –
  • Free Shipping
Arista DCS-7050QX-32-R 32P 40GbE QSFP+ RA Switch
Quick View
  •  
  • $159.00 –
  • Free Shipping
Arista DCS-7050S-52-R 52P 10GbE SFP+ RA Switch
Quick View
  •  
  • $175.00 –
  • Free Shipping
Arista DCS-7150S-52-CL-R 52P 10GbE SFP+ RA Switch
Quick View
  •  
  • $169.00 –
  • Free Shipping
Arista DCS-7050QX-32-F 32P 40GbE QSFP+ Switch
Quick View
  •  
  • $159.00 –
  • Free Shipping
Arista DCS-7260QX-64-R 64P 40GbE QSFP+ 2P SFP+ RA Switch
Quick View
  •  
  • $179.00 –
Arista DCS-7512R-FM 7500R Series Integrated Fan Switch Fabric Module DCS-7512R-FM
Quick View
  •  
  • $1,500.00 –
  • Free Shipping
Arista DCS-7050SX-72Q-R 48P SFP+ 6P QSFP+ Switch (Fair)
Quick View
  •  
  • $179.00 –
  • Free Shipping
Arista DCS-7280SE-72-F 48P 10GbE SFP+ 2P 100GbE MXP Switch
Quick View
  •  
  • $350.00 –
Arista DCS-7250QX-64-R 64P 40GbE QSFP+ RA Switch
Quick View
  •  
  • $299.00 –
Arista DCS-7050T-52-R 48P 10GbE Base-T 4P SFP+ RA Switch
Quick View
  •  
  • $449.00 –
  • Free Shipping
Brocade ICX6610-24P-PE ICX 6610-24P Layer 3 Switch
Quick View
Refurbished Brocade ICX6610-24P-PE ICX 6610-24P Layer 3 Switch
  • Color: Black
  • Type: Layer 3 Switch
  • Model #: ICX6610-24P-PE
  •  
  • $975.10 –
  • Free Shipping
Juniper EX3300-48T-BF EX3300-48T-BF Layer 3 Switch
Quick View
Refurbished Juniper EX3300-48T-BF EX3300-48T-BF Layer 3 Switch
  • Switch Type: Layer 3 Switch
  • Protocols: HCRP, SPP
  • Package Contents: Includes Rack mount kit (EX-RMK3), Console cable, Power cord
  • Model #: EX3300-48T-BF
  •  
  • $895.01 –
  • Free Shipping