Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
- Brand: Cisco Systems, Inc.
- Series: Catalyst C1300 Series
- Part Number: C1300-24MGP-4X
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
- Model #: C1300-24MGP-4X
- $1,353.99 –
- More options from $1,353.99 - $1,588.43
- Free Shipping

Quick View
D-Link 8-Port 2.5Gb Unmanaged Gaming Switch with 8 x 2.5G - Multi-Gig, Network, Fanless, Plug & Play - (DMS-108)
- Brand: D-Link
- Series: ProSafe
- Part Number: DMS-108
- Format: Desktop
- Model #: DMS108

Quick View
D-Link 5-Port 2.5Gb Unmanaged Gaming Switch (DMS-105) with 5 x 2.5Gb ports - Multi-Gig, Network, Fanless, Plug & Play
- Brand: D-Link
- Series: 100 Series
- Part Number: DMS-105
- Switch Type: multi-gigabit
- Model #: DMS105

Quick View
Netgear GS108 8-Port Gigabit Ethernet Unmanaged Switch, GS108-400NAS
- Brand: NETGEAR
- Series: ProSafe
- Part Number: GS108-400NAS
- Format: Desktop
- Model #: GS108-400NAS
- $49.99 –
- Free Shipping

Quick View
Cisco Business CBS220-16P-2G Smart Switch | 16 Port GE | PoE | 2x1G SFP | 3-Year Limited Hardware Warranty (CBS220-16P-2G-NA)
- Brand: Cisco Systems, Inc.
- Switch Type: ethernet
- Network Management Type: Managed
- Primary Ports: 16 x RJ45 + 2 x SFP
- Model #: CBS220-16P-2G
- $448.04
- $336.99 –
- Save: $111.05 (24%)
- More options from $336.99 - $385.85
- Free Shipping

Quick View
Netgear GS524PP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (300W), GS524PP-100NAS
- Brand: NETGEAR
- Format: Desktop / Rackmount
- Network Management Type: Unmanaged
- Primary Ports: 24 x RJ45
- Model #: GS524PP-100NAS
- $389.99 –
- Free Shipping

Quick View
Cisco Business 220 Gigabit Ethernet Switch, 8 x 10/100/1000 ports w/ 130W power budget, 2 x Gigabit SFP | CBS220-8FP-E-2G-NA
- Part Number: CBS220-8FP-E-2G
- Format: Rack-mountable
- Standards: Layer Supported: 2 Networking Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3ad IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1w IEEE 802.1s IEEE 802.1x IEEE 802.3af IEEE 802.3at
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Model #: CBS2208FPE2GNA
- $270.81 –
- More options from $245.99 - $270.81
- $16.99 Shipping

Quick View
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
- Brand: CISCO
- Series: Catalyst
- Part Number: C1300-8P-E-2G
- Format: Rack-mountable
- Model #: C1300-8P-E-2G
- $543.71
- $459.99 –
- Save: $83.72 (15%)
- More options from $459.99 - $473.32
- Free Shipping

Quick View
Cisco Catalyst 1200-48P-4G Smart Switch, 48 Port GE, PoE, 4x1GE SFP, Limited Lifetime Protection (C1200-48P-4G)
- Brand: CISCO
- Network Management Type: Managed
- Primary Ports: 48 x RJ45 + 4 x SFP
- PoE: Yes
- Model #: C1200-48P-4G
- $1,038.99 –
- More options from $1,038.99 - $1,119.51
- Free Shipping

Quick View
Cisco Catalyst C1300-8T-E-2G Ethernet Switch 10 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported - 2 SFP Slots - 10.65 W Power Consumption
- Brand: CISCO
- Series: Catalyst C1300-8T-E-2G
- Part Number: Catalyst C1300-8T-E-2G
- Switch Type: managed
- Model #: C1300-8T-E-2G
- $380.99 –
- More options from $380.99 - $408.09
- Free Shipping

Quick View
Netgear ProSafe GS510TPP 8-Port Gigabit Ethernet High-Power PoE+ Smart Switch with 2 Dedicated SFP Ports (190W), GS510TPP-100NAS
- Brand: NETGEAR
- Series: ProSafe
- Part Number: GS510TPP-100NAS
- Format: Rack-mountable Desktop
- Model #: GS510TPP-100NAS
- $345.99 –
- Free Shipping

Quick View
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
- Brand: CISCO
- Network Management Type: Managed
- Primary Ports: 18 x RJ45 + 2 x SFP
- Layer: 2
- Model #: CBS220-8T-E-2G
- $142.99 –
- More options from $142.99 - $171.64
- Free Shipping

Quick View
Cisco Business CBS110-16T Unmanaged Switch | 16 Port GE | Limited Lifetime Protection (CBS110-16T-NA)
- Part Number: CBS110-16T
- Format: Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
- Primary Ports: Total Number of Network Ports: 16 Port/Expansion Slot Details: 16 x Gigabit Ethernet Network
- Model #: CBS11016TNA
- $144.99 –
- More options from $144.99 - $147.81
- Free Shipping

Quick View
Cisco CBS220-48P-4X Smart Switch | 48 Port GE | PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48P-4X-NA)
- Brand: CISCO
- Network Management Type: Managed
- Primary Ports: 48 x RJ45 + 4 x SFP+
- PoE: Yes
- Model #: CBS220-48P-4X-NA
- $1,124.99
- $928.99 –
- Save: $196.00 (17%)
- More options from $928.99 - $1,082.69
- Free Shipping

Quick View
Cisco Business 220 Switch, 48 x 10/100/1000 ports w/ 382W power budget, 4 x Gigabit SFP | CBS220-48P-4G-NA
- Brand: Cisco Systems, Inc.
- Series: Business 220 Series
- Part Number: CBS220-48P-4G-NA
- Switch Type: managed network switch
- Model #: CBS22048P4GNA
- $797.99 –
- More options from $797.99 - $933.57
- Free Shipping

Quick View
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: CBS110-8PP-D-NA
- $150.46
- See price in cart
- More options from $123.99 - $139.36
- Free Shipping

Quick View
CISCO DESIGNED Business CBS220-24FP-4G Smart Switch | 24 Port GE | Full PoE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-24FP-4G-NA)
- Brand: CISCO
- Part Number: CBS220-24FP-4G-NA
- Switch Type: managed
- Format: 24-port GE / PoE + / 382W / 4 x GE uplinks
- Model #: CBS22024FP4GNA
- $764.99
- $698.99 –
- Save: $66.00 (8%)
- More options from $698.99 - $765.23
- Free Shipping

Quick View
Cisco Catalyst 1200-48T-4G Smart Switch, 48 Port GE, 4x1GE SFP, Limited Lifetime Protection (C1200-48T-4G)
- Brand: CISCO
- Network Management Type: Managed
- Primary Ports: 48 x RJ45 + 4 x SFP
- Layer: 3
- Model #: C1200-48T-4G
- $616.99 –
- More options from $616.99 - $677.53
- Free Shipping

Quick View
Cisco CBS220-48FP-4X Smart Switch | 48 Port GE | Full PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48FP-4X-NA)
- Brand: Cisco Systems, Inc
- Series: Business
- Part Number: CBS220-48FP-4X-NA
- Switch Type: managed
- Model #: CBS220-48FP-4X
- $1,446.13
- $1,303.99 –
- Save: $142.14 (9%)
- More options from $1,303.99 - $1,487.84
- Free Shipping

Quick View
Netgear GS524UP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 16-Ports PoE++ (480W), GS524UP-100NAS
- Brand: NETGEAR
- Part Number: GS524UP-100NAS
- Switch Type: unmanged
- Format: Desktop Rack-mountable
- Model #: GS524UP-100NAS
- $529.99 –
- Free Shipping

Quick View
Netgear GS516UP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 8-Ports PoE++ (380W), GS516UP-100NAS
- Brand: NETGEAR
- Format: Desktop / Rackmount
- Network Management Type: Unmanaged
- Primary Ports: 16 x RJ45
- Model #: GS516UP-100NAS
- $369.99 –
- Free Shipping

Quick View
Netgear GS516PP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (260W), GS516PP-100NAS
- Brand: NETGEAR
- Part Number: GS516PP-100NAS
- Format: Desktop Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
- Model #: GS516PP-100NAS
- $309.99 –
- Free Shipping

Quick View
Cisco Catalyst 9300 Managed Switch, 24-port 25G/10G/1G SFP28 with modular uplinks, Network Essentials | C9300X-24Y-E
- Brand: Cisco
- Series: C9300 Series
- Part Number: C9300X-24Y-E
- Primary Ports: 24 x SFP28
- Model #: C9300X-24Y-E
- $19,486.99 –
- More options from $19,486.99 - $29,421.82

Quick View
CISCO DESIGNED Business CBS220-48T-4X Smart Switch | 48 Port GE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48T-4X-NA)
- Model #: CBS22048T4XNA
- $732.99 –
- More options from $732.99 - $850.63
- $5.99 Shipping

Quick View
Cisco Business CBS220-48T-4G Smart Switch | 48 Port GE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-48T-4G-NA)
- Brand: Cisco Systems, Inc
- Series: Business
- Part Number: CBS220-48T-4G
- Format: Rack-mountable
- Model #: CBS220-48T-4G
- $483.99 –
- More options from $483.99 - $575.04
- Free Shipping

Quick View
Cisco Business CBS220-24T-4X Smart Switch | 24 Port GE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-24T-4X-NA)
- Brand: CISCO
- Switch Type: ethernet
- Network Management Type: Managed
- Primary Ports: 24 x RJ45 + 4 x SFP+
- Model #: CBS220-24T-4X
- $515.99
- $469.99 –
- Save: $46.00 (8%)
- More options from $469.99 - $547.67
- Free Shipping

Quick View
Cisco Catalyst C1300-48MGP-4X, 48-port Layer 3 Managed Switch | C1300-48MGP-4X
- Brand: Cisco Systems, Inc.
- Series: Catalyst 1300 Series
- Part Number: C1300-48MGP-4X
- Format: Rackmount
- Model #: C1300-48MGP-4X
- $2,409.99 –
- More options from $2,409.99 - $2,721.89
- Free Shipping

Quick View
Cisco Catalyst IE3100 Rugged Layer 3 Switch - 20 Ports - Manageable - Gigabit Ethernet - 1000Base-T - 3 Layer Supported - 36.70 W Power Consumption - 240 W PoE Budget IE-3100-18T2C-E
- Brand: CISCO
- Part Number: IE-3100-18T2C-E
- Model #: IE-3100-18T2C-E
- $4,591.74 –
- More options from $3,255.99 - $4,591.74

Quick View
Cisco Catalyst 9300 Network Essentials switch 24 ports managed rack-mountable
- Model #: C9300-24S-E#
- $5,866.99 –
- More options from $5,866.99 - $25,995.82

Quick View
Cisco Catalyst 9500 Network Advantage switch 48 ports managed rack-mountable
- Model #: C9500-48Y4C-A#
- $28,845.30 –
- More options from $28,594.82 - $28,845.30

Quick View
Cisco Catalyst 9200CX Network Essentials switch compact 8 ports managed rack-mountable
- Model #: C9200CX-8UXG-2X-E
- $2,722.73 –
- More options from $2,702.82 - $2,722.73

Quick View
Cisco Catalyst 9300 Network Essentials switch 48 ports managed rack-mountable
- Model #: C9300-48UN-E#
- $13,088.52 –
- More options from $10,943.99 - $30,059.82

Quick View
Cisco Catalyst 9300 Network Advantage switch 24 ports managed rack-mountable
- Model #: C9300-24S-A#
- $17,487.99 –
- More options from $17,487.99 - $25,995.82
- Free Shipping

Quick View
Cisco Catalyst IE3400 Rugged Series Network Essentials switch 10 ports managed
- Model #: IE-3400-8T2S-E#
- $6,809.74 –
- More options from $6,794.82 - $6,809.74

Quick View
Cisco expansion module 25 Gigabit Ethernet x 2
- Model #: C9300-NM-2Y=#
- $2,462.74 –
- More options from $2,451.82 - $2,462.74

Quick View
Crestron DMC-4KZ-C-DSP DigitalMedia 8G+ 4K60 4:4:4 HDR Input Card With Downmixing for DM Switchers (NOB)
- Model #: DMC-4KZ-C-DSP
- $793.20 –
- More options from $779.00 - $793.20
- Free Shipping

Quick View
Refurbished Arista DCS-7010T-48-F 48P 1GbE 4P 10GbE SFP+ Switch
- Model #: CAT-21530DS
- $120.40 –
- Free Shipping

Quick View
Refurbished QSFP-100G-LR-ARISTA 100GBASE-LR 10km SMF QSFP Transceiver XVR-10224-21
- Model #: QSFP100GLR-AQ
- $456.40 –
- Free Shipping

Quick View
Refurbished Arista DCS-7010T-48-R 48P 1GbE 4P 10GbE SFP+ RA Switch
- Model #: CAT-21530-RAkb
- $120.40 –
- Free Shipping

Quick View
Refurbished Arista DCS-7150S-52-CL-R 52P 10GbE SFP+ RA Switch
- Model #: CAT-21292-RAZV
- $280.40 –
- Free Shipping

Quick View
J9279A HPE Procurve 2510-24G 24X RJ-45 Ports Network Ethernet Switch J9279-60001 Network Switches & Management
- Model #: J9279-60001 J9279A
- $650.00 –
- Free Shipping

Quick View
Arista DCS-7050QX-32S-F 32P 40GbE QSFP+ 4P 10GbE SFP+ Switch (Kit)
- Model #: 011110565075
- $199.00 –

Quick View
Cisco Meraki MS130-8P-I Cloud Managed Switch, 8× Gigabit Ethernet, 120W PoE, Internal PSU - Hardware Only
- Model #: MS130-8P-I-HW
- $1,004.99 –
- Free Shipping

Quick View
- $279.10 –
- Free Shipping

Quick View
Cisco Industrial Ethernet 4000 Series switch 12 ports managed TAA Compliant
- Model #: IE-4000-4GC4GP4G-E#
- $1,412.00 –
- Free Shipping

Quick View
Cisco Catalyst 1000-24T-4X-L Switch, 24 Ports - Manageable - 2 Layer Supported
- Part Number: C1000-24T-4X-L
- Format: Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 10GBase-X
- Uplink Interface: Total Number of Expansion Slots: 4 Expansion Slot Type: SFP+ Number of SFP+ Slots: 4
- Model #: C100024T4XL
- $2,923.00 –
- Free Shipping

Quick View
Cisco Catalyst 9200CX Network Advantage switch compact 12 ports managed rack-mountable
- Model #: C9200CX-12P-2XGH-A
- $4,129.85
- $3,883.99 –
- Save: $245.86 (5%)

Quick View
Cisco Catalyst 9300 Network Advantage switch 48ports managed rack-mountable
- Model #: C9300-48UN-A#
- $10,943.99 –

Quick View
- $2,251.10 –
- Free Shipping

Quick View
HPE JH324A 5130 48G 4SFP+ 1-slot HI Switch
- Switch Type: Layer 3 Switch
- Protocols: HCRP, SPP
- Model #: JH324A
- $2,469.10 –
- Free Shipping

Quick View
Cisco C9200-24P-A-Refresh with DNA Advantage 1 Year License
- Model #: C9200-24P-A-Refresh-DNA-A-1Y
- $3,599.95 –
- Free Shipping

Quick View
Cisco IE-4000-16T4G-E IE-4000-16T4G-E Ethernet Switch
- Format: Rail-mountable
- Uplink Ports: Yes
- Uplink Interface: SFP
- Primary Ports: 16 x Fast Ethernet Network Fast Ethernet Gigabit Ethernet 4 x Gigabit Ethernet Uplink
- Model #: IE-4000-16T4G-E
- $3,455.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7280SR2-48YC6-R 48P 25GbE SFP25 6P 100GbE QSFP100 RA Switch
- Brand: Arista
- Model #: 011110928702
- $3,199.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7010T-48-R 48P 1GbE 4P 10GbE SFP+ RA Switch with rack mounts
- Model #: 011110045027
- $65.00 –
- More options from $65.00 - $69.00
- Free Shipping

Quick View
Refurbished Arista DCS-7280SE-64-F 48P 10GbE SFP+ 4P 40GbE QSFP+ Switch
- Brand: Arista
- Model #: 011110906311
- $199.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7280SR2A-48YC6-R 48P SFP25 6P QSFP100 RA Switch
- Brand: Arista
- Model #: 011110131966
- $2,599.00 –

Quick View
Refurbished Arista DCS-7050SX-64-R 48P 10GbE SFP+ 4P 40GbE QSFP+ RA Switch
- Model #: 011110782236
- $115.00 –

Quick View
Refurbished Arista DCS-7280SE-64-R 48P 10GbE SFP+ 4P 40GbE QSFP+ RA Switch
- Brand: Arista
- Model: DCS-7280SE-64-R
- Model #: 011110906380
- $199.00 –

Quick View
Refurbished Arista DCS-7050TX-72Q-R 48P 10GbE Base-T 6P 40GbE QSFP+ RA Switch
- Brand: Arista
- Model: DCS-7050TX-72Q-R
- Model #: 011110966865
- $199.00 –

Quick View
Refurbished Arista DCS-7010T-48-F 48P 1GbE 4P 10GbE SFP+ Switch with rack mounts
- Model #: 011110877147
- $69.00 –

Quick View
Refurbished Arista DCS-7300-SUP-D 7300 Series Switch Supervisor Module DCS-7300-SUP-D
- Brand: Arista
- Model #: 011110115690
- $235.00 –
- More options from $233.43 - $235.00
- Free Shipping

Quick View
Refurbished Arista DCS-7048T-A-R 48P 100/1000 4P 10GbE SFP+ ZTP RA Switch
- Model #: 011110884732
- $149.00 –

Quick View
Refurbished Arista DCS-7508R-FM 7500R Series Integrated Fan Switch Fabric Module DCS-7508R-FM
- Model #: 011110109842
- $99.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7050SX-72Q-R 48P 10GbE SFP+ 6P 40GbE QSFP+ RA Switch
- Model #: 011110998477
- $219.00 –

Quick View
Refurbished Arista DCS-7050QX-32S-R 32P 40GbE QSFP+ 4P 10GbE SFP+ RA Switch
- Model #: 011110638366
- $123.99 –

Quick View
Refurbished Arista DCS-7500-SUP2 7500R3 Series Switch Supervisor 2 Module DCS-7500-SUP2
- Model #: 011110109811
- $149.00 –

Quick View
Refurbished Arista DCS-7050TX-72Q-F 48P 10GbE Base-T 6P 40GbE QSFP+ Switch
- Brand: Arista
- Model #: 011110966797
- $199.00 –

Quick View
Refurbished Arista DCS-7280SE-72-R 48P 10GbE SFP+ 2P 100GbE MXP RA Switch
- Model #: 011110110718
- $350.00 –

Quick View
Refurbished Arista DCS-7050TX-128-R 96P 10GbE RJ45 8P 40GbE QSFP+ RA Switch
- Brand: Arista
- Model: DCS-7050TX-128-R
- Model #: 011110873408
- $599.00 –

Quick View
Refurbished Arista DCS-7050TX2-128-R 96P 10GbE RJ45 8P 40GbE QSFP+ Switch
- Model #: 011110079466
- $399.00 –

Quick View
Refurbished Arista DCS-7050SX2-128-R 96P 10GbE SFP+ 8P 40GbE QSFP+ Switch
- Brand: Arista
- Model #: 011110116420
- $699.00 –

Quick View
Refurbished Arista DCS-7050SX2-72Q-R 48P 10GbE SFP+ 6P 40GbE QSFP+ RA Switch
- Model #: 011110006240
- $599.00 –

Quick View
Refurbished Arista DCS-7050SX-128-R 96P 10GbE SFP+ 8P 40GbE QSFP+ RA Switch
- Model #: 011110074706
- $599.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7050TX-48-R 32P 10GbE Base-T 4P QSFP+ RA Switch (Kit)
- Model #: 011110069528
- $450.00 –

Quick View
Refurbished Arista DCS-7050SX-128-F 96P 10GbE SFP+ 8P 40GbE QSFP+ Switch
- Brand: Arista
- Model #: 011110879479
- $599.00 –

Quick View
Refurbished Arista DCS-7050SX2-128-F 96P 10GbE SFP+ 8P 40GbE QSFP+ Switch
- Brand: Arista
- Model #: 011110863225
- $699.00 –

Quick View
Refurbished Arista DCS-7050TX-64-R 48P 10GbE RJ45 4P 40GbE QSFP+ RA Switch (Kit)
- Brand: Arista
- Model #: 011110085177
- $399.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7050QX2-32S-R 32P 40GbE QSFP+ 4P 10GbE SFP+ RA Switch
- Model #: 011110066497
- $799.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7280SE-68-R 48P 10GbE SFP+ 2P 100GbE QSFP100 RA Switch
- Brand: Arista
- Model: DCS-7280SE-68-R
- Model #: 011110001023
- $999.00 –

Quick View
Refurbished Arista DCS-7050T-36-R 32P 10GbE Base-T 4P SFP+ RA Switch
- Model #: 011110855381
- $159.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7508E-FM 7500E Series Fabric-E Integrated Switch Fan Tray
- Model #: 011110109835
- $1,199.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7048T-A-F 48P 100/1000 4P 10GbE SFP+ ZTP Switch
- Brand: Arista
- Model: DCS-7048T-A-F
- Model #: 011110884411
- $149.00 –

Quick View
Refurbished Arista DCS-7124S-R 24P 10GbE SFP+ RA Switch
- Model #: 011110885531
- $199.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7124SX-R 24P 10GbE SFP+ RA Switch
- Model #: 011110879882
- $195.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7050QX-32-R 32P 40GbE QSFP+ RA Switch
- Model #: 011110638397
- $159.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7050S-52-R 52P 10GbE SFP+ RA Switch
- Model #: 011110667694
- $175.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7150S-52-CL-R 52P 10GbE SFP+ RA Switch
- Model #: 011110877727
- $169.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7050QX-32-F 32P 40GbE QSFP+ Switch
- Brand: Arista
- Model #: 011110637307
- $159.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7260QX-64-R 64P 40GbE QSFP+ 2P SFP+ RA Switch
- Model #: 011110005724
- $179.00 –

Quick View
Refurbished Arista DCS-7512R-FM 7500R Series Integrated Fan Switch Fabric Module DCS-7512R-FM
- Model #: 011110111517
- $1,500.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7050SX-72Q-R 48P SFP+ 6P QSFP+ Switch (Fair)
- Brand: Arista
- Model #: 011110125392
- $179.00 –
- Free Shipping

Quick View
Refurbished Arista DCS-7280SE-72-F 48P 10GbE SFP+ 2P 100GbE MXP Switch
- Model #: 011110110695
- $350.00 –

Quick View
Refurbished Arista DCS-7280QR-C36-R 56P 40GbE QSFP+ 12P 100GbE QSFP28 RA Switch
- Model #: 011110920836
- $1,649.00 –

Quick View
Refurbished Arista DCS-7250QX-64-R 64P 40GbE QSFP+ RA Switch
- Model #: 011110879738
- $299.00 –

Quick View
Refurbished Arista DCS-7050T-52-R 48P 10GbE Base-T 4P SFP+ RA Switch
- Model #: 011110004666
- $449.00 –
- Free Shipping

Quick View
Refurbished Brocade ICX6610-24P-PE ICX 6610-24P Layer 3 Switch
- Color: Black
- Type: Layer 3 Switch
- Model #: ICX6610-24P-PE
- $975.10 –
- Free Shipping

Quick View
Refurbished Juniper EX3300-48T-BF EX3300-48T-BF Layer 3 Switch
- Switch Type: Layer 3 Switch
- Protocols: HCRP, SPP
- Package Contents: Includes Rack mount kit (EX-RMK3), Console cable, Power cord
- Model #: EX3300-48T-BF
- $895.01 –
- Free Shipping




