Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now
SHOP BY Primary Ports

Quick View
RUCKUS ICX 8200 Compact Switch, 8x10/100/1000 Mbps PoE+ ports, 2x10 GbE SFP+ stacking/uplink-ports, 124 W PoE budget, three-year remote TAC support. Power cord not included | ICX8200-C08PF
- Brand: Ruckus Wireless
- Series: RUCKUS ICX 8200
- Part Number: ICX8200-C08PF
- Format: Desktop
- Model #: ICX8200-C08PF
- $1,670.00 –
- More options from $1,670.00 - $1,972.99
- Free Shipping

Quick View
Aruba 6300M 24SR5 CL6 PoE 4SFP56 Swch
- Weight: 17.2
- Model #: JL660A
- $13,499.00 –
- Free Shipping

Quick View
Planet IGS-10080MFT Industrial 8 100/1000X SFP + 2-Port 10/100/1000T Managed Switch (-40 ~ 75 degrees C)
- Format: DIN Rail Mount
- Primary Ports: 8 100/1000Base-SX/LX mini-GBIC SFP slots
- MAC Address Table: 8K entries, automatic source address learning and ageing
- VLAN Support: Yes
- Model #: IGS-10080MFT
- $496.00
- See price in cart
- More options from $388.99 - $436.00
- Free Shipping

Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
- Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
- Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
- Model #: WGSW-24040
- $332.00
- See price in cart
- Free Shipping

Quick View
TP-Link TL-SF1005D 5-Port Fast Ethernet 10/100Mbps Unmanaged Desktop Switch
- Weight: 0.41
- Model #: TLSF1005D

Quick View
- $144.99 –
- More options from $144.99 - $262.00
- Free Shipping

Quick View
RUCKUS ICX 8200 Compact Switch, 4x100/1000/2500 Mbps PoE++ ports, 4x 1/2.5/5/10Gbps PoE++ ports, 2x25 GbE SFP28 stacking/uplinkports, 240 W PoE budget, 3-Y remote TAC support | ICX8200-C08ZP
- Part Number: ICX8200-C08ZP
- Uplink Interface: 4× 100/1000/2500 Mbps RJ-45 PoE++ 90W ports; 4× 1/2.5/5/10 Gbps RJ-45 PoE++ 90W ports; 2× 1/10/25 GbE uplink/stacking SFP28 ports; USB Type-C port;RJ45 serial port;USB Type-A port;RJ45 Ethernet port (For console manag
- Power: Power Over Ethernet (PoE) Support: Yes PoE Power Consumption: 240W
- Max Power Consumption: Power / Device Type: Power Supply Max Power Consumption: 305 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Model #: ICX8200-C08ZP
- $2,998.00 –
- More options from $2,395.99 - $3,420.99
- Free Shipping

Quick View
Fortinet FortiSwitch 248E-POE, Layer 2/3 FortiGate switch controller compatible PoE+ switch with 48 GE RJ45 + 4 SFP ports, 24 port PoE w/ maximum 370 W limit | FS-248E-POE
- Brand: Fortinet
- Series: 200 Series
- Part Number: FS-248E-POE
- Format: Rackmount
- Model #: FS-248E-POE
- $2,470.99 –
- Free Shipping

Quick View
HP Rack Mount for HP Z2 Mini G9 Workstation (6C1U0AA)
- Brand: HP
- Part Number: 6C1U0AA
- Switch Type: Rack Mount
- Model #: 6C1U0AA
- $519.99 –
- More options from $519.99 - $1,369.64
- Free Shipping

Quick View
Juniper Networks EX4000Switch, 24-Port 10/100/1000BaseT, 4x 1G/10G SFP/SFP+ (optics sold separately) with Standard SW | EX4000-24T
- Brand: Juniper Networks, Inc.
- Series: EX4000
- Part Number: EX4000-24T
- Network Management Type: Managed
- Model #: EX4000-24T
- $1,753.40 –
- More options from $904.99 - $1,812.33
- Free Shipping

Quick View
TP-Link Omada 5-Port Gigabit Easy Managed Switch - 5 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 2 Layer Supported - 65 W PoE Budget - Twisted Pair - PoE Ports - Desktop, Wall Mountabl
- Brand: TP-Link
- Uplink Interface: RJ45
- Primary Ports: RJ45
- Primary Port Speed: 5000 megabits_per_second
- Model #: ES205GP

Quick View
Tripp Lite B006-DP2UA2 DisplayPort Dual-Display KVM Switch - 2 Computer(s) - 1 Local User(s) - 4096 x 2160 - 50 Hz, 60 Hz - 1 x Network (RJ-45) - 6 x USB - Desktop, Rack-mountable - 6 x DisplayPort
- Brand: Tripp Lite
- Part Number: B006-DP2UA2
- Switch Type: KVM Switch
- Format: Desktop, Rack-mountable
- Model #: B006-DP2UA2
- $393.12 –
- More options from $342.28 - $433.41
- Free Shipping

Quick View
Luxul 1Gb L2/L3 Managed Switch - 48 PoE+, 4 SFP Front-Facing Ports - TAA Compliant - SW-515-48P-F
- Brand: Luxul
- Series: SW-515
- Part Number: SW-515-48P-F
- Switch Type: Managed
- Model #: SW-515-48P-F
- $2,676.00
- $1,585.99 –
- Save: $1,090.01 (40%)
- More options from $1,585.99 - $1,673.86
- Free Shipping

Quick View
GIGABIT ETHERNET (1000-MBPS) MANAGED SWITCH - (20) SFP, (4) 100/1000-MBPS DUAL-M
- Model #: LGB5124A-R2
- $794.99 –
- More options from $794.99 - $912.98
- $11.62 Shipping

Quick View
FortiSwitch-124G-FPOE Layer 2 FortiGate Switch Controller Compatible PoE Switch with 24x 2.5G/1G/100M RJ45 ports (FS-124G-FPOE)
- Brand: Fortinet
- Series: FortiGate
- Part Number: FS-124G-FPOE
- Format: Rackmount
- Model #: FS-124G-FPOE
- $1,732.99 –
- Free Shipping

Quick View
Ruckus ICX7550-48F-E2 Entry-Level Aggregation 48 Ports 1G/10G SFP/SFP+ Managed Rack-Mountable Switch, 2 AC Power Supplies, 3 Fans Exhaust Airflow Installed
- Part Number: ICX7550-48F-E2
- Primary Ports: Interfaces: 36-port 100/1000 Mbps SFP, 12-port 1/10 Gbps SFP+, 2x 40/100Gbps QSFP+, USB Type-C SFP Ports: 36 SFP+ Ports: 12
- Buffer Memory: RAM / Total Installed Size: 4 GB Flash Memory / Installed Size: 4 GB
- Power: Power / Device Type: Power Supply Power / Installed Qty: 2 Power / Provided (W): 400 Watt Max Power Consumption: 166.8 Watt Power / Voltage Required: 100 to 240 VAC
- Model #: ICX7550-48F-E2
- $10,020.99 –
- Free Shipping

Quick View
TP-LINK TL-SG2210P 8-Port Gigabit Smart PoE Switch with 2 Combo SFP Slots, 8 POE Ports, 802.3at/af Compliant
- Brand: TP-Link
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3z, IEEE 802.3ab, IEEE 802.3ad, IEE 802.3af, IEEE 802.3x, IEEE 802.1d, IEEE 802.1s, IEEE 802.1w, IEEE 802.1q, IEEE 802.1p
- Network Management Type: Smart
- Primary Ports: 8 10/100/1000Mbps RJ45 Ports + 2 1000Mbps SFP Slots
- Model #: TL-SG2210P DUP
- $128.12 –
- More options from $116.43 - $133.66
- Free Shipping

Quick View
TRENDnet 5-Port Hardened Industrial Unmanaged Gigabit Switch, TI-PG50, 10/100/1000Mbps, DIN-Rail Switch, 4 x Gigabit PoE+ Ports, 1 x Gigabit Port, Gigabit Ethernet Network Switch
- Format: Rackmount
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3af, IEEE 802.3at
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TI-PG50
- $119.99 –
- More options from $119.99 - $188.48
- Free Shipping

Quick View
Extreme Networks - X435 switch 24x10/100/1000BASE-T PoE+ full/half-duplex ports, 4x1G/2.5G unpopulated SFP ports, 1 AC PSU, ExtremeXOS Value Edge license | X435-24P-4S
- Brand: Extreme Networks
- Series: X435
- Part Number: X435-24P-4S
- Format: Rackmount
- Model #: X435-24P-4S
- $1,719.99 –
- Free Shipping

Quick View
TP-Link TL-SG108S | 8 Port Gigabit Ethernet Switch | Desktop/Wall-Mount | Plug & Play | Fanless | Sturdy Metal | Limited Lifetime Protection | 802.1p/DSCP QoS & IGMP Snooping | Compact Design
- Format: Desktop
- Standards: IEEE 802.3i / 802.3u / 802.3ab/ 802.3x /802.1p
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG108S

Quick View
Allied Telesis AT-GS950/16-10 Managed Ethernet Switch
- Format: Rackmount
- Primary Ports: 16 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps + 1000Mbps
- VLAN Support: Yes
- Model #: AT-GS950/16-10
- $342.91 –
- More options from $340.99 - $411.49

Quick View
Aruba CX 5420 Switch Chassis - Manageable - 3 Layer Supported - 1000 W Power Consumption - Optical Fiber - PoE Ports - 4U - Compact - S0U59A
- Brand: Aruba
- Part Number: S0U59A
- Switch Type: Switch Chassis
- Format: Compact, 4U
- Model #: S0U59A
- $7,759.86 –
- More options from $7,759.86 - $10,088.00
- Free Shipping

Quick View
Luxul 1Gb L2/L3 Managed Switch - 48 PoE+ - 4 (10G) SFP+ Front-Facing Ports - TAA Compliant - SW-615-48P-F
- Brand: Luxul
- Series: SW-615
- Part Number: SW-615-48P-F
- Switch Type: Managed
- Model #: SW-615-48P-F
- $3,289.00
- See price in cart
- More options from $1,944.99 - $2,051.67
- Free Shipping

Quick View
TRENDnet TEG-S17D, 16-Port Gigabit Desktop Switch
Limited time offer, ends 10/09
- Brand: TRENDnet
- Series: ProSafe
- Model: TEG-S17D
- Part Number: TEG-S17D
- Model #: TEG-S17D

Quick View
Micro Mini Media Converter, 10-/100-/1000-Mbps Copper to 1000-Mbps Duplex Fiber, Multimode, 850-nm, 0.5 km, SC
- Model #: LMC4002A
- $415.99 –
- $11.20 Shipping

Quick View
Transition Networks SISTG1040-242-LRT Ethernet Switch SISTG1040242LRT
- Format: Wall Mountable
- Uplink Ports: Yes
- Uplink Interface: SFP
- Primary Ports: 4 x Gigabit Ethernet Network 2 x Gigabit Ethernet Expansion Slot
- Model #: SISTG1040-242-LRT
- $240.69 –
- More options from $238.99 - $402.02
- Free Shipping

Quick View
FortiSwitch-424E Layer 2/3 FortiGate switch controller compatible switch with 24 x GE RJ45 ports, 4 x 10 GE SFP+ uplinks
- Format: Rackmount
- Primary Ports: 24x GE RJ45 and 4x10 GE SFP+ ports Note: SFP+ ports are compatlble with 1 GE SFP
- VLAN Support: 4K
- Packet Forwarding Rate: 190 Mpps
- Model #: FS-424E
- $1,596.99 –
- Free Shipping

Quick View
BLACK BOX LGH1006A GIGABIT ETHERNET (1000-MBPS) EXTREME TEMPERATURE SWITCH - (4) 10/100/1000-MBPS C
- Switch Type: Others
- Weight: 1.3
- Model #: LGH1006A
- $328.54 –
- More options from $328.54 - $425.99
- Free Shipping

Quick View
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: ISW-801T
- $657.00 –
- Free Shipping

Quick View
Ruckus ICX8200-24 24 Ports 1G PoE Enterprise-Class Stackable Access Switch with Future-Proof Expandability - OEM
- Part Number: ICX8200-24
- Uplink Interface: Interfaces: 24x10/100/1000 Mbps RJ45 ; 4x1/10/25 Gbps SFP/SFP+/SFP28 uplinks; USB Type-C; RJ45 serial port; USB Type-A port; RJ45 Ethernet port 10/100/1000BASE-T Ports: 24
- Max Power Consumption: Max Power Consumption: 65 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Temperature: Min Operating Temperature: 0 Celsius Max Operating Temperature: 45 Celsius Min Storage Temperature: -40 Celsius Max Storage Temperature: 70 Celsius
- Model #: ICX8200-24
- $4,290.00
- $2,901.99 –
- Save: $1,388.01 (32%)
- Free Shipping

Quick View
HPE CW 2150 16p 10M/100M/1G PoE+ 4p SFP+ 1G/10G 248W Switch - 16 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 3 Layer Supported - 317 W Power Consumption - 248 W PoE - S6X55A#ABA
- Brand: HPE
- Part Number: S6X55A#ABA
- Dimensions: 17.3 in x 10.2 in x 1.7 in
- Weight: 7.94 lbs
- Model #: S6X55A#ABA
- $540.04 –
- More options from $540.04 - $649.99








