Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
  • 1Port - 12Ports
Netgear GS308LP 8-Port Gigabit Ethernet Unmanaged Essentials PoE+ Switch, GS308LP-100NAS
Quick View
Netgear Inc.
Netgear GS308LP 8-Port Gigabit Ethernet Unmanaged Essentials PoE+ Switch, GS308LP-100NAS
  • Brand: NETGEAR
  • Part Number: GS308LP-100NAS
  • Format: Desktop Wall Mountable Enclosure
  • Standards: IEEE 802.3az IEEE 802.1Q IEEE 802.3 IEEE 802.3ab IEEE 802.3u IEEE 802.1p IEEE 802.3x IEEE 802.3af IEEE 802.3at IEEE 802.3i
  • Model #: GS308LP-100NAS
  •  
  • $74.99 –
  • Free Shipping
Netgear Business GS105PP 5-Port Gigabit Ethernet Unmanaged PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS105PP 5-Port Gigabit Ethernet Unmanaged PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS105PP-300NAS
  • Format: Desktop, Wall Mountable, Enclosure, Compact
  • Standards: 10/100/1000Base-T
  • Model #: GS105PP-300NAS
  •  
  • $160.33 –
  • $7.52 Shipping
Netgear Business GS105P 5-Port Gigabit Ethernet Unmanaged PoE Switch
Quick View
Netgear Inc.
Netgear Business GS105P 5-Port Gigabit Ethernet Unmanaged PoE Switch
  • Brand: NETGEAR
  • Part Number: GS105P-300NAS
  • Format: Desktop, Wall Mountable, Enclosure, Compact
  • Standards: 10/100/1000Base-T
  • Model #: GS105P-300NAS
  •  
  • $118.50 –
  • $11.22 Shipping
TP-Link TL-SG108-M2 | 8 Port Multi-Gigabit Unmanaged Network Switch, Ethernet Splitter | 2.5G Bandwidth | Plug & Play | Desktop/Wall-Mount | Fanless Metal Design | Limited Lifetime Protection
Quick View
TP-Link TL-SG108-M2 | 8 Port Multi-Gigabit Unmanaged Network Switch, Ethernet Splitter | 2.5G Bandwidth | Plug & Play | Desktop/Wall-Mount | Fanless Metal Design | Limited Lifetime Protection
  • Format: Desktop
  • Standards: IEEE 802.3, 802.3u, 802.3ab, 802.3x, 802.1p, 802.3bz
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 2.5 Gbps
  • Model #: TL-SG108-M2
Netgear Business GS108EPP 8-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS108EPP 8-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS108EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS108EPP-100NAS
  •  
  • $223.07 –
  • $11.22 Shipping
Netgear AV Line M4350-8M2V 8-Port Managed Switch, 2.5G/10G/25G Multi-Gigabit Ethernet
Quick View
Netgear Inc.
Netgear AV Line M4350-8M2V 8-Port Managed Switch, 2.5G/10G/25G Multi-Gigabit Ethernet
  • Brand: NETGEAR
  • Part Number: MSM4310-100NES
  • Format: Rack-mountable
  • Standards: 2.5GBase-T, 25GBase-X, 1000Base-T, 10GBase-X
  • Model #: MSM4310-100NES
  •  
  • $3,988.54 –
  • $12.69 Shipping
Netgear Business GS108EP 8-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS108EP 8-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS108EP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS108EP-100NAS
  •  
  • $167.30 –
  • $11.22 Shipping
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 2p SFP 124W 1930 (JL681A#ABA)
Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 2p SFP 124W 1930 (JL681A#ABA)
  • Part Number: JL681A#ABA
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1.5 MB
  • Model #: JL681A#ABA
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T, IEEE 802.3u 100BASE-FX, IEEE 802.3z 1000BASE-SX, IEEE 802.3z 1000BASE-LX, 4-Port IEEE 802.3af/at Power over Ethernet end-span PSE
  • Primary Ports: 4 x RJ-45 Female 4 x RJ-45 (PoE+) Female
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES81GPOEW
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
Quick View
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T IEEE 802.3z 1000Base-SX/LX IEEE 802.3az Energy-Efficient Ethernet, IEEE 802.3x Flow Control, IEEE 802.1q VLAN Tagging, IEEE 802.1p QoS, IEEE 802.1x Port-Based Network Access Control, IEEE802.3ad Link Aggregation, IEEE 802.1d Spanning Tree Protocol, IEEE 802.1w Rapid Spanning Tree Protocol
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES101GP2SFW
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
Quick View
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-1008HP
  •  
  • $123.99 –
  • Free Shipping
PLANET IGS-620TF Industrial 4-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch
Quick View
PLANET IGS-620TF Industrial 4-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet / 10Base-T IEEE 802.3u Fast Ethernet / 100Base-TX IEEE 802.3ab Gigabit Ethernet / 1000Base-T IEEE 802.3z Gigabit Ethernet / 1000Base-SX/LX IEEE 802.3x Full-Duplex Flow Control
  • Primary Ports: 4 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-620TF
SonicWall Switch SWS12-8POE 10 Ports - Manageable - 2 Layer Supported - Modular - 2 SFP Slots - 73.30 W Power Consumption - 55 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - Desktop
Quick View
  •  
  • $314.99 –
  • Free Shipping
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-8P4S
PLANET IGS-500T Unmanaged Compact Industrial 5-Port 10/100/1000T Gigabit Ethernet Switch
Quick View
PLANET IGS-500T Unmanaged Compact Industrial 5-Port 10/100/1000T Gigabit Ethernet Switch
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet IEEE 802.1p Class of Service
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-500T
  •  
  • $117.99 –
  • Free Shipping
PLANET FSD-604HP Unmanaged 4-Port 10/100TX 802.3af/at PoE + 2-Port 10/100TX Desktop Switch (60 Watts)
Quick View
PLANET FSD-604HP Unmanaged 4-Port 10/100TX 802.3af/at PoE + 2-Port 10/100TX Desktop Switch (60 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Flow Control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 4-Port 10/100TX 802.3af/at PoE 2-Port 10/100TX
  • Primary Port Speed: 10/100Mbps
  • Model #: FSD-604HP
  •  
  • $49.99 –
  • Free Shipping
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-8P2S2X
HPE Networking Instant On Switch 8p Gigabit 2p SFP 1930 (JL680A#ABA)
Quick View
HPE Networking Instant On Switch 8p Gigabit 2p SFP 1930 (JL680A#ABA)
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1.5 MB
  • SNMP: Yes
  • Model #: JL680A#ABA
D-Link DGS-108 Unmanaged 8-Port Gigabit Switch
Quick View
D-Link DGS-108 Unmanaged 8-Port Gigabit Switch
  • Brand: D-Link
  • Format: Desktop/Wall Mount
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twistedpair copper) ANSI/IEEE 802.3 NWay auto-negotiation IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Network Management Type: Unmanaged
  • Model #: DGS-108
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 2.0 Mb
  • PoE: Yes
  • Model #: R8R46A#ABA
StarTech.com Unmanaged 2.5G Switch, 5 Port 2.5GBASE-T Unmanaged Ethernet Switch, Din Rail | Wall Mount, Multi-Gigabit, Auto-MDIX, 9K Jumbo
Quick View
StarTech.com Unmanaged 2.5G Switch, 5 Port 2.5GBASE-T Unmanaged Ethernet Switch, Din Rail | Wall Mount, Multi-Gigabit, Auto-MDIX, 9K Jumbo
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-TX, IEEE 802.3bz 2.5GBASE-T
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 2.5 Gbps
  • Model #: DS52000
StarTech.com Industrial 8 Port Gigabit PoE Switch 30W - Power Over Ethernet Switch - GbE POE+ Network Switch - Unmanaged
Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch 30W - Power Over Ethernet Switch - GbE POE+ Network Switch - Unmanaged
  • Format: Desktop
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Jumbo Frames: 9KB
  • Model #: IESC1G80UP
D-Link DGS-1008P Switches  4 to 10 Ports 8-port Gigabit Ethernet POE Switch
Quick View
D-Link DGS-1008P Switches 4 to 10 Ports 8-port Gigabit Ethernet POE Switch
  • Format: External
  • Standards: IEEE 802.3/3u, IEEE 802.3af
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1008P
Ubiquiti NanoSwitch, 4-port Gigabit Switch (N-SW)
Quick View
Ubiquiti NanoSwitch, 4-port Gigabit Switch (N-SW)
  • Brand: Ubiquiti Networks
  • Part Number: N-SW
  • Network Management Type: Managed
  • Primary Ports: 4 x RJ45
  • Model #: N-SW
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 65W 1830 (JL811A#ABA)
Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 65W 1830 (JL811A#ABA)
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • PoE: Yes
  • SNMP: Yes
  • Model #: JL811A#ABA
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - Twisted Pair, Optical Fiber
Quick View
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - Twisted Pair, Optical Fiber
  • Part Number: C28CTCHUS
  • Switch Type: managed
  • Format: Rackmount
  • Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
  • Model #: C28CTCHUS
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (65W) + 2 Optical SFP Ports | L3 Lite | NDAA/TAA Compliant (DGS-1210-10P)
Quick View
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (65W) + 2 Optical SFP Ports | L3 Lite | NDAA/TAA Compliant (DGS-1210-10P)
  • Format: Desktop
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3z
  • Uplink Ports: 2
  • Primary Ports: 8 10/100/1000BASE-T 2 SFP
  • Model #: DGS-1210-10P
Intellinet 5-Port Gigabit Ethernet Switch, Desktop Size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)
Quick View
Intellinet 5-Port Gigabit Ethernet Switch, Desktop Size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)
  • Format: External
  • Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3ab (Gigabit Ethernet) IEEE 802.3x (Flow Control and Backpressure)
  • Primary Ports: 5 x RJ45
  • MAC Address Table: 1K
  • Model #: 530378
StarTech.com IESC1G50UP Industrial 5 Port Gigabit PoE Switch - 30W - Power Over Ethernet Switch - Hardened GbE PoE+ Unmanaged Switch - Rugged High Power Gigabit Network Switch IP-30/-40°C to 75°C
Quick View
StarTech.com IESC1G50UP Industrial 5 Port Gigabit PoE Switch - 30W - Power Over Ethernet Switch - Hardened GbE PoE+ Unmanaged Switch - Rugged High Power Gigabit Network Switch IP-30/-40°C to 75°C
  • Format: Desktop
  • Standards: IEEE 802.3 10/100/1000BASE-T IEEE 802.3at PoE Plus CSMA/CD IEEE 802.3x Flow Control and Back Pressure
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IESC1G50UP
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1005P
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
  • Format: DIN-rail and Wall-mount Ear
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-4215-4P4T
Cudy 5-Port Gigabit Unmanaged Switch GS105
Quick View
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - with 5-year Support
Quick View
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - with 5-year Support
  • Part Number: LS28FZ60ZZPCUS
  • Switch Type: managed
  • Format: Rackmount
  • Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
  • Model #: LS28FZ60ZZPCUS
  • $1,678.00
  •  
  • $1,587.99 –
  • Save: $90.01 (5%)
  • Free Shipping
D-Link 5-Port Gigabit Unmanaged Desktop Switch (DGS-105)
Quick View
D-Link 5-Port Gigabit Unmanaged Desktop Switch (DGS-105)
  • Brand: D-Link
  • Format: Desktop/Wall Mount
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twistedpair copper) ANSI/IEEE 802.3 NWay auto-negotiation IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Network Management Type: Unmanaged
  • Model #: DGS-105
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
Quick View
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
  • Format: Wall-mount and DIN Rail Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az EEE (Energy Efficient Ethernet) RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2 ITU-T G.8032 ERPS (Ethernet Ring Protection Switching)
  • Primary Ports: 6 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5226-4P2T