Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Netgear AV Line M4350-24G4XF 24-Port Manageable 10 Gigabit Ethernet Switch, GSM4328-100NES
- Brand: NETGEAR
- Part Number: GSM4328100NES
- Standards: IEEE 802.3bt IEEE 802.3af IEEE 802.3at IEEE 802.1as IEEE 802.1Qav IEEE 802.1Qat IEEE 802.1ak IEEE 802.3az IEEE 802.3ad IEEE 802.1AX IEEE 802.1s IEEE 802.1w IEEE 802.1p IEEE 802.1Q IEEE 802.1BA
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Gigabit Ethernet Network Technology: 10GBase-X 10/100/ 1000Base-T
- Model #: GSM4328-100NES
- $2,579.99 –
- Free Shipping

Quick View
TP-Link 16 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1016DE)
- Format: Desktop
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
- Uplink Ports: None
- Primary Ports: 16 x RJ45
- Model #: TL-SG1016DE
- $106.88 –
- More options from $106.88 - $152.63

Quick View
TRENDnet TEG-S17D, 16-Port Gigabit Desktop Switch
Limited time offer, ends 10/09
- Brand: TRENDnet
- Series: ProSafe
- Model: TEG-S17D
- Part Number: TEG-S17D
- Model #: TEG-S17D

Quick View
TP-Link JetStream 28-Port Gigabit Smart Switch with 24-Port PoE+ (TL-SG2428P)
- Switch Type: other
- Format: Desktop
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE802.3z, IEEE 802.3ad, IEEE 802.3x, IEEE 802.3az, IEEE 802.1d, IEEE 802.1s, IEEE 802.1w, IEEE 802.1q, IEEE 802.1p, IEEE 802.1x
- Primary Ports: 24 x RJ45 + 4 x SFP
- Model #: SG2428P
- $323.61 –
- More options from $276.44 - $847.19
- Free Shipping

Quick View
TP-Link 16 Port 10/100Mbps Fast Ethernet Switch | Desktop or Wall-Mounting | Plastic Case Ethernet Splitter | Unshielded Network Switch | Plug and Play | Fanless Quiet | Unmanaged (TL-SF1016D)
- Format: Desktop
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100Mbps
- MAC Address Table: 1K
- Model #: TL-SF1016D
- $59.50 –
- More options from $59.50 - $63.55
- Free Shipping

Quick View
Ubiquiti EnterpriseXG 24 (Gen1), 24-port Layer 3 switch (USW-EnterpriseXG-24)
- Brand: Ubiquiti
- Series: Network Switch
- Part Number: USW-EnterpriseXG-24
- Format: Rackmount
- Model #: USW-EnterpriseXG-24
- $1,299.00 –
- More options from $1,299.00 - $1,884.11
- Free Shipping

Quick View
TP-Link TL-SG1016PE V3 | 16 Port Gigabit PoE Switch | Easy Smart Managed | 8 PoE+ Ports @150W | Plug & Play | Sturdy Metal w/ Shielded Ports | QoS, Vlan, IGMP & LAG | Limited Lifetime Protection
- Brand: TP-Link
- Series: ProSafe
- Part Number: TL-SG1016PE
- Format: Rackmount
- Model #: TL-SG1016PE
- $162.60
- $162.21 –
- More options from $134.44 - $372.56
- Free Shipping

Quick View
Cisco Catalyst C1300-24FP-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-24FP-4G
- Format: Rackmount
- Model #: C1300-24FP-4G
- $1,180.99 –
- More options from $1,180.99 - $1,313.40
- Free Shipping

Quick View
TP-Link 16 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Wall-Mount | Sturdy Metal w/Shielded Ports | Support QoS, Vlan, IGMP and Link Aggregation (TL-SG116E)
- Brand: TP-Link
- Part Number: TL-SG116E
- Switch Type: unmanaged
- Format: 16 Port, Enhanced Features
- Model #: TL-SG116E
- $105.09 –
- More options from $85.38 - $139.80

Quick View
TRENDnet 20-Port Gigabit Web Smart Switch; 16 x Gigabit Ports; 4 x shared Gigabit Ports (RJ-45/SFP); VLAN; QoS; LACP; IPv6 Support; 40 Gbps Switching Capacity; Lifetime Protection; TEG-204WS
- Format: Rackmount
- Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1s IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3az
- Primary Ports: 16 x Gigabit ports 4 x shared Gigabit ports (RJ-45 / SFP)
- Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit Ethernet: 2000 Mbps (full duplex)
- Model #: TEG-204WS

Quick View
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
- Brand: CISCO
- Network Management Type: Managed
- Primary Ports: 18 x RJ45 + 2 x SFP
- Layer: 2
- Model #: CBS220-8T-E-2G
- $142.99 –
- More options from $142.99 - $171.64
- Free Shipping

Quick View
Cisco Business CBS220-24T-4X Smart Switch | 24 Port GE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-24T-4X-NA)
- Brand: CISCO
- Switch Type: ethernet
- Network Management Type: Managed
- Primary Ports: 24 x RJ45 + 4 x SFP+
- Model #: CBS220-24T-4X
- $515.99
- $469.99 –
- Save: $46.00 (8%)
- More options from $469.99 - $547.67
- Free Shipping

Quick View
Cisco Catalyst C1200-16P-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1200-16P-2G
- Format: Manageable
- Model #: C1200-16P-2G
- $599.99 –
- More options from $581.81 - $626.48
- Free Shipping

Quick View
Cisco Catalyst C1300-16P-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-16P-2G
- Format: Rail-mountable
- Model #: C1300-16P-2G
- $899.74
- $748.99 –
- Save: $150.75 (16%)
- More options from $748.99 - $857.10
- Free Shipping

Quick View
TP-Link TL-SG3428X | 24 Port Gigabit Switch, 4 x 10GE SFP+ Slots | L2+ Smart Managed | Omada SDN Integrated | IPv6 | Static Routing | Support QoS, IGMP & LAG | Limited Lifetime Protection
- Format: Desktop
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Primary Port Type: 24 x 10/100/1000 Mbps RJ45 Ports 4 x 10G SFP+ Slots
- Model #: TL-SG3428X
- $334.99 –
- More options from $309.99 - $442.73

Quick View
Cisco Catalyst C1300-16P-4X Ethernet Switch, 16 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-16P-4X
- Format: Rack-mountable
- Model #: C1300-16P-4X
- $792.99 –
- More options from $792.99 - $904.03
- Free Shipping

Quick View
Cisco Catalyst C1300-24T-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-24T-4G
- Format: Rackmount
- Model #: C1300-24T-4G
- $658.99 –
- More options from $658.99 - $676.23
- Free Shipping

Quick View
HPE Juniper Networking EX2300-C Switch, Compact Fanless 12-port 10/100/1000BASE-T, 2 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-C-12T
- Brand: Juniper Networks, Inc.
- Series: EX2300-C
- Part Number: EX2300-C-12T
- Format: Desktop
- Model #: EX2300-C-12T
- $1,680.00
- $894.99 –
- Save: $785.01 (46%)
- More options from $750.00 - $1,611.67
- Free Shipping

Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
- Brand: Cisco Systems, Inc.
- Series: Catalyst C1300 Series
- Part Number: C1300-24MGP-4X
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
- Model #: C1300-24MGP-4X
- $1,353.99 –
- More options from $1,353.99 - $1,588.43
- Free Shipping

Quick View
Cisco Catalyst C1300-16FP-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-16FP-2G
- Format: Rack-mountable
- Model #: C1300-16FP-2G
- $1,130.99 –
- More options from $1,097.81 - $1,164.17
- Free Shipping

Quick View
Netgear AV Line M4350-8X8F 8-Port Manageable 10 Gigabit Ethernet Switch, XSM4316-100NES
- Brand: NETGEAR
- Part Number: XSM4316100NES
- Network Management Type: Managed
- Primary Ports: 8 x RJ45 + 8 x SFP+
- Model #: XSM4316-100NES
- $2,199.99 –
- Free Shipping

Quick View
D-Link DGS-1024C 24-Port 10/100/1000 Mbps Gigabit Unmanaged Desktop Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: DGS-1024C
- $89.00 –
- More options from $89.00 - $118.11
- Free Shipping

Quick View
TP-Link TL-SG1218MP | 16 Port Gigabit PoE Switch | 16 PoE+ Ports @250W, w/ 2 Uplink Gigabit Ports + 2 Combo SFP Slots | Plug & Play | Sturdy Metal | Rack-mountable
- Brand: TP-Link
- Series: ProSafe
- Part Number: TL-SG1218MP
- Format: Desktop
- Model #: TL-SG1218MP
- $212.05 –
- More options from $212.05 - $276.27

Quick View
Juniper Networks EX4400- Switch, 24-port 10/100/1000BASE-T PoE++ power + 1050 W AC PS (provides 783/1806W PoE++ power with single/dual PS) | EX4400-24P
- Brand: Juniper Networks, Inc.
- Series: EX4400
- Part Number: EX4400-24P
- Format: Rackmount
- Model #: EX4400-24P
- $1,876.20 –
- More options from $1,876.20 - $4,495.99
- Free Shipping

Quick View
TRENDnet 5-Port Gigabit PoE+ Switch, Camera DIP Switch extends PoE+ 200m (656 ft.), 60W PoE Budget, Black, TPE-TG51G
Limited time offer, ends 09/30
- Brand: TRENDnet
- Series: ProSafe
- Part Number: TPE-TG51g
- Format: Desktop
- Model #: TPE-TG51g

Quick View
TP-Link 16 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/ Shielded Ports | Rackmount | Fanless | Limited Lifetime Protection | Unmanaged (TL-SG1016)
- Format: Rackmount
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG1016

Quick View
Cisco Catalyst 1300 C1300-24XTS Layer 3 Switch, 12 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-24XTS
- Format: Rack-mountable
- Model #: C1300-24XTS
- $3,269.99 –
- More options from $3,269.99 - $3,658.79
- Free Shipping

Quick View
HPE Juniper Networking EX2300-C Switch, Compact Fanless 12-port 10/100/1000BASE-T PoE+, 2 X 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-C-12P
- Brand: Juniper Networks
- Series: EX2300-C
- Part Number: EX2300-C-12P
- Switch Type: Layer 3 Switch
- Model #: EX2300-C-12P
- $1,092.00
- $1,080.00 –
- More options from $1,080.00 - $2,911.00
- Free Shipping

Quick View
Cisco Catalyst C1300-24FP-4X Ethernet Switch, 24 Ports, Manageable, 10 Gigabit Ethernet, 10/100/1000Base-T, 10GBase-X, 3 Layer Supported, 370 W PoE Budget
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C130024FP4X
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
- Model #: C1300-24FP-4X
- $1,533.99 –
- More options from $1,533.99 - $1,591.82
- Free Shipping

Quick View
Juniper Networks EX4000Switch, 24-Port 10/100/1000BaseT, 4x 1G/10G SFP/SFP+ (optics sold separately) with Standard SW | EX4000-24T
- Brand: Juniper Networks, Inc.
- Series: EX4000
- Part Number: EX4000-24T
- Network Management Type: Managed
- Model #: EX4000-24T
- $1,753.40 –
- More options from $904.99 - $1,812.33
- Free Shipping

Quick View
Extreme Networks - X435 switch 24x10/100/1000BASE-T PoE+ full/half-duplex ports, 4x1G/2.5G unpopulated SFP ports, 1 AC PSU, ExtremeXOS Value Edge license | X435-24P-4S
- Brand: Extreme Networks
- Series: X435
- Part Number: X435-24P-4S
- Format: Rackmount
- Model #: X435-24P-4S
- $1,719.99 –
- Free Shipping

Quick View
Allied Telesis AT-GS950/16-10 Managed Ethernet Switch
- Format: Rackmount
- Primary Ports: 16 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps + 1000Mbps
- VLAN Support: Yes
- Model #: AT-GS950/16-10
- $342.91 –
- More options from $340.99 - $411.49

Quick View
TP-Link TL-SG1218MPE | 16 Port Gigabit PoE Switch | Easy Smart Managed | 16 PoE+ Ports @250W, 2 Non-PoE Ports, 2 Combo SFP Slots | QoS, Vlan, IGMP & LAG | Limited Lifetime Protection | Port Priority
- Switch Type: other
- Format: Rackmount
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3af, IEEE 802.3at, IEEE 802.1q, IEEE 802.1p
- Primary Ports: 16 x RJ45 + 2 x SFP
- Model #: TL-SG1218MPE
- $204.70 –
- More options from $204.70 - $413.12
- Free Shipping

Quick View
TRENDnet 20-Port Gigabit PoE+ Web Smart PoE+ Switch, 16 x Gigabit PoE+ Ports, 4 x Shared Gigabit Ports, Up To 30W Per Port, 185W Total Power Budget, Rack Mountable, Black, TPE-1620WS
- Brand: TRENDnet
- Format: Rackmount
- Standards: IEEE 802.3/3u/3ab, IEEE 802.3af/at
- Network Management Type: Smart
- Model #: TPE-1620WS
- $337.55 –
- More options from $324.99 - $504.88
- Free Shipping

Quick View
TP-Link 28-Port Gigabit Easy Smart Switch with 24-Port PoE+
- Format: 19" 1U rack mountable
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x IEEE 802.3af, IEEE 802.3at, IEEE 802.1q, IEEE 802.1p
- Uplink Interface: 26 10/100/1000 Mbps RJ45 Ports 2 Gigabit SFP Ports
- Primary Ports: 24 x RJ45
- Model #: TL-SG1428PE
- $259.90 –
- More options from $242.44 - $326.77

Quick View
TRENDnet TPE-3018LS (V1.0R) Smart 18-Port Gigabit PoE+ Smart Surveillance Switch
- Brand: TRENDnet
- Model: TPE-3018LS (V1.0R)
- Format: Desktop
- Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1s IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3af IEEE 802.3at IEEE 802.3az
- Model #: TPE-3018LS (V1.0R)


