Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
  • 13Ports - 30Ports
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EPP-100NAS
  •  
  • $446.16 –
  • $11.62 Shipping
Cisco Catalyst C1300-24P-4G Ethernet Switch, 24 Ports, Manageable, Gigabit Ethernet, 10/100/1000Base-T, 1000Base-X , 3 Layer Supported
Quick View
Cisco Catalyst C1300-24P-4G Ethernet Switch, 24 Ports, Manageable, Gigabit Ethernet, 10/100/1000Base-T, 1000Base-X , 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C130024P4G
  • Switch Type: Manageable
  • Model #: C1300-24P-4G
D-Link DGS-1024D Unmanaged 24-Port Gigabit Unmanaged Desktop or Rackmount Switch
Quick View
D-Link DGS-1024D Unmanaged 24-Port Gigabit Unmanaged Desktop or Rackmount Switch
  • Format: Rackmount
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Uplink Ports: None
  • Primary Ports: 24 x RJ45
  • Model #: DGS-1024D
HPE Networking Instant On Switch 24p Gigabit 2p SFP 1830 (JL812A#ABA)
Quick View
HPE Networking Instant On Switch 24p Gigabit 2p SFP 1830 (JL812A#ABA)
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1.5 MB
  • SNMP: Yes
  • Model #: JL812A#ABA
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: 19-inch Rack-mountable Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-16T4S
HPE Networking Instant On Switch 24p Gigabit 1430 (R8R49A#ABA)
Quick View
HPE Networking Instant On Switch 24p Gigabit 1430 (R8R49A#ABA)
  • Part Number: R8R49A#ABA
  • Primary Ports: 24 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 2.0 Mb
  • Model #: R8R49A#ABA
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
Quick View
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
  • Format: Rackmount
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-28
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
  • Brand: PLANET
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGSW-24040R
Sophos 100 CS110-24FP Ethernet Switch 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 2 Layer Supported - 410 W PoE Budget - Twisted Pair, Optical Fiber
Quick View
Sophos 100 CS110-24FP Ethernet Switch 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 2 Layer Supported - 410 W PoE Budget - Twisted Pair, Optical Fiber
  • Part Number: C12CTCHUS
  • Switch Type: managed
  • Format: Rackmount
  • Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
  • Model #: C12CTCHUS
  • $1,243.20
  •  
  • $1,126.99 –
  • Save: $116.21 (9%)
  • Free Shipping
Ubiquiti Standard 24 PoE, 24-Port Layer 2 PoE Switch (USW-24-PoE (95W))
Quick View
Ubiquiti Standard 24 PoE, 24-Port Layer 2 PoE Switch (USW-24-PoE (95W))
  • Brand: Ubiquiti Networks
  • Part Number: USW-24-POE
  • Format: Rackmount
  • Network Management Type: Managed
  • Model #: USW-24-POE
TP-Link TL-SG3428XPP-M2 JetStream 24-Port 2.5GBASE-T and 4-Port 10GE SFP+ L2+ Managed Switch with 16-Port PoE+ & 8-Port PoE++
Quick View
TP-Link
TP-Link TL-SG3428XPP-M2 JetStream 24-Port 2.5GBASE-T and 4-Port 10GE SFP+ L2+ Managed Switch with 16-Port PoE+ & 8-Port PoE++
  • Format: Rackmount
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10 Gbps
  • Primary Port Type: 24 x 2.5 Gbps RJ45 Ports 4 x 10G SFP+ Slots
  • Model #: TL-SG3428XPP-M2
TP-Link TL-SG3428XMP | Jetstream 24 Port Gigabit Smart Managed L2+ PoE switch | 24 PoE+ Port @384W, 4 x 10GE SFP+ Slots | Omada SDN Integrated | IPv6 and Static Routing | Limited Lifetime Protection
Quick View
TP-Link TL-SG3428XMP | Jetstream 24 Port Gigabit Smart Managed L2+ PoE switch | 24 PoE+ Port @384W, 4 x 10GE SFP+ Slots | Omada SDN Integrated | IPv6 and Static Routing | Limited Lifetime Protection
  • Format: Desktop
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • Primary Port Type: 24 x 10/100/1000 Mbps RJ45 Ports 4 x 10G SFP+ Slots
  • Model #: TL-SG3428XMP
HPE Networking Instant On 1930 24-port PoE Switch, 4 SFP+ ports 370W | JL684B#ABA
Quick View
HPE Networking Instant On 1930 24-port PoE Switch, 4 SFP+ ports 370W | JL684B#ABA
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • Buffer Memory: 1.5 MB
  • PoE: Yes
  • Model #: JL684B#ABA
Cisco Business CBS220-24T-4G Smart Switch | 24 Port GE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-24T-4G-NA)
Quick View
Cisco Business CBS220-24T-4G Smart Switch | 24 Port GE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-24T-4G-NA)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Layer: 2
  • Model #: CBS220-24T-4G-NA
Cisco Business CBS220-16P-2G Smart Switch | 16 Port GE | PoE | 2x1G SFP | 3-Year Limited Hardware Warranty (CBS220-16P-2G-NA)
Quick View
Cisco Business CBS220-16P-2G Smart Switch | 16 Port GE | PoE | 2x1G SFP | 3-Year Limited Hardware Warranty (CBS220-16P-2G-NA)
  • Brand: Cisco Systems, Inc.
  • Switch Type: ethernet
  • Network Management Type: Managed
  • Primary Ports: 16 x RJ45 + 2 x SFP
  • Model #: CBS220-16P-2G
HPE Networking Instant On 1930 24G Class4 PoE 4SFP/SFP+ 195W Switch (JL683B#ABA)
Quick View
HPE Networking Instant On 1930 24G Class4 PoE 4SFP/SFP+ 195W Switch (JL683B#ABA)
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • Buffer Memory: 1.5 MB
  • PoE: Yes
  • Model #: JL683B#ABA
Netgear GS524UP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 16-Ports PoE++ (480W), GS524UP-100NAS
Quick View
Netgear Inc.
Netgear GS524UP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 16-Ports PoE++ (480W), GS524UP-100NAS
  • Brand: NETGEAR
  • Part Number: GS524UP-100NAS
  • Switch Type: unmanged
  • Format: Desktop Rack-mountable
  • Model #: GS524UP-100NAS
  •  
  • $529.99 –
  • Free Shipping
Netgear GS724TP 24-Port Gigabit Ethernet PoE+ Smart Switch with 2x SFP Ports (190W), Optional Insight Cloud Management, GS724TP-300NAS
Quick View
Netgear Inc.
Netgear GS724TP 24-Port Gigabit Ethernet PoE+ Smart Switch with 2x SFP Ports (190W), Optional Insight Cloud Management, GS724TP-300NAS
  • Brand: NETGEAR
  • Part Number: GS724TP-300NAS
  • Format: Rack-mountable Desktop
  • Standards: IEEE 802.1x IEEE 802.1p IEEE 802.3az IEEE 802.3 IEEE 802.11ac IEEE 802.3at IEEE 802.3af IEEE 802.1Q IEEE 802.3ad IEEE 802.1D IEEE 802.1w IEEE 802.1s
  • Model #: GS724TP-300NAS
  •  
  • $369.99 –
  • Free Shipping
TRENDnet 8-Port Gigabit PoE+ Switch, 65W PoE Power Budget, 16Gbps Switching Capacity, IEEE 802.1p QoS, DSCP Pass-Through Support, Fanless, Wall Mountable, Lifetime Protection, Black, TPE-TG83
Quick View
Available Direct from TRENDnet Available Direct from TRENDnet
TRENDnet 8-Port 2.5G PoE++ Switch, TPE-BG380, 8 x 2.5GB PoE++ Ports, 230W Poe Power Budget, 40Gbps Switching Capacity, NDAA + TAA Compliant, Lifetime TRENDnet Protection
Quick View
TRENDnet 8-Port 2.5G PoE++ Switch, TPE-BG380, 8 x 2.5GB PoE++ Ports, 230W Poe Power Budget, 40Gbps Switching Capacity, NDAA + TAA Compliant, Lifetime TRENDnet Protection

Limited time offer, ends 09/30

  • Brand: TRENDnet
  • Series: ProSafe
  • Part Number: TPE-BG380
  • Format: Desktop
  • Model #: TPE-BG380
Available Direct from TRENDnet Available Direct from TRENDnet
HPE Networking Instant On Switch 12p 10GBT 4p SFP+ 1960 (JL805A#ABA)
Quick View
HPE Networking Instant On
HPE Networking Instant On Switch 12p 10GBT 4p SFP+ 1960 (JL805A#ABA)
  • Primary Ports: 12 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • SNMP: Yes
  • Power: 100 - 240 VAC
  • Model #: JL805A#ABA
  • $1,479.99 - $1,499.99
Netgear AV Line XSM4216F Fully Managed M4250 16 x 1G/10G Fiber SFP+ Switch, XSM4216F-100NAS
Quick View
Netgear Inc.
Netgear AV Line XSM4216F Fully Managed M4250 16 x 1G/10G Fiber SFP+ Switch, XSM4216F-100NAS
  • Switch Type: managed
  • Format: Desktop
  • Primary Ports: 16 x SFP+
  • Primary Port Speed: 10 Gbps
  • Model #: XSM4216F-100NAS
  •  
  • $1,319.99 –
  • Free Shipping
TRENDnet 24-Port Unmanaged Gigabit GREENnet Desktop Switch, Ethernet Network Switch, 24 x 10-100-1000 Gigabit Ethernet RJ-45 Ports, 48Gbps Switching Capacity, Lifetime Protection, Black, TEG-S24DG
Quick View
TRENDnet 24-Port Unmanaged Gigabit GREENnet Desktop Switch, Ethernet Network Switch, 24 x 10-100-1000 Gigabit Ethernet RJ-45 Ports, 48Gbps Switching Capacity, Lifetime Protection, Black, TEG-S24DG

Limited time offer, ends 09/30

  • Brand: TRENDnet
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX IEEE 802.3ab 1000Base-T IEEE 802.3x Flow Control IEEE 802.3az (draft 2.0)
  • Network Management Type: Unmanaged
  • Model #: TEG-S24DG
Available Direct from TRENDnet Available Direct from TRENDnet
NETGEAR 12x2.5G and 2xSFP+ Managed Switch | AV Line M4250-12M2XF, MSM4214X
Quick View
Netgear Inc.
NETGEAR 12x2.5G and 2xSFP+ Managed Switch | AV Line M4250-12M2XF, MSM4214X
  • Switch Type: managed
  • Format: Desktop
  • Primary Ports: 12 x RJ45 + 2 x SFP+
  • Primary Port Speed: 10 Gbps
  • Model #: MSM4214X-100NAS
HPE Networking Instant On Switch 24p Gigabit 2p 10GBT 2p SFP+ 1960 (JL806A#ABA)
Quick View
HPE Networking Instant On
HPE Networking Instant On Switch 24p Gigabit 2p 10GBT 2p SFP+ 1960 (JL806A#ABA)
  • Primary Ports: 26 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • SNMP: Yes
  • Layer: 2
  • Model #: JL806A#ABA
Netgear AV Line M4350-24F4V 28-Port Manageable 25 Gigabit Ethernet Switch, XSM4328FV-100NES
Quick View
Netgear Inc.
Netgear AV Line M4350-24F4V 28-Port Manageable 25 Gigabit Ethernet Switch, XSM4328FV-100NES
  • Brand: NETGEAR
  • Series: M4350
  • Part Number: XSM4328FV-100NES
  • Format: Rack-mountable Table Top
  • Model #: XSM4328FV-100NES
  •  
  • $3,359.99 –
  • Free Shipping
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
Quick View
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 12.0 Mb
  • Layer: 2
  • Model #: R8R50A#ABA
HPE Aruba Networking CX 6200F 24G Class-4 PoE 4SFP 370W Switch | S0M82A
Quick View
HPE Aruba Networking CX 6200F 24G Class-4 PoE 4SFP 370W Switch | S0M82A
  • Brand: HPE
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • PoE Power Budget: 370W
  • Power: 100V-120V/200V-240V
  • Model #: S0M82AABA
  •  
  • $3,473.99 –
  • Free Shipping
Netgear AV Line M4350-12X12F 12-Port Ethernet Manageable 10 Gigabit Ethernet Switch, XSM4324-100NES
Quick View
Netgear Inc.
Netgear AV Line M4350-12X12F 12-Port Ethernet Manageable 10 Gigabit Ethernet Switch, XSM4324-100NES
  • Brand: NETGEAR
  • Part Number: XSM4324-100NES
  • Network Management Type: Managed
  • Primary Ports: 12 x RJ45 + 12 x SFP+
  • Model #: XSM4324-100NES
  •  
  • $2,999.99 –
  • Free Shipping
Netgear GS728TXPv3 24-Port Manageable Gigabit PoE+ Smart Switches with 4 Dedicated 10G SFP+ Ports, GS728TXP-300NAS
Quick View
Netgear Inc.
Netgear GS728TXPv3 24-Port Manageable Gigabit PoE+ Smart Switches with 4 Dedicated 10G SFP+ Ports, GS728TXP-300NAS
  • Brand: NETGEAR
  • Part Number: GS728TXP300NAS
  • Standards: IEEE 802.1x IEEE 802.1Q IEEE 802.3ad IEEE 802.3x IEEE 802.1D IEEE 802.1s IEEE 802.1w IEEE 802.1ab IEEE 802.1p IEEE 802.1as IEEE 802.1Qat IEEE 802.3an IEEE 802.1BA IEEE 802.3i IEEE 802.1Qav IEEE 802.3z IEEE 802.3ae
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10GBase-X 10/100/ 1000Base-T
  • Model #: GS728TXP-300NAS
  •  
  • $489.99 –
  • Free Shipping
Netgear AV Line M4350-8X8F 8-Port Manageable 10 Gigabit Ethernet Switch, XSM4316-100NES
Quick View
Netgear Inc.
Netgear AV Line M4350-8X8F 8-Port Manageable 10 Gigabit Ethernet Switch, XSM4316-100NES
  • Brand: NETGEAR
  • Part Number: XSM4316100NES
  • Network Management Type: Managed
  • Primary Ports: 8 x RJ45 + 8 x SFP+
  • Model #: XSM4316-100NES
  •  
  • $2,199.99 –
  • Free Shipping
Netgear AV Line M4350-24G4XF 24-Port Manageable 10 Gigabit Ethernet Switch, GSM4328-100NES
Quick View
Netgear Inc.
Netgear AV Line M4350-24G4XF 24-Port Manageable 10 Gigabit Ethernet Switch, GSM4328-100NES
  • Brand: NETGEAR
  • Part Number: GSM4328100NES
  • Standards: IEEE 802.3bt IEEE 802.3af IEEE 802.3at IEEE 802.1as IEEE 802.1Qav IEEE 802.1Qat IEEE 802.1ak IEEE 802.3az IEEE 802.3ad IEEE 802.1AX IEEE 802.1s IEEE 802.1w IEEE 802.1p IEEE 802.1Q IEEE 802.1BA
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Gigabit Ethernet Network Technology: 10GBase-X 10/100/ 1000Base-T
  • Model #: GSM4328-100NES
  •  
  • $2,579.99 –
  • Free Shipping
Cisco Catalyst C1300-24FP-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-24FP-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-24FP-4G
  • Format: Rackmount
  • Model #: C1300-24FP-4G
TP-Link 16 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1016DE)
Quick View
TP-Link 16 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1016DE)
  • Format: Desktop
  • Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
  • Uplink Ports: None
  • Primary Ports: 16 x RJ45
  • Model #: TL-SG1016DE