Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Show More
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
Quick View
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
  • Brand: D-Link
  • Format: Rackmount
  • Standards: 802.3 Ethernet, 802.3u Fast Ethernet, 802.3x Flow Control, 802.3ab Gigabit Ethernet, 802.1p QoS
  • Network Management Type: Unmanaged
  • Model #: DGS-1016D
Available Direct from D-Link Available Direct from D-Link
Aruba CX 6000 24p 10M/100M/1G 4p SFP 1G Switch - 24 Ports - Manageable - Gigabit Ethernet - 2 Layer Supported - 4 SFP Slots - 22.40 W Power Consumption - Compact - R8N88B#ABA
Quick View
Aruba CX 6000 24p 10M/100M/1G 4p SFP 1G Switch - 24 Ports - Manageable - Gigabit Ethernet - 2 Layer Supported - 4 SFP Slots - 22.40 W Power Consumption - Compact - R8N88B#ABA
  • Brand: Aruba
  • Series: CX 6000
  • Part Number: R8N88B#ABA
  • Features: HPE Aruba CX 6000 Switch Series. Entry-level Layer 2. 24 ports + 4 SFP slots. ASIC. Manageable. ACLs, QoS, sFlow, IPv6. HPE Aruba Networking Central manageable. Compact.
  • Model #: R8N88B#ABA
  •  
  • $1,392.00 –
  • Free Shipping
ZyXEL 8-Port GbE Web Managed PoE Switch, GS1200-8HPv2
Quick View
ZyXEL 8-Port GbE Web Managed PoE Switch, GS1200-8HPv2
  • Standards: EEE 802.3u 100BASE-TX Ethernet: Yes IEEE 802.3ab 1000BASE-T Ethernet: Yes IEEE 802.3az EEE support: Yes IEEE 802.3x flow control: Yes IEEE 802.3z 1000BASE-X: Yes IEEE 802.1p CoS:Yes IEEE 802.3af PoE: Yes IEEE 802.3at PoE Plus: Yes (30W per port) Auto MDI/MDI-X: Yes IEEE802.1Q VLAN tagging: Yes
  • Primary Ports: 4 x 1000BASE-T 4 x 1000BASE-T PoE
  • MAC Address Table: 4K
  • VLAN Support: Yes
  • Model #: GS1200-8HP
HPE Aruba JL259A#ABA 2930F 24G 4 SFP Switch
Quick View
HPE Aruba JL259A#ABA 2930F 24G 4 SFP Switch
  • Primary Ports: (24) RJ-45 autosensing 10/100/1000 ports (4) SFP
  • Dimensions: 1.73" x 17.42" x 7.88"
  • Weight: 5.31 lbs.
  • Package Contents: (1) Aruba 2930F 24G 4SFP Switch, (1) power cord, (1) screw kit, (4) mounting ears, (4) bumper feet, (1) cable tie
  • Model #: JL259A#ABA
  •  
  • $2,133.99 –
  • Free Shipping
HPE Networking Instant On Switch 48p Gigabit 4p SFP+ 1930 (JL685A#ABA)
Quick View
HPE Networking Instant On Switch 48p Gigabit 4p SFP+ 1930 (JL685A#ABA)
  • Brand: HPE Networking Instant On
  • Series: HPE Networking Instant On Switch 1930
  • Model: JL685A#ABA
  • Part Number: JL685A#ABA
  • Model #: JL685A#ABA
D-Link DGS-108 Unmanaged 8-Port Gigabit Switch
Quick View
D-Link DGS-108 Unmanaged 8-Port Gigabit Switch
  • Brand: D-Link
  • Format: Desktop/Wall Mount
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twistedpair copper) ANSI/IEEE 802.3 NWay auto-negotiation IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Network Management Type: Unmanaged
  • Model #: DGS-108
RUCKUS ICX 8100 1RU Switch, 24x10/100/1000 Mbps PoE+ 802.3at, 30W Class 4 ports, 4x1GbE SFP uplink-ports, 370W PoE budget. Power cord not included | ICX8100-24P
Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 2.0 Mb
  • PoE: Yes
  • Model #: R8R46A#ABA
StarTech.com Unmanaged 2.5G Switch, 5 Port 2.5GBASE-T Unmanaged Ethernet Switch, Din Rail | Wall Mount, Multi-Gigabit, Auto-MDIX, 9K Jumbo
Quick View
StarTech.com Unmanaged 2.5G Switch, 5 Port 2.5GBASE-T Unmanaged Ethernet Switch, Din Rail | Wall Mount, Multi-Gigabit, Auto-MDIX, 9K Jumbo
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-TX, IEEE 802.3bz 2.5GBASE-T
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 2.5 Gbps
  • Model #: DS52000
HPE Networking CW 2050 48p 10/100/1000BASE-T 4p SFP 1G/2.5G Switch - S6X70A#ABA
Quick View
HPE Networking CW 2050 48p 10/100/1000BASE-T 4p SFP 1G/2.5G Switch - S6X70A#ABA
  • Brand: HPE
  • Series: Networking CW 2050
  • Part Number: S6X70A#ABA
  • Switch Type: 48-Port Gigabit Managed Switch
  • Model #: S6X70A#ABA
  •  
  • $825.00 –
  • Free Shipping
HPE Networking Instant On Switch 24p Gigabit 2p SFP 1830 (JL812A#ABA)
Quick View
HPE Networking Instant On Switch 24p Gigabit 2p SFP 1830 (JL812A#ABA)
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1.5 MB
  • SNMP: Yes
  • Model #: JL812A#ABA
D-Link DGS-1024D Unmanaged 24-Port Gigabit Unmanaged Desktop or Rackmount Switch
Quick View
D-Link DGS-1024D Unmanaged 24-Port Gigabit Unmanaged Desktop or Rackmount Switch
  • Format: Rackmount
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Uplink Ports: None
  • Primary Ports: 24 x RJ45
  • Model #: DGS-1024D
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
Quick View
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
  • Format: Rackmount
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-28
StarTech.com Industrial 8 Port Gigabit PoE Switch 30W - Power Over Ethernet Switch - GbE POE+ Network Switch - Unmanaged
Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch 30W - Power Over Ethernet Switch - GbE POE+ Network Switch - Unmanaged
  • Format: Desktop
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Jumbo Frames: 9KB
  • Model #: IESC1G80UP
D-Link DGS-1008P Switches  4 to 10 Ports 8-port Gigabit Ethernet POE Switch
Quick View
D-Link DGS-1008P Switches 4 to 10 Ports 8-port Gigabit Ethernet POE Switch
  • Format: External
  • Standards: IEEE 802.3/3u, IEEE 802.3af
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1008P
Ubiquiti NanoSwitch, 4-port Gigabit Switch (N-SW)
Quick View
Ubiquiti NanoSwitch, 4-port Gigabit Switch (N-SW)
  • Brand: Ubiquiti Networks
  • Part Number: N-SW
  • Network Management Type: Managed
  • Primary Ports: 4 x RJ45
  • Model #: N-SW
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: 19-inch Rack-mountable Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-16T4S
Cisco Catalyst 9200L 48-port PoE+ 4x10G uplink Switch, Network Essentials | C9200L-48P-4X-E
Quick View
Cisco Catalyst 9200L 48-port PoE+ 4x10G uplink Switch, Network Essentials | C9200L-48P-4X-E
  • Brand: Cisco
  • Series: 9200
  • Part Number: C9200L-48P-4X
  • Network Management Type: Managed
  • Model #: C9200L-48P-4X-E
Juniper Networks EX4600 Switch, 24 SFP+/SFP ports, 4 QSFP+ ports, 2 expansion slots, redundant fans, 2 AC power supplies, 2 power cords, 4-post rack mount kit, front to back airflow | EX4600-40F-AFO
Quick View
Juniper Networks EX4600 Switch, 24 SFP+/SFP ports, 4 QSFP+ ports, 2 expansion slots, redundant fans, 2 AC power supplies, 2 power cords, 4-post rack mount kit, front to back airflow | EX4600-40F-AFO
  • Format: Rack-mountable
  • Primary Port Speed: 10GBase-X 40GBase-X
  • Weight: 21.40 lb
  • Package Contents: Package Contents: EX4600 Ethernet Switch 2 x AC Power Supply
  • Model #: EX4600-40F-AFO
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 65W 1830 (JL811A#ABA)
Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 65W 1830 (JL811A#ABA)
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • PoE: Yes
  • SNMP: Yes
  • Model #: JL811A#ABA
Netgear 5-Port 1-G<G Ethernet Unmanaged Switch -  XS505M-200NAS
Quick View
Netgear Inc.
Netgear 5-Port 1-G<G Ethernet Unmanaged Switch - XS505M-200NAS
  • Brand: NETGEAR
  • Part Number: XS505M-200NAS
  • Switch Type: Unmanaged
  • Primary Port Count: 5
  • Model #: XS505M-200NAS
  •  
  • $424.58 –
  • Free Shipping
Netgear Business GS105EPP Ethernet Switch - 5 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - 4.50 W Power Consumption - 120 W PoE Budget - GS105EPP-100NAS
Quick View
Netgear Inc.
Netgear Business GS105EPP Ethernet Switch - 5 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - 4.50 W Power Consumption - 120 W PoE Budget - GS105EPP-100NAS
  • Brand: NETGEAR
  • Part Number: GS105EPP-100NAS
  • Switch Type: Managed
  • Format: Desktop, Wall Mountable, Enclosure
  • Model #: GS105EPP-100NAS
  •  
  • $174.27 –
  • Free Shipping
Cudy 8-Port Gigabit Unmanaged Switch GS108D
Quick View
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - Twisted Pair, Optical Fiber
Quick View
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - Twisted Pair, Optical Fiber
  • Part Number: C28CTCHUS
  • Switch Type: managed
  • Format: Rackmount
  • Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
  • Model #: C28CTCHUS
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EPP-100NAS
  •  
  • $446.16 –
  • $11.62 Shipping
Cudy 8-Port Gigabit Unmanaged Switch GS108
Quick View
Cudy 16-Port Gigabit Unmanaged Switch GS1016
Quick View
Netgear S3600 Series XS748TM 44-Port 10G/Multi-Gigabit Ethernet Smart Switch with 4 SFP+ Ports
Quick View
Netgear Inc.
Netgear S3600 Series XS748TM 44-Port 10G/Multi-Gigabit Ethernet Smart Switch with 4 SFP+ Ports
  • Brand: NETGEAR
  • Part Number: XS748TM-100NAS
  • Format: Rack-mountable, Table Top
  • Standards: 10 Gigabit Ethernet
  • Model #: XS748TM-100NAS
  •  
  • $6,951.71 –
  • $13.55 Shipping
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (65W) + 2 Optical SFP Ports | L3 Lite | NDAA/TAA Compliant (DGS-1210-10P)
Quick View
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (65W) + 2 Optical SFP Ports | L3 Lite | NDAA/TAA Compliant (DGS-1210-10P)
  • Format: Desktop
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3z
  • Uplink Ports: 2
  • Primary Ports: 8 10/100/1000BASE-T 2 SFP
  • Model #: DGS-1210-10P
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
Quick View
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
  • Format: Rackmount
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
  • Primary Ports: 48 x 10/100/1000BASE-T PoE 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-52MP
Intellinet 5-Port Gigabit Ethernet Switch, Desktop Size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)
Quick View
Intellinet 5-Port Gigabit Ethernet Switch, Desktop Size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)
  • Format: External
  • Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3ab (Gigabit Ethernet) IEEE 802.3x (Flow Control and Backpressure)
  • Primary Ports: 5 x RJ45
  • MAC Address Table: 1K
  • Model #: 530378
QNAP QSW-M408S 6-port layer 2 managed switch. 6 x 2.5GbE (1G/100M) ports and 4 x 10G SFP+ ports. Easy management with web browser.
Quick View