Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Show More
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Cudy 16-Port Gigabit Unmanaged Switch GS1016
Quick View
Netgear S3600 Series XS748TM 44-Port 10G/Multi-Gigabit Ethernet Smart Switch with 4 SFP+ Ports
Quick View
Netgear Inc.
Netgear S3600 Series XS748TM 44-Port 10G/Multi-Gigabit Ethernet Smart Switch with 4 SFP+ Ports
  • Brand: NETGEAR
  • Part Number: XS748TM-100NAS
  • Format: Rack-mountable, Table Top
  • Standards: 10 Gigabit Ethernet
  • Model #: XS748TM-100NAS
  •  
  • $6,951.71 –
  • $13.55 Shipping
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (65W) + 2 Optical SFP Ports | L3 Lite | NDAA/TAA Compliant (DGS-1210-10P)
Quick View
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (65W) + 2 Optical SFP Ports | L3 Lite | NDAA/TAA Compliant (DGS-1210-10P)
  • Format: Desktop
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3z
  • Uplink Ports: 2
  • Primary Ports: 8 10/100/1000BASE-T 2 SFP
  • Model #: DGS-1210-10P
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
Quick View
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
  • Format: Rackmount
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
  • Primary Ports: 48 x 10/100/1000BASE-T PoE 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-52MP
Intellinet 5-Port Gigabit Ethernet Switch, Desktop Size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)
Quick View
Intellinet 5-Port Gigabit Ethernet Switch, Desktop Size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)
  • Format: External
  • Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3ab (Gigabit Ethernet) IEEE 802.3x (Flow Control and Backpressure)
  • Primary Ports: 5 x RJ45
  • MAC Address Table: 1K
  • Model #: 530378
QNAP QSW-M408S 6-port layer 2 managed switch. 6 x 2.5GbE (1G/100M) ports and 4 x 10G SFP+ ports. Easy management with web browser.
Quick View
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
Quick View
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-24P-4X
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RFC 951,...
  • Model #: C1300X-24P-4X
Sophos CS210-48FP Ethernet Switch 48 Ports - Manageable - Gigabit Ethernet, 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 2.5GBase-T, 1000Base-X, 10GBase-X - with 1-year Support
Quick View
Sophos CS210-48FP Ethernet Switch 48 Ports - Manageable - Gigabit Ethernet, 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 2.5GBase-T, 1000Base-X, 10GBase-X - with 1-year Support
  • Part Number: LS24FZ12ZZPCUS
  • Switch Type: managed
  • Format: Rackmount
  • Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
  • Model #: LS24FZ12ZZPCUS
  • $4,389.60
  •  
  • $4,133.99 –
  • Save: $255.61 (5%)
  • Free Shipping
HPE Networking Instant On Switch 24p Gigabit 1430 (R8R49A#ABA)
Quick View
HPE Networking Instant On Switch 24p Gigabit 1430 (R8R49A#ABA)
  • Part Number: R8R49A#ABA
  • Primary Ports: 24 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 2.0 Mb
  • Model #: R8R49A#ABA
StarTech.com IESC1G50UP Industrial 5 Port Gigabit PoE Switch - 30W - Power Over Ethernet Switch - Hardened GbE PoE+ Unmanaged Switch - Rugged High Power Gigabit Network Switch IP-30/-40°C to 75°C
Quick View
StarTech.com IESC1G50UP Industrial 5 Port Gigabit PoE Switch - 30W - Power Over Ethernet Switch - Hardened GbE PoE+ Unmanaged Switch - Rugged High Power Gigabit Network Switch IP-30/-40°C to 75°C
  • Format: Desktop
  • Standards: IEEE 802.3 10/100/1000BASE-T IEEE 802.3at PoE Plus CSMA/CD IEEE 802.3x Flow Control and Back Pressure
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IESC1G50UP
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1005P
Cisco C1300X-24MU-4X Ethernet Switch, 24-port Layer 3 managed switch | C1300X-24MU-4X
Quick View
Cisco C1300X-24MU-4X Ethernet Switch, 24-port Layer 3 managed switch | C1300X-24MU-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-24MU-4X
  • Format: Rackmount
  • Model #: C1300X-24MU-4X
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
  • Format: DIN-rail and Wall-mount Ear
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-4215-4P4T
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
  • Brand: PLANET
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGSW-24040R
HPE Juniper Networking, Compact, fanless switch offering 12 x 1GbE, PoE+ (30W) access ports, 2 x 1/10G SFP+ uplink ports, and 2 x 10G SFP+ VC ports with a total PoE budget of 240W | EX4000-12P
Quick View
  • $2,319.00
  •  
  • $1,090.99 –
  • Save: $1,228.01 (52%)
  • Free Shipping
Cudy 5-Port Gigabit Unmanaged Switch GS105
Quick View
Sophos 100 CS110-24FP Ethernet Switch 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 2 Layer Supported - 410 W PoE Budget - Twisted Pair, Optical Fiber
Quick View
Sophos 100 CS110-24FP Ethernet Switch 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 2 Layer Supported - 410 W PoE Budget - Twisted Pair, Optical Fiber
  • Part Number: C12CTCHUS
  • Switch Type: managed
  • Format: Rackmount
  • Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
  • Model #: C12CTCHUS
  • $1,243.20
  •  
  • $1,126.99 –
  • Save: $116.21 (9%)
  • Free Shipping
RUCKUS ICX 8100 Compact Switch, 8x10/100/1000 Mbps PoE+ 802.3at, 30W Class 4 ports, 2x10GbE SFP+ uplink-ports, 124W PoE budget. Power cord not included | ICX8100-C08PF-X
Quick View
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - with 5-year Support
Quick View
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - with 5-year Support
  • Part Number: LS28FZ60ZZPCUS
  • Switch Type: managed
  • Format: Rackmount
  • Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
  • Model #: LS28FZ60ZZPCUS
  • $1,678.00
  •  
  • $1,587.99 –
  • Save: $90.01 (5%)
  • Free Shipping
Asus QG-U1050 Ethernet Switch - TAA compliant - 5 Ports - 2.5 Gigabit Ethernet - 2.5GBase-T, 100Base-TX - 2 Layer Supported - Twisted Pair - White
Quick View
D-Link 5-Port Gigabit Unmanaged Desktop Switch (DGS-105)
Quick View
D-Link 5-Port Gigabit Unmanaged Desktop Switch (DGS-105)
  • Brand: D-Link
  • Format: Desktop/Wall Mount
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twistedpair copper) ANSI/IEEE 802.3 NWay auto-negotiation IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Network Management Type: Unmanaged
  • Model #: DGS-105
Transition Networks Managed Hardened Gigabit Ethernet PoE++ Switch
Quick View
Transition Networks Managed Hardened Gigabit Ethernet PoE++ Switch
  • Format: Wall Mountable
  • Primary Port Speed: 1000Base-X 10/100/1000Base-T
  • Weight: 2.4
  • Parts: 5 Year
  • Model #: SISPM1040-582-LRT
Planet FGSW-2624HPS4 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Ethernet Switch / 420W PoE budget
Quick View
Planet FGSW-2624HPS4 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Ethernet Switch / 420W PoE budget
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet over Fiber-Optic IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 24 x 10/100BASE-TX RJ45 copper with 24-port IEEE 802.3at / af PoE injector 2 x 10/100/1000BASE-T Gigabit RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots, shared with port-25 to port-26
  • MAC Address Table: 4K
  • Switching Method: Store and Forward
  • Model #: FGSW-2624HPS4
Transition Networks Unmanaged Hardened Gigabit Ethernet PoE+ Switch
Quick View
Transition Networks Unmanaged Hardened Gigabit Ethernet PoE+ Switch
  • Format: DIN Rail Mountable Wall Mountable
  • Primary Port Speed: 1000Base-X 10/100/1000Base-T
  • Weight: 15.20 oz
  • Parts: 5 Year
  • Model #: SISTP1040-342-LRT
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
Quick View
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
  • Format: Wall-mount and DIN Rail Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az EEE (Energy Efficient Ethernet) RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2 ITU-T G.8032 ERPS (Ethernet Ring Protection Switching)
  • Primary Ports: 6 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5226-4P2T
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
Quick View
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-511S15
Cisco C1300X-48P-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48P-4X
Quick View
Cisco C1300X-48P-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48P-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-48P-4X
  • Format: Rackmount
  • Model #: C1300X-48P-4X
Juniper Networks EX4400, 48-port 10/100/1000BASE-T + 550 W DC PS (DAC for Virtual Chassis ordered separately) | EX4400-48T-DC
Quick View
  • $11,810.00
  •  
  • $6,060.99 –
  • Save: $5,749.01 (48%)
  • Free Shipping
Ruckus ICX7550-24-E2 24 Ports 1G Mid-Range Enterprise-Class Stackable Access/Aggregation Switch, 2 AC Power Supplies with Exhaust Airflow Installed
Quick View
Ruckus ICX7550-24-E2 24 Ports 1G Mid-Range Enterprise-Class Stackable Access/Aggregation Switch, 2 AC Power Supplies with Exhaust Airflow Installed
  • Part Number: ICX7550-24-E2
  • Format: 1RU
  • Primary Ports: Interfaces: 24-port 10/100/1000 Mbps; 2-port 40 Gbps Uplink/Stack QSFP+, expansion module slot 10/100/1000BASE-T Ports: 24
  • Buffer Memory: RAM / Total Installed Size: 4 GB Flash Memory / Installed Size: 4 GB
  • Model #: ICX7550-24-E2
  • $8,690.00
  •  
  • $6,107.99 –
  • Save: $2,582.01 (29%)
  • Free Shipping
Ubiquiti Standard 24 PoE, 24-Port Layer 2 PoE Switch (USW-24-PoE (95W))
Quick View
Ubiquiti Standard 24 PoE, 24-Port Layer 2 PoE Switch (USW-24-PoE (95W))
  • Brand: Ubiquiti Networks
  • Part Number: USW-24-POE
  • Format: Rackmount
  • Network Management Type: Managed
  • Model #: USW-24-POE