Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Useful Links
Customer Ratings
Sort By:
View:
D-Link 8-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (64W) | Compact Metal Desktop |NDAA Compliant - (DGS-1100-08PV2)
Quick View
D-Link 8-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (64W) | Compact Metal Desktop |NDAA Compliant - (DGS-1100-08PV2)
  • Brand: D-Link
  • Series: ProSafe
  • Part Number: DGS-1100-08PV2
  • Switch Type: Layer 2
  • Model #: DGS110008PV2
Fortinet FortiSwitch-124F-FPOE Layer 2 FortiGate switch controller compatible PoE+ switch with 24 GE RJ45 + 4 10G SFP+ ports, 24 port PoE | FS-124F-FPOE
Quick View
Fortinet FortiSwitch-124F-FPOE Layer 2 FortiGate switch controller compatible PoE+ switch with 24 GE RJ45 + 4 10G SFP+ ports, 24 port PoE | FS-124F-FPOE
  • Part Number: FS-124F-FPOE
  • Format: Rackmount
  • Management Interface: 24x GE RJ45 and 4x 10GE SFP+
  • Management Feature: Automation Stitches Display Average Bandwidth and Allow Sorting on Physical Port / Interface Traffic Dual Firmware Support HTTP / HTTPS IPv4 and IPv6 Management Link Monitor Managed from FortiGate Packet Capture POE Control Modes Provide warning if L2 table is getting full RMON Group 1 SNMP v1/v2c/v3 SNMP v3 traps SNTP Software download/upload: TFTP/FTP/GUI SPAN, RSPAN, and ERSPAN Standard CLI and Web GUI Interface Support for HTTP REST APIs for Configuration and Monitoring Syslog UDP/TCP System alias command System Temperature and Alert Telnet / SSH
  • Model #: FS-124F-FPOE
D-LINK BUSINESS DGS-1510-28X SmartPro 24Port Gigabit Switch
Quick View
D-LINK BUSINESS DGS-1510-28X SmartPro 24Port Gigabit Switch
  • Brand: D-Link
  • Part Number: DGS-1510-28X
  • Switch Type: Ethernet Switch
  • Uplink Interface: RJ45, SFP+
  • Model #: DGS-1510-28X
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1005P
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (130W) + 2 Optical SFP Ports|L3 Lite|NDAA/TAA Compliant (DGS-1210-10MP)
Quick View
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (130W) + 2 Optical SFP Ports|L3 Lite|NDAA/TAA Compliant (DGS-1210-10MP)
  • Switch Type: 8-Port Gigabit Smart Managed PoE Switch with 2 Gigabit SFP ports, 130W PoE Budget
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-FX 100 Mbps over fiber optic IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twisted- pair copper) IEEE 802.3z 1000BASE-X 1 Gbps over fiber optic IEEE 802.3az Energy Efficient Ethernet (EEE) IEEE 802.3x Flow Control IEEE 802.3af/at compliance (for PoE ports on PoE models)
  • Primary Ports: 8 x 10/100/1000 (PoE+) + 2 x Gigabit SFP
  • Model #: DGS-1210-10MP
Netgear Business GS105PP 5-Port Gigabit Ethernet Unmanaged PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS105PP 5-Port Gigabit Ethernet Unmanaged PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS105PP-300NAS
  • Format: Desktop, Wall Mountable, Enclosure, Compact
  • Standards: 10/100/1000Base-T
  • Model #: GS105PP-300NAS
  •  
  • NZ$351.90 –
  • NZ$71.18 Shipping
Netgear AV Line M4350-16M4V Ethernet Switch - 16 Ports - Manageable - 2.5 Gigabit Ethernet, 25 Gigabit Ethernet - 2.5GBase-T, 25GBase-X - 3 Layer Supported - 689.60 W Power Consumption - MSM4320-100NE
Quick View
  •  
  • NZ$15,354.80 –
  • NZ$354.40 Shipping
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T, IEEE 802.3u 100BASE-FX, IEEE 802.3z 1000BASE-SX, IEEE 802.3z 1000BASE-LX, 4-Port IEEE 802.3af/at Power over Ethernet end-span PSE
  • Primary Ports: 4 x RJ-45 Female 4 x RJ-45 (PoE+) Female
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES81GPOEW
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-801T
  •  
  • NZ$358.80 –
  • NZ$111.00 Shipping
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
Quick View
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-1008HP
  •  
  • NZ$282.90 –
  • NZ$149.75 Shipping
Netgear Business GS105P 5-Port Gigabit Ethernet Unmanaged PoE Switch
Quick View
Netgear Inc.
Netgear Business GS105P 5-Port Gigabit Ethernet Unmanaged PoE Switch
  • Brand: NETGEAR
  • Part Number: GS105P-300NAS
  • Format: Desktop, Wall Mountable, Enclosure, Compact
  • Standards: 10/100/1000Base-T
  • Model #: GS105P-300NAS
  •  
  • NZ$262.20 –
  • NZ$120.78 Shipping
BRAINBOXES SW-508 INDUSTRIAL ETHERNET 8PORT SW
Quick View
BRAINBOXES SW-508 INDUSTRIAL ETHERNET 8PORT SW
  • Switch Type: Others
  • Weight: 0.5
  • Model #: SW-508
Netgear Business GS108EP 8-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS108EP 8-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS108EP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS108EP-100NAS
  •  
  • NZ$368.00 –
  • NZ$107.67 Shipping
HPE Aruba Networking 2930F 48G PoE+ 4SFP+ Switch | JL256A#ABA
Quick View
HPE Aruba Networking 2930F 48G PoE+ 4SFP+ Switch | JL256A#ABA
  • Brand: HPE
  • Model: JL256A#ABA
  • Part Number: JL256A
  • Primary Ports: (48) RJ-45 autosensing 10/100/1000 PoE+ ports (4) SFP+ 1/10GbE ports
  • Model #: JL256A#ABA
  •  
  • NZ$7,377.25 –
  • NZ$274.76 Shipping
Ubiquiti Enterprise 48 PoE, 48-Port Layer 3 PoE+ Switch (USW-Enterprise-48-PoE (720W))
Quick View
Ubiquiti Enterprise 48 PoE, 48-Port Layer 3 PoE+ Switch (USW-Enterprise-48-PoE (720W))
  • Brand: Ubiquiti Networks
  • Series: UniFi
  • Part Number: USW-Enterprise-48-PoE (720W)
  • Format: Rackmount
  • Model #: USW-Enterprise-48-PoE (720W)
  •  
  • NZ$3,858.25 –
  • NZ$260.69 Shipping
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
Quick View
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3af Power over Ethernet
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with IEEE 802.3af PoE injector 1-port 100Base-FX SFP interface
  • MAC Address Table: 2K
  • Switching Method: Store and Forward
  • Model #: ISW-514PTF
  •  
  • NZ$485.30 –
  • NZ$184.04 Shipping
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
Quick View
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T IEEE 802.3z 1000Base-SX/LX IEEE 802.3az Energy-Efficient Ethernet, IEEE 802.3x Flow Control, IEEE 802.1q VLAN Tagging, IEEE 802.1p QoS, IEEE 802.1x Port-Based Network Access Control, IEEE802.3ad Link Aggregation, IEEE 802.1d Spanning Tree Protocol, IEEE 802.1w Rapid Spanning Tree Protocol
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES101GP2SFW
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8P2S
SonicWall SWS14-24FPOE Switch, w/ 3-Year wireless network management essential and support | 02-SSC-8376
Quick View
  •  
  • NZ$2,365.55 –
  • NZ$176.55 Shipping
Aruba X511 12-port Cable Guard JL742A
Quick View
  •  
  • NZ$169.05 –
  • NZ$129.64 Shipping
D-Link 5-Port Gigabit Unmanaged Desktop Switch (DGS-105)
Quick View
D-Link 5-Port Gigabit Unmanaged Desktop Switch (DGS-105)
  • Brand: D-Link
  • Format: Desktop/Wall Mount
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twistedpair copper) ANSI/IEEE 802.3 NWay auto-negotiation IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Network Management Type: Unmanaged
  • Model #: DGS-105
StarTech 5-Port Unmanaged Industrial Network Switch I51G-ETHERNET-SWITCH
Quick View
StarTech 5-Port Unmanaged Industrial Network Switch I51G-ETHERNET-SWITCH
  • Brand: StarTech
  • Part Number: I51G-ETHERNET-SWITCH
  • Uplink Interface: RJ45
  • Primary Ports: RJ45
  • Model #:
Transition Networks Managed Hardened Gigabit Ethernet PoE++ Switch
Quick View
Transition Networks Managed Hardened Gigabit Ethernet PoE++ Switch
  • Format: Wall Mountable
  • Primary Port Speed: 1000Base-X 10/100/1000Base-T
  • Weight: 2.4
  • Parts: 5 Year
  • Model #: SISPM1040-582-LRT
Netgear Business GS108EPP 8-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS108EPP 8-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS108EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS108EPP-100NAS
  •  
  • NZ$489.90 –
  • NZ$107.67 Shipping
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: WGS-5225-8T2SV
  •  
  • NZ$776.25 –
  • NZ$184.04 Shipping
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T2S
  •  
  • NZ$547.40 –
  • NZ$123.04 Shipping
Black Box Industrial (8) 10/100/1000 PoE + (2) Gigabit Ethernet Switch
Quick View
Black Box Industrial (8) 10/100/1000 PoE + (2) Gigabit Ethernet Switch
  • Format: Wall Mountable
  • Primary Ports: Gigabit Ethernet 10 x Gigabit Ethernet Network
  • Primary Port Speed: 10/100/1000Base-TX
  • Stackable: Wall Mountable DIN Rail Mountable Panel-mountable
  • Model #: LPH3100A
  •  
  • NZ$1,718.10 –
  • NZ$133.45 Shipping
D-Link 28-Port 10-Gigabit Smart Managed PoE Switch DGS125028XMP6KV
Quick View
D-Link 28-Port 10-Gigabit Smart Managed PoE Switch DGS125028XMP6KV
  • Switch Type: managed
  • Model #: DGS125028XMP6KV
ZyXEL GS1350-12HP 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 130W with 2 SFP Uplinks
Quick View
ZyXEL GS1350-12HP 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 130W with 2 SFP Uplinks
  • Part Number: GS1350-12HP
  • Format: Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair, Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
  • Uplink Interface: Total Number of Network Ports: 8 Uplink Port: Yes Modular: Yes Port/Expansion Slot Details: 8 x Gigabit Ethernet PoE+ 2 x Gigabit Ethernet Network 2 x Gigabit Ethernet Expansion Slot
  • Model #: GS1350-12HP
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T
  •  
  • NZ$448.50 –
  • NZ$123.04 Shipping
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
Quick View
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-621T series 2 x port 100Base-FX interface on ISW-621T for up to 2km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-621T
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15km (-40 ~ 75 Degrees C Operating Temperature)
Quick View
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15km (-40 ~ 75 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511TS15 for up to 15km (single-mode fiber 9/125µm) transmission distance
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-511TS15
  •  
  • NZ$279.45 –
  • NZ$111.00 Shipping

Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.

Network Switches Are Versatile Networking Solutions

Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.

Switches Accommodate Shifts in Business and IT Trends

Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.

Multiple Network Management Options Provide a Positive User Experience

There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.

Switches Provide the Highest Levels of Security

Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.

Network Switches Provide Comprehensive and Advanced Networking Features

Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.