Your Browsing History
- In Stock
- Sold by Newegg
- New

Quick View
Cudy 5-Port Gigabit Switch with USB-C Power Input GS105U
- Model #: GS105U
- $29.99
- $19.99 –
- Save: $10.00 (33%)
- More options from $19.99 - $37.81
- $17.76 Shipping

Quick View
Cisco Catalyst 1300 C1300-8MGP-2X Layer 3 Switch, 8 Ports - Manageable - Gigabit Ethernet, 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 2.5GBase-T, 10GBase-X - 3 Layer Supported
- Part Number: C1300-8MGP-2X
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1ab
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet 2.5 Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 2.5GBase-T 10GBase-X Maximum Data Transfer Rate: 1.25 GB/s
- Model #: C1300-8MGP-2X
- $729.99 –
- More options from $729.99 - $862.25
- Free Shipping

Quick View
Netgear GS752TPP 48-Port Gigabit PoE+ Smart Switch with Remote/Cloud Management and 4 SFP Ports (760W), GS752TPP-300NAS
- Brand: NETGEAR
- Part Number: GS752TPP300NAS
- Network Management Type: Smart
- Primary Ports: 48 x RJ45 + 4 x SFP
- Model #: GS752TPP-300NAS
- $1,029.99 –
- Free Shipping

Quick View
in 30 days
Netgear GS348PP 48-Port Gigabit Ethernet Unmanaged PoE+ Essentials Switch with 24-Ports PoE+ (380W), GS348PP-100NAS- Brand: NETGEAR
- Part Number: GS348PP-100NAS
- Format: Desktop Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
- Model #: GS348PP-100NAS
- $459.99 –
- Free Shipping

Quick View
Cisco Catalyst C1300-48T-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-48T-4X
- Format: Rack-mountable
- Model #: C1300-48T-4X
- $1,306.99 –
- More options from $1,306.99 - $1,495.35
- Free Shipping

Quick View
NETGEAR 24x10G/Multi-Gig PoE+ (576W base, up to 720W) and 4xSFP28 25G | XSM4328CV
- Model #: XSM4328CV100NES
- $4,479.99 –
- Free Shipping

Quick View
Netgear GS348 48-Port Gigabit Ethernet Unmanaged Essentials Switch, GS348-100NAS
- Brand: NETGEAR
- Part Number: GS348-100NAS
- Format: Desktop Rack-Mountable
- Standards: 802.3ab 1000BASE-T Gigabit Ethernet 802.3u 100BASE-TX Fast Ethernet 802.3i 10BASE-T Ethernet 802.3x Flow Control 802.1p Priority QoS (all models) 802.1p Priority QoS and Honors DSCP tags 802.3 CSMA / CD 802.3az Energy Efficient Ethernet
- Model #: GS348-100NAS
- $249.99 –
- Free Shipping

Quick View
- $106.99 –
- Free Shipping

Quick View
Cisco Catalyst C1300-8T-E-2G Ethernet Switch 10 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported - 2 SFP Slots - 10.65 W Power Consumption
- Brand: CISCO
- Series: Catalyst C1300-8T-E-2G
- Part Number: Catalyst C1300-8T-E-2G
- Switch Type: managed
- Model #: C1300-8T-E-2G
- $380.16 –
- More options from $380.16 - $408.09
- Free Shipping

Quick View
Netgear AV Line M4250-10G2F-PoE+ 8x1G PoE+ 125W 2x1G and 2xSFP Managed Switch, GSM4212P-100NAS
- Brand: NETGEAR
- Part Number: GSM4212P-100NAS
- Format: Rackmount
- Network Management Type: Managed
- Model #: GSM4212P-100NAS
- $749.99
- See price in cart
- Free Shipping

Quick View
- $449.99 –
- More options from $429.99 - $489.48
- Free Shipping

Quick View
StarTech 5-Port Unmanaged Industrial Network Switch I51G-ETHERNET-SWITCH
- Brand: StarTech
- Part Number: I51G-ETHERNET-SWITCH
- Uplink Interface: RJ45
- Primary Ports: RJ45
- Model #:
- $93.99 –
- More options from $93.99 - $102.33
- Free Shipping

Quick View
Ubiquiti NanoSwitch, 4-port Gigabit Switch (N-SW)
- Brand: Ubiquiti Networks
- Part Number: N-SW
- Network Management Type: Managed
- Primary Ports: 4 x RJ45
- Model #: N-SW
- $49.49 –
- More options from $48.32 - $64.25
- Free Shipping

Quick View
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
- Brand: CISCO
- Network Management Type: Managed
- Primary Ports: 18 x RJ45 + 2 x SFP
- Layer: 2
- Model #: CBS220-8T-E-2G
- $142.99 –
- More options from $142.99 - $171.64
- Free Shipping

Quick View
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
- Brand: NETGEAR
- Part Number: GS116EPP-100NAS
- Format: Desktop, Wall Mountable, Enclosure
- Standards: 10/100/1000Base-T
- Model #: GS116EP-100NAS
- $390.39 –
- $11.62 Shipping

Quick View
Netgear ProSafe GS728TPP 28-Port PoE Gigabit Ethernet Smart Switch, GS728TPP-300NAS
- Brand: NETGEAR
- Part Number: GS728TPP-300NAS
- Switch Type: Smart Switch
- Format: Rackmount
- Model #: GS728TPP-300NAS
- $529.99 –
- Free Shipping

Quick View
Tripp Lite N254-024-6A 24-Port Rackmount Cat6A Feedthrough Patch Panel Rj45 Ethernet 1U
- Color: Black
- Type: Office Products
- Model #: N254-024-6A
- $322.99 –
- More options from $322.99 - $433.00
- Free Shipping

Quick View
HPE Networking Instant On Switch 20p Gigabit CL4 4p Gigabit CL6 PoE 2p 10GBT 2p SFP+ 370W 1960 (JL807A#ABA)
- Primary Ports: 26 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- PoE: Yes
- SNMP: Yes
- Model #: JL807A#ABA
- $1,199.99 –
- More options from $1,179.99 - $1,249.99
- Free Shipping

Quick View
Cisco Catalyst C1300, 12 x 10 Gigabit copper ports, 2 x 10 Gigabit SFP+, 1 x GE management port, Rack-mountable | C1300-12XT-2X
- Brand: Citrix Systems
- Series: Catalyst 1300
- Part Number: C1300-12XT-2X
- Format: Rackmount
- Model #: C1300-12XT-2X
- $1,855.33
- $1,624.99 –
- Save: $230.34 (12%)
- More options from $1,624.99 - $1,743.81
- Free Shipping

Quick View
Ubiquiti UniFi WAN Switch RJ45 (USW-WAN-RJ45)
- Model #: USW-WAN-RJ45
- $268.00 –
- More options from $268.00 - $422.59
- $11.45 Shipping

Quick View
Aten 4-Port USB 3.0 4K HDMI KVMP Switch CS1824
- Model #: CS1824
- $597.00
- See price in cart
- More options from $380.99 - $975.90
- $11.62 Shipping

Quick View
Netgear GS752TXPv3 48-Port Gigabit Ethernet PoE+ Smart Switch with 4 Dedicated 10G SFP+ Ports, GS752TXP-300NAS
- Brand: NETGEAR
- Part Number: GS752TXP300NAS
- Network Management Type: Smart
- Primary Ports: 48 x RJ45 + 4 x SFP+
- Model #: GS752TXP-300NAS
- $869.99 –
- Free Shipping

Quick View
- $117.00
- See price in cart
- More options from $31.92 - $38.36
- Free Shipping

Quick View
StarTech.com Cat 6 RJ45 Modular Plug for Solid Wire - 50 Pack
- Type: Consumer Electronics
- Color: Black
- Specifications: Product Type:Network Connector Connector Details:RJ-45 Male
- Parts: 2 Year
- Model #: CRJ45C6SOL50
- $32.99 –
- Free Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit 2p SFP 1830 (JL812A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- SNMP: Yes
- Model #: JL812A#ABA
- $204.99 –
- More options from $99.31 - $311.00
- Free Shipping

Quick View
Cisco Catalyst C1300-8FP-2G Ethernet Switch, 10 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-8FP-2G
- Format: Rackmount
- Model #: C1300-8FP-2G
- $497.95 –
- More options from $497.95 - $555.79
- Free Shipping

Quick View
Ubiquiti EnterpriseXG 24 (Gen1), 24-port Layer 3 switch (USW-EnterpriseXG-24)
- Brand: Ubiquiti
- Series: Network Switch
- Part Number: USW-EnterpriseXG-24
- Format: Rackmount
- Model #: USW-EnterpriseXG-24
- $1,299.00 –
- More options from $1,299.00 - $1,866.29
- Free Shipping

Quick View
Cisco Catalyst C1300-48P-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
- Part Number: C1300-48P-4X
- Format: Rackmount
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 10GBase-X
- Model #: C1300-48P-4X
- $2,043.92
- $1,782.99 –
- Save: $260.93 (12%)
- More options from $1,782.99 - $1,967.02
- Free Shipping

Quick View
Cisco Catalyst 1300 C1300-24XT Layer 3 Switch, 20 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
- Part Number: C1300-24XT
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1p IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1ab
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10GBase-T 10GBase-X Maximum Data Transfer Rate: 1.25 GB/s
- Model #: C1300-24XT
- $3,092.99 –
- More options from $3,092.99 - $3,461.56
- Free Shipping

Quick View
NETGEAR 26-Port PoE Gigabit Ethernet Smart Switch (GS724TPP) - Managed, Optional Insight Cloud Management, 24 x PoE+ @ 380W, 2 x 1G SFP, Desktop or Rackmount, and Limited Lifetime Protection
- Model #: Newegg_Delete
- $579.99
- $489.99 –
- Save: $90.00 (15%)
- Free Shipping

Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T
- $201.60
- See price in cart
- Free Shipping

Quick View
Panduit CJ688TGBU PANDUIT Mini-Com Cat.6 UTP Module - RJ-45
- Model #: CJ688TGBU
- $20.99
- $17.99 –
- Save: $3.00 (14%)
- More options from $10.99 - $23.82
- $2.99 Shipping

Quick View
Ubiquiti Networks USW-Flex-Mini-5 Compact 5-Port Gigabit Switch Ethernet USW
- Brand: Ubiquiti
- Part Number: USW-Flex-Mini-5
- Format: Compact Desktop
- Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
- Model #: USW-Flex-Mini-5
- $147.99 –
- More options from $147.99 - $209.75
- Free Shipping

Quick View
Netgear Business GS105PP 5-Port Gigabit Ethernet Unmanaged PoE+ Switch
- Brand: NETGEAR
- Part Number: GS105PP-300NAS
- Format: Desktop, Wall Mountable, Enclosure, Compact
- Standards: 10/100/1000Base-T
- Model #: GS105PP-300NAS
- $160.33 –
- $7.52 Shipping

Quick View
Netgear GS524 24-Port Gigabit Ethernet Unmanaged Switch, GS524-300NAS
- Brand: NETGEAR
- Series: Gigabit Unmanaged Switch
- Part Number: GS524-300NAS
- Format: Wall Mountable
- Model #: GS524-300NAS
- $205.43
- $149.99 –
- Save: $55.44 (26%)
- Free Shipping

Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Model #: WGS-5225-8T2SV
- $345.99 –
- More options from $327.20 - $345.99
- Free Shipping


