Your Browsing History
- In Stock
- Sold by Newegg
- Make an Offer
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
AQC113 M.2 B+M 10GbE Network Card to RJ45 Ethernet Network Adapter for Desktop
- Brand: Unbranded
- Part Number: AQC113
- Speed: 10 Gbps
- Connectors: Ethernet/ Network Cards
- Model #: 357958082801
- $125.99 –
- Free Shipping

Quick View
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
- Brand: Cisco Systems, Inc.
- Series: C1300X Series
- Part Number: C1300X-24P-4X
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RFC 951,...
- Model #: C1300X-24P-4X
- $1,426.99 –
- More options from $1,426.99 - $1,623.42
- Free Shipping

Quick View
Cisco C1300X-24NGU-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24NGU-4X
- Brand: Cisco Systems, Inc.
- Series: C1300X Series
- Part Number: C1300X-24NGU-4X
- Format: Rackmount
- Model #: C1300X-24NGU-4X
- $1,714.40 –
- More options from $1,652.82 - $1,861.95

Quick View
Cisco C1300X-48P-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48P-4X
- Brand: Cisco Systems, Inc.
- Series: C1300X Series
- Part Number: C1300X-48P-4X
- Format: Rackmount
- Model #: C1300X-48P-4X
- $2,209.99 –
- More options from $2,209.99 - $2,392.86
- Free Shipping

Quick View
Netgear AV Line M4350-24F4V 28-Port Manageable 25 Gigabit Ethernet Switch, XSM4328FV-100NES
- Brand: NETGEAR
- Series: M4350
- Part Number: XSM4328FV-100NES
- Format: Rack-mountable Table Top
- Model #: XSM4328FV-100NES
- $3,359.99 –
- Free Shipping

Quick View
ZyXEL XGS2220-54HP 48-Port Gigabit L3 Managed and Nebula Pro Cloud Managed Switch, 40 PoE+ / 10 PoE++ Ports at 600W with 4x SFP+ 10G Uplinks and 2x 10G Ethernet Ports
- Brand: ZyXEL
- Part Number: XGS2220-54HP
- Switch Type: Manageable
- Format: Rack-mountable
- Model #: XGS222054HP
- $1,538.95 –
- More options from $1,296.99 - $1,710.94

Quick View
Netgear AV Line M4350-40X4C Ethernet Switch - 40 Ports - Manageable - 100 Gigabit Ethernet - 3 Layer Supported - Modular - 750 W Power Consumption - 196 W PoE Budget - PoE Ports - 1U - XSM4344C-100NES
- Brand: NETGEAR
- Series: M4350
- Part Number: XSM4344C-100NES
- Switch Type: Ethernet Switch
- Model #: XSM4344C-100NES
- $11,999.99 –
- Free Shipping

Quick View
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-501T
- $114.99 –
- Free Shipping

Quick View
Netgear Business GS728TXUPv3 24-Port Manageable Gigabit Ethernet PoE+ and PoE++ Smart Switch, GS728TXUP-300NAS
- Brand: NETGEAR
- Series: Smart w/ Optional Cloud
- Part Number: GS728TXUP-300NAS
- Format: Rackmount
- Model #: GS728TXUP-300NAS
- $729.99 –
- Free Shipping

Quick View
Fortinet FortiSwitch 248D 48 Port Layer 2/3 Gigabit Ethernet Switch - FS-248D
- Switch Type: ethernet
- Weight: 10.10
- Model #: FS-248D
- $1,267.99 –
- Free Shipping

Quick View
Netgear AV Line M4350-32F8V 40-Port Manageable 25 Gigabit Ethernet Switch, XSM4340FV-100NES
- Brand: NETGEAR
- Series: AV Line
- Part Number: XSM4340FV-100NES
- Format: Compatible Rack Unit: 1U Form Factor: Rack-mountable Table Top
- Model #: XSM4340FV-100NES
- $4,999.99 –
- Free Shipping

Quick View
Cisco Catalyst C1300-16XTS Layer 3 Switch, 8 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
- Part Number: C1300-16XTS
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3ad IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1p IEEE 802.1w IEEE 802.1x IEEE 802.3af IEEE 802.3at IEEE 802.1ab IEEE 802.3az
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Network Technology: 10GBase-T 10GBase-X Maximum Data Transfer Rate: 1.25 GB/s
- Model #: C1300-16XTS
- $2,522.99 –
- More options from $2,522.99 - $2,819.83
- Free Shipping

Quick View
Intel SFP+ Module - For Data Networking, Optical Network 1 x 10GBase-SR Network - Optical Fiber Multi-mode - 10 Gigabit Ethernet - 10GBase-SR - Hot-pluggable
- Compatible Brand: Intel
- Device Type: Transceiver
- Fiber Cable: Multi-mode Optical Fiber
- Ports: 10GBase-SR
- Model #: E10GSFPSRX
- $34.75 –
- More options from $34.75 - $36.00
- Free Shipping

Quick View
10Gb SFP PCI-e Network Card, 82599(X520-DA1) Controller, 10Gbps Ethernet Adapter, 10Gbe SFP+ Port, 10G NIC Card, Support Windows/Windows Server/VMware
- Model #: C12Y-ZY1090
- $128.00 –
- Free Shipping

Quick View
Intel Ethernet Server Adapter X520-T2
- Connectors: RJ-45 Copper
- Features: 10GBASE-T Dual Port Standard Cat6a cabling with RJ45 connectors Low cost, low power, 10 Gigabit Ethernet (10GbE) performance for the entire data center Standard CAT-6a cabling with RJ45 connectors
- Parts: 30 DAYS WARRANTY
- Labor: 30 DAYS WARRANTY
- Model #: X520-T2
- $207.55 –
- More options from $207.55 - $251.00
- Free Shipping

Quick View
Intel X520-SR2 Dual Ports 10 Gigabit Ethernet Converged Network Adapter, PCI Express 2.0 x8, Low Profile
- Model #: intel-wk-4
- $45.99 –
- Free Shipping

Quick View
Cisco C1300X-24MU-4X Ethernet Switch, 24-port Layer 3 managed switch | C1300X-24MU-4X
- Brand: Cisco Systems, Inc.
- Series: C1300X Series
- Part Number: C1300X-24MU-4X
- Format: Rackmount
- Model #: C1300X-24MU-4X
- $1,605.99 –
- More options from $1,605.99 - $1,693.81
- Free Shipping

Quick View
Cisco C1300X-10NU-2X Ethernet Switch, 10-port managed Layer 3 switch | C1300X-10NU-2X
- Brand: Cisco Systems, Inc.
- Series: C1300X Series
- Part Number: C1300X-10NU-2X
- Format: Rackmount
- Model #: C1300X-10NU-2X
- $849.99 –
- More options from $849.99 - $909.81
- Free Shipping

Quick View
TRENDnet 5-Port Hardened Industrial Unmanaged Gigabit Switch, TI-PG50, 10/100/1000Mbps, DIN-Rail Switch, 4 x Gigabit PoE+ Ports, 1 x Gigabit Port, Gigabit Ethernet Network Switch
- Format: Rackmount
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3af, IEEE 802.3at
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TI-PG50
- $119.99 –
- More options from $119.99 - $188.48
- Free Shipping

Quick View
Vszerda 10Gb PCI-E Network Card NIC, Dual RJ45 Copper Ports, Compare to Intel X540-T2, with Intel X540-BT2 Chip, PCIe X8, 10Gbase-T Ethernet LAN Adapter Support Windows Server/Windows/Linux/VMware ESX
Limited time offer, ends 10/25
- Brand: H!Fiber.com
- Part Number: B08FBBX8MX_CANARF
- Speed: 100 megabits_per_second
- Features: Desktop
- Model #: B08FBBX8MX1
- $138.99 –
- Free Shipping

Quick View
Netgear AV Line M4350-24M4X4V 28-Port Managed Switch, Multi-Gigabit Ethernet up to 25G
- Brand: NETGEAR
- Part Number: MSM4332-100NES
- Format: Rack-mountable
- Standards: 2.5GBase-T, 1000Base-T, 5GBase-T, 10GBase-T, 10GBase-X, 25GBase-X
- Model #: MSM4332-100NES
- $5,908.95 –
- $13.87 Shipping

Quick View
Netgear AV Line M4350-8X8F 8-Port Manageable 10 Gigabit Ethernet Switch, XSM4316-100NES
- Brand: NETGEAR
- Part Number: XSM4316100NES
- Network Management Type: Managed
- Primary Ports: 8 x RJ45 + 8 x SFP+
- Model #: XSM4316-100NES
- $2,199.99 –
- Free Shipping

Quick View
HPE Networking 10G LR SFP+ LC 10km SMF C-Class Transceiver - For Data Networking, Optical Network - 1 x LC 10GBase-LR Network - Optical Fiber - Single-mode - 10 Gigabit Ethernet - 10GBase-LR10 km Maxi
- Compatible Brand: HPE
- Model #: S2P31A
- $1,928.99 –
- More options from $1,928.99 - $2,752.58
- Free Shipping

Quick View
Vszerda 10Gb RJ45 PCI-E Network Card NIC, Compare to Intel X540-T1, with Intel X540-BT2 Chip, Single RJ45 Ports, PCI Express X8, Ethernet Converged Network Adapter Support Windows/Linux/VMware
Limited time offer, ends 10/25
- Brand: H!Fiber.com
- Part Number: X540-10G-1T-X8
- Speed: 10 gigabytes_per_second
- Features: Desktop
- Model #: X540-10G-1T-X81
- $98.99 –
- Free Shipping

Quick View
X540-T2 10G Dual RJ45 Port PCI-E Ethernet Network Adapter For Chipset X540
- Brand: Intel
- Model: X540-T2
- Part Number: X540-T2
- Standards: IEEE 802.3 – Original Ethernet standard (10 Mbps) IEEE 802.3u – Fast Ethernet (100 Mbps) IEEE 802.3ab – Gigabit Ethernet over copper (1000BASE-T) IEEE 802.3an – 10 Gigabit Ethernet over copper (10GBASE-T) IEEE 802.3x – Flow control (full-duplex) IEEE 802.3ad – Link aggregation / LACP (teaming multiple ports) IEEE 802.1Q – VLAN tagging IEEE 802.1p – Quality
- Model #: ZZL-RNU-ASD1461850
- $87.99 –
- Free Shipping

Quick View
ZyXEL 12-Port Multi-Gigabit Ethernet Web Managed Switch, XGS125012
- Brand: ZyXEL
- Part Number: XGS125012
- Switch Type: Manageable
- Network Media: Network Technology: 10GBase-X 10GBase-T 10/ 100/1000Base-T Media Type Supported: Twisted Pair Optical Fiber
- Model #: RNAB08TC3VJ61
- $359.99 –
- Free Shipping

Quick View
Extreme Networks Inc. SFP+ Transceiver Module - 10 Gigabit Ethernet
- Wavelength: 850nm
- Fiber Cable: Multi-Mode Fiber (MMF)
- Ports: LC
- Max Distance: 300M
- Model #: 10301
- $1,165.99
- $1,031.99 –
- Save: $134.00 (11%)
- Free Shipping

Quick View
Cisco Catalyst C9200CX-8P-2X2G Ethernet Switch - 8 Ports - Manageable - 10 Gigabit Ethernet - 1000Base-T, 10GBase-X - 3 Layer Supported - Modular - 240 W PoE Budget - C9200CX-8P-2X2G-E
- Brand: CISCO
- Part Number: C9200CX-8P-2X2G-E
- Switch Type: Managed
- Format: Rack-mountable, DIN Rail Mountable, Wall Mountable, Compact
- Model #: C9200CX-8P-2X2G-E
- $2,375.99 –
- More options from $1,919.82 - $3,210.63

Quick View
Netgear ProSafe GS752TP 48-Port Manageable Gigabit Ethernet Switch, GS752TP-300NAS
- Brand: NETGEAR
- Part Number: GS752TP-300NAS
- Network Management Type: Smart
- Primary Ports: 48 x RJ45 + 4 x SFP
- Model #: GS752TP-300NAS
- $679.99 –
- Free Shipping

Quick View
10 Gigabit M.2 M Key Ethernet Network Expansion Card
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
- Connectors: 1 x RJ45
- Model #: SY-PEX24087
- $159.99 –
- More options from $159.99 - $173.46
- Free Shipping










