Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
Quick View
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
  • Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper with 16-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatib...
  • Model #: GS-4210-16P4C
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
  • Brand: PLANET
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGSW-24040R
Planet GS-4210-16UP4C 16-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
Quick View
Planet GS-4210-16UP4C 16-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper ports with 6-Port IEEE 802.3at / af / Ultra PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatible with 100BASE-FX SFP...
  • Model #: GS-4210-16UP4C
SonicWall NSa 4800 Network Security/Firewall - Centralized Management - 24 Port - 10 Gigabit Ethernet - 3000 VPN - 24x RJ-45 - 8 Total Expansion Slots - 50 Hz, 60 Hz - 1U - Rack-mountable  03-SSC-1845
Quick View
  • $9,020.00
  •  
  • $7,216.00 –
  • Save: $1,804.00 (20%)
  • Free Shipping
Ubiquiti Networks - sunMAX SolarPoint (SM-SP-40)
Quick View
Ubiquiti Networks - sunMAX SolarPoint (SM-SP-40)
  • Primary Ports: (4) 10/100 MbE fast ports
  • PoE: Yes
  • Power: Power method PV panel (H4 connectors) Max. power consumption 2W Supported voltage range 10–60V (Reverse protection, surge protection) Max. open circuit voltage: 60V
  • Dimensions: 202 x 190 x 50 mm (8 x 7.5 x 2")
  • Model #: SM-SP-40
  •  
  • $199.00 –
  • Free Shipping
yealink w70b - dect ip base station
Quick View
yealink w70b - dect ip base station
  • Brand: Yealink
  • Part Number: 1302017
  • Type: Telephone
  • Dimensions: 2.51 L x 10 W x 13 H centimeters
  • Model #: RNAB09BFXNK65
TRENDnet Hardened Industrial SFP to Gigabit UPoE Media Converter, IP30 Rated Housing, Includes DIN-rail & Wall Mounts, Operating Temp. -40 to 75 °C (-40 to 167 °F), TI-UF11SFP
Quick View
TRENDnet Hardened Industrial SFP to Gigabit UPoE Media Converter, IP30 Rated Housing, Includes DIN-rail & Wall Mounts, Operating Temp. -40 to 75 °C (-40 to 167 °F), TI-UF11SFP
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af IEEE 802.3at IEEE 802.3bt draft
  • Primary Ports: 1 x Gigabit UPoE port 1 x 100/1000Mbps SFP slot
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
  • Model #: TI-UF11SFP (V1.0R)
Viking - E-20-IP-EWP - VoIP Speaker Phone with Push Button UV Stable Light Gray Plastic Surface Mount Only with Enhanced
Quick View
  • $435.56
  •  
  • $433.51 –
  • $430.11 - $433.51
TRENDnet TPE-TG82ES (V1.0R) 8-Port Gigabit EdgeSmart PoE+ Switch
Quick View
TRENDnet TPE-TG82ES (V1.0R) 8-Port Gigabit EdgeSmart PoE+ Switch
  • Standards: IEEE 802.1d IEEE 802.1w IEEE 802.1p IEEE 802.1Q IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3ad IEEE 802.3af IEEE 802.3at IEEE 802.3az
  • Primary Ports: 8 x Gigabit PoE+ ports
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit Ethernet: 2000 Mbps (full duplex)
  • MAC Address Table: 4K
  • Model #: TPE-TG82ES (V1.0R)
TRENDnet TPE-TG160G 16-Port Gigabit PoE+ Switch
Quick View
TRENDnet TPE-TG160G 16-Port Gigabit PoE+ Switch
  • Brand: TRENDnet
  • Format: Rackmount
  • Standards: IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3af (15.4 Watts / port) IEEE 802.3at (30 Watts / port) IEEE 802.3az
  • Primary Ports: 16 x Gigabit PoE/PoE+ ports
  • Model #: TPE-TG160G
  •  
  • $417.99 –
HP A-MSR30-20 Multi-Service Router
Quick View
HP
HP A-MSR30-20 Multi-Service Router
  • Protocols: HCRP, SPP
  • Brand: HP
  • Speed: 10/100/1000Base-T
  • Model #: JF284A
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
  • Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
  • Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
  • Model #: WGSW-24040
Cisco Catalyst 1300 C1300-24XS Layer 3 Switch, Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-X, 1000Base-T - 3 Layer Supported
Quick View
Cisco Catalyst 1300 C1300-24XS Layer 3 Switch, Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-X, 1000Base-T - 3 Layer Supported
  • Part Number: C1300-24XS
  • Format: Rackmount
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1ab
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10GBase-X 1000Base-T Maximum Data Transfer Rate: 1.25 GB/s
  • Model #: C1300-24XS
Fortinet FortiGate FG-100F Security Firewall Appliance w/ FortiCare Premium and FortiGuard Unified Threat Protection (UTP), 1-Y | FG-100F-BDL-950-12
Quick View
Fortinet FortiGate FG-100F Security Firewall Appliance w/ FortiCare Premium and FortiGuard Unified Threat Protection (UTP), 1-Y | FG-100F-BDL-950-12
  • Brand: Fortinet
  • Series: FortiGate 100F Series
  • Part Number: FG-100F-BDL-950-12
  • Form Factor: Rack Mountable
  • Model #: FG-100F-BDL-950-12
  •  
  • $4,497.99 –
  • Free Shipping
Ubiquiti Networks EdgeSwitch 8 Ports 150W Ethernet Switch ES-8-150W
Quick View
  •  
  • $589.00 –
  • Free Shipping
Mikrotik CRS326-24S+2Q+RM 2 x 40 Gbps QSFP+ ports and 24 x 10 Gbps SFP+ ports
Quick View
  •  
  • $899.99 –
  • Free Shipping
Ubiquiti UniFi WAN Switch RJ45 (USW-WAN-RJ45)
Quick View
Ubiquiti 10G CWDM SM Opt Module - UACC-OM-SFP10-1590
Quick View
Ubiquiti 10G CWDM SM Opt Module - UACC-OM-SFP10-1590
  • Brand: Ubiquiti
  • Part Number: UACC-OM-SFP10-1590
  • Wavelength: 1590 nm; 1340 nm; 1620 nm
  • Parts: 1 Year
  • Model #: UACC-OM-SFP10-1590
  • $149.00
  •  
  • $137.99 –
  • Save: $11.01 (7%)
  • $17.76 Shipping
HP Ethernet 10Gb 2-Port 561FLR-T FIO Adapter
Quick View
HP
HP Ethernet 10Gb 2-Port 561FLR-T FIO Adapter
  • Weight: 20
  • Parts: 30 days warranty
  • Labor: 30 days warranty
  • Model #: 700700-B21
  •  
  • $49.99 –
  • Free Shipping
D-Link SmartPro DGS-1510-20 Ethernet Switch
Quick View
D-Link SmartPro DGS-1510-20 Ethernet Switch
  • Format: Stackable
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet 802.3ae 10 GbE IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
  • Primary Ports: 16 x 10/100/1000 Mbps 2 x Gigabit SFP 2 x 10G SFP+
  • MAC Address Table: 16K
  • Model #: DGS-1510-20
  •  
  • $317.55 –
QLogic QLE4062C-CK 8Gbps PCI Express x4 2.50 GHz iSCSI Host Bus Adapter
Quick View
QLogic QLE4062C-CK 8Gbps PCI Express x4 2.50 GHz iSCSI Host Bus Adapter
  • Connectors: 2 x RJ-45 iSCSI
  • Temperature: 32°F (0°C) to 131°F (55°C) Operating -4°F (-20°C) to 158°F (70°C) Storage
  • Humidity: 10 % ~ 90 % (Non-condensing)
  • Weight: 20
  • Model #: QLE4062C-CK
D-Link DEM-410CX 1-Port 10GBase-CX4 Module for DGS-3600 Series
Quick View
D-Link DEM-410CX 1-Port 10GBase-CX4 Module for DGS-3600 Series
  • Specifications: Data Rate and Operation : 20 Gigabits per Second (Full-duplex) Diagnostic LEDs : Link , Activity Dimensions (WxDxH) : 2.2in x 5.9in x 1.1in (55.9mm x 149.9mm x 27.9mm) Weight : 0.4 lbs (0.18kg) Emissions : FCC Class A , CE , C-Tick No Extra Transceivers Needed Ideal Solution for Stacking Switches in Short Distances within Wiring Closets (15m-20m) Low-Latency 10-Gigabit Network Connection Utilizing a Twin-Axial Copper Cable
  • Parts: 1 year limited
  • Labor: 1 year limited
  • Model #: DEM-410CX
  •  
  • $241.90 –
  • Free Shipping