Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
  • Brand: PLANET
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGSW-24040R
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
  • Format: DIN-rail and Wall-mount Ear
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-4215-4P4T
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-8P2S2X
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: 19-inch Rack-mountable Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-16T4S
Ubiquiti G2 Touch Max (UTP-TouchMax)
Quick View
Ubiquiti G2 Touch Max (UTP-TouchMax)
  • Brand: Ubiquiti Networks
  • Part Number: UTP-TouchMax
  • Type: VoIP Phones
  • Display: Screen Surface Treatments: Fingerprint-Resistant Coating Size: 178 mm (7") diagonal Resolution: 1280 x 800 HD
  • Model #: UTP-TOUCHMAX-U
  •  
  • $313.99 –
  • Free Shipping
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
Quick View
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Flow Control
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX SFP interface
  • MAC Address Table: 2K
  • Switching Method: Store and Forward
  • Model #: ISW-621TF
  •  
  • $96.99 –
  • Free Shipping
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-501T
  •  
  • $114.99 –
  • Free Shipping
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-801T
  •  
  • $160.99 –
  • Free Shipping
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
Quick View
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x full-duplex Flow Control
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX interface on
  • MAC Address Table: 2K
  • Model #: ISW-621TS15
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-801T
  •  
  • $657.00 –
  • Free Shipping
Intellinet 560993 16-Port Gigabit Ethernet PoE+ Switch
Quick View
Intellinet 560993 16-Port Gigabit Ethernet PoE+ Switch
  • Brand: Intellinet
  • Format: Rackmount
  • Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3ab (Twisted Pair Gigabit Ethernet) IEEE 802.3af (Power over Ethernet 802.3at Type 1) IEEE 802.3at (Power over Ethernet 802.3at Type 2) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3x (flow control, for full duplex mode)
  • Primary Ports: 16 x PoE ports
  • Model #: 560993
D-Link SmartPro DGS-1510-20 Ethernet Switch
Quick View
D-Link SmartPro DGS-1510-20 Ethernet Switch
  • Format: Stackable
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet 802.3ae 10 GbE IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
  • Primary Ports: 16 x 10/100/1000 Mbps 2 x Gigabit SFP 2 x 10G SFP+
  • MAC Address Table: 16K
  • Model #: DGS-1510-20
  •  
  • $320.34 –
d-link 2rj6268 websmart dgs-1210-28 ethernet switch
Quick View
  •  
  • $216.32 –
  • Free Shipping
D-Link DXS-1210-10TS 10-Port 10 Gigabit WebSmart Switch with 8 10GBase-T Ports and 2 SFP+ ports
Quick View
D-Link DXS-1210-10TS 10-Port 10 Gigabit WebSmart Switch with 8 10GBase-T Ports and 2 SFP+ ports
  • Standards: IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3az compliance IEEE 802.3an 10GBASE-T 10GbE over copper IEEE 802.3ae 10GbE over fiber IEEE 802.3z 1000BASE-X Auto MDI/MDIX support for 1000/10GBASE-T
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10 Gbps
  • MAC Address Table: 16K
  • Model #: DXS-1210-10TS
  •  
  • $1,344.90 –
  • Free Shipping
D-Link DES-3852 Managed Layer 3 Switch
Quick View
D-Link DES-3852 Managed Layer 3 Switch
  • Brand: D-Link
  • Standards: IEEE 802.3 Ethernet, 802.3u Fast Ethernet, 802.3ab Gigabit Ethernet, 802.3z Gigabit Ethernet, 802.1d Spanning Tree, 802.1w Rapid Spanning Tree, 802.1p Priority Tags, 802.1q VLANs (4K static/ 255 dynamic), 802.3ad Link Aggregation (32 Groups/8 ports), 802.3x Flow Control, 802.1x Port-based /MAC based Authentication, 802.1s (Multiple Spanning Tree)
  • Primary Ports: 48 10/100 Mbps Ports, 2 Combo SFP/1000BASE-T Ports, & 2 Built-in 1000BASE-T Uplinks
  • Primary Port Speed: 10/100Mbps + 1000Mbps
  • Model #: DES-3852
  •  
  • $1,508.90 –
  • Free Shipping
NETIS PE6108G Unmanaged 8-Port Gigabit Switch with 8 PoE Port 120W IEEE802.3af/at
Quick View
NETIS PE6108G Unmanaged 8-Port Gigabit Switch with 8 PoE Port 120W IEEE802.3af/at
  • Format: Desktop
  • Standards: IEEE 802.3u 1000Base-TX, IEEE 802.3u 100BASE -TX, IEEE 802.3 10BASE -T, IEEE 802.3at, IEEE 802.3x Flow Contro
  • Primary Ports: 8 10/100/1000Mbps RJ45 port, with PoE function
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: PE6108G
  •  
  • $49.98 –
  • Free Shipping
Direct from Netis Systems Direct from Netis Systems
  • $48.00 - $49.98
NETIS ST3116G Unmanaged 16 Port Gigabit Ethernet Rackmount Switch
Quick View
NETIS ST3116G Unmanaged 16 Port Gigabit Ethernet Rackmount Switch
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T, IEEE 802.3u 100Base-TX, IEEE802.3ab 1000BASE-T , IEEE 802.3x Flow Control, IEEE 802.3az
  • Uplink Ports: None
  • Primary Ports: 16 x RJ45
  • Model #: ST3116G
  •  
  • $58.88 –
  • Free Shipping
Direct from Netis Systems Direct from Netis Systems
  • $50.00 - $58.88
NETIS ST3124P Unmanaged 24 Port Fast Ethernet Desktop Plastic Switch
Quick View
NETIS ST3124P Unmanaged 24 Port Fast Ethernet Desktop Plastic Switch
  • Format: Desktop
  • Standards: IEEE 802.3 10Base-T, IEEE 802.3u 100Base-TX, IEEE 802.3x Flow Control, IEEE 802.3az
  • Primary Ports: 24 x 10/100 Mbps RJ45 port, Auto-Negotiation, Auto MDI / MDIX
  • Primary Port Speed: 10/100Mbps
  • Model #: ST3124P
  •  
  • $28.88 –
  • Free Shipping
Direct from Netis Systems Direct from Netis Systems
  • $27.00 - $28.88
NETIS ST3105S Unmanaged 5 Port Fast Ethernet Desktop Plastic Switch
Quick View
NETIS ST3105S Unmanaged 5 Port Fast Ethernet Desktop Plastic Switch
  • Brand: NETIS
  • Format: Desktop
  • Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x
  • Network Management Type: Unmanaged
  • Model #: ST3105S
  •  
  • $12.99 –
  • Free Shipping
Available Direct from Netis Systems Available Direct from Netis Systems
  • $6.00 - $12.99
NETIS ST3116P Unmanaged 16 Port Fast Ethernet Plastic Desktop Switch
Quick View
NETIS ST3116P Unmanaged 16 Port Fast Ethernet Plastic Desktop Switch
  • Format: Desktop
  • Standards: IEEE 802.3 10Base-T, IEEE 802.3u 100Base-TX, IEEE 802.3x Flow Control, IEEE 802.3az
  • Primary Ports: 16 x 10/100 Mbps RJ45 port, Auto-Negotiation, Auto MDI / MDIX
  • MAC Address Table: 8K
  • Model #: ST3116P
  •  
  • $24.99 –
  • $7.99 Shipping
Direct from Netis Systems Direct from Netis Systems
  • $24.00 - $24.99
Netis ST3116GS 8 Port 16 Port Unmanaged 10/100/1000M Gigabit Ethernet Rackmount Switch | Plug-and-Play and Effective Power Saving Technology Support Auto MDI/MDIX Function
Quick View
Netis ST3116GS 8 Port 16 Port Unmanaged 10/100/1000M Gigabit Ethernet Rackmount Switch | Plug-and-Play and Effective Power Saving Technology Support Auto MDI/MDIX Function
  • Format: Rackmount
  • Uplink Interface: RJ45
  • Primary Ports: 16 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: ST3116GS
Direct from Netis Systems Direct from Netis Systems
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
Quick View
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-804HPT
Ubiquiti Networks US-48-US Managed Gigabit Switches with SFP
Quick View
Ubiquiti Networks US-48-US Managed Gigabit Switches with SFP
  • Format: Rail-mountable
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Primary Port Type: 48 x 10/100/1000 Mbps RJ45 Ethernet Ports 2 x 1/10 Gbps SFP+ Ethernet Ports 2 x 1 Gbps SFP Ethernet Ports 1 x RJ45 Serial Port Out-of-Band, Ethernet In-Band
  • Model #: US-48
  •  
  • $879.01 –
  • Free Shipping
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
Quick View
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
  • Format: Rail-mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-duplex flow control
  • Primary Ports: 8x 10/100/1000Base-T Ports
  • Primary Port Speed: 10/100/1000Base-T
  • Model #: IGS-801T
  •  
  • $164.00 –
  • Free Shipping
PLANET IVC-234GT Unmanaged Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
Quick View
PLANET IVC-234GT Unmanaged Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet ITU-T G.993.1 VDSL ITU-T G.997.1 ITU-T G.993.2 VDSL2 (Profile 17a/30a Support) ITU-T G.993.5 G.Vectoring and G.INP ITU-T G.998
  • Primary Ports: 4 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IVC-234GT
Planet MGSW-28240F 24-Port 100/1000BASE-X SFP with 4-Port 10G SFP+ L2/L4 Managed Metro Ethernet Switch
Quick View
Planet MGSW-28240F 24-Port 100/1000BASE-X SFP with 4-Port 10G SFP+ L2/L4 Managed Metro Ethernet Switch
  • Primary Ports: 24 1000Base-SX/LX/BX SFP interfaces, (Compatible with 100Base-FX SFP Transceiver), 4 1/10GBase-SR/LR SFP+ slots, 4 10/ 100/1000Base-T TP/SFP combo ports
  • MAC Address Table: 16K entries, automatic source address learning and ageing
  • Switching Method: Store and Forward
  • VLAN Support: Yes
  • Model #: MGSW-28240F
Juniper Networks EX2300 Switch, 24-port 10/100/1000BASE-T, 4 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-24T
Quick View
Juniper Networks EX2300 Switch, 24-port 10/100/1000BASE-T, 4 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-24T
  • Brand: Juniper Networks, Inc.
  • Format: Desktop
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45
  • Model #: EX2300-24T
D-Link DIS-100G-5W 5-Port Unmanaged Industrial Switch, -40 Degree C to +75 Degree C
Quick View
D-Link DIS-100G-5W 5-Port Unmanaged Industrial Switch, -40 Degree C to +75 Degree C
  • Standards: IEEE 802.3 for Ethernet IEEE 802.3u for Fast Ethernet IEEE 802.3ab for Gigabit Ethernet IEEE 802.3z for Gigabit fiber IEEE 802.3x Flow Control IEEE 802.3af/at Power over Ethernet (DIS-100G-5PSW) IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 2K
  • Model #: DIS-100G-5W
  •  
  • $207.90 –
  • Free Shipping
HPE Juniper Networking EX2300 Switch, 24-port 10/100/1000BASE-T with internal DC PSU, 4 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-24T-DC
Quick View
HPE Juniper Networking EX2300 Switch, 24-port 10/100/1000BASE-T with internal DC PSU, 4 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-24T-DC
  • Brand: Juniper Networks, Inc.
  • Series: EX2300
  • Part Number: EX2300-24T-DC
  • Format: Desktop
  • Model #: EX2300-24T-DC
Juniper Networks EX4100 Switch, 48-port 10/100/1000BASE-T PoE+ switch, 4x1GbE/10GbE SFP/SFP + uplinks, 4x10GbE stacking/uplink ports | EX4100-F-48P
Quick View
Juniper Networks EX4100 Switch, 48-port 10/100/1000BASE-T PoE+ switch, 4x1GbE/10GbE SFP/SFP + uplinks, 4x10GbE stacking/uplink ports | EX4100-F-48P
  • Brand: Juniper Networks, Inc.
  • Series: EX4100-F
  • Part Number: EX4100-F-48P
  • Format: Desktop
  • Model #: EX4100-F-48P
Planet SGS-6340-24P4S Layer 3 24-Port 10/100/1000T 802.3at PoE + 4-Port 1000X SFP Stackable Managed Switch (370W)
Quick View
Planet SGS-6340-24P4S Layer 3 24-Port 10/100/1000T 802.3at PoE + 4-Port 1000X SFP Stackable Managed Switch (370W)
  • Format: Rackmount
  • Uplink Ports: 4
  • Uplink Interface: SFP & RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: SGS-6340-24P4S
  •  
  • $775.00 –
  • Free Shipping
Intellinet 5-Port Gigabit Ethernet PoE+ Switch, Four PSE PoE+ Gigabit Ports, One Gigabit Port, PoE Power Budget of 40 W, IEEE 802.3at/af Compliant, Desktop, Wall-mount Option
Quick View
Intellinet 5-Port Gigabit Ethernet PoE+ Switch, Four PSE PoE+ Gigabit Ports, One Gigabit Port, PoE Power Budget of 40 W, IEEE 802.3at/af Compliant, Desktop, Wall-mount Option
  • Brand: Intellinet Network Solutions
  • Format: Desktop
  • Network Management Type: Unmanaged
  • Primary Ports: 5 x RJ45
  • Model #: 561792
  •  
  • $104.00 –
  • $8.00 Shipping
TE122P 1 Port T1 E1 J1 Card + PCI interface +  Echo Cancellation Port,TE122,TE110,TE110P
Quick View
TE122P 1 Port T1 E1 J1 Card + PCI interface + Echo Cancellation Port,TE122,TE110,TE110P

Limited time offer, ends 10/10

  • Brand: TE122
  • Type: Wired VoIP
  • Standards: Bus Type: PCI
  • Protocols: Echo Cancellation: Additional Payment
  • Model #: ST TE122P
Juniper EX4650 48x25GbE+8x100GbE Ethernet Switch
Quick View
Juniper EX4650 48x25GbE+8x100GbE Ethernet Switch
  • Switch Type: Chassis
  • Standards: IEEE 802.1Qaz
  • Uplink Interface: SFP
  • Switching Method: Store and Forward
  • Model #: EX4650-48Y-AFO
PLANET GS-5220-48PL4X Managed L2+ 48-Port 10/100/1000T 802.3at PoE + 4-Port 10G SFP+ Managed Switch
Quick View
PLANET GS-5220-48PL4X Managed L2+ 48-Port 10/100/1000T 802.3at PoE + 4-Port 10G SFP+ Managed Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 48-Port 10/100/1000T 802.3at PoE 4-Port 10G SFP+
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 16K
  • Model #: GS-5220-48PL4X
  •  
  • $1,376.00 –
  • $14.00 Shipping