Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
D-Link DES-3852 Managed Layer 3 Switch
Quick View
D-Link DES-3852 Managed Layer 3 Switch
  • Brand: D-Link
  • Standards: IEEE 802.3 Ethernet, 802.3u Fast Ethernet, 802.3ab Gigabit Ethernet, 802.3z Gigabit Ethernet, 802.1d Spanning Tree, 802.1w Rapid Spanning Tree, 802.1p Priority Tags, 802.1q VLANs (4K static/ 255 dynamic), 802.3ad Link Aggregation (32 Groups/8 ports), 802.3x Flow Control, 802.1x Port-based /MAC based Authentication, 802.1s (Multiple Spanning Tree)
  • Primary Ports: 48 10/100 Mbps Ports, 2 Combo SFP/1000BASE-T Ports, & 2 Built-in 1000BASE-T Uplinks
  • Primary Port Speed: 10/100Mbps + 1000Mbps
  • Model #: DES-3852
  •  
  • $1,508.90 –
  • Free Shipping
NETIS PE6108G Unmanaged 8-Port Gigabit Switch with 8 PoE Port 120W IEEE802.3af/at
Quick View
NETIS PE6108G Unmanaged 8-Port Gigabit Switch with 8 PoE Port 120W IEEE802.3af/at
  • Format: Desktop
  • Standards: IEEE 802.3u 1000Base-TX, IEEE 802.3u 100BASE -TX, IEEE 802.3 10BASE -T, IEEE 802.3at, IEEE 802.3x Flow Contro
  • Primary Ports: 8 10/100/1000Mbps RJ45 port, with PoE function
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: PE6108G
  •  
  • $49.98 –
  • Free Shipping
Direct from Netis Systems Direct from Netis Systems
  • $48.00 - $49.98
NETIS ST3116G Unmanaged 16 Port Gigabit Ethernet Rackmount Switch
Quick View
NETIS ST3116G Unmanaged 16 Port Gigabit Ethernet Rackmount Switch
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T, IEEE 802.3u 100Base-TX, IEEE802.3ab 1000BASE-T , IEEE 802.3x Flow Control, IEEE 802.3az
  • Uplink Ports: None
  • Primary Ports: 16 x RJ45
  • Model #: ST3116G
  •  
  • $58.88 –
  • Free Shipping
Direct from Netis Systems Direct from Netis Systems
  • $50.00 - $58.88
NETIS ST3124P Unmanaged 24 Port Fast Ethernet Desktop Plastic Switch
Quick View
NETIS ST3124P Unmanaged 24 Port Fast Ethernet Desktop Plastic Switch
  • Format: Desktop
  • Standards: IEEE 802.3 10Base-T, IEEE 802.3u 100Base-TX, IEEE 802.3x Flow Control, IEEE 802.3az
  • Primary Ports: 24 x 10/100 Mbps RJ45 port, Auto-Negotiation, Auto MDI / MDIX
  • Primary Port Speed: 10/100Mbps
  • Model #: ST3124P
  •  
  • $28.88 –
  • Free Shipping
Direct from Netis Systems Direct from Netis Systems
  • $27.00 - $28.88
NETIS ST3105S Unmanaged 5 Port Fast Ethernet Desktop Plastic Switch
Quick View
NETIS ST3105S Unmanaged 5 Port Fast Ethernet Desktop Plastic Switch
  • Brand: NETIS
  • Format: Desktop
  • Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x
  • Network Management Type: Unmanaged
  • Model #: ST3105S
  •  
  • $12.99 –
  • Free Shipping
Available Direct from Netis Systems Available Direct from Netis Systems
  • $6.00 - $12.99
NETIS ST3116P Unmanaged 16 Port Fast Ethernet Plastic Desktop Switch
Quick View
NETIS ST3116P Unmanaged 16 Port Fast Ethernet Plastic Desktop Switch
  • Format: Desktop
  • Standards: IEEE 802.3 10Base-T, IEEE 802.3u 100Base-TX, IEEE 802.3x Flow Control, IEEE 802.3az
  • Primary Ports: 16 x 10/100 Mbps RJ45 port, Auto-Negotiation, Auto MDI / MDIX
  • MAC Address Table: 8K
  • Model #: ST3116P
  •  
  • $24.99 –
  • $7.99 Shipping
Direct from Netis Systems Direct from Netis Systems
  • $24.00 - $24.99
Netis ST3116GS 8 Port 16 Port Unmanaged 10/100/1000M Gigabit Ethernet Rackmount Switch | Plug-and-Play and Effective Power Saving Technology Support Auto MDI/MDIX Function
Quick View
Netis ST3116GS 8 Port 16 Port Unmanaged 10/100/1000M Gigabit Ethernet Rackmount Switch | Plug-and-Play and Effective Power Saving Technology Support Auto MDI/MDIX Function
  • Format: Rackmount
  • Uplink Interface: RJ45
  • Primary Ports: 16 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: ST3116GS
Direct from Netis Systems Direct from Netis Systems
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
Quick View
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-804HPT
Ubiquiti Networks US-48-US Managed Gigabit Switches with SFP
Quick View
Ubiquiti Networks US-48-US Managed Gigabit Switches with SFP
  • Format: Rail-mountable
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Primary Port Type: 48 x 10/100/1000 Mbps RJ45 Ethernet Ports 2 x 1/10 Gbps SFP+ Ethernet Ports 2 x 1 Gbps SFP Ethernet Ports 1 x RJ45 Serial Port Out-of-Band, Ethernet In-Band
  • Model #: US-48
  •  
  • $879.01 –
  • Free Shipping
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
Quick View
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
  • Format: Rail-mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-duplex flow control
  • Primary Ports: 8x 10/100/1000Base-T Ports
  • Primary Port Speed: 10/100/1000Base-T
  • Model #: IGS-801T
  •  
  • $164.00 –
  • Free Shipping
D-Link 8-Port EasySmart Gigabit PoE Ethernet Switch - Lifetime Warranty (DGS-1100-08P)
Quick View
D-Link 8-Port EasySmart Gigabit PoE Ethernet Switch - Lifetime Warranty (DGS-1100-08P)
  • Brand: D-Link
  • Standards: IEEE 802.3/3u/3ab, IEEE 802.3af
  • Network Management Type: Smart
  • Primary Ports: 8 x RJ45
  • Model #: DGS-1100-08P
  •  
  • $122.23 –
  • Free Shipping
TP-Link TL-SL1311MP | 8 Port 10/100Mbps Fast Ethernet PoE Switch | 8 PoE+ Ports @124W, w/ 2 Uplink Gigabit Ports + 1 SFP Port | Limited Lifetime Protection | PoE Recovery | Extend & Isolation Mode
Quick View
TP-Link
TP-Link TL-SL1311MP | 8 Port 10/100Mbps Fast Ethernet PoE Switch | 8 PoE+ Ports @124W, w/ 2 Uplink Gigabit Ports + 1 SFP Port | Limited Lifetime Protection | PoE Recovery | Extend & Isolation Mode
  • Format: Desktop
  • Primary Ports: 8x 10/100 Mbps 802.3af/at PoE+ Ports, 2x Gigabit RJ45 Ports, 1x Gigabit SFP Port
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 2K
  • Model #: TL-SL1311MP
PLANET IVC-234GT Unmanaged Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
Quick View
PLANET IVC-234GT Unmanaged Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet ITU-T G.993.1 VDSL ITU-T G.997.1 ITU-T G.993.2 VDSL2 (Profile 17a/30a Support) ITU-T G.993.5 G.Vectoring and G.INP ITU-T G.998
  • Primary Ports: 4 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IVC-234GT
Planet MGSW-28240F 24-Port 100/1000BASE-X SFP with 4-Port 10G SFP+ L2/L4 Managed Metro Ethernet Switch
Quick View
Planet MGSW-28240F 24-Port 100/1000BASE-X SFP with 4-Port 10G SFP+ L2/L4 Managed Metro Ethernet Switch
  • Primary Ports: 24 1000Base-SX/LX/BX SFP interfaces, (Compatible with 100Base-FX SFP Transceiver), 4 1/10GBase-SR/LR SFP+ slots, 4 10/ 100/1000Base-T TP/SFP combo ports
  • MAC Address Table: 16K entries, automatic source address learning and ageing
  • Switching Method: Store and Forward
  • VLAN Support: Yes
  • Model #: MGSW-28240F
Juniper Networks EX2300 Switch, 24-port 10/100/1000BASE-T, 4 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-24T
Quick View
Juniper Networks EX2300 Switch, 24-port 10/100/1000BASE-T, 4 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-24T
  • Brand: Juniper Networks, Inc.
  • Format: Desktop
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45
  • Model #: EX2300-24T
D-Link DIS-100G-5W 5-Port Unmanaged Industrial Switch, -40 Degree C to +75 Degree C
Quick View
D-Link DIS-100G-5W 5-Port Unmanaged Industrial Switch, -40 Degree C to +75 Degree C
  • Standards: IEEE 802.3 for Ethernet IEEE 802.3u for Fast Ethernet IEEE 802.3ab for Gigabit Ethernet IEEE 802.3z for Gigabit fiber IEEE 802.3x Flow Control IEEE 802.3af/at Power over Ethernet (DIS-100G-5PSW) IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 2K
  • Model #: DIS-100G-5W
  •  
  • $207.90 –
  • Free Shipping
HPE Juniper Networking EX2300 Switch, 24-port 10/100/1000BASE-T with internal DC PSU, 4 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-24T-DC
Quick View
HPE Juniper Networking EX2300 Switch, 24-port 10/100/1000BASE-T with internal DC PSU, 4 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-24T-DC
  • Brand: Juniper Networks, Inc.
  • Series: EX2300
  • Part Number: EX2300-24T-DC
  • Format: Desktop
  • Model #: EX2300-24T-DC
Juniper Networks EX4100 Switch, 48-port 10/100/1000BASE-T PoE+ switch, 4x1GbE/10GbE SFP/SFP + uplinks, 4x10GbE stacking/uplink ports | EX4100-F-48P
Quick View
Juniper Networks EX4100 Switch, 48-port 10/100/1000BASE-T PoE+ switch, 4x1GbE/10GbE SFP/SFP + uplinks, 4x10GbE stacking/uplink ports | EX4100-F-48P
  • Brand: Juniper Networks, Inc.
  • Series: EX4100-F
  • Part Number: EX4100-F-48P
  • Format: Desktop
  • Model #: EX4100-F-48P
D-Link SmartPro DGS-1510-20 Ethernet Switch
Quick View
D-Link SmartPro DGS-1510-20 Ethernet Switch
  • Format: Stackable
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet 802.3ae 10 GbE IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
  • Primary Ports: 16 x 10/100/1000 Mbps 2 x Gigabit SFP 2 x 10G SFP+
  • MAC Address Table: 16K
  • Model #: DGS-1510-20
  •  
  • $323.48 –
Planet SGS-6340-24P4S Layer 3 24-Port 10/100/1000T 802.3at PoE + 4-Port 1000X SFP Stackable Managed Switch (370W)
Quick View
Planet SGS-6340-24P4S Layer 3 24-Port 10/100/1000T 802.3at PoE + 4-Port 1000X SFP Stackable Managed Switch (370W)
  • Format: Rackmount
  • Uplink Ports: 4
  • Uplink Interface: SFP & RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: SGS-6340-24P4S
  •  
  • $775.00 –
  • Free Shipping
Intellinet 5-Port Gigabit Ethernet PoE+ Switch, Four PSE PoE+ Gigabit Ports, One Gigabit Port, PoE Power Budget of 40 W, IEEE 802.3at/af Compliant, Desktop, Wall-mount Option
Quick View
Intellinet 5-Port Gigabit Ethernet PoE+ Switch, Four PSE PoE+ Gigabit Ports, One Gigabit Port, PoE Power Budget of 40 W, IEEE 802.3at/af Compliant, Desktop, Wall-mount Option
  • Brand: Intellinet Network Solutions
  • Format: Desktop
  • Network Management Type: Unmanaged
  • Primary Ports: 5 x RJ45
  • Model #: 561792
  •  
  • $104.00 –
  • $8.00 Shipping
Juniper EX4650 48x25GbE+8x100GbE Ethernet Switch
Quick View
Juniper EX4650 48x25GbE+8x100GbE Ethernet Switch
  • Switch Type: Chassis
  • Standards: IEEE 802.1Qaz
  • Uplink Interface: SFP
  • Switching Method: Store and Forward
  • Model #: EX4650-48Y-AFO
PLANET GS-5220-48PL4X Managed L2+ 48-Port 10/100/1000T 802.3at PoE + 4-Port 10G SFP+ Managed Switch
Quick View
PLANET GS-5220-48PL4X Managed L2+ 48-Port 10/100/1000T 802.3at PoE + 4-Port 10G SFP+ Managed Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 48-Port 10/100/1000T 802.3at PoE 4-Port 10G SFP+
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 16K
  • Model #: GS-5220-48PL4X
  •  
  • $1,376.00 –
  • $14.00 Shipping
Catalyst 1000 16Port Ge Full
Quick View
Catalyst 1000 16Port Ge Full
  • : 8.45
  • Model #: C100016FP2GL
  •  
  • $19,190.00 –
  • Free Shipping
TRENDnet TEG-S50G Unmanaged Gigabit GREENnet Switch
Quick View
Refurbished TRENDnet TEG-S50G Unmanaged Gigabit GREENnet Switch
  • Brand: TRENDnet
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Network Management Type: Unmanaged
  • Primary Ports: 5 x RJ45
  • Model #: TEG-S50G
  •  
  • $19.99 –
  • Free Shipping
LINKSYS EZXS55W-RM EtherFast 5-Port Workgroup Switch
Quick View
Refurbished LINKSYS EZXS55W-RM EtherFast 5-Port Workgroup Switch
  • Format: External
  • Standards: IEEE802.3, IEEE802.3u
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: EZXS55W-RM
  •  
  • $29.99 –
  • Free Shipping
D-Link DSS-16+/RE Unmanaged 16-Port Desktop/Rackmount Switch
Quick View
Refurbished D-Link DSS-16+/RE Unmanaged 16-Port Desktop/Rackmount Switch
  • Brand: D-Link
  • Format: Desktop/Rackmount
  • Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x, IEEE 802.3 Nway Auto-negotiation, IEEE 802.1p Qos Prioritization
  • Network Management Type: Unmanaged
  • Model #: DSS-16+/RE
  •  
  • $49.99 –
  • Free Shipping
Ubiquiti UniFi Switch Pro XG 24 (USW-Pro-XG-24)
Quick View
Ubiquiti UniFi Switch Pro XG 24 (USW-Pro-XG-24)

OUT OF STOCK

  • Model #: USW-Pro-XG-24
  •  
  • $1,163.00 –
  • Free Shipping
Netgear GS305E 5-Port Gigabit Ethernet SOHO Plus Easy Smart Managed Essentials Switch, GS305E-100NAS
Quick View
Netgear GS305E 5-Port Gigabit Ethernet SOHO Plus Easy Smart Managed Essentials Switch, GS305E-100NAS

OUT OF STOCK

  • Brand: NETGEAR
  • Part Number: GS305E-100NAS
  • Standards: IEEE 802.3 Ethernet IEEE 802.3ab 1000BASE-T IEEE 802.3u 100BASE-T IEEE 802.3ab 1000BASE-T IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.3x Full-duplex Flow Control
  • Network Management Type: Smart
  • Model #: GS305E-100NAS
  • $29.99
  •  
  • $24.99 –
  • Save: $5.00 (16%)
  • Free Shipping
Netgear ProSafe GS105 5-Port Gigabit Ethernet Unmanaged Switch, GS105NA
Quick View
Netgear ProSafe GS105 5-Port Gigabit Ethernet Unmanaged Switch, GS105NA

OUT OF STOCK

  • Brand: NETGEAR
  • Series: ProSafe
  • Standards: IEEE 802.3i 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3z 1000BASE-T Gigabit Ethernet
  • Network Management Type: Unmanaged
  • Model #: GS105NA
  • $39.99
  •  
  • $32.99 –
  • Save: $7.00 (17%)
  • Free Shipping
PLANET Technology - GS-4210-24T2S - Planet 24-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces - 24 Ports - Manageable - 4 Layer Supported - Modular - Twisted Pair, Optical Fiber - 1U
Quick View
PLANET Technology - GS-4210-24T2S - Planet 24-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces - 24 Ports - Manageable - 4 Layer Supported - Modular - Twisted Pair, Optical Fiber - 1U

OUT OF STOCK

  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
  • Primary Ports: 24-port 10/100/1000BASE-T Gigabit RJ45 copper 2 x 100/1000BASE-X mini-GBIC / SFP slots
  • MAC Address Table: 8K
  • Switching Method: Store and Forward
  • Model #: GS-4210-24T2S
  •  
  • $197.99 –
  • Free Shipping
TP-Link 5 Port Fast Ethernet 10/100Mbps PoE Switch | 4 PoE Ports @58W | Desktop | Plug & Play | Sturdy Metal w/ Shielded Ports | Fanless | Limited Lifetime Protection | Unmanaged (TL-SF1005P)
Quick View
NETGEAR 8-port, 5-speed Unmanaged Switch 10-Gigabit/Multi-Gigabit | XS508M
Quick View
NETGEAR 8-port, 5-speed Unmanaged Switch 10-Gigabit/Multi-Gigabit | XS508M

OUT OF STOCK

  • Brand: NETGEAR
  • Format: Rackmount / Desktop
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Full-Duplex Flow Control IEEE 802.1p Class of Service IEEE 802.3az Energy Efficient Ethernet IEEE 802.3an 10GBASE-T IEEE 802.3bz 5 Gbps and 2.5 Gbps Ethernet Over Copper Twisted Pair Cable IEEE 802.3ae 10-Gigabit Ethernet Over Fiber IEEE 802.3aq 10-Gigabit over Fiber (10GBASE-LRM) IEEE 802.3z Gigabit Ethernet 1000BASE-SX/LX
  • Network Management Type: Unmanaged
  • Model #: XS508M-100NAS
  •  
  • $629.99 –
  • Free Shipping
Intellinet 8-Port Gigabit Ethernet Switch, Desktop size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)
Quick View
Intellinet 8-Port Gigabit Ethernet Switch, Desktop size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)

OUT OF STOCK

  • Brand: Intellinet
  • Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3ab (Gigabit Ethernet) IEEE 802.3x (Flow Control and Backpressure)
  • Network Management Type: Unmanaged
  • Primary Ports: 8 x RJ45
  • Model #: 530347
  • $71.99
  •  
  • $58.18 –
  • Save: $13.81 (19%)
  • Free Shipping
PLANET WGS-5225-8P2SV Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
Quick View
PLANET WGS-5225-8P2SV Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen

OUT OF STOCK

  • Format: Wall Mountable
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Switching Method: Store and Forward
  • Model #: WGS-5225-8P2SV
  •  
  • $444.99 –
  • Free Shipping