Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now
SHOP BY Primary Ports

Quick View
PLANET FSD-1008HP Unmanaged 8-Port 10/100TX 802.3at PoE + 2-Port 10/100TX Desktop Switch (120 watts)
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
- Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port 10/100TX
- MAC Address Table: 8K
- Model #: FSD-1008HP
- $88.99 –
- Free Shipping

Quick View
Cisco Catalyst C1200-24FP-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Part Number: C1200-24FP-4G
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.11ac IEEE 802.1x IEEE 802.3az IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3ad IEEE 802.1Q IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af IEEE 802.3at
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Model #: C1200-24FP-4G
- $824.99 –
- More options from $824.99 - $949.15
- Free Shipping

Quick View
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3af Power over Ethernet
- Primary Ports: 4-port 10/100Base-TX RJ-45 with IEEE 802.3af PoE injector 1-port 100Base-FX SFP interface
- MAC Address Table: 2K
- Switching Method: Store and Forward
- Model #: ISW-514PTF
- $215.99 –
- Free Shipping

Quick View
Planet FGSD-1008HPS 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Switch
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 8 x 10/100BASE-TX RJ45 copper with PoE in-line supported 2 x 10/100/1000BASE-T RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots to share with Port-9 to Port-10
- MAC Address Table: 4K
- Switching Method: Store and Forward
- Model #: FGSD-1008HPS
- $236.00
- See price in cart
- Free Shipping

Quick View
TRENDnet 8-Port Industrial Unmanaged Fast Ethernet DIN-Rail Switch; TI-E80 8 x Fast Ethernet Ports; 1.6Gbps Switching Capacity;8 Port Network Fast Ethernet Switch;IP30 Metal Switch;Lifetime Protection
- Format: DIN Rail Mountable
- Primary Port Speed: 100Base-X
- Model #: TI-E80
- $90.99 –
- Free Shipping

Quick View
PLANET GS-4210-16P2S Managed 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3
- Primary Ports: 16 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 100/1000BASE-X mini-GBIC/SFP slots 1 x RJ45 console interface for switch basic management and setup
- MAC Address...
- Model #: GS-4210-16P2S
- $324.99 –
- More options from $324.99
- Free Shipping

Quick View
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
- Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper with 16-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatib...
- Model #: GS-4210-16P4C
- $458.00
- See price in cart
- Free Shipping

Quick View
Cisco Catalyst C1300-48T-4G Ethernet Switch, 54 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-48T-4G
- Format: Rack-mountable
- Model #: C1300-48T-4G
- $959.99 –
- More options from $959.99 - $1,083.82
- Free Shipping

Quick View
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T IEEE 802.3z 1000Base-SX/LX IEEE 802.3az Energy-Efficient Ethernet, IEEE 802.3x Flow Control, IEEE 802.1q VLAN Tagging, IEEE 802.1p QoS, IEEE 802.1x Port-Based Network Access Control, IEEE802.3ad Link Aggregation, IEEE 802.1d Spanning Tree Protocol, IEEE 802.1w Rapid Spanning Tree Protocol
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IES101GP2SFW
- $451.99 –
- More options from $451.99 - $574.84
- Free Shipping

Quick View
Transition Networks Managed Hardened Gigabit Ethernet PoE++ Switch
- Format: Wall Mountable
- Primary Port Speed: 1000Base-X 10/100/1000Base-T
- Weight: 2.4
- Parts: 5 Year
- Model #: SISPM1040-582-LRT
- $888.80
- $880.49 –
- More options from $880.49 - $1,663.94
- Free Shipping

Quick View
PLANET IGS-620TF Industrial 4-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet / 10Base-T IEEE 802.3u Fast Ethernet / 100Base-TX IEEE 802.3ab Gigabit Ethernet / 1000Base-T IEEE 802.3z Gigabit Ethernet / 1000Base-SX/LX IEEE 802.3x Full-Duplex Flow Control
- Primary Ports: 4 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-620TF
- $198.00
- See price in cart
- Free Shipping

Quick View
Black Box Industrial (8) 10/100/1000 PoE + (2) Gigabit Ethernet Switch
- Format: Wall Mountable
- Primary Ports: Gigabit Ethernet 10 x Gigabit Ethernet Network
- Primary Port Speed: 10/100/1000Base-TX
- Stackable: Wall Mountable DIN Rail Mountable Panel-mountable
- Model #: LPH3100A
- $766.99 –
- More options from $766.99 - $845.63
- Free Shipping

Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T2S
- $245.99 –
- Free Shipping

Quick View
Fortinet FortiSwitch-148F-POE, Layer 2 FortiGate switch controller compatible PoE+ switch with 48 GE RJ45 + 4 10G SFP+ ports, 24 port PoE | FS-148F-POE
- Part Number: FS-148F-POE
- Format: 1 RU Rack Mount
- Primary Ports: 48x GE RJ45 and 4x 10GE SFP+
- VLAN Support: Yes
- Model #: FS-148F-POE
- $1,596.99 –
- Free Shipping

Quick View
Black Box LGB1126A-R2 Gigabit Managed Ethernet Switch - 26-Port
- Model #: LGB1126A-R2
- $527.99
- $481.99 –
- Save: $46.00 (8%)
- More options from $481.99 - $586.27
- Free Shipping

Quick View
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-8P4S
- $767.80
- See price in cart
- Free Shipping

Quick View
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-621T series 2 x port 100Base-FX interface on ISW-621T for up to 2km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-621T
- $132.00
- See price in cart
- Free Shipping

Quick View
D-Link 28-Port 10-Gigabit Smart Managed PoE Switch DGS125028XMP6KV
- Switch Type: managed
- Model #: DGS125028XMP6KV
- $529.99
- $482.01 –
- Save: $47.98 (9%)
- More options from $482.01 - $558.99
- Free Shipping

Quick View
Tripp Lite Industrial Gigabit Ethernet PoE injector - 60W PoE++ 802.3bt Midspan -40 to +75 IP30 housing - Dual 24-57VDC DIN rail - 1 Port 57 V DC - 1x RJ-45 Input - 1x RJ-45 Output - NPOEI-60W-1G
- Brand: Tripp Lite
- Model: NPOEI-60W-1G
- Part Number: NPOEI-60W-1G
- Switch Type: PoE Injector (Midspan)
- Model #: NPOEI60W1G
- $232.24 –
- More options from $197.86 - $266.99
- Free Shipping

Quick View
PLANET IGS-500T Unmanaged Compact Industrial 5-Port 10/100/1000T Gigabit Ethernet Switch
- Format: DIN Rail Mount
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet IEEE 802.1p Class of Service
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-500T
- $117.99 –
- Free Shipping

Quick View
TRENDnet 16-Port Gigabit PoE+ Switch, 16 x Gigabit PoE+ Ports, 246W PoE Power Budget, 32 Gbps Switching Capacity, Desktop Switch, Ethernet Network Switch, Metal, Lifetime Protection, Black, TPE-TG160g
- Brand: TRENDnet
- Standards: IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3af (15.4 Watts/port) IEEE 802.3at (30 Watts/port) IEEE 802.3a
- Uplink Ports: None
- Primary Ports: 16 x Gigabit PoE/PoE+ ports
- Model #: TPE-TG160g
- $259.99 –
- More options from $259.99 - $525.99
- Free Shipping

Quick View
NETGEAR 24-Port Multi-Gigabit (2.5G) Ethernet Ultra60 PoE++ Smart Switch with 4 SFP+ Ports | MS324TXUP
- Parts: 5 Year
- Model #: MS324TXUP-100NAS
- $1,679.99 –
- Free Shipping

Quick View
Planet ISW-800T IP30 Compact Size 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 degrees C)
- Model #: ISW-800T
- $97.99 –
- Free Shipping

Quick View
Transition Networks Unmanaged Hardened Gigabit Ethernet PoE+ Switch
- Format: DIN Rail Mountable Wall Mountable
- Primary Port Speed: 1000Base-X 10/100/1000Base-T
- Weight: 15.20 oz
- Parts: 5 Year
- Model #: SISTP1040-342-LRT
- $302.69 –
- More options from $302.69 - $334.17
- Free Shipping

Quick View
Planet GS-4210-16UP4C 16-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper ports with 6-Port IEEE 802.3at / af / Ultra PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatible with 100BASE-FX SFP...
- Model #: GS-4210-16UP4C
- $853.60
- See price in cart
- Free Shipping

Quick View
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511TS15 for up to 15km (single-mode fiber 9/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-511TS15
- $121.99 –
- Free Shipping

Quick View
Planet ISW-511T 4+1 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511T for up to 2 km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-511T
- $112.99 –
- Free Shipping

Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
- Brand: Cisco Systems, Inc.
- Series: Catalyst C1300 Series
- Part Number: C1300-24MGP-4X
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
- Model #: C1300-24MGP-4X
- $1,353.99 –
- More options from $1,353.99 - $1,588.43
- Free Shipping

Quick View
Ubiquiti Networks - sunMAX SolarPoint (SM-SP-40)
- Primary Ports: (4) 10/100 MbE fast ports
- PoE: Yes
- Power: Power method PV panel (H4 connectors) Max. power consumption 2W Supported voltage range 10–60V (Reverse protection, surge protection) Max. open circuit voltage: 60V
- Dimensions: 202 x 190 x 50 mm (8 x 7.5 x 2")
- Model #: SM-SP-40
- $199.00 –
- Free Shipping

Quick View
SONICWALL 02-SSC-2466 Switch 52 Ports - Manageable - 2 Layer Supported - Modular - 530 W Power Consumption - 740 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - 1U - Rack-mountable
- Format: Desktop
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- MAC Address Table: 32K
- Model #: 02-SSC-2466
- $1,466.99 –
- Free Shipping

Quick View
Planet ISW-500T IP30 Compact Size 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 degrees C)
- Format: DIN Rail Mount
- Model #: ISW-500T
- $91.99 –
- More options from $81.40 - $91.99
- Free Shipping

Quick View
HPE Aruba Networking CX 6100, 48-port PoE Switch, 4 SFP+ ports 370W | JL675A#ABA
- Brand: HPE
- Series: CX 6100
- Part Number: JL675A
- Primary Ports: 48 x RJ45 + 4 x SFP
- Model #: JL675A#ABA
- $3,602.99 –
- Free Shipping

Quick View
Extreme Networks 5320 24-port 30W PoE Switch, 8 x 1/10Gb SFP+ ports | 5320-24P-8XE
- Brand: Extreme Networks
- Series: 5320
- Standards: IEEE 802.3 Media Access Standards IEEE 802.3ab 1000BASE-T IEEE 802.3at PoE IEEE 802.3ae 10GBASE-X IEEE 802.3az Energy Efficient Ethernet
- Network Management Type: Managed
- Model #: 5320-24P-8XE
- $4,030.99 –
- Free Shipping

Quick View
Planet IGS-5225-8T2S2X Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 ~ 75 degrees C)
- Format: DIN Rail Mount
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Model #: IGS-5225-8T2S2X
- $887.80
- See price in cart
- Free Shipping




