Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Open Box Netgear GS108X 8-Port Gigabit Unmanaged Switch with 10 Gigabit SFP+ Uplink, GS108X-100NAS
- Brand: NETGEAR
- Part Number: GS108X-100NAS
- Network Management Type: Unmanaged
- Primary Ports: 8 x RJ45 + 1 x SFP+
- Model #: GS108X-100NAS
- $99.99
- $59.99 –
- Save: $40.00 (40%)
- $11.22 Shipping

Quick View
Refurbished HPE Networking Instant On Switch 8p Gigabit CL4 PoE 65W 1830 (JL811A#ABA)
- Brand: HPE Instant On
- Part Number: JL811A#ABA
- Network Management Type: Smart
- Primary Ports: 8 x RJ45
- Model #: JL811A#ABA
- $174.00 –
- Free Shipping

Quick View
Refurbished HPE Networking Instant On 8-Port Gigabit Managed Switch 1830 (JL810A#ABA)
- Brand: HPE Instant On
- Part Number: JL810A#ABA
- Network Management Type: Smart
- Primary Ports: 8 x RJ45
- Model #: JL810A#ABA
- $53.99 –
- Free Shipping

Quick View
Ubiquiti Ultra 60W 8-Port Layer 2 PoE Switch (USW-Ultra-60W (52W))
- Brand: Ubiquiti Networks
- Series: Network Switch
- Format: Desktop
- Network Management Type: Managed
- Model #: USW-ULTRA-60W
- $239.99 –
- More options from $171.00 - $241.92

Quick View
HP J4812A Managed ProCurve Switch 2512
- Brand: HP
- Format: Rackmount
- Standards: IEEE 802.3x Flow Control IEEE 802.1D Spanning Tree IEEE 802.3ad Link Aggregation Control Protocol IEEE 802.1X Network Login IEEE 802.1Q GVRP IEEE 802.1w Rapid Convergence Spanning Tree IEEE 802.1Q VLANs IEEE 802.1p Priority
- Network Management Type: Managed
- Model #: J4812A
- $751.00 –
- Free Shipping

Quick View
Ubiquiti Pro 8 PoE, 8-port Layer 3 PoE Switch ((USW-Pro-8-PoE) (120W))
- Brand: Ubiquiti Networks
- Series: Network Switch
- Part Number: USW-Pro-8-PoE (120W)
- Format: Desktop
- Model #: USW-Pro-8-PoE (120W)
- $523.94 –
- More options from $344.00 - $523.94
- Free Shipping

Quick View
NETIS PE6108G Unmanaged 8-Port Gigabit Switch with 8 PoE Port 120W IEEE802.3af/at
- Format: Desktop
- Standards: IEEE 802.3u 1000Base-TX, IEEE 802.3u 100BASE -TX, IEEE 802.3 10BASE -T, IEEE 802.3at, IEEE 802.3x Flow Contro
- Primary Ports: 8 10/100/1000Mbps RJ45 port, with PoE function
- Primary Port Speed: 10/100/1000Mbps
- Model #: PE6108G
- $49.98 –
- Free Shipping

Quick View
Netis P110GC 8GE Gigabit PoE Switch and 2GE Gigabit Uplink | 30W PoE+ Per Port 802.3af/at PoE Budget 120W | with 4KV Lightning Protection, Internal Power Supply and Long Distance Data Transmission
- Format: Desktop
- Standards: IEEE802.3/802.3u/802.3ab/802.3z
- Uplink Ports: 2
- Uplink Interface: RJ45
- Model #: P110GC
- $59.99 –
- Free Shipping

Quick View
NETIS ST3108S Unmanaged 8 Port Fast Ethernet Desktop Plastic Switch
- Brand: NETIS
- Format: Desktop
- Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x
- Network Management Type: Smart
- Model #: ST3108S
- $12.99 –
- Free Shipping

Quick View
Netis ST3108GC 8 Port 10/100/1000Mbps Gigabit Desktop Switch | Plug-and-Play and Effective Power Saving Technology Support Auto MDI/MDIX Function | Fanless and Compact Design
- Format: Desktop
- Standards: IEEE 802.3 10Base-T, IEEE 802.3u 100Base-TX, IEEE802.3ab 1000Bast-T
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: ST3108GC
- $19.99 –
- Free Shipping

Quick View
Ubiquiti Flex 10 GbE, Compact 5-port Layer 2 Switch (USW-Flex-XG)
- Brand: Ubiquiti Networks
- Series: Network Switch
- Part Number: USW-Flex-XG
- Format: Desktop
- Model #: USW-Flex-XG
- $495.74 –
- More options from $350.65 - $495.74
- Free Shipping

Quick View
(3-Pack) Ubiquiti Flexible 5-Port, Layer 2 PoE Switch (USW-Flex-3 (46W))
- Brand: Ubiquiti Networks
- Series: Network Switch
- Part Number: USW-Flex (46W)
- Format: Desktop
- Model #: USW-Flex-3 (46W)
- $376.20 –
- More options from $302.00 - $376.20
- Free Shipping

Quick View
HP JD866A#ABA Unmanaged V1405-5 Switch
- Format: External
- Standards: IEEE802.3, IEEE802.3u
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: JD866A#ABA
- $40.00 –
- Free Shipping

Quick View
HPE OfficeConnect 1920S 8G PPoE+ 65W Switch (JL383A)
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Layer: 3
- Power: Input voltage: 72.9W (maximum), 9.7W (idle) Power consumption: 435W (maximum), 34.2W (idle)
- Model #: JL383A#ABA
- $205.00 –
- Free Shipping

Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8P2S
- $399.00 –
- More options from $399.00 - $405.99
- Free Shipping

Quick View
SMC LG-ERICSSON SMC6110L2 Managed Tiger Switch Managed Ethernet Switch
- Format: Rackmount
- Primary Ports: 8 x RJ45
- Power: Input Voltage: 110 V AC / 220 V AC Input Voltage Range: 100 V AC to 240 V AC Power Source: Power Supply
- Parts: 1 year limited
- Model #: SMC6110L2
- $77.00 –
- Free Shipping

Quick View
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-804HPT
- $259.60 –
- More options from $248.99 - $259.60
- Free Shipping

Quick View
PLANET IVC-234GT Unmanaged Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
- Format: DIN Rail Mount
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet ITU-T G.993.1 VDSL ITU-T G.997.1 ITU-T G.993.2 VDSL2 (Profile 17a/30a Support) ITU-T G.993.5 G.Vectoring and G.INP ITU-T G.998
- Primary Ports: 4 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IVC-234GT
- $252.00
- See price in cart
- More options from $183.99 - $229.00
- Free Shipping

Quick View
HP JG922A 19208Gpoe Switch 8 Ports Managed Desktop Rackmountable Aba
- Format: Desktop
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Primary Port Type: (8) RJ-45 auto-negotiating 10/100/1000 PoE+ ports (2) SFP 1000 Mbps ports
- Model #: JG922A
- $727.00
- $706.00 –
- Free Shipping

Quick View
TP-Link TL-SL1311MP | 8 Port 10/100Mbps Fast Ethernet PoE Switch | 8 PoE+ Ports @124W, w/ 2 Uplink Gigabit Ports + 1 SFP Port | Limited Lifetime Protection | PoE Recovery | Extend & Isolation Mode
- Format: Desktop
- Primary Ports: 8x 10/100 Mbps 802.3af/at PoE+ Ports, 2x Gigabit RJ45 Ports, 1x Gigabit SFP Port
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 2K
- Model #: TL-SL1311MP
- $145.98 –
- More options from $79.99 - $145.98

Quick View
TP-Link JetStream TL-SG2008 V3 Smart 8-Port Gigabit Smart Switch
- Format: Desktop
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3x, IEEE 802.1d, IEEE 802.1s, IEEE 802.1w, IEEE 802.1q, IEEE 802.1p, IEEE 802.1x
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG2008 V3
- $155.70 –
- Free Shipping

Quick View
Ubiquiti UniFi Managed Gigabit Ethernet Switch (5-Pack) - US-8-60W-5
- Format: Desktop
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- VLAN Support: Yes
- Model #: US-8-60W-5
- $633.55 –
- Free Shipping

Quick View
Planet GSD-1222VHP 8-Port 802.3at PoE + 2-Port 10/100/1000T 2-Port SFP Ethernet Switch with PoE LCD Monitor
- Format: Desktop
- Primary Ports: 10 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps + 1000Mbps
- VLAN Support: The LCD switch features “Standard”, “VLAN” and “Extend” mode selection; the “Extend” mode features 30-watt PoE transmit distance of 250m
- Model #: GSD-1222VHP
- $220.50 –
- Free Shipping

Quick View
TP-Link TL-SG1006PP 5-Port Gigabit PoE Switch with 3 PoE+ and 1 PoE++ Ports
- Format: Desktop
- Primary Ports: 6 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Primary Port Type: 6 x 10/100/1000Mbps RJ45 Ports
- Model #: TL-SG1006PP
- $154.46 –

Quick View
D-Link 8-Port EasySmart Gigabit PoE Ethernet Switch - Lifetime Warranty (DGS-1100-08P)
- Brand: D-Link
- Standards: IEEE 802.3/3u/3ab, IEEE 802.3af
- Network Management Type: Smart
- Primary Ports: 8 x RJ45
- Model #: DGS-1100-08P
- $117.24 –
- Free Shipping

Quick View
TP-Link TL-SL1311P PoE 8-Port 10/100Mbps + 3-Port Gigabit Desktop Switch with 8-Port PoE+
- Format: Desktop
- Primary Ports: 10 x RJ45 + 1 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Primary Port Type: 8 x 10/100 Mbps 802.3af/at PoE+ Ports 2 x Gigabit RJ45 Ports 1 x Gigabit SFP Port
- Model #: TL-SL1311P
- $109.39 –

Quick View
ONV-POE31004P with 4-port PoE switch 4+1 Port Desktop Fast Ethernet Switch IP Network Cameras Powered
- Format: Desktop
- Standards: IEEE 802.3af, IEEE 802.3at
- Primary Ports: 4 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: POE31004P
- $55.00 –
- $10.00 Shipping

Quick View
ONV-POE31064P 4 Ports +2x Uplink ports Auto MDIX RJ45 IEEE 802.3af/at PoE Switch
- Standards: IEEE 802.3/3u, IEEE 802.3af
- Primary Ports: 10 x RJ45
- Power: 52VDC, 1.25A
- Package Contents: 1
- Model #: ONV-POE31064P
- $59.96 –
- $10.00 Shipping

Quick View
Planet Technology GSD-805 8-Port 10/100/1000Mbps Desktop Gigabit Ethernet Switch (Internal Power)
- Format: Desktop
- Standards: IEEE 802.3: Ethernet IEEE 802.3u: Fast Ethernet IEEE 802.3ab: Gigabit Ethernet IEEE 802.3x: Full-duplex flow control
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: GSD-805
- $53.60 –
- $8.00 Shipping

Quick View
Tenda TEG1105P-4-63W Unmanaged Switch
- Switch Type: Gigabit
- Format: Desktop
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3af, IEEE 802.3at
- Primary Ports: 5 x RJ45
- Model #: TEG1105P-4-63W
- $67.33 –

Quick View
Ultrapoe 6 Port PoE Switch 4 Ports 10/100Mbps PoE+ 2 Uplink 65W 803.af/at for IP Cameras VOIP Phones
- Part Number: POE-2006-4E-65W
- Switch Type: Unmanaged PoE Switch
- Format: Desktop
- Standards: IEEE 802.3af, IEEE 802.3at
- Model #: POE-2006-4E-65W
- $32.98 –
- Free Shipping

Quick View
D-Link DIS-100G-5W 5-Port Unmanaged Industrial Switch, -40 Degree C to +75 Degree C
- Standards: IEEE 802.3 for Ethernet IEEE 802.3u for Fast Ethernet IEEE 802.3ab for Gigabit Ethernet IEEE 802.3z for Gigabit fiber IEEE 802.3x Flow Control IEEE 802.3af/at Power over Ethernet (DIS-100G-5PSW) IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 2K
- Model #: DIS-100G-5W
- $207.90 –
- Free Shipping

Quick View
CISCO CBS350-8FP-2G-NA Managed Switch
- Format: Desktop
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Primary Port Type: 8 x 10/100/1000 PoE+ ports with 120W power budget 2 x Gigabit copper/SFP combo ports
- Model #: CBS350-8FP-2G-NA
- $349.95 –
- Free Shipping

Quick View
Cisco Meraki MS120-8 Compact Switch
- Format: Desktop
- Primary Ports: 8 x 10/100/1000BASE-T Ethernet RJ45 with auto negotiation and crossover detection (auto-MDIX crossover) 2 x 1 GbE SFP uplink
- VLAN Support: Yes
- Security: Integrated two-factor authentication for Dashboard management Role-based access control (RBAC) with granular device and configuration control SSO, Corporate-wide password policy enforcement IEEE 802.1X RADIUS, hybrid authentication and RADIUS server testing MAC-based RADIUS authentication (MAB) Port security: Sticky MAC, MAC whitelisting DHCP snooping, detection and blocking STP Enhancements include BPDU guard, Root guard IPv4 ACLs
- Model #: MS120-8-HW
- $499.95 –
- Free Shipping

Quick View
TP-Link TL-SG1210MP | 8 Port Gigabit PoE Switch | 8 PoE+ Ports @123W, w/ 2 Uplink Gigabit Ports + 1 Combo SFP Slot | Plug & Play | Extend, Priority & Isolation Mode | Limited Lifetime Protection
- Format: Desktop
- Primary Ports: 9 x RJ45 + 1 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Primary Port Type: 9 x 10/100/1000 Mbps RJ45 Ports 1 x 1000 Mbps Combo SFP/RJ45 Port
- Model #: TL-SG1210MP
- $199.99 –

Quick View
8-Port Gigabit Ethernet Unmanaged Essentials Switch (GS308) - Home Network Hub, Office Ethernet Splitter, Plug-and-Play, Silent Operation, Desktop or Wall Mount
Limited time offer, ends 10/16
- Brand: NETGEAR
- Series: GS308-300PAS
- Part Number: GS308-300PAS
- Format: Computers, servers, other switches, and networking hardware
- Model #: 192832438305
- $40.52 –
- Free Shipping



