Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
NETIS PE6108G Unmanaged 8-Port Gigabit Switch with 8 PoE Port 120W IEEE802.3af/at
- Format: Desktop
- Standards: IEEE 802.3u 1000Base-TX, IEEE 802.3u 100BASE -TX, IEEE 802.3 10BASE -T, IEEE 802.3at, IEEE 802.3x Flow Contro
- Primary Ports: 8 10/100/1000Mbps RJ45 port, with PoE function
- Primary Port Speed: 10/100/1000Mbps
- Model #: PE6108G
- $49.98 –
- Free Shipping

Quick View
NETIS ST3116G Unmanaged 16 Port Gigabit Ethernet Rackmount Switch
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T, IEEE 802.3u 100Base-TX, IEEE802.3ab 1000BASE-T , IEEE 802.3x Flow Control, IEEE 802.3az
- Uplink Ports: None
- Primary Ports: 16 x RJ45
- Model #: ST3116G
- $58.88 –
- Free Shipping

Quick View
NETIS ST3124P Unmanaged 24 Port Fast Ethernet Desktop Plastic Switch
- Format: Desktop
- Standards: IEEE 802.3 10Base-T, IEEE 802.3u 100Base-TX, IEEE 802.3x Flow Control, IEEE 802.3az
- Primary Ports: 24 x 10/100 Mbps RJ45 port, Auto-Negotiation, Auto MDI / MDIX
- Primary Port Speed: 10/100Mbps
- Model #: ST3124P
- $28.88 –
- Free Shipping

Quick View
NETIS ST3105S Unmanaged 5 Port Fast Ethernet Desktop Plastic Switch
- Brand: NETIS
- Format: Desktop
- Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x
- Network Management Type: Unmanaged
- Model #: ST3105S
- $12.99 –
- Free Shipping

Quick View
NETIS ST3116P Unmanaged 16 Port Fast Ethernet Plastic Desktop Switch
- Format: Desktop
- Standards: IEEE 802.3 10Base-T, IEEE 802.3u 100Base-TX, IEEE 802.3x Flow Control, IEEE 802.3az
- Primary Ports: 16 x 10/100 Mbps RJ45 port, Auto-Negotiation, Auto MDI / MDIX
- MAC Address Table: 8K
- Model #: ST3116P
- $24.99 –
- $7.99 Shipping

Quick View
Netis ST3116GS 8 Port 16 Port Unmanaged 10/100/1000M Gigabit Ethernet Rackmount Switch | Plug-and-Play and Effective Power Saving Technology Support Auto MDI/MDIX Function
- Format: Rackmount
- Uplink Interface: RJ45
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: ST3116GS

Quick View
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-804HPT
- $259.60 –
- More options from $248.99 - $259.60
- Free Shipping

Quick View
Ubiquiti Networks US-48-US Managed Gigabit Switches with SFP
- Format: Rail-mountable
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Primary Port Type: 48 x 10/100/1000 Mbps RJ45 Ethernet Ports 2 x 1/10 Gbps SFP+ Ethernet Ports 2 x 1 Gbps SFP Ethernet Ports 1 x RJ45 Serial Port Out-of-Band, Ethernet In-Band
- Model #: US-48
- $879.01 –
- Free Shipping

Quick View
Ubiquiti LBE-M5-23 Long-Range, Lightweight airMAX CPE
- Interface: 1 x 10/100 Ethernet Port
- Brand: Ubiquiti Networks
- Power Supply: Max. Power Consumption: 4W Power Supply: 24V, 0.2A PoE Adapter (Included) Power Method: Passive PoE (Pairs 4, 5+; 7, 8 Return)
- Temperature: Operating Temperature: -40 ~ 70 degree Celsius (-40 ~ 158 degree Fahrenheit)
- Model #: LBE-M5-23
- $91.81 –
- Free Shipping

Quick View
Planet IGS-801T 8-Port 10/100/1000Mbps Industrial Gigabit Ethernet Switch w/ Wide Operating Temperature
- Format: Rail-mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-duplex flow control
- Primary Ports: 8x 10/100/1000Base-T Ports
- Primary Port Speed: 10/100/1000Base-T
- Model #: IGS-801T
- $164.00 –
- Free Shipping

Quick View
Panduit FLBSIM-51 Full-Length Blanking Shade, Black
- Color: Black
- Type: Blanking Panel
- Specifications: Compatible Rack System: 19 Mounting Bolt Method: Threaded Overall Width (In.): 19.16 Overall Depth (In.) 3.11 Overall Height (In.): 2.82 Maximum Operating Temperature (°C): 50 Maximum Operating Temperature (°F): 122 Minimum Operating Temperature (°C): 0 Minimum Operating Temperature (°F): 32 Standards Met: CEA-310-E; ASTM D6413; RoHS Compliant Accessory Type: Full Length Blanking Shade
- Model #: FLBSIM-51
- $638.47 –
- $8.00 Shipping

Quick View
UBIQUITI - US PBE-5AC-GEN2-US POWERBEAMAC GEN2 5 GHZ HIGH
- Interface: 1 x 10/100/1000 Ethernet Port
- Brand: Ubiquiti Networks
- LED Indicator: Power, Ethernet, 4 x Signal Strength
- Power Supply: Power Supply: 24V, 0.5A Gigabit PoE Adapter (Included) Max. Power Consumption: 8.5W Power Method: Passive PoE (Pairs 4, 5+; 7, 8 Return) Supported Voltage Range: 20 to 26V DC
- Model #: PBE-5AC-GEN2-US
- $99.99 –
- Free Shipping

Quick View
PLANET IVC-234GT Unmanaged Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
- Format: DIN Rail Mount
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet ITU-T G.993.1 VDSL ITU-T G.997.1 ITU-T G.993.2 VDSL2 (Profile 17a/30a Support) ITU-T G.993.5 G.Vectoring and G.INP ITU-T G.998
- Primary Ports: 4 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IVC-234GT
- $252.00
- See price in cart
- More options from $183.99 - $229.00
- Free Shipping

Quick View
Planet MGSW-28240F 24-Port 100/1000BASE-X SFP with 4-Port 10G SFP+ L2/L4 Managed Metro Ethernet Switch
- Primary Ports: 24 1000Base-SX/LX/BX SFP interfaces, (Compatible with 100Base-FX SFP Transceiver), 4 1/10GBase-SR/LR SFP+ slots, 4 10/ 100/1000Base-T TP/SFP combo ports
- MAC Address Table: 16K entries, automatic source address learning and ageing
- Switching Method: Store and Forward
- VLAN Support: Yes
- Model #: MGSW-28240F
- $1,016.00
- See price in cart
- More options from $799.00 - $863.99
- $14.00 Shipping

Quick View
Juniper Networks EX2300 Switch, 24-port 10/100/1000BASE-T, 4 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-24T
- Brand: Juniper Networks, Inc.
- Format: Desktop
- Network Management Type: Managed
- Primary Ports: 24 x RJ45
- Model #: EX2300-24T
- $1,203.95 –
- More options from $1,018.99 - $1,203.95
- Free Shipping

Quick View
D-Link DIS-100G-5W 5-Port Unmanaged Industrial Switch, -40 Degree C to +75 Degree C
- Standards: IEEE 802.3 for Ethernet IEEE 802.3u for Fast Ethernet IEEE 802.3ab for Gigabit Ethernet IEEE 802.3z for Gigabit fiber IEEE 802.3x Flow Control IEEE 802.3af/at Power over Ethernet (DIS-100G-5PSW) IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 2K
- Model #: DIS-100G-5W
- $207.90 –
- Free Shipping

Quick View
Ubiquiti UAP-AC-HD-5 Unifi Access Point (5-PACK)
- Interface: 2 x 10/100/1000 Ethernet Ports
- Brand: Ubiquiti Networks
- Standards: 802.11 a/b/g/n/ac/ac-wave2
- Security: WEP, WPA-PSK, WPA-Enterprise (WPA / WPA2, TKIP / AES) 802.11 w/ PMF
- Model #: UAP-AC-HD-5-US
- $1,769.99 –
- Free Shipping

Quick View
HPE Juniper Networking EX2300 Switch, 24-port 10/100/1000BASE-T with internal DC PSU, 4 x 1/10GbE SFP/SFP+ (optics sold separately) | EX2300-24T-DC
- Brand: Juniper Networks, Inc.
- Series: EX2300
- Part Number: EX2300-24T-DC
- Format: Desktop
- Model #: EX2300-24T-DC
- $1,429.20 –
- More options from $1,429.20 - $3,233.00
- Free Shipping

Quick View
Juniper Networks EX4100 Switch, 48-port 10/100/1000BASE-T PoE+ switch, 4x1GbE/10GbE SFP/SFP + uplinks, 4x10GbE stacking/uplink ports | EX4100-F-48P
- Brand: Juniper Networks, Inc.
- Series: EX4100-F
- Part Number: EX4100-F-48P
- Format: Desktop
- Model #: EX4100-F-48P
- $4,099.20 –
- More options from $4,099.20 - $6,101.00
- Free Shipping

Quick View
Planet SGS-6340-24P4S Layer 3 24-Port 10/100/1000T 802.3at PoE + 4-Port 1000X SFP Stackable Managed Switch (370W)
- Format: Rackmount
- Uplink Ports: 4
- Uplink Interface: SFP & RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: SGS-6340-24P4S
- $775.00 –
- Free Shipping

Quick View
Intellinet 5-Port Gigabit Ethernet PoE+ Switch, Four PSE PoE+ Gigabit Ports, One Gigabit Port, PoE Power Budget of 40 W, IEEE 802.3at/af Compliant, Desktop, Wall-mount Option
- Brand: Intellinet Network Solutions
- Format: Desktop
- Network Management Type: Unmanaged
- Primary Ports: 5 x RJ45
- Model #: 561792
- $104.00 –
- $8.00 Shipping

Quick View
TE122P 1 Port T1 E1 J1 Card + PCI interface + Echo Cancellation Port,TE122,TE110,TE110P
Limited time offer, ends 10/10
- Brand: TE122
- Type: Wired VoIP
- Standards: Bus Type: PCI
- Protocols: Echo Cancellation: Additional Payment
- Model #: ST TE122P
- $140.00
- See price in cart
- $7.99 Shipping

Quick View
Juniper EX4650 48x25GbE+8x100GbE Ethernet Switch
- Switch Type: Chassis
- Standards: IEEE 802.1Qaz
- Uplink Interface: SFP
- Switching Method: Store and Forward
- Model #: EX4650-48Y-AFO
- $24,979.20 –
- More options from $24,979.20 - $27,980.00
- Free Shipping

Quick View
PLANET GS-5220-48PL4X Managed L2+ 48-Port 10/100/1000T 802.3at PoE + 4-Port 10G SFP+ Managed Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
- Primary Ports: 48-Port 10/100/1000T 802.3at PoE 4-Port 10G SFP+
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 16K
- Model #: GS-5220-48PL4X
- $1,376.00 –
- $14.00 Shipping

Quick View
Cisco Catalyst C9200CX-8P-2X2G-A Managed Switch, 8-Port PoE+ 240W Budget, 2x 10G SFP+ & 2x 1G Uplinks, Layer 3, Network Advantage
- Model #: C9200CX-8P-2X2G-A
- $2,646.00 –
- More options from $2,638.44 - $2,646.00
- Free Shipping

Quick View
Refurbished TRENDnet TEG-S50G Unmanaged Gigabit GREENnet Switch
- Brand: TRENDnet
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
- Network Management Type: Unmanaged
- Primary Ports: 5 x RJ45
- Model #: TEG-S50G
- $19.99 –
- Free Shipping

Quick View
Refurbished LINKSYS EZXS55W-RM EtherFast 5-Port Workgroup Switch
- Format: External
- Standards: IEEE802.3, IEEE802.3u
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: EZXS55W-RM
- $29.99 –
- Free Shipping

Quick View
Refurbished D-Link DSS-16+/RE Unmanaged 16-Port Desktop/Rackmount Switch
- Brand: D-Link
- Format: Desktop/Rackmount
- Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x, IEEE 802.3 Nway Auto-negotiation, IEEE 802.1p Qos Prioritization
- Network Management Type: Unmanaged
- Model #: DSS-16+/RE
- $49.99 –
- Free Shipping

Quick View
- $301.00 –
- More options from $301.00 - $392.65
- $12.99 Shipping

Quick View
- $1,163.00 –
- Free Shipping

Quick View
USB to LoRa Data Transfer Module Based On SX1262, 850~930MHz Frequency, Suitable for Data Acquisition in Industry and Agriculture, with TCXO Crystal Oscillator
OUT OF STOCK
- Model #: 9158154847802
- $52.99 –
- $5.99 Shipping

Quick View
Netgear GS305E 5-Port Gigabit Ethernet SOHO Plus Easy Smart Managed Essentials Switch, GS305E-100NAS
OUT OF STOCK
- Brand: NETGEAR
- Part Number: GS305E-100NAS
- Standards: IEEE 802.3 Ethernet IEEE 802.3ab 1000BASE-T IEEE 802.3u 100BASE-T IEEE 802.3ab 1000BASE-T IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.3x Full-duplex Flow Control
- Network Management Type: Smart
- Model #: GS305E-100NAS
- $29.99
- $24.99 –
- Save: $5.00 (16%)
- Free Shipping

Quick View
Netgear ProSafe GS105 5-Port Gigabit Ethernet Unmanaged Switch, GS105NA
OUT OF STOCK
- Brand: NETGEAR
- Series: ProSafe
- Standards: IEEE 802.3i 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3z 1000BASE-T Gigabit Ethernet
- Network Management Type: Unmanaged
- Model #: GS105NA
- $39.99
- $32.99 –
- Save: $7.00 (17%)
- Free Shipping

Quick View
PLANET Technology - GS-4210-24T2S - Planet 24-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces - 24 Ports - Manageable - 4 Layer Supported - Modular - Twisted Pair, Optical Fiber - 1U
OUT OF STOCK
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
- Primary Ports: 24-port 10/100/1000BASE-T Gigabit RJ45 copper 2 x 100/1000BASE-X mini-GBIC / SFP slots
- MAC Address Table: 8K
- Switching Method: Store and Forward
- Model #: GS-4210-24T2S
- $197.99 –
- Free Shipping

Quick View
Ubiquiti Networks LBE-M5-23-US LiteBeam M5, Long-Range, Lightweight airMAX CPE
OUT OF STOCK
- Interface: 1 x 10/100 Ethernet Port
- Brand: Ubiquiti Networks
- Power Supply: Max. Power Consumption: 4W Power Supply: 24V, 0.2A PoE Adapter (Included) Power Method: Passive PoE (Pairs 4, 5+; 7, 8 Return)
- Temperature: Operating Temperature: -40 ~ 70 degree Celsius (-40 ~ 158 degree Fahrenheit)
- Model #: LBE-M5-23-US
- $57.99 –
- Free Shipping

