Your Browsing History

Quick View
Refurbished Arista DCS-7500-SUP2 7500R3 Series Switch Supervisor 2 Module DCS-7500-SUP2
- Model #: 011110109811
- $149.00 –

Quick View
- $1,334.00 –
- Free Shipping

Quick View
Refurbished Dell Networking N3048ET-ON 48P 1GbE 2P 10GbE SFP+ Switch
- Brand: Dell
- Model: N3048ET-ON
- Model #: 011110053053
- $299.00 –

Quick View
EXTREMESWITCHING5420F 8
- Primary Ports: 16 x 10/100/1000BASE-T 802.3bt (90W) ports • Full / Half-Duplex(autosensing) • MACsec-capable 32 x 10/100/1000BASE-T 802.3at (30W) ports • Full / Half-Duplex(autosensing) • MACsec-capable 4 x 1/10Gb SFP+ uplink ports(unpopulated) • MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- VLAN Support: Yes
- PoE: All 5420 models support 30W, 60W, and 90W PoE that conforms with IEEE 802.3bt. This enables the 5420 to address the needs of powered edge devices, while eliminating the need for additional electrical cabling and circuits. In addition, 5420 PoE models support perpetual and fast PoE for even more efficient and reliable powered edge device operation
- ...
- Model #: 5420F-8W-16P-4XE
- $8,179.99 –
- More options from $7,221.00 - $8,179.99

Quick View
RUCKUS ICX 8200 Compact Switch, 4x100/1000/2500 Mbps PoE++ ports, 4x 1/2.5/5/10Gbps PoE++ ports, 2x25 GbE SFP28 stacking/uplinkports, 240 W PoE budget, 3-Y remote TAC support | ICX8200-C08ZP
- Part Number: ICX8200-C08ZP
- Uplink Interface: 4× 100/1000/2500 Mbps RJ-45 PoE++ 90W ports; 4× 1/2.5/5/10 Gbps RJ-45 PoE++ 90W ports; 2× 1/10/25 GbE uplink/stacking SFP28 ports; USB Type-C port;RJ45 serial port;USB Type-A port;RJ45 Ethernet port (For console manag
- Power: Power Over Ethernet (PoE) Support: Yes PoE Power Consumption: 240W
- Max Power Consumption: Power / Device Type: Power Supply Max Power Consumption: 305 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Model #: ICX8200-C08ZP
- $2,998.00 –
- More options from $2,395.99 - $3,420.99
- Free Shipping

Quick View
Extreme Networks 5420F 24-port 30W PoE Switch, 4 x 1/10Gb SFP+ ports, Base software included | 5420F-24P-4XE
- Primary Ports: 24 x 10/100/1000BASE-T 802.3at (30W) ports • Full / Half-Duplex(autosensing) • MACsec-capable 4 x 1/10Gb SFP+ uplink ports(unpopulated) • MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- VLAN Support: Yes
- PoE: All 5420 models support 30W, 60W, and 90W PoE that conforms with IEEE 802.3bt. This enables the 5420 to address the needs of powered edge devices, while eliminating the need for additional electrical cabling and circuits. In addition, 5420 PoE models support perpetual and fast PoE for even more efficient and reliable powered edge device operation
- Stackable: Yes
- Model #: 5420F-24P-4XE
- $5,087.99
- $4,445.99 –
- Save: $642.00 (12%)
- Free Shipping

Quick View
Extreme Networks 5320 16-Port 30W PoE Switch w/ AC power, 4 x 1/10Gb SFP+ uplink ports | 5320-16P-4XE
- Switch Type: Ethernet Switch
- Primary Ports: 16 x 10/100/1000BASE-T 802.3at (30W) ports • Full / Half-Duplex (autosensing) • MACsec-capable 4 x 1/10Gb SFP+ uplink ports (includes 2 x Stacking ports) • MACsec-capable 1 x Serial console port (RJ-45) 1 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- PoE: All 5320 models support 30W PoE that conforms with IEEE 802.3at. This enables the 5320 to address the needs of powered edge devices, while eliminating the need for additional electrical cabling and circuits. In addition, 5320 PoE models support perpetual and fast PoE for even more efficient and reliable powered edge device operation.
- Stackable: Yes
- Model #: 532016P4XE
- $3,289.99 –
- Free Shipping

Quick View
Extreme Networks 5320 48-Port 30W PoE Switch, 8 x 1/10Gb SFP+ ports | 5320-48P-8XE
- Switch Type: Ethernet Switch
- Primary Ports: 48 x 10/100/1000Base-T 802.3at (30W) ports • Full/Half-Duplex (autosensing) • MACsec-capable 8 x 1Gb SFP uplink ports (includes 2 x Stacking ports @ 10Gb) • Can be upgraded to 10Gb SFP+ via software license • MACsec-capable • 100Mb operation supported on last 4 uplink ports 1 x Serial console port (RJ-45) 1 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- PoE: All 5320 models support 30W PoE that conforms with IEEE 802.3at. This enables the 5320 to address the needs of powered edge devices, while eliminating the need for additional electrical cabling and circuits. In addition, 5320 PoE models support perpetual and fast PoE for even more efficient and reliable powered edge device operation.
- Stackable: Yes
- Model #: 5320-48P-8XE
- $5,837.99 –
- Free Shipping

Quick View
Extreme Networks 5420F 24-port Switch with 8 ports 90W and 16 ports 30W PoE, 4 x 1/10Gb SFP+ ports, Base software included | 5420F-8W-16P-4XE
- Brand: Extreme Networks
- Series: 5420 Series
- Part Number: 5420F-8W-16P-4XE
- Network Management Type: Managed
- Model #: 5420F8W16P4XE
- $7,780.00
- $5,162.99 –
- Save: $2,617.01 (33%)
- Free Shipping

Quick View
Extreme Networks 5420F 24-port Switch, 4 x1/10Gb SFP+ ports, Base software included | 5420F-24T-4XE
- Brand: Extreme Networks
- Series: 5420
- Network Management Type: Managed
- Primary Ports: 24 x 10/100/1000BASE-T ports • Full / Half-Duplex(autosensing) • MACsec-capable 4 x 1/10Gb SFP+ uplink ports(unpopulated) • MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- Model #: 5420F-24T-4XE
- $4,071.99
- $3,831.99 –
- Save: $240.00 (5%)
- Free Shipping

Quick View
Extreme Networks 5320 16-port 30W PoE Switch w/AC Power, 2 x 1/10Gb SFP+ ports | 5320-16P-2MXT-2X
- Brand: Extreme Networks
- Series: 5320 Series
- Part Number: 5320-16P-2MXT-2X
- Format: Rackmount
- Model #: 5320-16P-2MXT-2X
- $3,738.00
- $2,394.99 –
- Save: $1,343.01 (35%)
- Free Shipping

Quick View
RUCKUS ICX 8200 Switch, 24x10/100/1000 Mbps PoE+ ports, 4x25 GbE SFP28 stacking/uplink-ports, 370 W PoE budget, three-year remote TAC support. Power cord not included
- Part Number: ICX8200-24P
- Primary Ports: Interfaces: 24x10/100/1000 Mbps RJ45 ; 4x1/10/25 Gbps SFP/SFP+/SFP28 uplinks; USB Type-C; RJ45 serial port; USB Type-A port; RJ45 Ethernet port 10/100/1000BASE-T Ports: 24
- Power: Max Power Consumption: 525 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Temperature: Min Operating Temperature: 0 Celsius Max Operating Temperature: 45 Celsius Min Storage Temperature: -40 Celsius Max Storage Temperature: 70 Celsius
- Model #: ICX8200-24P
- $2,855.00 –
- More options from $2,855.00 - $3,527.99
- Free Shipping

Quick View
Ruckus ICX8200-24 24 Ports 1G PoE Enterprise-Class Stackable Access Switch with Future-Proof Expandability - OEM
- Part Number: ICX8200-24
- Uplink Interface: Interfaces: 24x10/100/1000 Mbps RJ45 ; 4x1/10/25 Gbps SFP/SFP+/SFP28 uplinks; USB Type-C; RJ45 serial port; USB Type-A port; RJ45 Ethernet port 10/100/1000BASE-T Ports: 24
- Max Power Consumption: Max Power Consumption: 65 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Temperature: Min Operating Temperature: 0 Celsius Max Operating Temperature: 45 Celsius Min Storage Temperature: -40 Celsius Max Storage Temperature: 70 Celsius
- Model #: ICX8200-24
- $4,290.00
- $2,901.99 –
- Save: $1,388.01 (32%)
- Free Shipping

Quick View
Extreme Networks 5520 24-port 90w PoE Switch, 2 x Stacking/QSFP28 ports, Base software included | 5520-24W
- Brand: Extreme Networks
- Series: 5520 Series
- Part Number: 5520-24W
- Network Management Type: Managed
- Model #: 552024W
- $7,204.00
- $4,867.99 –
- Save: $2,336.01 (32%)
- Free Shipping

Quick View
Extreme Networks 5520 48-port 90w PoE w/ 12 ports multi-rate Switch, 2 x Stacking/QSFP28 ports, Base software included | 5520-12MW-36W
- Brand: Extreme Networks
- Series: 5520 Series
- Part Number: 5520-12MW-36W
- Network Management Type: Managed
- Model #: 5520-12MW-36W
- $14,512.00
- $9,609.99 –
- Save: $4,902.01 (33%)
- Free Shipping

Quick View
Extreme Networks 5520-48W: High-Performance 48-Port 1GbE Switch with Modular Uplinks, PoE, and Advanced Routing Capabilities
- Brand: Extreme Networks
- Series: 5520
- Network Management Type: Managed
- Primary Ports: • 48 x 10/100/1000BASE-T 802.3bt (90W) ports ? Full / Half-Duplex (autosensing) ? MACsec-capable • 2 x Stacking/QSFP28 ports* (unpopulated) • 1 x Serial console port (RJ-45) • 1 x 10/100/1000BASE-T out-of-band management port • 2 x USB A ports for management or external USB flash • 1 x USB Micro-B console port • 1 x VIM slot
- Model #: 5520-48W
- $7,826.99
- $7,400.99 –
- Save: $426.00 (5%)
- Free Shipping

Quick View
Extreme Networks 5420F 48-port Switch with 16 ports 90W multi-rate and 32 ports 30W PoE, 4x 1/10Gb SFP+ ports | 5420F-16MW-32P-4XE
- Brand: Extreme Networks
- Series: 5420 Series
- Part Number: 5420F-16MW-32P-4XE
- Management Interface: Interfaces: 16 x 100M/1G/2.5GBASE-T 802.3bt (90W) ports MACsec-capable 32 x 10/100/1000BASE-T 802.3at (30W) ports Full / Half-Duplex(autosensing) MACsec-capable 4 x 1/10Gb SFP+ uplink ports(unpopulated) MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- Model #: 5420F16MW32P4XE
- $15,432.00
- $10,424.99 –
- Save: $5,007.01 (32%)
- Free Shipping

Quick View
Extreme Networks 5520 24-port SFP+ Switch, 24 x 100Mb/1Gb/10Gb SFP+ ports, includes 2 Stacking/QSFP28 ports | 5520-24X
- Brand: Extreme Networks
- Series: 5520 Series
- Part Number: 5520-24X
- Network Management Type: Managed
- Model #: 5520-24X
- $16,585.00
- $11,235.99 –
- Save: $5,349.01 (32%)
- Free Shipping

Quick View
Ruckus ICX8200-48 48 Ports 1G Enterprise-Class Stackable Access Switch with Future-Proof Expandability - OEM
- Part Number: ICX8200-48
- Primary Ports: Interfaces: 48× 10/100/1000 Mbps RJ-45 ports; 4× 1/10/25 GbE uplink/stacking SFP28 port; USB Type-C port;RJ45 serial port; USB Type-A port;RJ45 Ethernet port 10/100/1000BASE-T Ports: 48
- Power: Power / Device Type: Power Supply Max Power Consumption: 100 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Temperature: Min Operating Temperature: 0 Celsius Max Operating Temperature: 45 Celsius Min Storage Temperature: -40 Celsius Max Storage Temperature: 70 Celsius
- Model #: ICX8200-48
- $3,817.99 –
- Free Shipping

Quick View
HP JE074A#ABA Managed 5120-24G SI Switch
- Format: Rackmount
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab
- Primary Ports: 24 x RJ45 + 4 x SFP + 1 x RJ-45 serial console
- Primary Port Speed: 10/100/1000Mbps
- Model #: JE074A#ABA
- $567.00 –
- Free Shipping

Quick View
HP JE068A#ABA Managed 5120-24G EI Switch with 2 Slots
- Format: Rackmount
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab
- Primary Ports: 24 x RJ45 + 4 x SFP + 1 x RJ-45 serial console port
- Primary Port Speed: 10/100/1000Mbps
- Model #: JE068A#ABA
- $304.00 –
- Free Shipping

Quick View
Juniper EX2200-C Layer 3 Switch
- Format: Rack-mountable Desktop Wall Mountable
- Primary Port Speed: 10/100Base-TX 10/100/1000Base-T
- Protocols: HCRP, SPP
- Weight: 6.40 lb
- Model #: EX2200-C-12P-2G
- $545.10 –
- Free Shipping

Quick View
Juniper EX2200-C Layer 3 Switch
- Format: Rack-mountable Desktop Wall Mountable
- Primary Port Speed: 10/100Base-TX 10/100/1000Base-T
- Protocols: HCRP, SPP
- Weight: 4.60 lb
- Model #: EX2200-C-12T-2G
- $550.00 –
- Free Shipping

Quick View
Ruckus ICX8200-48ZP2-E 48 Ports Multigigabit Entry-Level+ Access 48 Ports Multigigabit PoE, 1 Power Supply
- Part Number: ICX8200-48ZP2-E
- Primary Ports: Interfaces: 32× 10/100/1000 Mbps RJ-45 PoE+ ports; 16× 100/1000/2500 Mbps RJ-45 PoE++ 90W ports; 4× 1/10/25 GbE uplink/stacking SFP28 ports USB Type-C; RJ45 serial port; USB Type-A port; RJ45 Ethernet port 10/100/1000BASE-T Ports: 32
- PoE Power Budget: Power Over Ethernet (PoE) Support: Yes PoE Power Consumption: 1480 w
- Power: Power / Device Type: Power Supply Power / Installed Qty: 2 Max Power Consumption: 920 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Model #: ICX8200-48ZP2-E
- $8,037.00 –
- More options from $5,924.99 - $8,037.00
- Free Shipping

Quick View
Ruckus ICX8200-48PF2-E Entry-Level+ Access 48 Ports 1G PoE Switch, Managed, Rack-Mountable, 1 Fan & 1 Power Supply
- Part Number: ICX8200-48PF2-E
- Primary Ports: Interfaces: 48× 10/100/1000 Mbps RJ-45 PoE+ ports; 4× 1/10/25 GbE uplink/stacking SFP28 ports; USB Type-C; RJ45 serial port; RJ45 Ethernet port 10/100/1000BASE-T Ports: 48
- PoE Power Budget: Power Over Ethernet (PoE) Support: Yes PoE Power Consumption: 740w
- Power: Power / Device Type: Power Supply Max Power Consumption: 920 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Model #: ICX8200-48PF2-E
- $7,881.00 –
- More options from $5,076.99 - $7,881.00
- Free Shipping

Quick View
HP 2610 Series J9089A#ABA Managed ProCurve Switch
- Brand: HP
- Series: 2610 Series
- Format: Rackmount
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab
- Model #: J9089A#ABA
- $1,100.00 –
- Free Shipping

Quick View
HP J9019A ProCurve Switch 2510-24
- Brand: HP
- Standards: IEEE 802.3x Flow Control IEEE 802.3ad Link Aggregation Control Protocol IEEE 802.1X Network Login IEEE 802.1Q VLAN tagging IEEE 802.1s Multiple Spanning Trees IEEE 802.1AB Link Layer Discovery Protocol IEEE 802.1Q VLANs IEEE 802.1p Priority
- Primary Ports: 24 RJ-45 10/100 ports (IEEE 802.3 Type 10Base-T, IEEE 802.3u Type 100Base-T) 1 RJ-45 serial console port 2 Dual Personality Ports each port can be used as either an RJ-45 10/100/1000 port (IEEE 802.3 Type 10Base-T; IEEE 802.3u Type 100Base-TX; IEEE 802.3ab 1000Base-T Gigabit Ethernet) or an open mini-GBIC slot (for use with mini-GBIC transceivers)
- Primary Port Speed: 10/100Mbps + 1000Mbps
- Model #: J9019A
- $310.09 –
- Free Shipping

Quick View
Ruckus ICX7150-48ZP-E8X10GR 48 Ports Managed Rack-Mountable Switch
- Part Number: ICX7150-48ZP-E8X10GR
- Uplink Ports: 8x 10 Gigabit Ethernet SFP+
- Primary Ports: 16x 100/1000 Mbps/2.5 Gigabit Ethernet PoH RJ-45, 32x 1 Gigabit Ethernet PoE+ RJ-45
- Management Interface: 1x RJ-45 Serial Console, 1x RJ-45 Out of Band Management, 1x USB Type C, 1x USB (for external file storage)
- Model #: ICX7150-48ZP-E8X10GR
- $6,954.00 –
- Free Shipping

Quick View
Extreme Networks 5420F 48-port Switch, 4 x 1/10Gb SFP+ ports, Base software included | 5420F-48T-4XE
OUT OF STOCK
- Brand: Extreme Networks
- Series: 5420
- Network Management Type: Managed
- Primary Ports: 48 x 10/100/1000BASE-T ports • Full / Half-Duplex(autosensing) • MACsec-capable 4 x 1/10Gb SFP+ uplink ports(unpopulated) • MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- Model #: 5420F-48T-4XE
- $5,200.00
- $4,899.99 –
- Save: $300.01 (5%)
- Free Shipping

Quick View
Extreme Networks Extreme Switching 5420M-24W-4YE -Ethernet Switch - 24 Ports - 2 Layer Supported - Modular - 90 W PoE Budget - Twisted Pair, Optical Fiber - PoE Ports
OUT OF STOCK
- Brand: Extreme Networks
- Series: 5420
- Network Management Type: Managed
- Primary Ports: 24 x 10/100/1000BASE-T 802.3bt (90W) ports • Full / Half-Duplex(autosensing) • MACsec-capable 4 x 1/10/25Gb SFP28 uplink ports (unpopulated) • MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- Model #: 5420M-24W-4YE
- $4,995.99
- $4,582.99 –
- Save: $413.00 (8%)
- Free Shipping

Quick View
Extreme Networks 5420M 48-port 90W PoE Switch, 4 x 1/10/25Gb SFP28 ports, Base software included | 5420M-48W-4YE
OUT OF STOCK
- Brand: Extreme Networks
- Series: 5420
- Network Management Type: Managed
- Primary Ports: 48 x 10/100/1000BASE-T 802.3bt (90W) ports • Full / Half-Duplex(autosensing) • MACsec-capable 4 x 1/10/25Gb SFP28 uplink ports (unpopulated) • MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- Model #: 5420M-48W-4YE
- $6,581.99 –
- Free Shipping

Quick View
Extreme Networks 5420F 48-port 30W PoE Switch, 4 x 1/10Gb SFP+ ports, Base Software included | 5420F-48P-4XE
OUT OF STOCK
- Brand: Extreme Networks
- Series: 5420
- Network Management Type: Managed
- Primary Ports: 48 x 10/100/1000BASE-T 802.3at (30W) ports • Full / Half-Duplex(autosensing) • MACsec-capable 4 x 1/10Gb SFP+ uplink ports(unpopulated) • MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- Model #: 5420F-48P-4XE
- $5,985.99 –
- Free Shipping

Quick View
Planet MGSD-10080F 8-Port 100/1000X SFP + 2-Port 10/100/1000T Managed Metro Ethernet Switch
OUT OF STOCK
- Format: Wall Mountable
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid Spanning tree protocol IEEE 802.1s Multiple Spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2
- Primary Ports: 8 1000Base-SX/LX/BX SFP interfaces, from port 1 to port 8 Compatible with 100Base-FX SFP, 2 10/ 100/1000Base-T RJ-45 Auto-MDI/MDI-X ports, 1 x RJ-45-to-RS-232 serial port (115200, 8, N, 1)
- Primary Port Speed: 20Gbps / non-blocking
- Model #: MGSD-10080F
- $376.00
- Free Shipping

Quick View
Extreme Networks 5520 48-port Switch, x Stacking/QSFP28 ports, Base software included | 5520-48T
OUT OF STOCK
- Brand: Extreme Networks
- Network Management Type: Managed
- Primary Ports: • 48 x 10/100/1000BASE-T ports ? Full / Half-Duplex (autosensing) ? MACsec-capable • 2 x Stacking/QSFP28 ports* (unpopulated) • 1 x Serial console port (RJ-45) • 1 x 10/100/1000BASE-T out-of-band management port • 2 x USB A ports for management or external USB flash • 1 x USB Micro-B console port • 1 x VIM slot
- Model #: 5520-48T
- $5,679.99 –
- Free Shipping

Quick View
Extreme Networks 5420F 24-port SFP Switch, 4 x 1/10Gb SFP+ ports, Base software included | 5420F-24S-4XE
OUT OF STOCK
- Brand: Extreme Networks
- Series: 5420
- Network Management Type: Managed
- Primary Ports: 24 x 100/1000BASE-X (SFP) ports (unpopulated) • MACsec-capable 4 x 1/10Gb SFP+ uplink ports(unpopulated) • MACsec-capable 2 x Stacking/SFP-DD ports* (unpopulated) 1 x Serial console port (RJ-45) 1 x 10/100/1000BASE-T out-of-band management port 2 x USB A ports for management or external USB flash 1 x USB Micro-B console port
- Model #: 5420F-24S-4XE
- $4,328.99 –
- $11.72 Shipping



