Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Useful Links
Customer Ratings
Sort By:
View:
Netgear M4250-40G8XF-PoE++ AV Line Managed Switch GSM4248UX100NAS
Quick View
  •  
  • ¥1,002,117 –
  • ¥29,083 Shipping
Ubiquiti EnterpriseXG 24 (Gen1), 24-port Layer 3 switch (USW-EnterpriseXG-24)
Quick View
Ubiquiti EnterpriseXG 24 (Gen1), 24-port Layer 3 switch (USW-EnterpriseXG-24)
  • Brand: Ubiquiti
  • Series: Network Switch
  • Part Number: USW-EnterpriseXG-24
  • Format: Rackmount
  • Model #: USW-EnterpriseXG-24
  •  
  • ¥233,886 –
  • ¥12,109 Shipping
Fortinet FortiSwitch-124F-FPOE Layer 2 FortiGate switch controller compatible PoE+ switch with 24 GE RJ45 + 4 10G SFP+ ports, 24 port PoE | FS-124F-FPOE
Quick View
Fortinet FortiSwitch-124F-FPOE Layer 2 FortiGate switch controller compatible PoE+ switch with 24 GE RJ45 + 4 10G SFP+ ports, 24 port PoE | FS-124F-FPOE
  • Part Number: FS-124F-FPOE
  • Format: Rackmount
  • Management Interface: 24x GE RJ45 and 4x 10GE SFP+
  • Management Feature: Automation Stitches Display Average Bandwidth and Allow Sorting on Physical Port / Interface Traffic Dual Firmware Support HTTP / HTTPS IPv4 and IPv6 Management Link Monitor Managed from FortiGate Packet Capture POE Control Modes Provide warning if L2 table is getting full RMON Group 1 SNMP v1/v2c/v3 SNMP v3 traps SNTP Software download/upload: TFTP/FTP/GUI SPAN, RSPAN, and ERSPAN Standard CLI and Web GUI Interface Support for HTTP REST APIs for Configuration and Monitoring Syslog UDP/TCP System alias command System Temperature and Alert Telnet / SSH
  • Model #: FS-124F-FPOE
TP-Link TL-SX1008 | 8 Port 10G/Multi-Gig Unmanaged Ethernet Switch | Desktop/Rackmount | Plug & Play | Sturdy Metal Casing | Speed Auto-Negotiation
Quick View
TP-Link 16 Port 10/100Mbps Fast Ethernet Switch | Desktop or Wall-Mounting | Plastic Case Ethernet Splitter | Unshielded Network Switch | Plug and Play | Fanless Quiet | Unmanaged (TL-SF1016D)
Quick View
  •  
  • ¥7,406 –
  • ¥14,424 Shipping
TP-Link 48 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/ Shielded Ports | Rackmount | Fanless | Lifetime Protection | Traffic Optimization | Unmanaged (TL-SG1048)
Quick View
Netgear Business GS105P 5-Port Gigabit Ethernet Unmanaged PoE Switch
Quick View
Netgear Inc.
Netgear Business GS105P 5-Port Gigabit Ethernet Unmanaged PoE Switch
  • Brand: NETGEAR
  • Part Number: GS105P-300NAS
  • Format: Desktop, Wall Mountable, Enclosure, Compact
  • Standards: 10/100/1000Base-T
  • Model #: GS105P-300NAS
  •  
  • ¥21,808 –
  • ¥8,759 Shipping
D-LINK BUSINESS DGS-1510-28X SmartPro 24Port Gigabit Switch
Quick View
D-LINK BUSINESS DGS-1510-28X SmartPro 24Port Gigabit Switch
  • Brand: D-Link
  • Part Number: DGS-1510-28X
  • Switch Type: Ethernet Switch
  • Uplink Interface: RJ45, SFP+
  • Model #: DGS-1510-28X
TP-Link 16 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1016DE)
Quick View
TP-Link 16 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1016DE)
  • Format: Desktop
  • Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
  • Uplink Ports: None
  • Primary Ports: 16 x RJ45
  • Model #: TL-SG1016DE
Netgear AV Line M4350-16M4V Ethernet Switch - 16 Ports - Manageable - 2.5 Gigabit Ethernet, 25 Gigabit Ethernet - 2.5GBase-T, 25GBase-X - 3 Layer Supported - 689.60 W Power Consumption - MSM4320-100NE
Quick View
  •  
  • ¥1,272,408 –
  • ¥20,268 Shipping
TP-Link TL-SG2210P, Jetstream 8 Port Gigabit Smart Managed PoE Switch, 8 PoE+ Ports @61W, 2 SFP Slots, Omada SDN Integrated, PoE Recovery, IPv6, Static Routing, Limited Lifetime Protection
Quick View
TP-Link
TP-Link TL-SG2210P, Jetstream 8 Port Gigabit Smart Managed PoE Switch, 8 PoE+ Ports @61W, 2 SFP Slots, Omada SDN Integrated, PoE Recovery, IPv6, Static Routing, Limited Lifetime Protection
  • Format: Desktop
  • Standards: IEEE 802.3af, IEEE 802.3at
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TL-SG2210P
  •  
  • ¥23,024 –
  • ¥10,399 Shipping
ZyXEL 8-Port Gigabit Smart Managed PoE Switch, 8 PoE+ Ports at 77W, Fanless, TAA Compliant, GS1900-8HPREV03F
Quick View
ZyXEL 8-Port Gigabit Smart Managed PoE Switch, 8 PoE+ Ports at 77W, Fanless, TAA Compliant, GS1900-8HPREV03F
  • Brand: ZyXEL
  • Part Number: GS1900-8HPREV03F
  • Switch Type: Manageable: Yes
  • Format: Desktop Rack-mountable Under Table Wall Mountable
  • Model #: GS19008HPREV03F
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (130W) + 2 Optical SFP Ports|L3 Lite|NDAA/TAA Compliant (DGS-1210-10MP)
Quick View
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (130W) + 2 Optical SFP Ports|L3 Lite|NDAA/TAA Compliant (DGS-1210-10MP)
  • Switch Type: 8-Port Gigabit Smart Managed PoE Switch with 2 Gigabit SFP ports, 130W PoE Budget
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-FX 100 Mbps over fiber optic IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twisted- pair copper) IEEE 802.3z 1000BASE-X 1 Gbps over fiber optic IEEE 802.3az Energy Efficient Ethernet (EEE) IEEE 802.3x Flow Control IEEE 802.3af/at compliance (for PoE ports on PoE models)
  • Primary Ports: 8 x 10/100/1000 (PoE+) + 2 x Gigabit SFP
  • Model #: DGS-1210-10MP
TP-Link TL-SG1008MP - switch - 8 ports - unmanaged - rack-mountabl (TL-SG1008MP)
Quick View
TP-Link TL-SG1008MP - switch - 8 ports - unmanaged - rack-mountabl (TL-SG1008MP)
  • Brand: TP-Link
  • Series: ProSafe
  • Part Number: TL-SG1008MP
  • Switch Type: Others
  • Model #: TL-SG1008MP
TP-Link 5 Port 10/100 Mbps Fast Ethernet Switch | Desktop Ethernet Splitter | Ethernet Hub | Plug & Play | Fanless Quiet | Desktop Design | Green Technology | Unmanaged (TL-SF1005D), White
Quick View
Netgear Business GS108EP 8-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS108EP 8-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS108EP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS108EP-100NAS
  •  
  • ¥30,411 –
  • ¥7,775 Shipping
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T, IEEE 802.3u 100BASE-FX, IEEE 802.3z 1000BASE-SX, IEEE 802.3z 1000BASE-LX, 4-Port IEEE 802.3af/at Power over Ethernet end-span PSE
  • Primary Ports: 4 x RJ-45 Female 4 x RJ-45 (PoE+) Female
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES81GPOEW
Netgear Business GS108EPP 8-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS108EPP 8-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS108EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS108EPP-100NAS
  •  
  • ¥40,548 –
  • ¥7,775 Shipping
Ubiquiti Enterprise 48 PoE, 48-Port Layer 3 PoE+ Switch (USW-Enterprise-48-PoE (720W))
Quick View
Ubiquiti Enterprise 48 PoE, 48-Port Layer 3 PoE+ Switch (USW-Enterprise-48-PoE (720W))
  • Brand: Ubiquiti Networks
  • Series: UniFi
  • Part Number: USW-Enterprise-48-PoE (720W)
  • Format: Rackmount
  • Model #: USW-Enterprise-48-PoE (720W)
  •  
  • ¥316,691 –
  • ¥16,065 Shipping
TP-Link TL-SG3452P | 48 Port Gigabit L2+ Managed PoE Switch | 48 PoE+ Port @384W, 4 x SFP Slots | PoE Auto Recovery | Omada SDN Integrated | IPv6 | Static Routing | 5 Year Manufacturer Warranty
Quick View
TP-Link
TP-Link TL-SG3452P | 48 Port Gigabit L2+ Managed PoE Switch | 48 PoE+ Port @384W, 4 x SFP Slots | PoE Auto Recovery | Omada SDN Integrated | IPv6 | Static Routing | 5 Year Manufacturer Warranty
  • Format: Rack Mountable
  • Primary Ports: 48× gigabit RJ45 ports and 4× gigabit SFP Slots provide high-speed connections.
  • VLAN Support: Yes
  • Jumbo Frames: 9 KB
  • Model #: SG3452P
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
Quick View
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-1008HP
  •  
  • ¥23,152 –
  • ¥11,017 Shipping
TRENDnet TI-OE110 Industrial Waterproof Gigabit PoE+ Extender
Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8P2S
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
Quick View
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3af Power over Ethernet
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with IEEE 802.3af PoE injector 1-port 100Base-FX SFP interface
  • MAC Address Table: 2K
  • Switching Method: Store and Forward
  • Model #: ISW-514PTF
  •  
  • ¥39,690 –
  • ¥12,794 Shipping
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
Quick View
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T IEEE 802.3z 1000Base-SX/LX IEEE 802.3az Energy-Efficient Ethernet, IEEE 802.3x Flow Control, IEEE 802.1q VLAN Tagging, IEEE 802.1p QoS, IEEE 802.1x Port-Based Network Access Control, IEEE802.3ad Link Aggregation, IEEE 802.1d Spanning Tree Protocol, IEEE 802.1w Rapid Spanning Tree Protocol
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES101GP2SFW
Aruba X511 12-port Cable Guard JL742A
Quick View
  •  
  • ¥14,059 –
  • ¥9,709 Shipping
HPE Aruba Networking 2930F 48G PoE+ 4SFP+ Switch | JL256A#ABA
Quick View
HPE Aruba Networking 2930F 48G PoE+ 4SFP+ Switch | JL256A#ABA
  • Brand: HPE
  • Model: JL256A#ABA
  • Part Number: JL256A
  • Primary Ports: (48) RJ-45 autosensing 10/100/1000 PoE+ ports (4) SFP+ 1/10GbE ports
  • Model #: JL256A#ABA
  •  
  • ¥613,842 –
  • ¥16,644 Shipping
TP-Link 8 Port Gigabit Ethernet Network Switch | Plug and Play | Desktop or Wall-Mount | Plastic Case Ethernet Splitter | Fanless | Traffic Optimization | Unmanaged (TL-SG1008D)
Quick View
TP-Link 8 Port Gigabit Ethernet Network Switch | Plug and Play | Desktop or Wall-Mount | Plastic Case Ethernet Splitter | Fanless | Traffic Optimization | Unmanaged (TL-SG1008D)
  • Format: Desktop
  • Standards: IEEE 802.3i / 802.3u / 802.3ab / 802.3x
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TL-SG1008D
  •  
  • ¥6,944 –
  • ¥12,575 Shipping
StarTech 5-Port Unmanaged Industrial Network Switch I51G-ETHERNET-SWITCH
Quick View
StarTech 5-Port Unmanaged Industrial Network Switch I51G-ETHERNET-SWITCH
  • Brand: StarTech
  • Part Number: I51G-ETHERNET-SWITCH
  • Uplink Interface: RJ45
  • Primary Ports: RJ45
  • Model #:

Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.

Network Switches Are Versatile Networking Solutions

Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.

Switches Accommodate Shifts in Business and IT Trends

Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.

Multiple Network Management Options Provide a Positive User Experience

There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.

Switches Provide the Highest Levels of Security

Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.

Network Switches Provide Comprehensive and Advanced Networking Features

Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.