Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Juniper QFX5110-48S-DC-AFI, 48x SFP+ and 4x QSFP28 ports
Quick View
TP-Link 5 Port Gigabit Ethernet Network Switch - Ethernet Splitter | Plug & Play | Fanless | Sturdy Metal w/ Shielded Ports | Traffic Optimization | Unmanaged | Limited Lifetime Protection(TL-SG105)
Quick View
  • $17.99
  •  
  • $14.99 –
  • Save: $3.00 (16%)
  • Free Shipping
TP-Link 8 Port Gigabit Ethernet Network Switch | Ethernet Splitter | Sturdy Metal w/ Shielded Ports | Plug-and-Play | Traffic Optimization | Unmanaged (TL-SG108)
Quick View
TP-Link 8 Port Gigabit Ethernet Network Switch | Ethernet Splitter | Sturdy Metal w/ Shielded Ports | Plug-and-Play | Traffic Optimization | Unmanaged (TL-SG108)
  • Brand: TP-Link
  • Format: Desktop
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Network Management Type: Unmanaged
  • Model #: TL-SG108
  •  
  • $19.99 –
  • Free Shipping
TP-Link TL-SG1005P| 5 Port Fast Ethernet PoE Switch | 4 PoE+ Ports @67W | Desktop | Plug & Play | Sturdy Metal w/ Shielded Ports | Fanless | Limited Lifetime Protection | Extend & Priority Mode
Quick View
TP-Link 8-Port 8-Port 10/100/1000Mbps Desktop Swtich
Quick View
TP-Link 8-Port 8-Port 10/100/1000Mbps Desktop Swtich
  • Format: Desktop
  • Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TL-SG108E
  • $29.99
  •  
  • $27.99 –
  • Save: $2.00 (6%)
  • Free Shipping
TP-Link 16 Port Gigabit Ethernet Network Switch, Desktop/ Wall-Mount, Fanless, Sturdy Metal w/ Shielded Ports, Traffic Optimization, Unmanaged, Limited Lifetime Protection (TL-SG116)
Quick View
TP-Link 16 Port Gigabit Ethernet Network Switch, Desktop/ Wall-Mount, Fanless, Sturdy Metal w/ Shielded Ports, Traffic Optimization, Unmanaged, Limited Lifetime Protection (TL-SG116)
  • Brand: TP-Link
  • Format: Desktop
  • Standards: IEEE 802.3i, IEEE802.3u, IEEE802.3ab, IEEE802.3x, IEEE802.1p
  • Network Management Type: Unmanaged
  • Model #: TL-SG116
TP-Link 24 Port Gigabit Ethernet Switch | Desktop or Rackmount | Lifetime Protection | Plug & Play | Shielded Ports | Sturdy Metal | Fanless Quiet | Traffic Optimization | Unmanaged (TL-SG1024S)
Quick View
TP-Link 24 Port Gigabit Ethernet Switch | Desktop or Rackmount | Lifetime Protection | Plug & Play | Shielded Ports | Sturdy Metal | Fanless Quiet | Traffic Optimization | Unmanaged (TL-SG1024S)
  • Switch Type: desktop
  • Format: Desktop / Rackmount
  • Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab , IEEE 802.3x
  • Primary Ports: 24 x 10/100/1000 Mbps RJ45 Ports (Auto Negotiation / Auto MDI / MDIX)
  • Model #: TL-SG1024S
TP-Link 5 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Desktop/Wall-Mount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP and Link Aggregation (TL-SG105E)
Quick View
TP-Link 5 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Desktop/Wall-Mount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP and Link Aggregation (TL-SG105E)
  • Brand: TP-Link
  • Format: Desktop
  • Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
  • Network Management Type: Unmanaged
  • Model #: TL-SG105E
TRENDnet 10-Port Industrial Gigabit L2 Managed PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 24-57V DC Power Input, IP30, VLAN, Black, TI-PG102i
Quick View
TRENDnet 10-Port Industrial Gigabit L2 Managed PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 24-57V DC Power Input, IP30, VLAN, Black, TI-PG102i
  • Switch Type: Switches
  • Format: DIN Rail Mount
  • Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.1ax IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3az IEEE 802.3af IEEE 802.3at
  • Primary Ports: 8 x Gigabit PoE+ ports 2 x 100/1000 Mbps SFP slots
  • Model #: TI-PG102i
Available Direct from TRENDnet Available Direct from TRENDnet
TRENDnet 5-Port Hardened Industrial Gigabit DIN-Rail Switch, TI-G50, 10 Gbps, IP50 Rated, Ethernet Splitter, NDAA & TAA Compliant, DIN-Rail and Wall Mounts Included, Lifetime Protection, Black
Quick View
TRENDnet 5-Port Hardened Industrial Gigabit DIN-Rail Switch, TI-G50, 10 Gbps, IP50 Rated, Ethernet Splitter, NDAA & TAA Compliant, DIN-Rail and Wall Mounts Included, Lifetime Protection, Black
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3x
  • Primary Ports: 5 x Gigabit ports
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
  • Model #: TI-G50
  • $81.35 - $92.33
D-Link 10-Port Gigabit Smart Managed Switch | 8 GbE + 2 Optical SFP Ports | L3 Lite | Surveillance Mode | NDAA/TAA Compliant (DGS-1210-10)
Quick View
D-Link 10-Port Gigabit Smart Managed Switch | 8 GbE + 2 Optical SFP Ports | L3 Lite | Surveillance Mode | NDAA/TAA Compliant (DGS-1210-10)
  • Format: Rackmount
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-10
TP-Link 24 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1024DE)
Quick View
TP-Link 24 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1024DE)
  • Format: Rackmount
  • Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
  • Primary Ports: 24 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TL-SG1024DE
D-Link DGS-1024D Unmanaged 24-Port Gigabit Unmanaged Desktop or Rackmount Switch
Quick View
D-Link DGS-1024D Unmanaged 24-Port Gigabit Unmanaged Desktop or Rackmount Switch
  • Format: Rackmount
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Uplink Ports: None
  • Primary Ports: 24 x RJ45
  • Model #: DGS-1024D
Ubiquiti UniFi Switch US-8-60W - switch - 8 ports - managed (UBI-US-8-60W)
Quick View
Ubiquiti UniFi Switch US-8-60W - switch - 8 ports - managed (UBI-US-8-60W)
  • Part Number: UBI-US-8-60W
  • Format: Desktop
  • Primary Ports: (8) GbE RJ45 ports
  • Primary Port Speed: Total non-blocking throughput 8 Gbps Switching capacity 16 Gbps Forwarding rate 11.9 Mpps
  • Model #: US-8-60W
Intellinet 8-Port Gigabit Ethernet Switch, Desktop Size, Green Ethernet power-saving technology, Black
Quick View
Intellinet 8-Port Gigabit Ethernet Switch, Desktop Size, Green Ethernet power-saving technology, Black
  • Format: Desktop
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Switching Method: Store and Forward
  • Model #: 561754
Available Direct from Intellinet Network Solutions Available Direct from Intellinet Network Solutions
TP-Link 5 Port 10/100 Mbps Fast Ethernet Switch | Desktop Ethernet Splitter | Ethernet Hub | Plug & Play | Fanless Quiet | Desktop Design | Green Technology | Unmanaged (TL-SF1005D), White
Quick View
  •  
  • $9.99 –
  • Free Shipping
Ubiquiti Standard 48 PoE (Gen1) Layer 2, PoE Switch (US-48-500W (500W))
Quick View
Ubiquiti Standard 48 PoE (Gen1) Layer 2, PoE Switch (US-48-500W (500W))
  • Primary Ports: (48) GbE RJ45 ports (2) 1G SFP ports (2) 1/10G SFP+ ports
  • Primary Port Speed: Total non-blocking throughput 70 Gbps Switching capacity 140 Gbps Forwarding rate 104.16 Mpps
  • LEDs: System Status Ethernet PoE Speed/ Link/Activity SFP Speed/Link/Activity
  • Power: Power method Universal input, 100—240V AC, 50/60 Hz Power supply AC/DC, internal, 500W Supported voltage range 100—240V AC Max. power consumption Excluding PoE output: 64W Including PoE output: 500W Total available PoE 500W
  • Model #: US-48-500W
TP-Link 8 Port Gigabit Ethernet Network Switch | Plug and Play | Desktop or Wall-Mount | Plastic Case Ethernet Splitter | Fanless | Traffic Optimization | Unmanaged (TL-SG1008D)
Quick View
TP-Link 8 Port Gigabit Ethernet Network Switch | Plug and Play | Desktop or Wall-Mount | Plastic Case Ethernet Splitter | Fanless | Traffic Optimization | Unmanaged (TL-SG1008D)
  • Format: Desktop
  • Standards: IEEE 802.3i / 802.3u / 802.3ab / 802.3x
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TL-SG1008D
TRENDnet 8-Port Gigabit GREENnet Switch, Ethernet Network Switch, 8 x 10-100-1000 Mbps Gigabit Ethernet Ports, 16 Gbps Switching Capacity, Metal, Lifetime Protection, Black, TEG-S82G
Quick View
TRENDnet 8-Port Gigabit GREENnet Switch, Ethernet Network Switch, 8 x 10-100-1000 Mbps Gigabit Ethernet Ports, 16 Gbps Switching Capacity, Metal, Lifetime Protection, Black, TEG-S82G
  • Format: Wall Mountable
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3az
  • Uplink Ports: None
  • Primary Ports: 8 x RJ45
  • Model #: TEG-S82g
Available Direct from TRENDnet Available Direct from TRENDnet
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T
TP-Link 8 Port 10/100Mbps Fast Ethernet Switch | Desktop Ethernet Splitter | Ethernet Hub | Plug and Play | Fanless Quiet | Desktop Design | Green Technology | Unmanaged (TL-SF1008D)
Quick View
TP-Link 8 Port 10/100Mbps Fast Ethernet Switch | Desktop Ethernet Splitter | Ethernet Hub | Plug and Play | Fanless Quiet | Desktop Design | Green Technology | Unmanaged (TL-SF1008D)
  • Brand: TP-Link
  • Format: Desktop
  • Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x
  • Network Management Type: Unmanaged
  • Model #: TL-SF1008D
  •  
  • $19.99 –
  • Free Shipping
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: WGS-5225-8T2SV
TP-Link TL-SG3452X | 48 Port Gigabit Switch, 4 x 10GE SFP+ Slots | L2+ Smart Managed | Omada SDN Integrated | IPv6 | Static Routing | Support QoS, IGMP & LAG
Quick View
TP-Link
TP-Link TL-SG3452X | 48 Port Gigabit Switch, 4 x 10GE SFP+ Slots | L2+ Smart Managed | Omada SDN Integrated | IPv6 | Static Routing | Support QoS, IGMP & LAG
  • Part Number: TL-SG3452X
  • Format: Rackmount
  • Primary Ports: 48 x RJ45 + 4 x SFP+
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • Model #: TL-SG3452X
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
Quick View
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
  • Brand: D-Link
  • Format: Rackmount
  • Standards: 802.3 Ethernet, 802.3u Fast Ethernet, 802.3x Flow Control, 802.3ab Gigabit Ethernet, 802.1p QoS
  • Network Management Type: Unmanaged
  • Model #: DGS-1016D
Available Direct from D-Link Available Direct from D-Link
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
Quick View
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
  • Format: Rackmount
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-28
D-Link DGS-1510-28XMP Systems 28-Port Gigabit SmartPro Stackable PoE/PoE+ Switch Including 4 10GbE SFP+ Ports
Quick View
D-Link DGS-1510-28XMP Systems 28-Port Gigabit SmartPro Stackable PoE/PoE+ Switch Including 4 10GbE SFP+ Ports
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet 802.3ae 10 GbE, IEEE 802.3x Flow Control for Full-Duplex Mode, Auto-negotiation
  • Primary Ports: 24* 10/100/1000Mbps Port PoE (370w) 4*10G SFP+ Ports
  • MAC Address Table: 16K
  • Switching Method: Store and Forward
  • Model #: DGS-1510-28XMP
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
Quick View
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-1008HP
  •  
  • $123.99 –
  • Free Shipping
Intellinet Network Solutions 5-Port Gigabit Ethernet PoE+ Switch (561228)
Quick View
Intellinet Network Solutions 5-Port Gigabit Ethernet PoE+ Switch (561228)
  • Format: Desktop
  • Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3ab (1000Base-T Gigabit Ethernet) IEEE 802.3af (Power over Ethernet 802.3at Type 1) IEEE 802.3at (Power over Ethernet 802.3at Type 2) IEEE 802.3az (Energy Efficient Ethernet EEE)
  • Primary Ports: 5 x RJ45
  • MAC Address Table: 2K
  • Model #: 561228