Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
TP-Link 5 Port Fast Ethernet 10/100Mbps PoE Switch | 4 PoE Ports @58W | Desktop | Plug & Play | Sturdy Metal w/ Shielded Ports | Fanless | Limited Lifetime Protection | Unmanaged (TL-SF1005P)
OUT OF STOCK
- Brand: TP-Link
- Switch Type: Others
- Format: Desktop
- Network Management Type: Managed
- Model #: TL-SF1005P
- $39.99 –
- More options from $39.99
- Free Shipping

Quick View
NETGEAR 8-port, 5-speed Unmanaged Switch 10-Gigabit/Multi-Gigabit | XS508M
OUT OF STOCK
- Brand: NETGEAR
- Format: Rackmount / Desktop
- Standards: IEEE 802.3 Ethernet IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Full-Duplex Flow Control IEEE 802.1p Class of Service IEEE 802.3az Energy Efficient Ethernet IEEE 802.3an 10GBASE-T IEEE 802.3bz 5 Gbps and 2.5 Gbps Ethernet Over Copper Twisted Pair Cable IEEE 802.3ae 10-Gigabit Ethernet Over Fiber IEEE 802.3aq 10-Gigabit over Fiber (10GBASE-LRM) IEEE 802.3z Gigabit Ethernet 1000BASE-SX/LX
- Network Management Type: Unmanaged
- Model #: XS508M-100NAS
- $629.99 –
- Free Shipping

Quick View
Ubiquiti CloudKey+ (UCK-G2-PLUS)
OUT OF STOCK
- LAN Ports: (1) GbE RJ45 port
- Brand: Ubiquity Networks
- Series: Gateway
- LEDs: (1) Power: white/blue
- Model #: UCK-G2-PLUS
- $199.00 –
- More options from $199.00 - $217.33
- Free Shipping

Quick View
Ubiquiti Networks airMAX Rocket Prism 5AC (RP-5AC-Gen2)
OUT OF STOCK
- Frequency Band: Operating Frequency (MHz) Worldwide 5150–5875 MHz USA U-NII-1: U-NII-2A: U-NII-2C: U-NII-3 5150–5250 MHz 5250–5350 MHz 5470–5725 MHz 5725–5850 MHz Management Radio (MHz) Worldwide 2412–2472 MHz USA 2412–2462 MHz
- Brand: Ubiquiti Networks
- Series: Wireless
- LED Indicator: (4) Signal strength: software-adjustable to correspond to custom RSSI levels GPS, LAN, power
- Model #: RP-5AC-GEN2-US
- $229.00 –
- More options from $229.00 - $316.37
- Free Shipping

Quick View
Ubiquiti Networks INS-3AF-I-G Instant 802.3af Indoor Converters
OUT OF STOCK
- Type: PoE Converter
- Color: Black
- Specifications: Networking Interface: PoE In (802.3af): 1 x Gigabit RJ45 Port PoE Out (24V Passive): 1 x Gigabit RJ45 Port Operating Temperature: 0 to 70 degree C (32 to 158 degree F) Power Input: 48V, 802.3af Max. Power Output: 24V, 0.5A Power Method: 24V Passive PoE (Pairs 4, 5+; 7, 8 Return)
- Model #: INS-3AF-I-G
- $26.99 –
- $2.99 Shipping

Quick View
Intellinet 8-Port Gigabit Ethernet Switch, Desktop size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)
OUT OF STOCK
- Brand: Intellinet
- Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3ab (Gigabit Ethernet) IEEE 802.3x (Flow Control and Backpressure)
- Network Management Type: Unmanaged
- Primary Ports: 8 x RJ45
- Model #: 530347
- $71.99
- $58.18 –
- Save: $13.81 (19%)
- Free Shipping

Quick View
PLANET WGS-5225-8P2SV Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
OUT OF STOCK
- Format: Wall Mountable
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Switching Method: Store and Forward
- Model #: WGS-5225-8P2SV
- $444.99 –
- Free Shipping

Quick View
PLANET IFGS-1022HPT Unmanaged Industrial 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP/SFP Combo Ethernet Switch
OUT OF STOCK
- Format: DIN Rail Mount
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x Flow Control and Back Pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port Gigabit TP/SFP
- MAC Address Table: 16K
- Model #: IFGS-1022HPT
- $315.99 –
- Free Shipping

Quick View
Planet IGS-5225-4UP1T2S Industrial L2+ 4-Port 10/100/1000T Ultra PoE + 1-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
OUT OF STOCK
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3bt Power over Ethernet ready RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 5 x RJ45 + 2 SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-4UP1T2S
- $563.99 –
- Free Shipping

Quick View
PLANET WGS-803 Unmanaged 8-Port 10/100/1000T Wall-mounted Gigabit Ethernet Switch
OUT OF STOCK
- Format: Wall Mountable
- Standards: IEEE 802.3: Ethernet IEEE 802.3u: Fast Ethernet IEEE 802.3ab: Gigabit Ethernet IEEE 802.3x: Flow Control
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-803
- $159.60
- Free Shipping

Quick View
Ubiquiti Networks PS-5AC Shielded airMAX ac BaseStation with airPrism Technology
OUT OF STOCK
- Interface: 1 x 10/100/1000 Ethernet Port
- Brand: Ubiquiti Networks
- LED Indicator: Power
- Power Supply: Max. Power Consumption: 10W Power Supply: 24V, 1A Gigabit PoE Adapter (Included) Power Method: Passive PoE (Pairs 4, 5+; 7, 8 Return) Supported Voltage Range: 20 to 26V DC
- Model #: PS-5AC
- $275.99 –
- Free Shipping

Quick View
Planet GSW-1820VHP 16-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
OUT OF STOCK
- Brand: PLANET
- Format: 19-inch Desktop size, 1U Height, Rack Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Network Management Type: Unmanaged
- Model #: GSW-1820VHP
- $384.00
- Free Shipping

Quick View
PLANET FGSD-1011HP 8-Port 10/100TX 802.3at/af PoE + 1-Port 10/100/1000T + 1-Port 100/1000X SFP Desktop Switch
OUT OF STOCK
- Format: Desktop
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX / LX IEEE 802.3x Flow Control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 8 x 10/100 Mbps Fast Ethernet ports 1 x 10/100/1000BASE-T Gigabit Ethernet port 1 x 1000BASE-X mini-GBIC SFP interface
- MAC Address Table: 4K
- Model #: FGSD-1011HP
- $122.99 –
- Free Shipping

Quick View
Ubiquiti Network airFiber 60 Long-Range (AF60-LR)
OUT OF STOCK
- Frequency Band: RF Operating frequency* 57–71 Ghz * Depends on regulatory region. Channel bandwidth 2160, 1080 MHz Polarization Vertically linear Beamwidth Azimuth: 3 dB 1.6° Elevation: 3 dB 1.6°
- Brand: Ubiquiti Networks
- Series: Wave 60 GHz
- LED Indicator: Power Flashing white: bootup in progress White: not connected to UISP application Blue: connected to UISP application Ethernet Flashing blue: Ethernet activity GPS Blue: receiving at least (4) GPS satellite signals 60G Blue: active connection
- Model #: AF60-LR
- $328.90 –
- Free Shipping

Quick View
PLANET IGS-1020TF Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch (-40~75 Degrees C)
OUT OF STOCK
- Format: DIN Rail and Wall Mount Design
- Standards: IEEE 802.3 Ethernet/10BASE-T IEEE 802.3u Fast Ethernet/100BASE-TX IEEE 802.3ab Gigabit Ethernet/1000BASE-T IEEE 802.3z Gigabit Ethernet/1000BASE-SX/LX IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet (EEE) IEEE 802.1p Cos
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-1020TF
- $294.40
- Free Shipping

Quick View
Ubquiti Power Distribution Hi-Density, support large, rack-mounted UniFi hardware deployments | USP-PDU-HD
OUT OF STOCK
- Brand: Ubiquiti Networks
- Part Number: USP-PDU-HD
- Primary Ports: (1) 10/100 MbE RJ45 port (3) GbE RJ45 ports for network redundancy
- Button: (1) Factory-reset (1) Circuit breaker
- Model #: USP-PDU-HD
- $999.00 –
- Free Shipping

Quick View
ZyXEL GS2220-28HP GS2220-28HP 24-Port Gigabit L2+ Managed and Nebula Pro Cloud Managed Switch, 24 PoE+ Ports at 375W with 4 SFP Uplinks
OUT OF STOCK
- Brand: ZyXEL
- Part Number: GS2220-28HP
- Switch Type: Others
- Format: 24-port PoE+ / 4-port GbE combo
- Model #: GS222028HP
- $839.99 –
- Free Shipping

Quick View
PLANET GSD-1002M 8-Port 10/100/1000Mbps + 2-Port 100/1000X SFP Managed Desktop Switch
OUT OF STOCK
- Primary Ports: 8 x 10/100/1000Base-T RJ45 Auto-MDI/MDI-X port / 2 100/1000Base-X SFP interfaces
- MAC Address Table: 8K entries
- Switching Method: Store and Forward
- VLAN Support: Yes
- Model #: GSD-1002M
- $135.99 –
- Free Shipping

Quick View
PLANET GS-4210-48P4S Managed 48-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000BASE-X SFP Managed Switch
OUT OF STOCK
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 48 x 10/100/1000BASE-T Gigabit RJ45 copper ports with 48-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots
- MAC Address Table: 16K
- Switching Method: Store and ...
- Model #: GS-4210-48P4S
- $1,025.99 –
- Free Shipping

Quick View
Ubiquiti Networks airMAX Lite AP GPS (LAP-GPS)
OUT OF STOCK
- Frequency Band: Operating Frequency (MHz) US/ CA U-NII-1 U-NII-2A U-NII-2C U-NII-3 5150 - 5250 MHz 5250 - 5350 MHz 5470 - 5725 MHz 5725 - 5850 MHz Worldwide 5150 - 5875 MHz Management Radio (MHz) US/CA 2412 - 2462 MHz Worldwide 2412 - 2472 MHz
- Power Supply: Power method Passive PoE 2-pair (4, 5+; 7, 8 return) Power supply 24V, 0.3A gigabit PoE adapter (Included) Supported voltage range 20—27V DC Max. power consumption 7.1W
- Temperature: -40 to 70° C (-40 to 158° F)
- Humidity: 5 to 95% noncondensing
- Model #: LAP-GPS-US
- $99.00 –
- $11.72 Shipping

Quick View
PLANET ISW-501T 5-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
OUT OF STOCK
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: ISW-501T
- $76.00
- Free Shipping

Quick View
Juniper Networks EX4000 Switch, 48-Port Multi-Gig switch with 8x 100M/1G/2.5GBaseT, 40x 10/100/1000BaseT, PoE++, 4x 1G/10G SFP/SFP+ (optics sold separately) | EX4000-48MP
OUT OF STOCK
- Brand: Juniper Networks, Inc.
- Series: EX4000
- Part Number: EX4000-48MP
- Network Management Type: Managed
- Model #: EX4000-48MP
- $7,895.00
- $4,067.99 –
- Save: $3,827.01 (48%)
- Free Shipping

